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1 Introduction and Installation 

 

 

1.1 ZWCAD+ Introduction 

Topics in this section: 

 About ZWCAD+ and Other CAD Softwares 

ZWCAD+ is designed for anyone who wants a fast and efficient CAD program with all the power and 

versatility of standard programs such as AutoCAD® by Autodesk®, Inc., or MicroStation® by Bentley 

Systems, Inc., at an affordable price. Using today's advanced technology, ZWCAD+ integrates the 

Microsoft® Windows® interface with a powerful CAD engine. 

 Compare ZWCAD+ Drawing with Manual Drafting 

ZWCAD+ greatly reduces the time and effort it takes to create and revise drawings. Not only can 

you produce accurate drawings faster, you can also reuse the information in your drawings. 

 Work with Other Data and Programs 

Traditional paper drawings serve only as a means of communicating information between the 

person who created the drawing and the person viewing the drawing. The drawings contain no 

more information than what is visually imparted by the creator and seen by the viewer. 

ZWCAD+ offers rich possibilities for analyzing drawings and attaching additional data to them. 

 Use Advanced CAD Features 

In addition to being compatible with AutoCAD, ZWCAD+ goes several steps further by providing you 

with innovative features to increase your productivity. 

 Get More Information 

In addition to the ZWCAD+ documentation, much of the assistance you need as you use ZWCAD+ is 

specific to the commands you work with on the screen. To obtain immediate information as you 

work, use these additional sources of information. 

1.2 About ZWCAD+ and Other CAD Softwares 

ZWCAD+ is designed for anyone who wants a fast and efficient CAD program with all the power and 

versatility of standard programs such as AutoCAD® by Autodesk®, Inc., or MicroStation® by Bentley 

Systems, Inc., at an affordable price. Using today's advanced technology, ZWCAD+ integrates the 

Microsoft® Windows® interface with a powerful CAD engine. 
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ZWCAD+ provides unparalleled compatibility with AutoCAD, using most of the same file formats 

including those for drawings (.dwg files), commands, linetypes, hatch patterns, and text styles. You 

can also use AutoCAD menu files and run AutoLISP® programs directly without modification. 

ZWCAD+ is more compatible with the AutoCAD program than any other CAD product, delivers 

additional tools with advanced CAD features, and has a seamless Microsoft® Windows integration. 

This powerful program provides a superb combination of features for CAD users like architects, 

engineers, and designers. 

ZWCAD+ incorporates standard features found in other CAD programs, along with features and 

capabilities you won't find anywhere else. Its multiple document interface (MDI) lets you open and 

work with several drawings at the same time. You can easily copy drawing entities between 

drawings. 

Using AutoCAD legacy drawings 

ZWCAD+ fully supports AutoCAD legacy drawings. ZWCAD+ reads and writes DWG files in their 

native format without any loss of data, from AutoCAD 2009 back to Version 10, including AutoCAD 

LT®. Because ZWCAD+ uses DWG as its native file format, no translation is required. 

ZWCAD+ supports three-dimensional wireframes and surfaces. Three dimensional drawings can be 

displayed in wireframe, hidden line view, and surface shading. 

ZWCAD+ supports displaying and working with raster images in your drawings. When a drawing 

containing proxy entities is loaded into ZWCAD+, a message displays indicating that some entities 

will not display. 

It's easy to customize ZWCAD+. You can modify menus and toolbars, create custom menus, dialog 

boxes, command aliases, and scripts, and add custom programs written in any of several 

programming languages, including LISP and ZDS™ (ZWCAD+ Development System™, the program's 

Autodesk® ADS compatible language). There is also Microsoft® Visual Basic for Applications (VBA). 

You can run existing LISP applications in ZWCAD+ with little or no modification. ZWCAD+ uses the 

APPLOAD command so you can easily load LISP programs. 

ZWCAD+ reads files that contain dialog control language (DCL) statements as well, which makes 

ZWCAD+ compatible with dialog boxes created for AutoCAD. 

Using AutoCAD commands with ZWCAD+ 

Because ZWCAD+ supports hundreds of AutoCAD commands, you use the commands you already 

know. For example, to draw a circle, use the CIRCLE command. To copy a circle, use the COPY 

command. 

When you press Enter or the spacebar, you activate the command—just like in AutoCAD. ZWCAD+ 

accepts the special characters used by AutoCAD, such as point filters (for example, .xy), relative 

coordinates (the @ symbol), and the apostrophe (the ' prefix) for transparent commands. ZWCAD+ 

function keys are also similar to those used in AutoCAD. Because you do not need to learn a new 

set of commands, you are immediately productive with ZWCAD+. 

 Compare ZWCAD+ Drawing with Manual Drafting 

ZWCAD+ greatly reduces the time and effort it takes to create and revise drawings. Not only can 

you produce accurate drawings faster, you can also reuse the information in your drawings. 
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These are the primary reasons for making the transition to CAD from traditional, manual drafting 

on paper. 

As with any tool, however, to use it effectively, you need to be familiar with some of the special 

features, functions, and concepts of CAD. If you are familiar with manual drafting, you'll find some 

conceptual similarities in CAD as well as some differences. 

Drawing to scale 

In traditional, manual drafting, you usually determine the scale of the drawing before you even 

start to draw, because you are working with a sheet of paper of a fixed size. You may have to reduce 

or enlarge the entity you are drawing to fit within the confines of the paper. 

When you create a drawing in ZWCAD+, you draw everything full size. You determine the type of 

units in which your drawing is measured. If you are drawing a building, 1 drawing unit might equal 

1 inch. If you are drawing a map, 1 drawing unit might equal 1 mile. Your drawing environment and 

the CAD drawing file itself are not limited to the size of a particular sheet of paper. 

 

1 drawing unit equals 1 inch.  1 drawing unit equals 1 

foot. 

As you draw, you can use commands such as Pan and Zoom to work on different part of the 

drawing and to magnify the display of the drawing to view small details. These commands have no 

effect on the actual size of the entities in your drawing; they affect only the way the drawing is 

displayed on your screen. Only when you print or plot your drawing do you need to set the scale so 

that the printed drawing fits within a specific paper size. 

Using tools 

In manual drafting, you use tools such as pencils, rulers, T squares, templates, erasers, and so on. 

When you create a drawing in ZWCAD+, you use a mouse instead of a pencil, and you use the 

mouse to select other tools-commands you select from a ribbon, a menu or a toolbar. 

You use some tools to create basic entities, such as lines, circles, and arcs, and other tools to 

modify existing entities (for example, to copy or move them or to change properties such as color 

and linetype). 
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Organizing information 

In traditional drafting, you often separate elements such as walls, dimensions, structural steel 

members, and electrical plans onto separate, translucent overlays. When you want to print the 

working drawings, you can create several different drawings by combining different overlays. 

When you create a drawing in ZWCAD+, you use layers to organize elements in a similar manner. 

However, the layers feature in CAD offers numerous advantages over physical transparencies. 

The number of overlays you can combine to print a manually drafted drawing is limited by the 

printing process. There is no such limitation in CAD. With ZWCAD+, you can define an unlimited 

number of layers, any of which can be visible or invisible at any time. 

You can name each layer and assign each its own color, linetype, lineweight, and print style. 

You can also lock individual layers to ensure that information on those layers isn't altered 

accidentally. 

 

Use layers to organize drawing information. 

Drawing accurately 

When you create a manual drawing, ensuring accuracy typically requires a lot of manual 

calculations and rechecking. By contrast, ZWCAD+ offers a number of drawing aids that ensure 

accuracy from the start. For example, you create and modify entities based on an underlying 

Cartesian coordinate system. Every location in the drawing has its own x,y,z coordinates. You can 

also display a grid as a visual reference to your coordinate system. 
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Each position in the CAD drawing has its corresponding 

x,y,z coordinates within Cartesian Coordinate System. 

Point 5,2,0 is 5 units to the right (along the x axis), 2 

units up (along the y axis), and 0 units (along the z axis) 

from the origin (the 0,0,0 point) Settings such as snap 

and entity snap allow you to draw accurately without 

specifying coordinates. 

The snap setting forces the selected points to adhere to the grid increment or to any other 

increment you set. Entity snaps let you snap to precise geometric points on existing entities�?for 

example, the endpoint of a line or the center of a circle. Another setting, orthogonal, constrains 

lines so that they are drawn parallel to the vertical and horizontal axes. Polar tracking and object 

snap tracking help you draw objects at specific angles or in specific relationships to other objects. 

When you turn on polar tracking and object snap tracking, temporary alignment paths help you 

create objects at precise positions and angles. You will discover techniques that make specific 

design tasks easier. 

 

Paper based drawings lack the high degree 

of accuracy possible when using CAD. Lines 

often overlap or fail to meet adjacent lines. 
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Snap and entity snap force the cursor to 

adhere to a specified increment or attach 

to key geometric points on existing 

entities. You can also constrain lines to 

vertical and horizontal axes. 

Drawing efficiently 

In paper based, manual drafting, you often have to redraw the same entity several times at 

different scales or from different vantage points. You may also need to redraw the border and title 

block on each new sheet. 

One of the most powerful features of ZWCAD+ is that when you create a drawing, you can reuse 

individual entities, borders, and title blocks as often as you want. You need draw an entity only 

once; the final printed drawing can show the entity at several different scales and viewpoints. 

You usually begin drawing in model space on the Model tab, creating the drawing (a floor plan, a 

map, or a three dimensional part) without regard to the final layout on paper. When you are ready 

to print your drawing, you have the option to switch to paper space on a Layout tab, where you lay 

out the drawing as you want it to appear on a sheet of paper. 
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You create the basic drawing in model space on the Model tab. 

 

When you're ready to print or plot your drawing, you can switch to paper space on a Layout tab, 

where you provide a layout of the drawing as you want it to appear on a sheet of paper. 
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Reusing CAD drawings and entities 

When you create a paper drawing manually, you can draw repetitive symbols by tracing a plastic 

template. After you draw a symbol in ZWCAD+, you can reuse that symbol without having to 

redraw it. You simply save the symbol as a block. You can then insert copies of that block anywhere 

in your drawing. You can also save the symbol as a separate drawing for use in other drawings. 

 

You can draw a symbol one time, save it as a block, and then insert multiple 

copies of that symbol anywhere in your drawing. 

In addition, you can reuse entire drawings and insert individual drawings into other drawings. 

You can also use an external reference, which acts as a pointer to another drawing rather than a 

copy of the entire drawing. Using an external reference has an added advantage: when you update 

the externally referenced drawing, each drawing that references it can be automatically updated. 

Making changes 

To make changes to a paper drawing, you erase and then redraw. With ZWCAD+, you use 

commands to modify entities in the drawing. You can move, rotate, stretch, or change the scale of 

entities. When you want to remove an entity, you can delete it with a single click of the mouse. If 

you make a mistake while creating or modifying your drawing, you can easily reverse your actions. 
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You can easily change an entity using commands such as move, 

rotate, stretch, and scale instead of redrawing the entity. 

 

 Work with Other Data and Programs 

Traditional paper drawings serve only as a means of communicating information between the 

person who created the drawing and the person viewing the drawing. The drawings contain no 

more information than what is visually imparted by the creator and seen by the viewer. 

ZWCAD+ offers rich possibilities for analyzing drawings and attaching additional data to them. 

For instance, although it may be impractical to count entities in a complex paper drawing, this task 

is simple in CAD. ZWCAD+ can calculate the number of entities in a drawing and compute area and 

distance. 

CAD drawings can also contain information in addition to visible entities. You can attach invisible 

database information to visible drawing entities and extract the information for analysis in a 

database or spreadsheet. (Working with information in a data base requires a program from a third 

party vendor, or you can create your own means of exporting the data in LISP or ZDS. Or, you can 

also use VBA.) 
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You can extract information stored in the drawing as visible or invisible 

attributes and use that data for analysis in a database or spreadsheet. 

ZWCAD+ provides in-place editing of Microsoft® objects, such as those created in Microsoft® Word 

and Microsoft® Excel software programs. In place editing makes it easy to share data with other 

users and programs. For example, you can include ZWCAD+ drawings in files created using 

Microsoft® Word, and you can insert files created using Microsoft® Word into your ZWCAD+ 

drawings. 

 Use Advanced CAD Features 

In addition to being compatible with AutoCAD, ZWCAD+ goes several steps further by providing you 

with innovative features to increase your productivity. 

Editing multiple documents simultaneously 

With ZWCAD+, you can open and edit multiple drawings simultaneously. You can also copy and 

paste elements among opened drawings. 

Editing multiple entities 

ZWCAD+ allows you to change most of the properties of all selected entities using a single, tabbed 

dialog box. 
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Performing unlimited undo and redo 

ZWCAD+ increases your power undo and redo of editing actions. 

 Get More Information 

In addition to the ZWCAD+ documentation, much of the assistance you need as you use ZWCAD+ is 

specific to the commands you work with on the screen. To obtain immediate information as you 

work, use these additional sources of information: 

Status bar 

To find out more detailed information about a tool when you pause the cursor over it, look on the 

status bar at the bottom of the screen. 

Help document 

ZWCAD+ help document is available on the screen when you press F1. 

1.3 Installation 

This section helps you get started using ZWCAD+ software by explaining how to install it and 

providing basic information about how to use it. 

NOTE This guide assumes that you have used other Windows based programs and are familiar with 

Windows terminology and techniques. 

 System Requirements 

You need the following software and hardware to install and run ZWCAD+. 

 Install ZWCAD+ 

A setup program guides you through the ZWCAD+ installation process. The program transfers files 

to a folder that it creates on your hard disk. The program also creates a menu item on the Start 

menu. 

 System Requirements 

Minimum System Requirements 

Operating system 

Microsoft® Windows XP SP2 and above 

Microsoft® Windows 2003 Server 

Microsoft® Windows 2008 Server 

Microsoft® Windows Vista 

Microsoft® Windows 7 

Microsoft® Windows 8  

Processor Intel® Pentium™ 4 1.5GHz or equivalent AMD® processor 

RAM 1GB 
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Display card 128M 

Hard disk 2GB free space in OS disk, 1GB free space in installation disk 

Resolution 1024*768 VGA with True Color 

Pointing device Mouse, trackball, or other devices 

DVD-ROM Any speed (for installation only) 

 

Recommended System Requirements 

Operating system 

Microsoft® Windows XP SP2 and above 

Microsoft® Windows 2003 Server 

Microsoft® Windows 2008 Server 

Microsoft® Windows Vista 

Microsoft® Windows 7 

Microsoft® Windows 8  

Processor Intel® Core™2 Duo or AMD® Athlon™ X2 CPU or higher 

RAM 2GB or more 

Display card 1GB or more 

Hard disk 4GB free space in OS disk, 2GB free space in installation disk 

Resolution 
1440*900 with NVidia 8 series or Radeon HD series or 

higher 

Pointing device Mouse, trackball, or other devices 

DVD-ROM Any speed (for installation only) 

 

 Install ZWCAD+ 

A setup program guides you through the ZWCAD+ installation process. The program transfers files 

to a folder that it creates on your hard disk. The program also creates a menu item on the Start 

menu. 

To install ZWCAD+ from a compact disc 

Insert the ZWCAD+ compact disc into your CD ROM drive. 

Double click the installation file of your desired software on the CD page. 

Follow the instructions of the installation prompts, choose from Standard Edition and Professional 

Edition to determine which one to install. 

NOTE If you did not receive a ZWCAD+ compact disc, for example, if you downloaded the program 

from the Internet, follow the instructions that came with the program. 

 



 

 21 

2 The User Interface 

 

 

 

You can work with the ZWCAD+ window and its elements in a variety of ways. For example, you can 

display and rearrange the toolbars, display the command bar, and enable the status bar. The 

toolbars and command bar can also be floated anywhere on the screen or docked to the edges of 

the main ZWCAD+ window. You can customize the menu bar at the top of the window. 

The Application Menu: Click the application button to search for commands 

and have an access to tools used for creating, opening and publishing a 

file. 

The Ribbon: A palette that displays task-based tools and controls. 

Quick Access Toolbar: Display the frequently used tools. 

Menu Bar: You can customize the menu bar at the top of the window. 

Toolbars: You can customize the toolbars, changing the appearance and 

arrangement of tools and adding your own commands and macros. The toolbars 

can be moved and docked to any location on your screen. 

Drawing Area: Your drawings are displayed in the drawing window. 

User Coordinate System (UCS): The icon indicates the orientation of the 

drawing in two dimensional space (default setting). 

Model Space and Layout Space tabs: Click a tab to switch between the 

drawing of your model and a printed layout. 

The Command Window: You can type commands in the command bar. To 

reposition the command bar, drag it to another location on your screen. 

Properties tab: You can modify the value you wanted in each column. 
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Status Bar: Display information such as the current cursor coordinates, and 

mode settings. 

 

Topics in this section: 

 The Application Menu 

Use the button to search for commands and have an access to tools used for creating, opening and 

publishing a file. 

 The Ribbon 

A palette that displays task-based tools and controls. 

 Quick Access Toolbar 

Frequently used tools in the drawing. 

 Menus and Shortcut Menus 

You can use menus and shortcut menus for access to frequently used commands, settings, and 

modes. 

 Toolbars 

Use buttons on toolbars to start commands, display flyout toolbars, and display tooltips. You can 

display or hide, dock, and resize toolbars.  

 The Command Window 

Display commands, system variables, options, messages, and prompts. The Command Window can 

be docked and resized.  

 Dynamic Input 

Users can make the dynamic input box move with the cross cursor, and display command and 

system variable interface dynamically near the cursor so as to focus on the drawing area. 

 Customize the Drawing Environment 

In ZWCAD+, many elements of the working environment can be customized to fit your needs. 

 Tool Palettes  

Tool Palettes provide an efficient tool that is used to organize, share, and place command, block as 

well as other tools. With Tool Palettes, you can organize blocks and commands in a window in 

order to use them efficiently. 

2.1 The Application Menu 

Click the application button to search for commands and have an access to tools used for creating, 

opening and publishing a file. 
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Search for commands 

Provide tools used for searching for commands quickly. You can search for commands on the Quick 

Access toolbar, in the application menu, and on the ribbon. 

The search results will be directly displayed in the application menu. You can enter any language for 

searching. 

 

Access frequently used tools 

The frequently used buttons in the application menu include those common tools used for starting 

or publishing a file, such as: New, Open, Etransmit, Save, Save as, Plot, Plot Preview, Close, Options, 

etc. 

NOTE You can close ZWCAD+ by double clicking the Application button. 

Browse files 

View the Recent Documents and Opened Documents lists, or view the thumbnail of an opened file. 
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You can sort the recently used files by the following four ways in the Recent Documents. 

 By Ordered List 

 By Access Data 

 By Size 

 By Type 

You can display the list of current opened files by using the Large Icons and Small Icons in the 

Opened Documents; or you can display the thumbnails of current opened files by using the Large 

Images and Small Images. 
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NOTE Only saved files can be displayed in the Opened Documents list. 

 

Commands Reference 

OPTIONS: Customize the ZWCAD+ settings 

System Variables Reference 

None 

2.2 The Ribbon 

The ribbon will be displayed when you open a file, providing a tool desired for creating and 

modifying drawings. 

The ribbon consists of several panels, which are organized into each tab according to their task 

label. The tools and controls in each panel are also available in toolbars and dialog boxes. 

If you click the arrow in the lower right corner of the panel, a dialog box related to this panel will be 

opened. 

On the panel, multiple radio buttons can be collapsed into a single button. If you click the arrow on 

the left or at the bottom of the button, all tool buttons in the list will be displayed in a drop-down 

method. If you click the button in the list, the previous button will be replaced by this button. 

 

 

Some ribbon panels display a dialog box related to that panel. You can click the launch button ( ) 

in the lower right corner of the panel to display the corresponding dialog box. 
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Display and hide ribbon panel 

You can display or hide the ribbon panel by clicking the drop-down button ( ) near the ribbon 

tab. 

 

 

Expand a panel 

You can expand a panel and display other function buttons and controls by clicking the drop-down 

button ( ) at the bottom of the ribbon panel. 

 

 

Contextual Ribbon Tabs 

When you execute some commands or choose objects of a certain type, a special contextual ribbon 

tab is displayed in the Ribbon interface instead of a toolbar or dialog box in the Classic interface. 

When you end the command, the contextual tab is closed. 
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Radio Buttons 

A radio button can be used to toggle the button displayed currently. That means you can display all 

function buttons in the drop-down list of a radio button by cycling through the list. 

 

 

 

Switch between Ribbon and Classic menu 

Users can easily switch between ribbon and classic menus through the button in the status bar 

at the bottom of the platform. The task-based workspace 2D Drafting & Annotation is defined by 

default in ZWCAD+ 2015. 

 

Commands Reference 

OPTIONS: Customize the ZWCAD+ settings 
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System Variables Reference 

None 

2.3 Quick Access Toolbar 

Display the buttons of nine frequently used tools, which are: New, Open, Save, Save As, Plot, Plot 

Preview, Undo, Redo and Help. 

 

 

 

 

Commands Reference 

QNEW: Opens the Select Template dialog box to create a new drawing file 

OPEN: Opens an existing drawing file 

QSAVE: Saves the current drawing 

SAVEAS: Saves a copy of the current drawing under a new file name 

PLOT: Plots a drawing to a plotter, printer, or file 

PREVIEW: Previews the plot effects of the current drawing file 

U: Reverses the last operation 

MREDO: Reverses the effects of several previous UNDO or U commands 

HELP: Displays on-line help information window 

System Variables Reference 

None 

2.4 Menus and Shortcut Menus 

Menus 

You can use any of the option on the Menus ( ) from the menu bar at the top of the ZWCAD+ 
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drawing area. Choose one of the following methods to use a menu: 

On the menu bar, click a menu name to choose the menu or to expand a list of options; you can 

also use the UP ARROW (↑), DOWN ARROW (↓), LEFT ARROW (←) and RIGHT ARROW (→) to 

move to and expand the menu, and then press ENTER to select the menu. 

In the Classic interface, press Alt and the key for the underlined letter in the menu name to open 

the corresponding menu item list, and then choose menu items from it. For example, to edit the 

drawing file, press <Alt+E> to open the Edit menu.  

You can create a new menu with the path you specified (for example, a customized menu) in the 

Options dialog box, Files tab. 

Shortcut Menus 

Shortcut menus provide quick access to specific commands. A shortcut menu displays when you 

right click an object, toolbar, status bar, the Model tab name, or a Layout tab name. The selections 

presented in the shortcut menu depend on what you clicked. 

When you right click a toolbar, the program displays a shortcut menu that lets you toggle the 

command bar, status bar, and various toolbars on and off. If you select one or more objects and 

then right click, the program displays a shortcut menu from which you can choose a command to 

modify the selected objects.  

To quickly access the relevant commands currently performed, you can right click on different area 

on the drawing window to display different shortcut menu, with the shortcut menu you can speed 

up the access. 

If you have entered commands or system variables, right click on the command line to perform the 

command or system variable automatically, without displaying the shortcut menu. 

To display a short cut menu from which you can choose an object snap and track, press and hold 

down the Shift key, and then right click anywhere within the drawing window. 

Recent Input 

"Recent Input" option is used for recording the recent manipulations, from the Recent Input list on 

right click menu, you can view the latest manipulations as well as the previous command options, 

and also manipulate commands by directly selecting from the recent input list. System variable 

INPUTHISTORYMODE is used for controlling its content, value from 0 to 15. If INPUTHISTORYMODE 

is set to 0, you cannot see the Recent Input option on right click menu, thus you can't view the 

latest input; if you set the INPUTHISTORYMODE to a value within 0-15, latest input records are 

displayed orderly. System variable CMDINPUTHISTORYMAX is used for controlling how many items 

to be displayed in the Recent Input menu option. You can set the value from 0 to 20; generally use 

the maximum as 20. Any value that is smaller than the maximum determines the number of items 

to be displayed on the right click menu. 

The contents displayed in the Recent Input menu option differs under various circumstances. For 

example, right click on the screen if there is no manipulation currently used, the latest commands 

ever manipulated will be displayed by the latest precedence orders. When right click in the process 

of a certain command, Recent Input displays items specific to the current manipulation such as 

coordinates, angle, length or relevant keyword. In case that current manipulation is not relative to 

any of the recent input, Recent Input option will not displayed on right click menu. 
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Commands Reference 

COPYCLIP: Copies objects to the Clipboard 

CUTCLIP: Copies objects to the Clipboard and removes the objects from the drawing  

GROUPUNNAME: Creates unnamed group. 

MENULOAD: Loads partial menu files 

MENUUNLOAD: Unloads partial menu files 

OPTIONS: Customizes the ZWCAD+ settings 

OSNAP: Sets running object snap modes 

PAN: Moves the view in the current viewport 

PASTECLIP: Inserts data from the Clipboard 

PROPERTIES: Controls properties of existing objects 

TRAYSETTINGS: Controls the display of icons and notifications in the status bar tray 

U: Reverses the most recent operation 

UNGROUP: Cancels grouping for entities. 

ZOOM: Increases or decreases the apparent size of objects in the current viewport 

System Variables Reference 

PICKFIRST: Controls whether you select objects before (noun-verb selection) or after you issue a 

command 

SHORTCUTMENU: Controls whether Default, Edit, and Command mode shortcut menus are 

available in the drawing area 

TRAYICONS: Controls whether a tray is displayed on the status bar 

TRAYNOTIFY: Controls whether service notifications are displayed in the status bar tray 
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TRAYTIMEOUT: Controls the length of time (in seconds) that service notifications are displayed 

INPUTHISTORYMODE: Controls what to be displayed in recent input option on right click menu. 

CMDINPUTHISTORYMAX: Setups maximum of recent input history in command line. 

2.5 Toolbars 

Toolbars partially contain buttons that start commands. When you move your mouse or pointing 

device over a toolbar button, the tooltip displays the name of the button. 

The Standard toolbar at the top of the drawing area is similar to that found in Microsoft® Office 

programs. It contains commonly used ZWCAD+ commands such as COPY, PAN and ZOOM, as well as 

Microsoft Office standard commands such as New, Open, and Save. 

The ZWCAD+ classic menu initially displays several toolbars by default: 

Standard toolbar 

Styles toolbar 

Layers toolbar  

Properties toolbar 

Draw toolbar 

Modify toolbar 

You can display or hide these toolbars and additional ones. Using +CUSTOMIZE command, you can 

also create your own toolbars. 

You can move the floating command window anywhere on the screen and resize its width and 

height with the pointing device. Dock the command window by dragging it until it is over the top or 

bottom docking region of the ZWCAD+ window, but you can't change its size. 

Displaying and hiding toolbars 

When you start ZWCAD+ classic interface at the first time, multiple toolbars are displayed. ZWCAD+ 

provides more than a dozen toolbars, which you can customize by adding and deleting tools in both 

classic and ribbon interfaces. You can also move and resize toolbars, and you can create new 

toolbars. You can use a shortcut menu to display or hide toolbars. 

To choose which toolbars to display 

Execute TOOLBAR command to open the Toolbar tab in the Customize dialog box. 

Choose the toolbars you want to display in the Customize dialog box, and then click OK. 

TIP Right click anywhere on a docked toolbar to display the toolbar shortcut menu, and then 

choose Toolbars. 

 

Starting commands using toolbars 

To start a command from a toolbar, click a command button and respond to the prompts. 
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Commands Reference 

TOOLBAR: Displays, hides and customizes toolbars 

CUSTOMIZE: Customizes toolbars, buttons, shortcut keys 

System Variables Reference 

TOOLTIPS: Controls the display of tooltips 

2.6 The Command Window 

The command bar is a dockable window in which you can type ZWCAD+ commands and view 

prompts and other program messages. You can move the command bar by dragging it. 

When the command bar is floating, you can drag the top or bottom of the window to change the 

number of lines of text it displays. You can dock the command bar at the top or bottom of the 

drawing. 

Displaying and hiding the command line window 

 Please choose Tools » Palettes » Command Line on the ribbon. 

 You can execute COMMANDLINE/COMMANDLINEHIDE command to 

display or hide the command line in both classic and ribbon interfaces. 

 

Topics in this section: 

 Enter Commands or System Variables 

You can enter a command or system variable by using the keyboard. System variables are settings 

that control how certain commands work. Some commands also have abbreviated names called 

command aliases. 

 Edit Within the Command Window 

You can navigate and edit text in the command window to correct or repeat commands. 

 Switch between Dialog Boxes and the Command Line 
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You can display prompts on the command line instead of using a dialog box, or switch back again. 

This option is useful primarily when using scripts. 

 Enter Commands or System Variables 

Type a command or system variable by using the keyboard. System variables are such parameters 

that are available for controlling how certain commands work. 

Enter Commands on the Command Line 

Type the full command name on the command line and press ENTER or SPACEBAR, or right-click 

your pointing device to start the command. 

Some commands also have abbreviated names. Abbreviated command names are called command 

aliases. 

Specify Command Options 

Once you have entered a command on the command line, ZWCAD+ displays either a set of options 

or a dialog box. To choose a different option, enter one of the options in the brackets (either 

uppercase or lowercase letter is OK), and then press ENTER or SPACEBAR. 

Execute Commands 

To execute commands, press SPACEBAR or ENTER, or right-click your pointing device when the 

command names has been entered or responsive to prompts. 

Repeat and Cancel Commands 

If you want to repeat a command that you have just used, press ENTER or SPACEBAR. 

To cancel a command in progress, press ESC. 

To repeat the command you just used 

Do one of the following: 

Press SPACEBAR. 

Press ENTER. 

Right-click in the drawing. 

Nesting a command 

If you are working in the command bar, you can use another command from within a command, 

called nesting. This kind of command is also known as a transparent command. To use a command 

inside an active command, type an apostrophe before you type the command, such as 'circle, 'line, 

or 'pyramid. You can nest commands indefinitely in ZWCAD+. Many menu and toolbar macros work 

this way by default; for example, select color, reference grid, zoom, and snap. When you have 

finished with the nested command, the original command resumes. 

For example, you turn on the object snap while you are drawing a circle, thus you can setup Object 

snap mode before continuing drawing. 
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Command: circle 

Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 'osnap 

(Setup object snap mode as Center in Draft Settings dialog, and then close the 

dialog to go on performing CIRCLE command) 

Specify center point for circle or [3P/2P/Ttr (tan tan radius)]:  

Enter System Variables on the Command Line 

System variables are available for controlling how certain commands work. For example, 

GRIDMODE is used to control the status ON or OFF for "SNAP", "GRID" or "ORTHO" mode; 

sometimes you use a system variable in order to change a setting. System variable can be used to 

display the current status as well. 

While using another command; you can examine or change a system variable's setting 

transparently. However, new values may not take effect until the interrupted command ends.  

 

Commands Reference 

COPYCLIP: Copies objects to the Clipboard 

MULTIPLE: Repeats the next command until canceled 

OPTIONS: Customizes the ZWCAD+ settings 

PASTECLIP: Inserts data from the Clipboard 

SETVAR: Lists or changes the values of system variables 

System Variables Reference 

CMDNAMES: Displays the names of the active and transparent commands 

 Edit Within the Command Window 

Navigating and Editing Within the Command Window 

The standard keys below are provided for navigating and editing text in the command window to 
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correct or repeat commands. 

UP ARROW (↑), DOWN ARROW (↓), LEFT ARROW (←) and RIGHT ARROW (→) 

INS (Insert), DEL (Delete) 

PAGE UP, PAGE DOWN 

HOME, END 

BACKSPACE 

Using UP ARROW (↑), DOWN ARROW (↓) and pressing ENTER, you can repeat any command used 

in the current session by cycling through the commands in the command window. 

By default, pressing CTRL+C copies highlighted text to the Clipboard. Pressing CTRL+V pastes text 

from the Clipboard to the text window or the command window. 

If you right-click on the command window or text window, ZWCAD++ displays a shortcut menu 

from which you can copy selected text or the entire command history, select those recently used 

commands, paste text, and access the Options dialog box of the Command window. 

In general, a command line with two or three lines of previous prompts is given to several 

commands, called the command history, which is sufficient for viewing and editing. To see more 

than one line of command history, you can scroll through the history or resize the command 

window by dragging its border upwards, or you can press F2 to use the text window. 

The text window is a window similar to the command window in which you can enter commands 

and view prompts and messages. With a complete command history for the current ZWCAD+ 

session displayed, the text window can be used to view lengthy output of commands such as LIST, 

which displays detailed information about objects you select. 

Docking and Resizing the Command Window  

By default, the command window is docked. The docked command window is the same width as 

the ZWCAD+ window. 

You can resize the window vertically by dragging the splitter bar, which is located on the top edge 

of the window when it is docked on the bottom and at the bottom edge of the window when it is 

docked at the top. 

Undock the command window by dragging it away from the docking region. When you undock the 

window, the floating window is the size it was before you undocked it. You can move the floating 

command window anywhere on the screen and resize its width and height with the pointing 

device. 

Dock the command window by dragging it until it is over the top or bottom docking region of the 

ZWCAD+ window. 

Modifying a Command 

If you are working in the command bar, there are several ways that you can modify a command as 

you work. You can modify the active command using any of the following options: 

Object snaps — Type an object snap command, such as nearest or midpoint, to enable a 

one-time object snap for a single selection. You can also use a one-time object snap to override a 

running object snap. 
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Extension snaps — Type int after selecting a command, such as Line or Circle, to enable a 

one-time snap to the logical location where two objects would intersect if they were of infinite 

length. Type app to enable a similar one time snap if the extensions would not intersect in three 

dimensional space but would intersect in the current view. 

Using the Prompt History Window 

The Prompt History window displays a history of the commands and prompts issued since you 

started the current session of ZWCAD+. By default, the program tracks up to 256 command lines. 

There is no limit to the number of command lines you can track, but program performance may be 

degraded if you choose to track an excessively high number of lines. 

To display or close the Prompt History window 

Press F2. 

To view entries in the Prompt History window 

Do one of the following: 

Drag the scroll bars. 

Use the Up (↑) and Down (↓) arrows to display previously used commands. 

To copy or paste text in the Prompt History window 

If you want to copy text from the text window, do one of the following to get the text field that you 

want: 

Highlight text using your mouse. 

Press Ctrl + Shift + arrow keys to highlight the desired text. 

Right-click and choose whether to copy or paste in the pop-up shortcut menu. 

TIP You can also copy the entire command history by choosing Copy History. 

 

Commands Reference 

GRAPHSCR: Closes the text window 

LOGFILEOFF: Closes the log file opened by LOGFILEON  

LOGFILEON: Writes the text window contents to a file 

System Variables Reference 

LOGFILEMODE: Specifies whether the contents of the text window are written to a log file  

LOGFILENAME: Specifies the path and name of the log file for the current drawing  

LOGFILEPATH: Specifies the path for the log files for all drawings in a session 
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 Switch between Dialog Boxes and the Command Line  

Some functions are both provided similarly though the command line and from a dialog box. In 

many cases, you can enter a hyphen in front of the command to suppress the dialog box and 

display prompts on the command line instead. 

For example, entering LINETYPE on the command line displays the Linetype Manager. Entering 

-LINETYPE on the command line displays the equivalent command line options. There may be tiny 

differences between the options in the dialog box and those available on the command line. 

The system variables below affect the display of dialog boxes as well: 

ATTDIA controls whether INSERT uses a dialog box for attribute value entry. 

EXPERT controls whether certain warning dialog boxes are displayed. 

FILEDIA controls the display of dialog boxes used with commands that read and write files. For 

example, if FILEDIA is set to 1, OPEN displays the Open Drawing As dialog box. If FILEDIA is set to 0, 

OPEN displays prompts on the command line. Even when you set FILEDIA to 0, you can get a file 

dialog box displayed through entering a tilde (~) at the first prompt.  

 

Commands Reference 

None 

System Variables Reference 

ATTDIA: Controls whether the INSERT command uses a dialog box for attribute value entry  

CMDNAMES: Displays the names of the active and transparent commands 

EXPERT: Controls whether certain prompts are issued  

FILEDIA: Suppresses display of the file dialog boxes 

2.7 Dynamic Input 

"Dynamic input" box is a floating window which appears near the cross cursor in the 

implementation of any drawing command or system variable. It provides a convenient method for 

users to input commands or system variables dynamically and display the index information. 

When the DYN mode is turned on, a drop-down box will appear near the cross cursor, displaying 

the index information of commands and system variables dynamically. This information updates 

dynamically when the cursor moves. There is no dynamic input box appearing in the drawing area if 

you don’t implement commands and system variables. 

 

Commands Reference 

None 
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System Variables Reference 

ZWCMDLINE: Turns on or off dynamic input function 

2.8 Customize the Drawing Environment 

In ZWCAD+, many elements of the working environment can be customized to fit your needs. 

Topics in this section: 

 Set Interface Options 

You can change many of the settings that affect the ZWCAD+ interface and drawing environment. 

 Save and Restore Profiles 

You can create profiles for different users or projects and share profiles by importing and exporting 

profile files.  

 Set Interface Options 

In the Options dialog box, you can change many of the settings that affect the ZWCAD+ interface 

and drawing environment. 

Settings of modifying interface: 

Automatic Save (Open and Save tab) — Save your drawing at specified time intervals. To use this 

option, in the Options dialog box, Open and Save tab, select Automatic Save and enter the interval 

in minutes. 

Color (Display tab) — Specify the background colors used in the layout and Model tabs and the 

color used for prompts and crosshairs. 

Font (Display tab) — Change the fonts used in the ZWCAD+ window and in the text window. This 

setting does not affect the text in your drawings. 

Search Path (Files tab) — Set the search path ZWCAD+ uses to find drawing support files such as 

text fonts, drawings, linetypes, and hatch patterns. 

Interface color (Change Skins menu) — Set ZWCAD+ window skins. 

Controlling size and position of each toolbar or window 

After starting ZWCAD+, you can fix or adjust position and size of each toolbar or window by 

dragging. Software interface includes toolbar, command window, "Properties" palette, "Quick 

Calculator" window, "Design Center" window, and so on. 

Controlling position of toolbar 

Toolbars can be floating or fixed. The floating toolbar locates in arbitrary location of the drawing 

area of ZWCAD+ window, can be dragged to its new location, adjust its size or fixed. Fixed toolbar 
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attaches to any of the edges in drawing area. Once the toolbar is fixed, its size can't be adjusted. 

You can remove the fixed toolbar by dragging it to a new fixing position. 

Controlling size and position of other windows 

When dragging the command window, "Properties" palette and "DesignCenter" window, buoys will 

be displayed in the corners and center position of the drawing area. If not select buoys but 

dragging the selected window to an arbitrary position of the drawing area, the window will be on 

floating state, which users can adjust the size of the window based on the actual needs. If click on 

the one of the buoys in the process of dragging, the location of the window will be fixed to the top, 

bottom and left side or right side of a fixed region of ZWCAD+ window. At this time, the size of 

window can be adjusted in only one direction. 

Displaying commands on a shortcut menu 

Shortcut menus provide quick access to specific commands. A shortcut menu displays when you 

right click an object, toolbar, status bar, the Model tab name, or a Layout tab name. The selections 

presented in the shortcut menu depend on what you clicked. 

When you right click a toolbar, the program displays a shortcut menu that lets you toggle the 

command bar, status bar, and various toolbars on and off. If you select one or more objects and 

then right click, the program displays a shortcut menu from which you can choose a command to 

modify the selected objects. To display a short cut menu from which you can choose an object snap, 

press and hold down the Shift key, and then right click anywhere within the drawing window. 

Using the command bar 

The command bar is a dockable window in which you type ZWCAD+ commands and view prompts 

and other program messages. To display the command bar, choose Tools > Command Line. You can 

move the command bar by way of dragging. 

When the command bar is floating, you can drag the top or bottom of the window to change the 

number of lines of text it displays. You can dock the command bar at the top or bottom of the 

drawing. 

Using the status bar 

If you elect not to use the command bar, the status bar displays information about the selected 

command or tool. It also displays the current cursor coordinates, mode settings, and other 

information about current settings. 

In addition to displaying information, the status bar is a quick way to access many features. 

You can click status bar items to make changes, and right click items to display short cut menus that 

allow you more choices. 
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A Cursor Coordinates (x,y,z). 

B Snap Mode. Left click to toggle on or off.  

C Grid Display. Left click to toggle on or off. 

D Ortho Mode. Left click to toggle on or off. 

E Polar Tracking. Left click to change colors. 

F Object Snap. Left click to select object snaps on or off. 

G Object Snap Tracking. Left click to toggle on or off. 

H Dynamic input. Left click to toggle on or off. 

I Show/Hide Lineweight. Left click to toggle on or off. 

J Cycle select. Left click to toggle on or off. 

K Model or Paper space. Left click to toggle between model space and paper space. 

To change the items that display on the status bar 

1. Right click an empty area of the status bar. 

2. Select an item to add or remove it. 

To change the setting of an item on the status bar 

Right click the status bar item you want to change, and then select the desired setting. 

 

Commands Reference 
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LOGFILEOFF: Closes log file opened by LOGFILEON command 

LOGFILEON: Writes contents of text window into files 

OPTIONS: Customizes the ZWCAD+ settings 

VIEWRES: Sets the resolution for objects in the current viewport 

System Variables Reference 

APERTURE: Sets the display size for the aperture, in pixels 

CURSORSIZE: Determines the size of the crosshairs as a percentage of the screen size  

DCTCUST: Displays path and file name of current customized spelling dictionary 

DCTMAIN: Displays file name of current major spelling dictionary 

DEFPLSTYLEE: Specifies default print style for new objects 

EXTNAMES: Sets parameters for named objects stored in definition list (such as linear and layers) 

FILLMODE: Specifies whether hatches (including solid-fill), two-dimensional solids, wide polylines, 

are filled in 

GRIPBLOCK: Controls the assignment of grips in blocks 

GRIPCOLOR: Controls the color of non-selected grips 

GRIPHOT: Controls the color of selected grips 

GRIPS: Controls the use of selection set grips for the Stretch, Move, Rotate, Scale, and Mirror Grip 

modes 

INSUNITS: Specifies graphics units for blocks dragged from Design Center and inserted into the 

drawing or the automatic scaling of images 

INSUNITSDEFSOURCE: Sets units value for contents of source  

INSUNITSDEFTARGET: Sets units value for objective drawing  

ISAVEBAK: Raise preservation speed of incremental, especially for large-scale graphics  
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ISAVEPERCENT: Specifies total wear space allowed in the graphics document 

LOCALE: Displays language code of ISO in current versions 

LOGFILEMODE: Specifies whether to write the contents of text window into log files 

LOGFILENAME: Specifies log file path and name for current graphics 

LOGFILEPATH: Specifies log file path and name for all graphics in a drawing 

MTEXTED: Sets primary and secondary text editor for mtext objects 

OLEQUALITY: Sets default print quality of OLE objects  

OLESTARTUP: Controls whether to load source applications when embedding OLE objects 

OSNAPCOORD: Controls whether to alternative object snap by entering coordinates from the 

command line 

PAPERUPDATE: Controls display of warning dialog box (if attempt to print layout with default 

specified drawing size in an approach different from print configuration file) 

PICKADD: Controls whether subsequent selections replace the current selection set or add to it  

PICKAUTO: Controls automatic windowing at the Select Objects prompt  

PICKBOX: Sets the object selection target height, in pixels 

PICKDRAG: Controls the method of drawing a selection window  

PICKFIRST: Controls whether to select object before or after the implementation of command 

(select objects first, next execute command) 

PICKSTYLE: Controls the use of grouping select and associate hatch select 

PSTYLEPOLICY: Controls whether color property of the object is associated with the print style 

QTEXTMODE: Controls how text is displayed 

RASTERPREVIEW: Controls whether to save BMP preview images together with the drawing 

SAVEFILE: Stores the current automatic save file name 

SAVEFILEPATH: Specifies the path to the directory for all automatic save files for the current 
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session 

SAVETIME: Sets the automatic save interval, in minutes  

SDI: Controls whether the program runs in single- or multiple-document interface 

SELECTIONCYCLING: Turns on or off cycle select function 

TDUSRTIMER: Stores the user-elapsed timer  

VISRETAIN: Controls visibility, color, linear, linewidth and print styles of layers dependent on 

external reference  

XLOADCTL: Controls to turn on or off demand-loading, and using whether referenced file or its 

copies when demand-loading Xref files 

ZWCMDLINE: Turns on or off dynamic input function 

 Save and Restore Profiles 

Creating profiles for different users or projects and sharing profiles by importing and exporting 

profile files are enabled in ZWCAD+. 

By default, your current options are stored in a profile named Default. The current profile name, as 

well as the current drawing name, is displayed in the Options dialog box in ZWCAD+. 

ZWCAD+ stores the profile information in the system registry and saves it as a text file (an ARG file). 

ZWCAD+ also organizes essential data and maintains changes in the registry as required. 

If you make changes to your current profile during a ZWCAD+ session and you want to save those 

changes in the ARG file, you must export the profile. When you export the profile with the current 

profile name, ZWCAD+ updates the ARG file with the new settings. You can re-import the profile 

into ZWCAD+ to update your profile settings. 

 

Commands Reference 

OPTIONS: Customizes the ZWCAD+ settings 

System Variables Reference 

CPROFILE: Displays the name of the current profile  

 Tool Palettes 

Tool Palettes provide an efficient tool that is used to organize, share, and place commands, blocks 

as well as other tools. With Tool Palettes, you can organize blocks and commands in a window in 

order to use them efficiently. The default tool palettes of ZWCAD+ are: Command Tool Samples, 
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Architectural, Draw, Electrical, Hatch Patterns, Mechanical, Modeling and Modify. 

You can configure tool palettes with the shortcut menus by right-clicking on the different areas of 

the Tool Palettes window. For example, with the shortcut menu, you can add, rename, or delete 

tool palettes, as well as copying a tool on the current tool palette to another palette. 

The objects that are created using a tool from the Tool Palettes have the same properties as the 

objects you create from the menu or toolbar. To run a command, click the desired tool on the Tool 

Palette. For example, you can create a line by clicking the line tool. 

When you click an arrow next to a tool, all other tools that have the similar properties are displayed. 

The objects that are created using a tool on a tool flyout have the same properties as the objects 

you created from the original tool.  

You can create a block tool by dragging a block out of an exterior file to the current tool palette 

performed from the Design Center. The items to be added to a tool palette are called Tool. By 

clicking the block tool, you can insert the block into your current drawing. 

ZWCAD+ supports using existing entities as tools via adding the entity to the tool palettes. You can 

firstly select the entity to be used as tool from the drawing area, select Copy from right click menu, 

and then right click on anyone of the palettes or current palette, select Paste option, thus a tool is 

created. Currently supported entities are arc, defined attributes, circle, ellipse, line, 2D and 3D 

polyline, mline, mtext, point, 3Dmesh, ray, region, 2Dsolid, spline curve, text, tolerance, trace, 

construction line wipeout and so on. 

Once you have added geometric entities (circle, line, polyline, etc.) to a tool palette by way of copy 

and paste, a new tool list with flyout will be automatically generated on the palettes. For example, 

a triangle will be displayed on the new geometric entity icon, click this triangle to flyout tool list 

containing lines, construction line, polyline, circle, etc. 

The changes made to the Tool Palettes are saved as a configuration file automatically, which are still 

available when you launch ZWCAD+ again. 

 

Commands Reference 

TOOLPALETTES: Opens Tool Palette window 

TOOLPALETTESCLOSE: Closes Tool Palette window 

System Variables Reference 

PALETTEOPAQUE: Controls the transparence of the Tool Palette window  
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3 Create and Save a Drawing 

 

 

 

 

Topics in this section: 

 Create a New Drawing 

Use several methods to create a new drawing. 

 Open an Existing Drawing 

Find and open one or more existing drawings, even damaged drawings.  

 Save a Drawing 

You save drawing files for later use just as you do with other Microsoft Windows applications. You 

can also set up automatic saving and backup files and save only selected objects. 

 Error Report 

An error report module will intercept any unhandled exception generated by ZWCAD+, build a 

complete debug report, and optionally send a crash report. 

3.1 Create a New Drawing 

When the system variables FILEDIA and STARTUP are set to 1, typing NEW opens Create New 

Drawing dialog box, from which you can use Default Setting, Template or Wizard to create a new 

drawing. 

When the FILEDIA and STARTUP are set to 1 and 0 separately, typing NEW opens Select Template 

dialog box, from which you can select the desired one or use the default template by clicking the 

arrowhead button next to the Open button. 

The default drawing template file can be set in the Templates Search Path from the Files tab in the 

Options dialog box. 

 

Topics in this section: 

 Start a Drawing from Scratch 

A quick way to begin a new drawing is to start from scratch, which starts a drawing that uses 

settings from a default drawing template file. 

 Use a Setup Wizard 

A setup wizard establishes basic drawing settings step by step. 
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 Use a Template File 

A drawing template file contains standard settings. Select one of the template files supplied, or 

create your own template files. 

 Start a Drawing from Scratch 

You can select either imperial or metric units for the new drawing if you choose Start from Scratch 

in the Create New Drawing dialog box. The setting you select determines default values which are 

used for many system variables controlling text, dimensions, grid, snap, and the default linetype 

and hatch pattern file. 

 Imperial. A new drawing with the imperial measurement system. The 

drawing uses internal default values, and the default boundary is 12 

× 9 inches. 

Metric. A new drawing with the metric measurement system. The drawing uses internal default 

values, and the default boundary is 429 × 297 millimeters. 

When you start ZWCAD+, there are three options for choosing to draw. You can start from scratch 

using default settings, you can start from a template file with a preset environment, or you can use 

a wizard to step you through the process, in each case, you can choose the conventions and 

defaults you want to use. 

 

Create a New Drawing 

You can create a new drawing quickly by using settings from a default drawing template file. 

To start a drawing from scratch with the Create New Drawing dialog box:  

On the File menu, click New. 

In the Create New Drawing dialog box, click Start from Scratch. 

Under Default Settings, click either Imperial or Metric. 

Standard toolbar:  

Command line NEW 

 

Commands Reference 

NEW: Creates a new drawing 

OPTIONS: Customizes the ZWCAD+ settings 

QNEW: Starts a new drawing with the option of using a default drawing template file 
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System Variables Reference 

FILEDIA: Suppresses display of the file dialog boxes 

MEASUREINIT: Sets the initial drawing units as imperial or metric 

MEASUREMENT: Sets drawing units as imperial or metric for the current drawing only 

STARTUP: Controls whether the Create New Drawing dialog box is displayed when starting a new 

drawing 

 Use a Setup Wizard 

From the Create New Drawing dialog box, you can select "Use a Wizard" tab to create a new 

drawing by the wizard. There are two wizard options illuminated as follows: 

Advanced Setup Wizard 

From this option, you can set units of measurement, precision of displayed units, and grid limits. 

Also specify angle settings such as units of measurement style, precision, direction, and orientation 

based on template zwcadiso.dwt. 

Quick Setup Wizard 

From this option, you can specify units of measurement, precision of displayed units, and grid limits 

based on template zwcadiso.dwt. 

 

To begin a new drawing using a wizard 

On the File menu, click New. 

In the Create New Drawing dialog box, click Use a Wizard. 

Click Quick Setup or Advanced Setup. 

Complete the wizard pages using the Next and Back buttons to move forward and backward. 

On the last page, click Finish. 

Standard toolbar:  

Command line NEW 

 

Commands Reference 

NEW: Creates a new drawing 
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System Variables Reference 

FILEDIA: Suppresses display of the file dialog boxes 

MEASUREINIT: Sets the initial drawing units as imperial or metric 

MEASUREMENT: Sets drawing units as imperial or metric for the current drawing only 

STARTUP: Controls whether the Create New Drawing dialog box is displayed when starting a new 

drawing 

 Use a Template File 

Drawing template files contain standard settings and have a ".dwt" file extension. 

There are two methods provided for creating a new drawing when the system variable FILEDIA is 

set to 1. 

When the STARTUP is set to 1, typing NEW opens Create New Drawing dialog box, from which you 

can select the desired template to create a new drawing if you click Use a Template tab. 

When the STARTUP is set to 1, typing NEW opens Select Template dialog box, from which you can 

select the desired template to create a new drawing. 

The changes made to a new drawing based on an existing template file do not affect the template 

file. 

Create a Drawing Template File 

When you need to create several drawings with the default settings, you can save time by creating 

a template file designed to create the same drawing files so that you does not need to specify 

default settings each time you start. Conventions and settings commonly stored in template files 

include: 

Unit type and precision 

Title blocks, borders, and logos 

Layer names 

Snap, Grid, and Ortho settings 

Grid limits 

Dimension styles 

Text styles 

Linetypes 

Recover the default drawing template file 

If you have changed the settings in the template file zwcad.dwt or zwcadiso.dwt, you can reset 

them by creating a new drawing with no template and then saving the drawing as a drawing 

template file in order to replace zwcad.dwt or zwcadiso.dwt. 

When the STARTUP is set to 0, you can also create a new drawing with the original defaults by 

clicking the arrowhead next to Open button to select one of the No Template options from the 
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Select Template dialog box. 

 

To start a drawing by selecting a template file 

On the File menu, click New. 

In the Select Template dialog box, select a template from the list and click Open. 

ZWCAD+ opens the drawing as drawing1.dwg. The default drawing name changes to reflect the 

number of new drawings that have been opened. For example, if you open another drawing from a 

template, the default drawing name is drawing2.dwg. If you want to start a new drawing with no 

template file, click the arrow next to the Open button and then click one of the "no template" 

options from the list. 

Standard toolbar:  

Command line NEW 

 

Commands Reference 

NEW: Creates a new drawing 

OPTIONS: Customizes the ZWCAD+ settings 

QNEW: Starts a new drawing with the option of using a default drawing template file 

System Variables Reference 

FILEDIA: Suppresses display of the file dialog boxes 

MEASUREINIT: Sets the initial drawing units as imperial or metric 

MEASUREMENT: Sets drawing units as imperial or metric for the current drawing only 

STARTUP: Controls whether the Create New Drawing dialog box is displayed when starting a new 

drawing 

3.2 Open an Existing Drawing 

You can open drawing (.dwg) files, Drawing Exchange Format (.dxf) files and drawing template 

(.dwt) files. 

You can also open and check drawings that you suspect are damaged. 

To open an existing drawing 

On the File menu, click Open. 
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In Files of Type, choose the type of file you want to open. 

Choose the folder containing the desired file. 

Do one of the following: 

Choose the drawing you want to open, and then click Open. 

Double click the drawing you want to open. 

If the drawing requires a password, enter the password, click OK to verify the password, and then 

click Open again. 

Standard toolbar:  

Command line OPEN 

TIP You can also open drawings while browsing files on your computer using 

programs that came with your operating system, such as Windows File Explorer 

or My Computer. Just double click the file to get it open in ZWCAD+. Easily 

find the drawing you want by viewing thumbnail images of the drawing files 

as you browse them. 

TIP To quickly open a drawing file that you recently used, choose File > 

<file name> from the main menu.  

 

Topics in this section: 

 Find and Open a Drawing File 

You can search for a drawing using name, location, and date filters or properties such as keywords 

that you added to the drawing. 

 Work with Multiple Open Drawings 

You can open more than one drawing in a single session. 

 Recover a Damaged File 

When a file is damaged, you can recover some or all of the data by reverting to a backup file or by 

using commands to find and correct errors.  

 Find and Open a Drawing File 

You can search for a drawing using name, location, and date filters or properties such as keywords 

that you added to the drawing. 
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Open drawing 

Uses Open on the File menu or Standard toolbar to open Select File dialog box, from which you can 

select the desired file. 

You can also open a drawing by dragging a drawing into anywhere outside the drawing area. 

However, if you drag a drawing into the drawing area of an open drawing, the new drawing is 

inserted into the open drawing as a block reference instead of opening it. 

You can also double-click drawing to launch ZWCAD+ program to open it. If ZWCAD+ is running, the 

drawing opens in the current session. 

Change the default drawing folder 

Each time you launch ZWCAD+, the path you specified to open a latest drawing is displayed in each 

standard file selection dialog box. You can also specify a default path to ZWCAD+ by changing the 

default drawing folder. 

Find a drawing file 

Clicking Tools > Find button from the Select File dialog box displays Find dialog box, from which you 

can search drawing through name, location and date filters. 

You can preview the selected drawing in the Select File dialog box. When the system variable 

RASTERPREVIEW is on, a preview image with BMP format is generated and saved with the drawing. 

Set the search path 

The Files tab of Options dialog box is used by ZWCAD+ to search drawing support files. The support 

files include text fonts, drawings, linetypes and hatch patterns. 

The system variable MYDOCUMENTSPREFIX is designed to store the location of My Documents 

folder for the current user. 

You can also specify the location of temporary files on the Files tab of the Options dialog box. 

Temporary files are created on the specified path and then deleted when you exit ZWCAD+ 

program. The default temporary folder is specified to the location that Microsoft Windows uses. 

You should specify another location for temporary files when you run ZWCAD+ in a write-protected 

director (for example, if you are working on a network or open files on a CD). The director must not 

be written-protected and can provide enough disk space for the temporary files. 

Add identifying information to drawings 

You can find the specified drawings more easily by adding keywords or other information to them 

in the Drawing Properties dialog box opened from the File menu. The drawing properties such as 

title, author, subject, keyword or other important information can help identify drawings more 

easily. You can also assign hyperlink addresses, director paths and multiple custom properties to 

your drawings. 

The Drawing Properties dialog box contains the following drawing information: 

General. It contains the drawing type, location, size and other information. These informations 
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are stored by the operation system and can be read-only. You can change these values only through 

Windows Explorer. 

Summary. This tap contains the drawing properties such as author, title and subject. 

Statistics. The drawing size, created date and latest modified date and other information are 

displayed in this tap. 

Custom. Specifies the custom file properties.  

 

Commands Reference 

OPEN: Opens an existing drawing file 

OPTIONS: Customizes the ZWCAD+ settings  

DWGPROPS: Sets and displays the properties of the current drawing 

System Variables Reference 

REMEMBERFOLDERS: Controls the default path for the Look In or Save In option in standard file 

selection dialog boxes 

MYDOCUMENTSPREFIX: Stores the full path to the My Documents folder for the user currently 

logged-on 

 Work with Multiple Open Drawings 

You can open multiple drawings at one time in ZWCAD+. There are several methods for switching a 

drawing to another. 

Acting the drawing by clicking it. 

Uses shortcut keys of <Ctrl+F6> or <Ctrl+Tab>. This option is not available while ZWCAD+ is running 

other command. 

You can change the display styles to Cascade, Title Vertically or Title Horizontally from the Window 

menu. You can also use Arrange Icons to align icons if there are several minimum drawings. 

You can quickly reference other drawings to copy and paste between drawings. You can also use 

Match command to copy properties from objects in one drawing to objects in another drawing. 

Object snaps, the Copy with Basepoint (COPYBASE) command, and the Paste to Original 

Coordinates (PASTEORIG) command is used to ensure accurate placement, especially when copying 

objects from one drawing to another. 
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Document Switch Preview 

In a Microsoft® Windows Vista or Microsoft® Windows 7 system, ZWCAD+ provides you the 

document switch preview function. 

When you hold down the <Ctrl+Tab> shortcut key, the document switch preview window will be 

displayed at the center of the main window of ZWCAD+ application. In this window, the previews of 

all opened drawings are displayed in order. The file name and file path of the current preview are 

also displayed. If you open too many drawings and the document switch preview window cannot 

display all these drawing previews on one page, you can roll the middle button of the mouse to 

page down. 

You can switch any preview to be the current one by using the following three methods while 

holding down Ctrl. Meanwhile, the large preview of the current preview will be displayed in the 

drawing area. 

 Press Tab continuously;  

 Press the ↑(Up), ↓(Down), ←(Left), →(Right), End and Home keys; 

 Select any preview using a pointing device. 

After you release Ctrl, the document switch preview window disappears and the current preview 

drawing is switched to the current drawing. 

NOTE The document switch preview function is only available after you 

opened three or more drawings. 

 

Commands Reference 

None 

System Variables Reference 

DOCSWITCHSTYLE: Determines whether to switch between opened drawings in the document 

switch preview method or not by controlling the behavior of the <Ctrl+Tab> shortcut key 

 Recover a Damaged File 

You can recover some or all of data by reverting to a backup file or using commands to find and 

correct errors if a drawing file is damaged. A drawing file may be damaged by a hardware failure, 

power outage and system crash. You can minimize loss by saving files frequently. 

ZWCAD+ can recover a slightly damaged drawing file while opening it. 
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If a drawing is damaged, you can use RECOVER command to check and attempt to open it. Then 

uses AUDIT command to find and correct errors. 

Though ZWCAD+ can recover a damaged drawing file, it is not sure that the recovery drawing is the 

same exactly as the original one. You had better create a backup file if the drawing is important. On 

the Open and Save tap of Options dialog box, you can specify the backup file are created when you 

save drawings and set the proper interval time for saving. Then a backup copy file with a ".bak" 

extension is created when you save the named drawing once again. After that, a backup file is 

always updated while you executing the command SAVE or SAVEAS. 

If ZWCAD+ exits unexpectedly, it attempts to rename the current backup file in order to avoid 

covering the original one. 

You can recover a drawing file by saving a ".bak" file to a ".dwg" file. 

Files can become damaged for many reasons. For example, if you are working on a drawing during 

a power outage, a system crash, or a hardware failure, your drawing file may become damaged. 

ZWCAD+ allows you to open and check damaged files to attempt file recovery. 

Recovering a file attempts to open one of the following file types: 

Standard drawing files with a ".dwg" extension. 

Drawing Exchange Format files with a ".dxf" file extension. 

Drawing templates with a ".dwt" file extension. 

You can also audit any open file to check it for errors. You specify whether you want ZWCAD+ to fix 

any errors that are found automatically. ZWCAD+ fixes as many errors as possible and any errors 

that cannot be fixed are reported as "Ignored" in the Prompt History window. 

To open a damaged file 

Choose File > Drawing Utilities > Recover from the main menu 

In Files of Type, choose the type of file you want to recover. 

Choose the directory containing the damaged file. 

Choose the damaged file you want to recover. 

Click Open. 

Command line RECOVER 

 

To check errors for a drawing file 

To choose from the opened drawing, click on File > Drawing Utilities > Audit from the main menu. 

Input Y or N to determine whether to fix the errors that are automatically found by ZWCAD+. If you 

input Y, a report similar to the following example is displayed at the command line prompt: 

Auditing Header 

DXF Name Current Value Validation Default 

DIMASO  1  0 or 1  1 
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DIMSHO  1  0 or 1  1 

Error found in auditing header variables 

1 Blocks audited 

Pass 1 2 objects audited 

Pass 2 2 objects audited 

Pass 3 100 objects audited 

Total errors found 2 fixed 2 

If you input N, the last statement changes to: 

Total errors found 0 fixed 0 

Command line AUDIT 

 

Drawing Recovery 

Once terminated by hardware problems, power failure or software problems, the application is 

capable of backup the opened drawing file. At the next startup, the program starts "Drawing 

Recovery" manager in which all of the auto-backup drawing files that have been closed accidentally 

will be displayed. You can open the file of your demand by double clicking at the Backup File list on 

the "Drawing Recovery", if there is any damage to the file, system attempts to recover the drawing 

in process of backup. 

When program or system stopped by accident, the drawing files need to recover are sorted into the 

following types. 

Recovered drawing file saved when program fails (DWG) 

Auto saved file, so called "auto-save" file (zw$) 

Backup file (BAK) 

Source drawing file (DWG)  
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Commands Reference 

AUDIT: Evaluates the integrity of a drawing 

OPTIONS: Customizes the ZWCAD+ settings 

RECOVER: Repairs a damaged drawing  

System Variables Reference 

AUDITCTL: Controls whether the AUDIT command creates an audit report (ADT) file 

3.3 Save a Drawing 

You save drawing files for later use just as you do with other Microsoft Windows applications. You 

can also set up automatic saving and backup files and save only selected objects. 

The file extension for drawing files is ".dwg", and unless you change the default file format in which 

drawings are saved, drawings are saved in the latest drawing-file format. 

After you have saved your drawing for the first time, you can save it with a new name. In addition 

to drawing (.dwg) files, you can also save a drawing in a Drawing Exchange Format (.dxf) file or a 

drawing template (.dwt) file. 

If you created your drawing using a template, saving the drawing does not alter the original 

template. 

To save a drawing 

Choose File > Save from the main menu. 

Command line SAVE 

TIP When you save a drawing the first time, the program displays the Save 

Drawing As dialog box so that you can choose a directory and type a name 

for the drawing. 

 

Save Your Drawing Automatically 

You can specify to save drawing files automatically in order to minimize the lost data once a 

problem occurs. 

If you start the automatic save option, your drawing is saved at specified time intervals. By default, 

system assigned the name filename.zw$ for temporarily saved files, filename here refers to current 

drawing name 

The temporary files are removed automatically when a drawing closes normally. However, these 

files are not deleted if there is a program failure or power failure. You can recover the drawing by 



 

 57 

reverting to a previous version of your drawing from the automatically saved file. In order to do 

that, you have to rename the file using a ".dwg" extension. 

Use Backup Files 

ZWCAD+ creates a backup file with the current drawing name and a ".bak" extension to save the 

previous version of the current drawing when launching "backup automatically" option. 

You can revert to the previous version of your drawing anytime using a ".dwg" extension in place of 

the .zw$ extension. 

Save Part of a Drawing File 

You can use BLOCK command or WBLOCK command to create a new drawing from part of an 

existing drawing. You can select entities or a block definition in your current drawing and save them 

in a new drawing file. The description also can be saved in the new drawing. 

Save to a Different Type of Drawing File 

Choose the format from Files of Type in the Save Drawing As dialog box, you can save a drawing to 

an earlier version of the drawing format (DWG) or drawing interchange format (DXF), or save a 

drawing as a template file. 

You can save a drawing with a new name and in any of the following file formats: 

Standard drawing files with a ".dwg" extension. You can choose a DWG file format that is 

compatible with various versions of AutoCAD. 

Drawing Exchange Format files with a ".dxf" file extension. You can choose a DXF file format that is 

compatible with various versions of AutoCAD. 

Drawing templates with a ".dwt" file extension. Drawing templates allow you to easily create new 

drawings that reuse your drawing settings and entities. 

To save a drawing with a new name or file format 

Choose File > Save As from the main menu. 

In the Save Drawing As dialog box, under Files of Type, choose the file format. 

Specify the name of the file you want to create. 

Click Save. 

Command line SAVEAS 

TIP You can also export drawing files to various file formats. 

 

Reduce the Time Required to Save a Drawing File 

In order to reduce the time of saving a drawing file, you can specify the incremental save 

percentage on the Open and Save tap of Options dialog box or from the ISAVEPERCENT system 

variable. 

The incremental save updates only the portions of the saved drawing file you changed. Drawing 

files will contain a percentage of potentially wasted space when you use incremental saves. This 
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percentage increases after each incremental save until it reaches the specified maximum value, and 

then a full save is perform. 

When the ISAVEPERCENT system variable is set to 0, all saves are full saves. This option required 

more time to save a drawing file but can reduce the size of drawing files. It is recommend you 

perform a full save before transmitting or archiving a drawing. 

 

Commands Reference 

BLOCK: Creates a block definition from objects you select  

OPTIONS: Customizes the ZWCAD+ settings 

QSAVE: Saves the current drawing 

QUIT: Exits the program  

SAVE: Saves the drawing under the current file name or a specified name 

SAVEAS: Saves a copy of the current drawing under a new file name  

WBLOCK: Writes objects or a block to a new drawing file 

System Variables Reference 

DWGCHECK: Determines whether the drawing is terminally edited by applications other than 

ZWCAD+ 

DWGNAME: Stores drawing name input by the user 

DWGPREFIX: Stores drawing file driver/directory prefix 

DWGTITLED: Indicates whether current drawing has been named 

ISAVEBAK: Improves saving speed, especially for drawings in large scale 

ISAVEPERCENT: Determines allowed usage capacity of drawing files 

RASTERPREVIEW: Controls whether BMP preview images are saved with the drawing 

SAVEFILE: Stores the current automatic save file name 

SAVEFILEPATH: Specifies the path to the directory for all automatic save files for the current 
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session 

SAVENAME: Stores the file name and directory path of the current drawing after you save it  

SAVETIME: Sets the automatic save interval, in minutes 

3.4 Error Report 

An error report module will intercept any unhandled exception generated by ZWCAD+, build a 

complete debug report, and optionally send a crash report. 

Sending error report may help assess the stability of ZWCAD+ software while working in user 

environment, and improve the quality of our product. When errors are encountered in the 

procedure of some programs, a dialog box pops up for the user to record the cause of the error and 

send error report automatically created by the software to the assigned email address so as to help 

us diagnose the cause of the error and improve our software. 

Once the software encounters exceptional shutdown, a folder named BugReport will be 

automatically generated under the catalog X:\Users\Current User\AppData\Roaming\CrashReport\ 

if your operating system is Microsoft Windows 7 (the catalog will be X:\Documents and 

Settings\Current User\Application Data\CrashReport\BugReport if your operating system is 

Microsoft Windows XP), in which all of the compressed packages generated for the exceptional 

situations are contained, with *.LOG, *.DMP, *.REG as well as error drawing files included in each 

package. Here LOG, REG and DMP files share the same name with the compressed package 

automatically generated. 

Describe Error Contents 

When errors occur in the program, a dialog box prompts "ZWCAD.EXE has encountered a problem 

and needs to close, we are sorry for the inconveniences" for the user to input descriptions of the 

problem in the text window showing "Describe what you were doing when the error occurred", 

whereas it is an optional requirement. 

View Contents of Error Report Files 

Generally, the software generates four error reporting files, individually named as *.LOG, *.DMP, 

*.REG and the crashed drawing file itself. In this error report dialog box, you can see the contents of 

error reports by clicking on the "Click here" link. You can optionally select a file in the "Error Report 

Contents" dialog box, or double click a file to view its contents. 

Send Error Report 

Clicks on "Send Error Report" button on the Error Reporting dialog box, then you can send the 

information of assigned error reports to CrashReport@zwcad.com as well as its problem 

descriptions. 

If the network isn't connecting, a prompt box pops up telling you that "The error report wasn't sent, 

please send the file to CrashReport@zwcad.com". From this prompt box, you can see the name of 

error report file together its saving path. 
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Don't Send 

Additionally, user can choose not to send error report. 

 

Commands Reference 

None 

System Variables Reference 

None 
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4 Control the Drawing Views 

 

 

Topics in this section: 

 Redraw and Regenerate a Drawing 

As you work on a drawing, visual elements may remain after the completion of a command. You 

can remove these elements by refreshing, or redrawing, the display. 

 Magnify a View (Zoom) 

You can use ZOOM command to zoom in or zoom out the drawing view to meet your need. ZOOM 

does not change the absolute size of objects in the drawing; it changes only the magnification of 

the view. 

 Pan a View 

Use PAN command or use the window scroll bars to shift the location of your view. 

 Display Multiple Views in Model Space 

Model space viewport is the drawing area that you can divide them into one or more adjacent 

rectangular views on the Model tap. Among multiple viewports, you have to make one view 

current for executing view commands. 

 Save and Restore Views 

You can save views by name and restore them for plotting or when you need to refer to specific 

details. A named view is comprised of specific magnification, location and orientation. 

 Specify a 3D View 

You can set a 3D view to facilitate verifying the 3D effects of the drawing, constructing and 

visualizing 3D models. 

4.1 Redraw and Regenerate a Drawing 

As you work on a drawing, visual elements may remain after the completion of a command. You 

can remove these elements by refreshing, or redrawing, the display. 

To redraw (refresh) the current window display 

Choose View > Redraw from the main menu. 
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Command line REDRAW 

Information about drawing entities is stored in a database as floating point values, ensuring a high 

level of precision. Sometimes a drawing must be recalculated, or regenerated, from the floating 

point database to convert those values to the appropriate screen coordinates. This occurs 

automatically. You can also manually initiate a regeneration. When the drawing is regenerated, it is 

also redrawn. 

To regenerate the current window, type REGEN in the command line. If more than one window is 

displayed, type REGENALL to regenerate all the windows. 

 

Commands Reference 

REDRAW: Refreshes the display in the current viewport and removes the marker blips from the 

current viewport 

REDRAWALL: Refreshes the displays in all viewport and removes the marker blips from all 

viewports. 

REGEN: Regenerates the current view and recomputes the screen coordinate for all entities in the 

current viewport 

REGENALL: Regenerates the current view and recomputes the screen coordinate for all entities in 

all viewports 

System Variables Reference 

None 

4.2 Magnify a View (Zoom) 

You can use ZOOM command to zoom in or zoom out the drawing view to meet your need. ZOOM 

does not change the absolute size of objects in the drawing; it changes only the magnification of 

the view. 

With this zooming feature, you can change the magnification of your drawing at any time. The 

cursor changes to a magnifying glass when a zoom tool is active. Zoom out to reduce the 

magnification so you can see more of the drawing, or zoom in to increase the magnification so you 

can see a portion of the drawing in greater detail. 

NOTE If you are working in a layout viewport and cannot zoom, the layout 

viewport may be locked. The scale and view do not change in model space 

while panning or zooming in a locked layout viewport. 

Zooming in and out 
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One of the easiest ways to change the magnification of the drawing is to zoom in or out by a preset 

increment. On the Zoom toolbar, the Zoom In tool doubles the current magnification of the 

drawing. The Zoom Out tool reduces the magnification of the drawing by half. The portion of the 

drawing located at the center of the current viewport remains centered on the screen as you zoom 

in and out. 

 

Zooming methods 

To zoom, you can use any of the following methods: 

To define the portion of the drawing to zoom, create a window. 

To zoom in real time, use the Zoom Realtime tool on the Standard toolbar. 

If you have a mouse with a wheel, rotate the wheel to zoom in and out. 

Zoom to Magnify a Specified Rectangular Area 

You can specify a rectangular area defined by two corners to display the objects within that area as 

large as possibly. 

The lower-left corner of the specified area becomes the lower-left corner of the new view. 

 

To zoom in to an area using a window 

Choose View > Zoom > Window from the main menu. 

Select one corner of the window around the area you want to magnify. 

Specify the opposite corner of the window around the area you want to magnify. 

Standard toolbar:  

Command line ZOOM 
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To specify a rectangular window around 

the area you want to magnify, select first 

one corner(A), and then select the 

opposite corner (B) 

Results 

 

Zoom in Real Time 

With the Realtime option, you zoom dynamically by moving your pointing device up or down. By 

right-clicking, you can display a shortcut menu with additional viewing options. 

To zoom in real time 

Choose View > Zoom > Realtime from the main menu. 

Hold the Ctrl and the left mouse button, then drag the cursor. 

To zoom in, move the cursor up the screen; to zoom out, move the cursor down the screen. 

To stop zooming, release the mouse button. 

Standard toolbar:  

Command line RTZOOM 

 

To zoom using a mouse with a wheel 

Rotate the wheel away from you to zoom in or toward you to zoom out. 

Each rotation of the wheel away from you zooms out .8 times; each rotation toward you zooms in 

1.25 times. 

 

Displaying the previous view of a drawing 

After you zoom in or pan to view a portion of your drawing in greater detail, you may want to zoom 

back out to see the entire drawing. On the View > Zoom menu, the Previous tool lets you restore 

the previous view. Selecting this tool repeatedly steps back through up to 25 successive zoomed or 

panned views. 

Zooming to a specific scale 

You can increase or decrease the magnification of your view by a precise scale factor measured 

relative to the overall size of the drawing or in relation to the current display. When you change the 
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magnification factor, the portion of the drawing located at the center of the current viewport 

remains centered on the screen. 

To change the magnification of the view relative to the overall size of the drawing, type a number 

representing the magnification scale factor. For example, if you type a scale factor of 2, the drawing 

appears at twice its original size. If you type a magnification factor of .5, the drawing appears at half 

its original size. 

You can also change the magnification of the drawing relative to its current magnification by adding 

an x after the magnification scale factor. For example, if you type a scale factor of 2x, the drawing 

changes to twice its current size. If you type a magnification factor of .5x, the drawing changes to 

half its current size. 

To zoom to a specific scale relative to the current display 

Do one of the following: 

Choose View > Zoom > Scale from the main menu. 

On the Zoom toolbar, click the Zoom Scale. 

Type ZOOM in the command line, choose the Scale option, and then press Enter. 

Type the scale factor, followed by an x (such as 2x). 

Press Enter. 

Zoom toolbar:  

Command line ZOOM 

 

Combining zooming and panning 

With the Center option, you can scale objects and specify a new view center. You can specify the 

scale factor relative to paper space unit or to the current view. 

  

 

To change the center of the current view 

Choose View > Zoom > Center from the main menu. 
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Select the point you want located at the center of the new view. 

Specify the zoom scale factor or the height of the drawing in drawing units. 

Zoom toolbar:  

Command line ZOOM 

 

Current view(left) showing the point to be centered in the new view (A), and the new 

view(right) zoomed using a scale factor of 2x 

 

Displaying the entire drawing 

ZOOM Extents displays a view that includes all of the objects in the drawing as large as possible. 

The view can display the objects on layers that are turned off but do not include objects on frozen 

layers. 

ZOOM All displays all of objects within either the user-defined limits or the drawing extents, 

whichever view is larger. 

 

You can use the Zoom All tool on the zoom toolbar to display an entire drawing. If you have drawn 

any entities outside the defined limits of the drawing, the extents of the drawing are displayed. If 

you drew all entities within the limits of the drawing, the drawing is displayed all the way to the 
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drawing limits. 

The Zoom Extents tool on the zoom toolbar displays the drawing to its extents, making the image 

fill the display to the greatest possible magnification. 

 

Zoom extents (displays all entities) Zoom all (displays to drawing limits) 

 

Commands Reference 

ZOOM: Increases or decreases the apparent size of objects in the current viewport  

System Variables Reference 

EXTMAX: Stores the upper-right point of the drawing extents 

EXTMIN: Stores the lower-left point of the drawing extents 

RTDISPLAY: Controls the display of raster images during Realtime ZOOM or PAN 

WHIPTHREAD: Controls whether to use an additional processor to improve the speed of 

operations such as ZOOM and PAN that redraw or regenerate the drawing 

ZOOMFACTOR: Controls the incremental change applied by each mouse-wheel's 

forward/backward movement  

4.3 Pan a View 

Use PAN command or use the window scroll bars to shift the location of your view. 

With the Realtime option of PAN, you pan dynamically by moving your pointing device. Like 

panning with a camera, PAN does not change the location or magnification of objects on your 

drawing; it changes only the view. By right-clicking, you can display a shortcut menu with additional 

viewing options. 

You can move the view of a drawing displayed in the current viewport by scrolling, panning, or 

rotating the view. Doing this changes the portion of the drawing you are viewing without changing 

the current magnification. Scrolling lets you move around in the drawing horizontally and vertically. 

Panning lets you move the drawing in any direction. Rotating lets you view your drawing from any 
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angle. 

Using scroll bars 

To assist you in navigating within a drawing, horizontal and vertical scroll bars are available in each 

drawing window. The size of the scroll box in relation to the scroll bar indicates the current level of 

drawing magnification. The position of the scroll box in relation to the scroll bar indicates the 

location of the center of the drawing in relation to the extents of the drawing (the smallest 

rectangle containing all the entities in the drawing). 

 

Using the Pan command 

You can move the drawing in any direction using the pan command. Panning shifts or slides the 

view of the drawing horizontally, vertically, or diagonally. The magnification of the drawing remains 

the same, as does its orientation in space. The only change is the portion of the drawing displayed. 

To pan, you can use any of the following methods: 

For precise panning, specify two points defining the magnitude and direction of the pan. The first 

point, or base point, indicates the starting point of the pan. The second point indicates the amount 

of pan displacement relative to the first point. 

To pan in real time, use the Pan Realtime tool on the Standard toolbar. 

If you have a mouse with a wheel, press and hold the wheel, and then move the mouse. 

To pan in real time 

Choose View > Zoom > Realtime from the main menu. 

Move the cursor in the direction you want to pan. 

To stop panning, press Enter, ESC or choose Exit from the shortcut menu. 

Standard toolbar:  

Command line PAN 

 

To pan using a mouse with a wheel 

Press and hold the wheel, and then move the mouse in the direction you want to pan. 

(The MBUTTONPAN system variable controls this feature.) 

 

Commands Reference 

PAN: Moves the view in the current viewport 

System Variables Reference 

MBUTTONPAN: Controls the behavior of the third button or wheel on the pointing device  
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RTDISPLAY: Controls the display of raster images during Realtime ZOOM or PAN  

WHIPTHREAD: Controls whether to use an additional processor to improve the speed of 

operations such as ZOOM and PAN that redraw or regenerate the drawing  

4.4 Display Multiple Views in Model Space 

Model space viewport is the drawing area that you can divide them into one or more adjacent 

rectangular views on the Model tap. Among multiple viewports, you have to make one view 

current for executing view commands. 

When you begin a new drawing, it is displayed in a single window. You can view the drawing in a 

second window, or you can divide one window into multiple windows. You can also open and 

display multiple drawings. 

 

Topics in this section: 

 Set Model Space Viewports 

On the Model tab, you can split the drawing area into one or more adjacent rectangular views 

known as model space viewports. 

 Work with Multiple Drawings 

With the multiple document interface (MDI) feature, you can open more than one drawing in 

ZWCAD+. Because you can open and work on several drawings at one time, you can copy, cut, or 

paste an entity from one drawing to another. 

 Set Model Space Viewports 

In large or complex drawings, displaying different views reduces the time needed to zoom or pan in 

a single view. Also, errors you might miss in one view may be apparent in the others. 

Viewports created on the Model tab completely fill the drawing area and do not overlap. As you 

make changes in one viewport, the others are updated simultaneously. Three model space 

viewports are shown in the illustration. 
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Use Model Space Viewports 

You can do the following operations at the model space viewport: 

Set Snap, Grid, and UCS icon modes; Pan; Zoom; and restore named views. 

Save orientations of UCS with individual viewports. 

When executing a command, you can draw from one viewport to another. 

Name a viewport arrangement in order to you can reuse it on the Model tab or insert it on a layout 

tab. 

When you work on 3D models, it is much helpful that setting up different UCS in individual 

viewports. 

Split and Join Model Space Viewports 

From the separated viewport, you can continue to split or join them. 

The illustrations below show several default model space viewport configurations. 

 

Select and Use the Current Viewport 

To make the desired viewport the current viewport, you click inside it through the existing 

viewports. When the cursor stays at the current viewport, it is displayed as crosshairs instead of an 

arrow. 
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You cannot change the current viewport when a view command is in progress. 

Working with Multiple Views of a Single Drawing 

You can open and work with several views of the same drawing simultaneously. 

After you divide a single window into multiple windows, you can control each window separately. 

For example, you can zoom or pan in one window without affecting the display in any of the other 

windows. You can control the grid, snap, and view orientation separately for each window. You can 

restore named views in individual windows, draw from one window to another, and name window 

configurations individually so you can reuse them later. 

As you draw, any changes you make in one window are immediately visible in the others. You can 

switch from one window to another at any time, even in the middle of a command, by clicking the 

window's title bar. 

You can divide a single drawing window into multiple tiled windows (called viewports) on the 

Model tab. You can control the number of windows created and the arrangement of the windows. 

You can also save and restore named window configurations and display a list of the current and 

saved window configurations. 

To create multiple views 

Choose View > Viewports from the main menu. 

In viewports menu, choose 1, 2, 3, or 4 viewports. 

Type h if you want the horizontal orientation, or type v if you want the vertical orientation. 

Command line VPORTS 

 

You can divide a drawing window into two windows arranged vertically 
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(A) or horizontally (B); three windows arranged left (C), right (D), 

above (E), below (F), vertically (G), or horizontally (H); or four tiled 

windows (I). 

 

To join two views 

Choose View > Viewports > Join from the main menu. 

Click anywhere inside the window you want to keep. 

Click anywhere inside the adjacent window you want to join to the first window. 

Command line VPORTS 

 

To restore a named window configuration 

Type -VPORTS and press ENTER. 

On the command line, type Restore. 

Type the name of the window configuration you want to restore. 

 

Commands Reference 

VPORTS: Creates multiple viewports  

System Variables Reference 

MAXACTVP: Sets the maximum number of viewports that can be active at one time in a layout  

TILEMODE: Makes the Model tab or the last layout tab current  

CVPORT: Sets the identification number of the current viewport 

VIEWCTR: Stores the center of view in the current viewport  

VIEWSIZE: Stores the height of the view in the current viewport  

4.5 Work with Multiple Drawings 

With the multiple document interface (MDI) feature, you can open more than one drawing in 

ZWCAD+. Because you can open and work on several drawings at one time, you can copy, cut, or 

paste an entity from one drawing to another. 

Each drawing appears in a drawing window, which has the following advantages: 

You can see two or more drawings side by side. 

You can easily copy entities from one drawing to another. 

 

Under the Window menu, the following three methods that determine how drawings are arranged 

are provided for user's choice. 

Cascade 
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Tile Horizontally 

Tile Vertically 

 

One session of ZWCAD+ with four drawings open. 

When you work with more than one drawing open in its own window, you can easily, cut, copy, and 

paste in between drawings. If you copy an entity from one window to another and then want to 

undo that action, you must undo it from the drawing into which you copied the entity. If you cut 

and paste an entity and then want to undo that action, you must undo it in both drawings.  

 

Commands Reference 

None 

System Variables Reference 

None 

 Save and Restore Views 

You can save views by name and restore them for plotting or when you need to refer to specific 

details. A named view is comprised of specific magnification, location and orientation. 

You can also restore up to 10 previous views. When you end drawing, the previous views cannot be 

restored. If you want to restore views among sessions, you have to save the drawing along with 

views by name. 

When you restore views, you can view all saved views along with their information. You can delete 

views when you do not need them. A drawing can be saved along with unlimited views. 
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Save a View 

When you name and save a view, the following settings are saved: 

Magnification, center point, and view direction 

The location of the view: the Model tab or a specific layout tab 

Layer visibility in the drawing at the time the view is saved 

User coordinate system 

3D perspective and clipping 

If you have divided the drawing window into multiple views, you can save the current window 

arrangement so that you can recall it to the screen later. The number and placement of the 

windows are saved exactly as they are currently displayed. The settings for each window are also 

saved. 

Restore a Named View 

With the -VIEW Restore, you can restore a named view to the current view. 

Named views can be used to do the following: 

Restore views on the model space viewport or layout viewport. 

Specify the area to plot. 

Determined which model space view is displayed when opening the drawing. 

You can specify a layout view when you open the drawing only if you save the drawing from that 

specified layout tab. 

 

Commands Reference 

RENAME: Changes the names of objects  

VPORTS: Creates multiple viewports 

System Variables Reference 

None 

4.6 Specify a 3D View 

You can set a 3D view to facilitate verifying the 3D effects of the drawing, constructing and 

visualizing 3D models. 

An isometric view is a typical viewpoint that helps you create a 3D view which reduces the number 

of visually overlapping objects. You can specify a new viewpoint to create new objects or modify 

the existing objects. 

 

Topics in this section: 
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 View a Parallel Projection in 3D 

You can view a parallel projection of 3D models at any location in model space. 

 Set the Viewing Direction 

You view three dimensional drawings by setting the viewing direction. The viewing direction 

establishes the viewing position, the Cartesian coordinate corresponding to the viewpoint looking 

back at the origin point, the 0,0,0 coordinate. 

 Isometric 

You can define perspective views of a model to create realistic effects. With Isometric Snap, you 

can create 2D objects that appear to be 3D solids. 

 Define a 3D View with Coordinate Values or Angles 

You can define a viewing direction by typing the coordinate values of a point or two rotation angles 

(angle from the XY plane and angle from the X axis). 

 Change a 3D View Dynamically 

You can view objects from any viewing direction by holding down mouse or other pointing device 

and moving dynamically. 

 Hide Lines or Shade 3D Objects 

Hides or shapes for 3D objects in the current drawing, suppresses the display of the objects (partly 

or entirely) that are located behind other objects, or generates a simply shaded image displayed in 

the current view. 

 View a Parallel Projection in 3D 

You can view a parallel projection of 3D models at any location in model space. 

To determine the angle or viewpoint, you can: 

Select a preset 3D view from the View toolbar. 

Type angles or coordinate that represent the viewing location in 3D. 

Modify a view of the current UCS, the WCS or a saved UCS. 

Change the 3D view dynamically using pointing device. 

Viewing 3D model is available only in model space. If you are working in paper space, the 3D 

viewing commands such as VPOINT and PLAN cannot be used to define paper space views. The 

view in paper space is always a plane view. 

The plane view is a view that you look toward the origin (0, 0, 0) from a point at the positive Z axis. 

This method results in a view of the XY plane. You can restore the view and coordinate system that 
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is the default for most ZWCAD+ drawings by setting the UCS orientation to World and then setting 

3D views to Plan View.  

 

Commands Reference 

PLAN: Displays the plan view of a specified user coordinate system 

VPOINT: Sets the viewing direction for a three-dimensional visualization of the drawing 

System Variables Reference 

VIEWDIR: Stores the viewing direction in the current viewport expressed in UCS coordinates 

WORLDVIEW: Determines whether input to the VPOINT command is relative to the WCS (default) 

or the current UCS 

BACKZ: Stores the back clipping plane offset from the target plane for the current viewport, in 

drawing units 

FRONTZ: Stores the front clipping plane offset from the target plane for the current viewport, in 

drawing units  

VIEWTWIST: Stores the view twist angle for the current viewport 

 Set the Viewing Direction 

You view three dimensional drawings by setting the viewing direction. The viewing direction 

establishes the viewing position, the Cartesian coordinate corresponding to the viewpoint looking 

back at the origin point, the 0,0,0 coordinate. When you view a drawing from the default viewpoint 

(0,0,1), you see a plan view of the drawing. 

You can change the viewing direction to look at the drawing from a different vantage point or to 

work on a three dimensional model from a different orientation. 

To set a new viewing direction 

Choose View > 3D Views > Viewpoint Presets from the main menu. 

Click the preset button. 

Click the preset view you want to use. 

You can set the current viewing direction to the plan view of the current user coordinate system 

(UCS), a previously saved UCS, or the World Coordinate System (WCS). 

 

To dynamically set a view direction 

Choose View > 3D Views > Viewpoint Presets from the main menu. 

Click the appropriate tools to dynamically change the viewpoint. 

To complete the command, click OK. 
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Command line DDVPOINT 

You can dynamically rotate the viewpoint within the XY plane and relative to the XY plane, and you 

can pan and zoom the drawing. As you change the viewpoint settings, the drawing display 

automatically updates. 

 

To display a plan view of the current drawing 

Choose View > 3D Views > Plan View from the main menu. 

It concludes three plan views: Current UCS, World UCS and Named UCS. Choose one what you 

want. 

Command line PLAN 

 

Commands Reference 

PLAN: Displays the plan view of a specified user coordinate system 

VPOINT: Sets the viewing direction for a three-dimensional visualization of the drawing 

System Variables Reference 

VIEWDIR: Stores the viewing direction in the current viewport expressed in UCS coordinates 

WORLDVIEW: Determines whether input to the VPOINT command is relative to the WCS (default) 

or the current UCS 

BACKZ: Stores the back clipping plane offset from the target plane for the current viewport, in 

drawing units 

FRONTZ: Stores the front clipping plane offset from the target plane for the current viewport, in 

drawing units  

VIEWTWIST: Stores the view twist angle for the current viewport 

 Isometric 

Choose Preset 3D Views 

You can define perspective views of a model to create realistic effects. 

Select predefined standard orthographic and isometric views by name or description. These views 

represent commonly used options: Top, Bottom, Front, Left, Right, and Back. In addition, you can 

set views from isometric options: SW (southwest) Isometric, SE (southeast) Isometric, NE 
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(northeast) Isometric, and NW (northwest) Isometric. 

To understand how the isometric views work, imagine you are looking down at the top of a box. If 

you move toward the lower-left corner of the box, you are viewing the box from the SW Isometric 

View. If you move toward the upper-left corner of the box, you are viewing it from NW Isometric 

View. 

 

Draw 2D Isometric Views 

With Isometric Snap, you can create 2D objects that appear to be 3D solids. 

By setting Isometric Snap on the Draft Settings dialog box and turning on Snap and Grid, you can 

easily align objects along one of three isometric planes. However, although the isometric drawing 

looks like 3D, it is actually a 2D representation. Therefore, you cannot extract distance and areas, 

display objects from different viewports, or delete hidden lines automatically. 

Set Isometric Grid and Snap 

By aligning along three major axes, isometric drawing simulates a 3D drawing from specified 

viewpoint. 

When the snap angle is set to 0, the axes of the isometric plane are 30 degrees, 90 degrees and 150 

degrees. 

With Isometric Snap on, you can work on any of three isometric planes, each with a pair of 

associated axes. 

Left. The left isometric plane defined by a pair of 90- and 150-degrees axes. The snap and grips 

align along the 90- and 150-degree axes. 

Top. The top isometric plane defined by a pair of 30- and 150-degrees axes. The snap and grips 

align along the 30- and 150-degrees axes. 

Right. The right isometric plane defined by a pair of 90- and 30-degrees axes. The snap and grips 

align along the 90- and 30-degrees axes. 
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In addition to using ISOPLANE command to switch isometric planes, you can also use shortcut key 

F5 or CTRL+E. specifying one of the three isometric planes results in Ortho and crosshairs to be 

aligned along the corresponding isometric axes. 

For example, when Ortho is on, the points you specified align along the simulated plane you are 

working on. Therefore, you can draw the top plane first, and switch to the left plane to draw 

another side, and then switch to the right plane to complete the drawing. 

 

Draw Isometric Circles 

You can create an isometric circle on the current isometric plane using Ellipse Isocircle. The Isocircle 

option is available only when the Isometric Snap is on. 

 

Commands Reference 

VIEW: Saves and restores named views 

DSETTINGS: Specifies settings for Snap mode, grid, and polar and object snap tracking 

GRID: Displays a dot grid in the current viewport 

ISOPLANE: Specifies the current isometric plane 

ORTHO: Constrains cursor movement 

SNAP: Restricts cursor movement to specified intervals 

System Variables Reference 

ISOLINES: Specifies the number of isolines per surface on objects 

SNAPISOPAIR: Controls the isometric plane for the current viewport  

SNAPSTYL: Sets the snap style for the current viewport 
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 Define a 3D View with Coordinate Values or Angles  

You can define a viewing direction by typing the coordinate values of a point or two rotation angles 

(angle from the XY plane and angle from the X axis). 

The specified point indicates your position in 3D space when you view the model while looking 

toward the origin (0, 0, 0). The viewpoint coordinate values are relative to the WCS unless you 

modify the system variable WORLDVIEW. 

The conventions for defining standard views are different among different industries. In 

architectural (ARC) design, the perpendicular plane of XY plane is the top view or plan view; in 

mechanical design, the perpendicular view is the front view. 

DDVPOINT is designed to rotate views to specify a viewing direction. 

The following illustration shows a view defined by two angles relative to the X axis and the XY plane 

of the WCS. 

 

 

Commands Reference 

VIEW: Saves and restores named views 

System Variables Reference 

WORLDVIEW: Determines whether input to the VPOINT command is relative to the WCS (default) 

or the current UCS 

 Change a 3D View Dynamically 

You can view objects from any viewing direction by holding down mouse or other pointing devices 

and moving dynamically. With dynamic viewing, you can display the effects of changing viewpoint 

while you change the view. 

You can execute move or zoom operations as the 3D Orbit is active. 

When the 3D Orbit is active, you are not allowed to modify objects. To close 3D Orbit, press Enter, 

ESC or choose Exit from the shortcut menu. 

 

Commands Reference 

None 
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System Variables Reference 

None 

 Hide Lines or Shade 3D Objects 

Hides or shapes for 3D objects in the current drawing, suppresses the display of the objects (partly 

or entirely) that are located behind other objects, or generates a simply shaded image displayed in 

the current view. 

Hide Lines 

You can suppress the objects (partly or entirely) that are located behind other objects using Hide. 

The system generates wireframe representations including hidden lines when you use VPOINT or 

VIEW command to create objects in 3D view. You can use HIDE command to remove the hidden 

lines to verify the current placement of these surfaces. 

When you view or plot wireframes, complex drawings usually appear too cluttered to convey 

accurate information. 

Hiding background objects that in reality would be obscured by objects in the front background 

simplifies the display of the drawing and clarifies the design. Shown as the following picture: 

 

Hiding background lines makes the display much clearer, but you cannot modify hidden-line or 

render views. It may take a long time to calculate and obscure hidden lines if the drawing is 

complex. However, you can speed up the process in the several ways. For example, you can avoid 

drawing details that will not be visible at the scale at which you are displaying or plotting the 

drawing. You can also exclude objects from the hiding process by zooming into a part of the 

drawing. 

Remove hidden lines on one or more selected objects to improve performance. 

When the system variable DISPSILH is set to 1, HIDE command displays only the silhouette lines of 

the objects. It does not display the inside edges generated by a nested face of an object. 

When the current view is shaded, hiding lines on solid objects also suppresses drawing the mesh 

image, and instead displays the objects using wireframe representation with the back lines hidden. 

Add Simple Shading to 3D Objects 

Although hiding lines can enhance the drawing and clarifies the design, shading produces a more 

realistic image of your model. 

You can modify shaded objects as you normally would. When a shaded object is selected, the 
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wireframe and grips appear on top of the shading. 

 

Commands Reference 

HIDE: Regenerates a three-dimensional model with hidden lines suppressed 

MVIEW: Creates and controls layout viewports 

REGEN: Regenerates the entire drawing from the current viewport 

System Variables Reference 

DISPSILH: Controls display of silhouette curves of solid objects in Wireframe mode 

HALOGAP: Specifies the distance to shorten a haloed line  

HIDEPRECISION: Controls the precision of hides and shades 

HIDETEXT: Specifies whether text objects created by the TEXT, DTEXT, or MTEXT commands are 

processed during a HIDE command 

OBSCUREDCOLOR: Specifies the color of obscured lines 

OBSCUREDLTYPE: Specifies the linetype of obscured lines 
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5 Precision Tools and the Properties 

of Drawing 

 

Topics in this section: 

Specify Units, Angles and Scale 

Specify the units of measurement you want to use, their format, and other conventions. 

Drawing Limits 

You can specify the drawing limits that form an invisible boundary around your drawing. 

Grid and Grid Snap 

Display grid points and use grid snap to enhance your drawing speed and efficiency. 

Use Object Snaps 

Using object snaps is a quick way to locate an exact position on an object without having to know 

the coordinate or draw construction lines. 

Use Polar Tracking and Object Snap Tracking 

Polar tracking restricts cursor movement to specified angles. PolarSnap restricts cursor movement 

to specified increments along a polar angle. 

Use Orthogonal Locking (Ortho Mode) 

You can restrict cursor movement to horizontal and vertical for convenience and precision when 

creating and modifying objects. 

Work with Linetypes 

You can use linetypes to distinguish objects from one another visually and make your drawing 

easier to read. 

Work with Layers 

Layers are like transparent overlays on which you organize and group different kinds of drawing 

information. 

Work with Colors 

Color helps to group objects visually. You can assign colors to object by layer or individually. 

Control Lineweights 

You can further differentiate objects in your drawing by controlling their lineweights both in the 

drawing display and in plotting. 

Control the Display of Overlapped Objects 
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Control how overlapping objects and certain other objects are displayed and plotted. 

Extract or Calculate Geometric Information from Objects 

Information about objects in your drawing are allowed to inquire by means of performing inquiry 

and calculation commands, you can also make useful calculations, such as area and circumference 

calculation. 

Specify Intervals on Objects 

You can divide a line, arc, circle, polyline, ellipse, or spline into a number of equal segments or mark 

off intervals of a specific length along an object. 

5.1 Specify Units, Angles and Scale 

Specify the units of measurement you want to use, their format, and other conventions. 

Determine Units of Measurement 

When you start drawing, you specify the units of measurement, their formats as well as the 

number of decimal fraction. 

Set the Units Format 

You can set the display format of the unit. These formats include scientific, decimal, engineering, 

architectural and fractional notation. To enter architectural feet and inches format, you can indicate 

feet using the prime symbol ('), for example, 72'3. You do not need to specify inches by entering 

quotation marks ("). 

You can set the unit type and precision in the Quick Setup wizard, the Advanced Setup wizard, or 

the Units Control dialog box. These settings control how your coordinate, offset, and distance 

entries are interpreted, and how coordinates and distances are displayed. 

The input format of three-dimension coordinates is the same as the input format of the 

two-dimension coordinates: scientific, decimal, engineering, architectural and fractional notation. 

The unit format for creating and listing objects, measuring distance and displaying coordinate 

locations is different from the dimension units setting used in creating dimension values. 

With ZWCAD+, you typically draw at full size (1:1 scale), and then set a scale factor when you print 

or plot your drawing. Before you begin drawing, however, you need to determine the relationship 

between drawing units and real world units. 

For example, you can decide whether one linear drawing unit represents an inch, a foot, a meter, or 

a mile. In addition, you can specify the way the program measures angles. For both linear and 

angular units, you can also set the degree of display precision, such as the number of decimal 

places or smallest denominator used when displaying fractions. The precision settings affect only 

the display of distances, angles, and coordinates. ZWCAD+ always stores distances, angles, and 

coordinates using floating point accuracy. 

Open drawing units dialog 

Choose Format > Units from the main menu. 

Command line UNITS 
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Convert Drawing Units 

When you create a new drawing in one system of measurement (imperial or metric) and then 

change to the other system, use SCALE to scale the model geometry by the appropriate conversion 

factor to obtain correct distances and dimensions. The conversion is shown as follows: 

For example, to convert inches to centimeters, you scale the drawing by a factor of 3.25. To convert 

from centimeters to inches, the scale factor is 1/3.25 or about 0.3077. 

Set Angle Conventions 

You can specify the location for angle 0 and the positive direction for the angle measurement: 

clockwise or counterclockwise. You can also specify the format and the number of decimal fraction. 

Shown as the following illustrations: 

Specify the measurement unit and precision. The units include grad, radian, surveyor's unit and 

degree, minute and second. 

Specify where the angle measurement starts from: east, west, south, north or others. For example, 

to enter a coordinate relative to the current coordinate for a property line that is 54 feet, 7 inches 

long with a bearing of 60 degrees north, 12 minutes, 6 seconds east, enter @54'7"<n60d12'6"e. 

Specify the positive direction: counterclockwise or clockwise. The angle 0 can be set to any 

location. 

Setting scale factors 

Instead of drawing to a particular scale, you draw everything full size in the program. Although it's a 

good idea to keep your scale factor in mind when setting up a drawing, you don't need to set the 

scale until you print it. For example, when you draw a mechanical part 40 inches in length with 

ZWCAD+, you actually draw it as 40 inches, rather than applying a scale factor as you draw. When 

you print your drawing, you can assign the scale at which the drawing is to print. 

Scale, however, does affect the way a few elements such as text, arrows, or linetypes print or plot 

in your drawing. For these, you can make adjustments when you first set up your drawing so that 

they print or plot at the correct size. For example, when you draw text, you need to determine the 

text size so that when you print it later at a particular scale, the text height is correct. 

After you determine the eventual scale of your finished drawing, you can calculate the scale factor 

for the drawing as a ratio of one drawing unit to the actual scale unit represented by each drawing 

unit. For example, if you plan to print your drawing at 1/8" = 1'-0", your scale factor ratio is 1:96 

(1/8" = 12" is the same as 1 = 96). If you want your printed scale to be 1 inch = 100 feet, your scale 

factor ratio is 1:1200. 

The following table shows some standard architectural and engineering scale ratios and equivalent 

text heights required to create text that measures 1/8 inch high when you print the drawing at the 

specified scale. 

Standard scale ratios and equivalent text heights 

Scale Scale factor Text height 

1/16" = 1'-0"  192 24" 
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1/8" = 1'-0"  96 12" 

3/16" = 1'-0"  64 8" 

1/4" = 1'-0" 48 6" 

3/8" = 1'-0" 32 4" 

1/2" = 1'-0" 24 3" 

3/4" = 1'-0" 16 2" 

1" = 1'-0" 12 1.5" 

1 1/2" = 1'-0" 8 1" 

3" = 1'-0" 4 0.5" 

1" = 10' 120 15" 

1" = 20' 240 30" 

1" = 30' 360 45" 

1" = 40' 480 60" 

1" = 50' 600 75" 

1" = 60' 720 90" 

1" = 100' 1200 150" 

You can use these scale factors to predetermine the size of your drawing to make sure that it fits on 

a specific size paper when you print it. You control the size of your drawing by the drawing limits. To 

calculate the drawing limits to match the size of your paper, multiply the dimensions of your paper 

size by your scale factor. 

For example, if the paper you use to print measures 36 inches x 24 inches and you print your 

drawing at 1/8" = 1'-0" (in other words, using a scale factor of 96), the size of your drawing 

measured in drawing units is 36 x 96 (or 3,456 units) wide and 24 x 96 (or 2,304 units) high. 

Keep in mind that you can print the finished drawing at any scale, regardless of the scale factor you 

calculate. You can also print on paper of a different size and use the Layout tabs to create different 

views of your drawing and to position and scale those views differently. The scaling factor is not 

related to the size of the entities you draw; it simply provides a preliminary guide to help you 

establish the text height and drawing limits when you begin your drawing. You can change the text 

height and drawing limits at any time. 

Apply scale factors 

You can set the following factor to determine whether the drawing is plotted on the model space or 

paper space. 

Text. Sets text height in the text style (STYLE) or in the process of creating text. The text plotted 

height should be set in proportion to scale factor in model space. The text created on the layout 

should be set at 1:1. 

Dimension. Sets dimension scale in the dimension style (DIMSTYLE) or through system variable 

DIMSCALE. 

Linetype. To plot objects from the Model tap, use system variables CELTSCALE and LTSCALE to set 
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scale for non-continuous lines. To plot objects from a layout (paper space), use system variable 

PSLTCALE. 

Hatch. Sets hatch scale in the Hatch and Gradient dialog box or through system variable HPSCALE. 

View. When you plot a drawing from a layout, you may need to use ZOOM XP command, where XP 

is a ratio that is relative to the paper size (scale factor of reciprocal). 

Setting the text height 

The text height setting controls the height of text, measured in drawing units. Set this value initially 

so that text used for your most common annotations, when scaled to the size at which you will 

print a drawing, measures 1/8-inch high on the printed drawing. 

For example, if you plan to print your drawing at 1/8" = 1'-0" and you want your text to be 1/8-inch 

high in the final drawing, create that text 1 foot high (in your real-world drawing units) so that 

when you print it, it appears 1/8-inch high on the paper. 

You must create text 4 feet high that you want to print 1/2-inch high. 

To set the text height 

Choose Format > Text Style from the main menu. 

Type a value in the Text Height text under Text Measurements. 

Press OK to save the current settings. 

NOTE The default text height applies only if the current text style height is 0.0. Otherwise, the text 

height for the current style takes precedence. 

 

Commands Reference 

UNITS: Controls coordinate and angle display formats and precision  

System Variables Reference 

UNITMODE: Controls the display format for units  

ANGBASE: Sets the base angle to 0 with respect to the current UCS  

ANGDIR: Sets the direction of positive angles 

AUNITS: Sets units for angles 

AUPREC: Sets the number of decimal places for all read-only angular units displayed on the status 

line, and for all editable angular units whose precision is less than or equal to the current AUPREC 

value  

5.2 Drawing Limits 
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You can specify the drawing limits that form an invisible boundary around your drawing. You can 

use the drawing limits to make sure that you do not create a drawing larger than can fit on a 

specific sheet of paper when printed at a specific scale. 

For example, if you plan to print your drawing at 1/8" = 1'-0" (in other words, using a scale factor of 

96) on a sheet of paper measuring 36 inches x 24 inches, you can set drawing limits to 3,264 units 

wide (that is, 34 x 96) and 2,112 units high (22 x 96), which allows a 1-inch margin around the 

edges of the printed image. 

To set the drawing limits 

Choose Format > Drawing Limits from the main menu. 

Specify the x-coordinate and y-coordinate of the upper right drawing limit and the lower left 

drawing limit. You can also click Select to specify the drawing limits by selecting points in the 

drawing. 

Command line LIMITS 

 

Commands Reference 

LIMITS: Sets drawing limits and grid limits displaying area of current Model or layout tab 

System Variables Reference 

None 

5.3 Grid and Grid Snap 

The grid is a rectangular pattern comprised of dots that extends over the area you specify as the 

grid limits. Displaying grids and using grids snap improve the performance of regenerating. 

Using the grid is like placing a sheet of coordinate paper under a drawing. The grid is not plotted. If 

you scale drawing, you may need to adjust grid spacing to be more appropriate for the new 

magnification. 

When you turn Snap mode on, the cursor adheres or snaps to the invisible grids. Therefore, you 

can specify precise points with the arrow keys, mouse or other pointing devices. 

Grid and snap settings are effective tools to use in your drawing to ensure accuracy. 

Although many users find it convenient to match grid points to snap settings, they are independent 

of each other and should not be confused. Grid points are for visual reference only; they do not 

affect your drawing and they do not print. Snap points are, by themselves, not visible; however, 

when set, they constrain the creation of new entities. 

In addition, the cursor can be restricted to move orthogonally only or guides can display on the 

screen automatically at specified polar angle increments. 

Change Grid and Snap Spacing 

You can turn Grid and Snap on and off and specify their spacing on the Snap and Grid tab at the 
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Drafting Settings dialog box. Grid spacing does not have to match snap spacing. A wide grid spacing 

can be used as a reference while a closer grid spacing helps you specify points accurately. 

 

Setting a reference grid 

A reference grid displays as a pattern of regularly spaced dots. You can turn the display on and off, 

and you can specify how far apart the dots are spaced. 

The reference grid extends only to the limits of the drawing, helping you to visualize the boundary 

of your drawing and to align entities and visualize distances between entities. You can turn the grid 

on and off as needed. You can also change the spacing of the grid at any time. 

To turn the grid on and set the grid spacing 

Choose Tools > Drafting Settings from the main menu. 

Click the Snap and Grid tab. 

Click the Grid On box. 

Under Grid tab, input a value in the Grid X Spacing field and Grid Y Spacing field separately. 

Click OK. 

Status bar Right-click on the Grid Display button to choose Settings. 

TIP To toggle the grid display on and off at any time, click the Grid Display button on the status bar, 

or press F7. 

 

Setting snap spacing 

Another way to ensure drawing accuracy is to turn on and set snap spacing. When snap is turned 

on, the program restricts the selection points to predetermined snap intervals. Although it is often 

helpful for snapping by means of matching the snap spacing with grid spacing, the setting is not 

required. 

To turn snap settings on and set snap spacing 

Choose Tools > Drafting Settings from the main menu. 

Click the Snap and Grid tab. 

Click the Snap On box. 

Under Snap tab, input a value in the Snap X Spacing field and Snap Y Spacing field separately. 

Click OK. 

Status bar Right-click on the Snap Mode button to choose Settings. 

TIP To toggle snap settings on and off at any time, click the Snap Mode button on the status bar, or 

press F9. 

 

Using isometric snap 
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You can use the Isometric Snap option to create two dimensional isometric drawings. With the 

isometric option, you are simply drawing a simulated three dimensional view on a 2D plane, much 

the same as you might draw on a piece of paper. Do not confuse isometric drawings with three 

dimensional drawings. You create three dimensional drawings in three dimensional space. 

The isometric option always uses three preset planes, which are denoted as left, right, and top. 

You cannot alter the arrangement of these planes. If the snap angle is 0, the three isometric axes 

are 30 degrees, 90 degrees, and 150 degrees. 

When you check the Isometric Snap option and select an isometric plane, the snap intervals, grid, 

and crosshairs align with the current plane. The grid is always shown as isometric and uses y 

coordinates to calculate the grid spacing. If you click the Draw Orthogonal check box, the program 

restricts the drawing of entities to the current isometric plane. 

To turn the Isometric Snap And Grid option on 

Choose Tools > Drafting Settings from the main menu. 

Click the Snap and Grid tab. 

In Snap Type tab, select the Isometric Snap check box. 

Click OK. 

Tip To choose a different isometric plane and toggle between three isometric planes, press F5. 

 

 

Commands Reference 

DSETTINGS: Specifies settings for Snap mode, grid, and polar and object snap tracking 

GRID: Displays a dot grid in the current viewport 

LIMITS: Sets and controls the limits of the grid display in the current Model or layout tab 

SNAP: Restricts cursor movement to specified intervals 

UNITS: Controls coordinate and angle display formats and precision 

System Variables Reference 
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ANGBASE: Sets the base angle to 0 with respect to the current UCS 

ANGDIR: Sets the direction of positive angles 

AUNITS: Sets units for angles 

AUPREC: Sets the number of decimal places for all read-only angular units displayed on the status 

line, and for all editable angular units whose precision is less than or equal to the current AUPREC 

value  

GRIDMODE: Specifies whether the grid is turned on or off 

GRIDUNIT: Specifies the grid spacing (X and Y) for the current viewport 

LIMCHECK: Controls the creation of objects outside the drawing limits 

LIMMAX: Stores the upper-right drawing limits for the current space, expressed as a world 

coordinate 

LIMMIN: Stores the lower-left drawing limits for the current space, expressed as a world 

coordinate 

SNAPANG: Sets the snap and grid rotation angle for the current viewport 

SNAPBASE: Sets the snap and grid origin point for the current viewport relative to the current UCS 

SNAPMODE: Turns the Snap mode on and off  

SNAPTYPE: Sets the snap style for the current viewport 

SNAPUNIT: Sets the snap spacing for the current viewport 

5.4 Use Object Snaps 

Object snaps enable you to quickly select exact geometric points on existing entities without having 

to know the exact coordinates of those points. With object snaps, you can select the endpoint of a 

line or arc, the center point of a circle, the intersection of any two entities, or any other 

geometrically significant position. You can also use object snaps to draw entities that are tangent or 

perpendicular to an existing entity. 

You can use object snaps whenever the program prompts you to specify a point, for example, if you 

are drawing a line or other object. To turn on the ESNAP mode, any of the following ways is 

available:  

Choose Tools > Drafting Settings from the main menu to open the Drafting Settings dialog box, 

toggle to Object Snap tab, and then tick the Object Snap On checkbox. 
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Press F3. 

Click the Object Snap button on the status bar.  

When using object snaps, the program recognizes only visible objects or visible portions of objects. 

You cannot snap to objects on layers that have been turned off or to the blank portions of dashed 

lines. 

When Object Snaps is turned on, a marker and a tooltip are displayed when you move the cursor 

over an object snap location on an object. 

Setting object snaps 

You can set object snaps using any of the following methods: 

Choose Tools > Drafting Settings > Object Snap, and then click one of the object snap tools. 

On the Object Snap toolbar, click one of the object snap tools 

On the status bar, right-click on the Object Snap button to choose Settings. 

Press and hold down the Shift key while right clicking anywhere within the drawing window to 

display the object snap shortcut menu, and then choose the object snap you want to set. 

Object Snap settings 

If you need to use one or more object snaps repeatedly, you can turn on running object snaps on 

the Grid and Snap tab of Drafting Settings dialog box. The object snap mode keeps on unless you 

turn it off. For example, you can use an object snap to draw a line to the center of a circle. 

If several object snaps on, the system chooses automatically the most suitable object snap. If there 

are two possible object snaps at the selection area, the system choose the one that is closer to the 

center of target box. 

If you turn several object snaps on, you need to check which one is in effect when you specify a 

point. If several object snaps are eligible at a given location, press the TAB key to cycle through the 

possibilities before you specify the point. 

Object Snap Restrictions 

With the object snap on, you can snap objects only visible on the screen, including objects on 

locked layers, layout viewport boundaries, and polyline segments. You cannot snap to objects that 

are not visible, including objects that are not displayed, objects on turned-off or frozen layers, or 

the blank portions of dashed lines. 

The object snap is available only when you are prompted to specify a point. There isn't any 

information about object snap displayed if you try to use an object snap at the Command prompt. 

AutoSnap Tools 

The automatic snap tool is a visual aid tool for snapping that help you see and use object snaps 

more efficiently. When any object snap is on, the system displays a marker and a tooltip when you 

move your cursor on over a snap point. AutoSnap turns on automatically when an object snap is on. 

By default, AutoSnap marker, tooltip and magnet are on. You can change the settings of AutoSnap 

on the Options dialog box. 
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AutoSnap consists of the following snap tools: 

Marker. The object snap location is displayed when the cursor moves over or near an object. 

Marker shape is determined by the snap it is marking. 

Tooltip. Indicates which part of the object you are snapping to in a flag at the cursor location. 

Magnet. Attracts and locks the cursor onto the nearest detected snap points. Provides a visual that 

is similar to snapping to a grid. 

Aperture box. Surrounds the crosshairs and defines an area within which, when you move the 

cursor, system evaluates objects for object snaps. You can determine the aperture box is displayed 

or not, and the aperture box size can be changed too. 

To change the size of the object snap target box 

Choose Tools > Options from the main menu. 

Switch to the Drafting tab. 

Under Aperture Size, slide to adjust the desired size. 

Click OK. 

 

Commands Reference 

APERTURE: Controls the size of the object snap target box  

OPTIONS: Customizes the ZWCAD+ settings 

OSNAP: Sets running object snap modes 

System Variables Reference 

APBOX: Turns the AutoSnap aperture box on or off  

AUTOSNAP: Controls AutoSnap marker, tooltip, and magnet 

OSMODE: Sets running Object Snap modes 

OSNAPCOORD: Controls whether coordinates entered on the command line override running 

object snaps  

5.5 Use Polar Tracking and Object Snap Tracking 

Auto tracking includes polar tracking and object snap tracking. You can turn them on and off by 

repressing POLAR and OTRACK button on the Status Bar. 

When the polar tracking mode is on, the cursor moves along the specified angle. When the object 

snap tracking is on, the cursor moves along an alignment path based on the snap point. 

Polar Tracking 
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When polar tracking is turned on, guides display on the screen automatically at the polar angle 

increment that you specify. For example, if you draw a line with polar tracking turned on with angle 

increment set as 65 degrees, the rubber-banding line displays at 65 degree increments. 

Polar tracking and orthogonal locking cannot be used at the same time-turning one option on turns 

the other option off. 

To enable polar tracking and specify the polar angle increment 

Do one of the following: 

Choose Tools > Drafting Settings from the main menu. 

On the Object Snap toolbar, click the Object Snap Settings button. 

Type DSETTINGS in the command line and then press Enter. 

Switch to the Polar Tracking tab. 

Select the Polar Tracking On checkbox. 

Do one of the following to specify the polar angle increments: 

Select an angle from the Increment Angle drop-down list. 

Mark the Additional Angles check box and click New to define a custom angle increment. 

Click OK. 

TIP To toggle polar tracking on and off at any time, click the Polar Tracking button on the status bar 

or press F10. 

 

To draw objects using polar tracking 

Turn on polar tracking and start a drawing command, such as ARC, CIRCLE, or LINE. You can also use 

polar tracking with editing commands, such as COPY and MOVE. 

As you move your cursor to specify points, notice the dotted polar tracking line that appears at the 

tracking angles you specified. Points you specify while the line is displayed conform to the polar 

tracking angle. 

 

Specify Polar Angles 

You can set a polar increment angle to polar tracking. The default angle includes 90, 45, 30, 22.5, 

18, 15, 10 and 5 degrees. You can also type a desired angle in the Additional Angles textbox. The 

value is stored in the system variable POLARANG. The orientation of angle 0 and the direction of 

object snap are dependent on your settings in the Drawing Settings dialog box (UNITS). 

The following illustration shows the alignment paths displayed as you move your cursor 90 degrees 

with the polar angle increment set to 30 degrees. 
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To set polar tracking angles 

Choose Tools > Drafting Settings from the main menu. 

In the Drafting Settings dialog box, on the Polar Tracking tab, select Polar Tracking On. 

From the Increment Angle list, select a desired angle. 

To set additional tracking angles, select Additional Angles. Then click New and enter the angle value 

in the text box. 

Under Polar Angle Measurement, specify whether polar tracking increments are based on the UCS 

or relative to the last object you created. 

Choose OK. 

 

Specify Polar Distances 

AutoSnap restricts cursor movement to increments of a polar distance you specified on the Snap 

and Grid tab of Drafting Settings dialog box. For example, if you specify a length of 6 units, the 

cursor snaps the length specified to lengths of 0, 6, 12, 18, 24, and so on. 

When you move cursor, a tooltip displays the nearest PolarSnap increment. Only when polar 

tracking and snap mode are on, you can restrict point entry to polar distance. 

To set polar snap distance 

Choose Tools > Drafting Settings from the main menu. 

In the Drafting Settings dialog box, on the Snap and Grid tab, select Snap On. 

In Snap Type, select PolarSnap. 

Under Polar Spacing, enter the polar distance. 

Choose the Polar Tracking tab and select Polar Tracking On. 

Select an angle from the Increment Angle list. You can specify your own angles by choosing 

Additional Angles and then New. 

Choose OK. 

 

Object Snap Tracking 

You must set an object snap and turn the object snap model on before you can track from an 

existing object's snap point. 

Object snap tracking can track along alignment paths that are based on object snap points and 

display tooltips at the acquired points. After you acquire a point, horizontal, vertical and polar 
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alignment paths relative to the point are displayed when the cursor moves over their drawing path. 

For example, you can specify a point along a path that is based on an object endpoint or midpoint 

or an intersection between objects. 

In the following picture, the Endpoint object snap is on. You create a line by clicking its start point 

(1), move the cursor over another line's endpoint (2) to acquire it, and then move the cursor along 

the horizontal alignment path to locate the endpoint you want for the line you are drawing. 

 

By default, the object snap tracking is set to Orthogonal. Alignment paths and tooltips are displayed 

at 0, 90, 180, and 270 degrees from acquired object points. However, you can use polar tracking 

angles instead on the Polar Tracking tab in the Drafting Settings dialog box. 

You can also use system variable TRACKPATH to control the display of polar and object snap 

tracking alignment paths. 

Tips for Using Object Snap Tracking 

With AutoTrack is on, you may try the following techniques: 

When you set Perpendicular, Endpoint and Midpoint object snap, and turn on object snap tracking 

mode, you can easily draw to point perpendicular to the end or midpoint of an object. 

Object snap tracking works in conjunction with temporary tracking points. At a point prompt, enter 

tt and specify a temporary tracking point. A small + is displayed at the point. When you move the 

cursor, the tracking alignment paths are displayed relative to the temporary point. To delete this 

point, move the cursor back over the +. 

After acquiring a point, you can specify a point at precise distances along alignment paths from the 

acquired point. 

You can use the Automatic and Shift to acquire options set on the Drafting tab of the Options dialog 

box to manage point acquisition. By default, point acquisition is set to Automatic. When working in 

close quarters, you can press SHIFT to temporarily avoid acquiring a point. 

 

Commands Reference 

APERTURE: Controls the size of the object snap target box 

OPTIONS: Customizes the ZWCAD+ settings 

OSNAP: Sets running object snap modes 

DSETTINGS: Specifies settings for Snap mode, grid, and polar and object snap tracking 
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SNAP: Restricts cursor movement to specified intervals 

System Variables Reference 

APBOX: Turns the AutoSnap aperture box on or off  

AUTOSNAP: Controls AutoSnap marker, tooltip, and magnet 

OSMODE: Sets running Object Snap modes 

OSNAPCOORD: Controls whether coordinates entered on the command line override running 

object snaps  

POLARANG: Sets the polar angle increment 

POLARDIST: Sets the snap increment when the SNAPSTYL system variable is set to 1 (polar snap)  

POLARMODE: Controls settings for polar and object snap tracking 

SNAPTYPE: Sets the snap style for the current viewport 

5.6 Use Orthogonal Locking (Ortho Mode) 

You can restrict cursor movement to the current horizontal and vertical axes so that you can draw 

at right angles, or orthogonally. For example, with the default 0 degree Orientation (angle 0 at the 

"three o'clock" or "east" position), when the Draw Orthogonal option is enabled, lines are 

restricted to 0 degrees, 90 degrees, 180 degrees, or 270 degrees. As you draw lines, the rubber 

banding line follows either the horizontal or vertical axis, depending on which axis is farthest from 

the cursor. When you enable the isometric snap and grid, cursor movement is restricted to 

orthogonal equivalents within the current isometric plane. 

Ortho mode and polar tracking cannot be on at the same time. Turning on Ortho turns off polar 

tracking. 

To enable orthogonal drawing 

Press F8. 

Status bar Click  

 

Commands Reference 

DSETTINGS: Specifies settings for Snap mode, grid, and polar and object snap tracking 



 

 98 

SNAP: Restricts cursor movement to specified intervals 

System Variables Reference 

OSMODE: Sets running Object Snap modes 

OSNAPCOORD: Controls whether coordinates entered on the command line override running 

object snaps  

POLARANG: Sets the polar angle increment 

POLARDIST: Sets the snap increment when the SNAPSTYL system variable is set to 1 (polar snap)  

POLARMODE: Controls settings for polar and object snap tracking 

SNAPTYPE: Sets the snap style for the current viewport 

5.7 Work with Linetypes 

ZWCAD+ provides simple and complex linetypes: 

A simple linetype consists of a repeating pattern of dots, dashes, or blank spaces. 

A complex linetype contains embedded shape and text objects along with dots, dashes, and spaces. 

You can use different linetypes to represent specific kinds of information. For example, if you are 

drawing a site plan, you can draw roads using a continuous linetype, a fence using a linetype of 

dashes with square posts, or a gas line using a complex linetype showing the text "GAS". 

By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, and BYBLOCK. You 

cannot rename or delete these linetypes. Your drawing may also contain an unlimited number of 

additional linetypes. You can load more linetypes into the program from a linetype library file. 

 

Topics in this section: 

 Load and Use Linetypes 

At the start of a project, you load the linetypes that are required for the project so that they are 

available when you need them.  

 Change the Linetype of an Object 

You can change the linetype of an object by reassigning it to another layer, by changing the linetype 

of the layer the object is on, or by specifying a linetype for the object explicitly. 

 Control Linetype Scale 
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You can use the same linetype at different scales by changing the linetype scale factor either 

globally or individually for each object. 

 Load and Use Linetypes 

A linetype is a repeating pattern of dashes, dots, and blank spaces displayed in a line or a curve. 

Loads linetype from a drawing to be reused when needed. 

Work with Linetypes 

You can assign linetypes to objects by layer, or by specifying the linetype explicitly. Besides choosing 

linetype, you can specify its scale to control the size of dashes and spaces, and create your own 

custom linetypes. 

NOTE You should not confuse these linetypes with the hardware linetypes provided by some 

plotters. Both linetypes of dashes produce the similar effects. However, if you use both linetypes at 

the same time, the results can be unpredictable. 

Load Linetypes 

ZWCAD+ includes the linetype definition files zwcad.lin and zwcadiso.lin. zwcad.lin is used in the 

imperial system; and zwcadiso.lin is used in the metric system. If you select zwcadiso.lin, you can 

use ISO pen-width option when you plot. 

If you want to know what linetypes are already available, you can display a list of linetypes that are 

loaded in the drawing or stored in an LIN (linetype definition) file. Both linetype definition files 

contain several complex linetypes. 

You can remove unreferenced linetype information with PURGE or by deleting the linetype from 

the Linetype Manager. BYBLOCK, BYLAYER, and CONTINUOUS linetypes cannot be removed.  

 

Commands Reference 

LINETYPE: Loads, sets, and modifies linetypes 

PURGE: Removes unused named items, such as block definitions and layers, from the drawing  

RENAME: Changes the names of objects 

System Variables Reference 

MEASUREINIT: Sets the initial drawing units as imperial or metric  

MEASUREMENT: Sets drawing units as imperial or metric for the current drawing only 

 Change the Linetype of an Object 
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You can change the linetype of an object by changing the linetype of the layer the object is on, 

reassigning the object to another layer, or by specifying a linetype for the object directly. 

Set the Current Linetype 

By default, all objects are created using the current linetype, which is displayed in the Linetype 

Control on the Properties toolbar. To modify this current linetype, you can select a linetype and 

make it current in the Linetype Manager dialog box. You can also do this setting using the Linetype 

option on the Properties palette. 

If the current linetype is BYLARER, objects are created using the linetype assigned to the current 

layer. 

If the current linetype is BYBLOCK, objects are created using CONTINOUS linetype until they are 

grouped into a block. When you insert the block, it acquires the current linetype setting. 

If you do not want to use the linetype assigned to the layer, you can specify a different linetype 

explicitly. 

ZWCAD+ does not display the linetype of certain objects: text, points, viewports, hatches, and 

blocks. 

To make the linetype current 

Select a linetype from the Linetype Control pull-down list on the Properties toolbar, which is set to 

the current linetype. 

 

Change the Linetype of an Object 

To change the linetype of an object, you can use following methods: 

If the linetype of an object is set to BYLARE, and the object is assigned to another layer, it acquired 

its linetype from the new layer. 

If the linetype of an object is set to BYLAYER, when you change the linetype assigned to a layer, the 

objects on that layer which are assigned the BYLAYER linetype are updated automatically. 

Specify a linetype for an object to override the linetype of the layer. You can specify different 

linetypes for each object. If you want to specify a different linetype to override the 

layer-determined linetype of an object, change an existing object's linetype from BYLAER to a 

specific linetype, such as DASHED. 

If you want to set a linetype for a subsequently created object, you can change the current linetype 

BYLAYER to a specific one in the Linetype Control on the Properties toolbar. 

 

Commands Reference 

LINETYPE: Loads, sets, and modifies linetypes 

CHANGE: Changes the properties of existing objects  

CHPROP: Changes the color, layer, linetype, linetype scale factor, lineweight, thickness, and plot 
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style of an object  

LAYER: Manages layers and layer properties 

PROPERTIES: Controls properties of existing objects 

System Variables Reference 

CELTYPE: Sets the linetype of new objects 

 Control Linetype Scale 

You can set global or individual scales for objects to control the display of linetypes. 

By default, the global and individual linetype scales are set to 1.0. The smaller the scale, the more 

repetitions of the pattern are produced per drawing unit. For example, if the scale is set to 0.2, five 

repetitions of the pattern in the linetype definition are displayed for each drawing unit. 

If short segments are too short to display one full linetype pattern, it is displayed as continuous. 

When the lines are too short to display even one dash sequence, you need to specify a smaller 

linetype scale. Otherwise, the linetype is displayed as continuous shown as the following 

illustration: 

 

For polylines, you can use system variable PLINEGEN to control whether a linetype pattern is 

centered on each segment or is continuous across vertices throughout the entire length of the 

polyline. 

 

The Global Scale Factor and Current Object Scale are displayed in the Linetype Manager. 

The Global Scale Factor and Current Object Scale are displayed in the Linetype Manager. The Global 

Scale Factor value is stored in the system variable LTSCALE, which changes the linetype scale 

globally for new and existing objects. The Current Object Scale is stored in the system variable 

CELTSCALE, which specifies the linetype scale for new objects. You can get the displayed linetype 

scale by multiplying the CELTSCALE value with the LTSCALE value. The linetype scales in the drawing 

can be changed easily either individually or globally. 
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In a layout, you can use system variable PSLTSCALE to adjust the linetype scale in different 

viewports. 

NOTE Setting the linetype scale too large or too small may result in a line pattern looking like a solid 

line, depending on what the scale view is or at what scale the drawing is printed. 

You can control a new entity's individual linetype scale factor as well as the overall or global scale 

factor applied to all the entities in the drawing. 

To set the current individual linetype scale 

Choose Format > Linetype from the main menu. 

Click the Show Details button. 

In the Current Object Scale field, type the linetype scale that you want to make current. 

Click OK. 

Command line LINETYPE 

 

To change the global linetype scale 

Choose Format > Linetype from the main menu. 

Click the Show Details button. 

In the Global Scale Factor field, type the global linetype scale that you want to change. 

Click OK. 

Command line LINETYPE 

 

Commands Reference 

LINETYPE: Loads, sets, and modifies linetypes 

PROPERTIES: Controls properties of existing objects 

System Variables Reference 

CELTSCALE: Sets the current object linetype scaling factor 

LTSCALE: Sets the global linetype scale factor  

PSLTSCALE: Controls paper space linetype scaling 

PLINEGEN: Sets how linetype patterns generate around the vertices of a 2D polyline 

5.8 Work with Layers 
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Layers are like transparent overlays on which you organize and group different kinds of drawing 

information.  

Topics in this section: 

 Overview of Layers 

Layers in ZWCAD+ are like the transparent overlays you use in manual drafting. You use layers to 

organize different types of drawing information. 

 Create and Name Layers 

By grouping objects into layers, you can control their display and make changes quickly and 

efficiently. 

 Change Layer Settings and Layer Properties 

Everything in a drawing is associated with a layer, in the course of creating a drawing, you can 

modify what you draw by renaming layer name, modifying the properties of a layer (color and 

linetype), or placing objects from one layer to another. 

 Filter and Sort the List of Layers 

Limits the display of layer name listed in the Layer Properties Manager and sorts them by name or 

by properties, such as color and visibility. 

 Save and Restore Layer Settings 

You can save the current layer settings in a drawing and restore them later. 

 Overview of Layers 

Layers in ZWCAD+ are like the transparent overlays you use in manual drafting. You use layers to 

organize different types of drawing information. In ZWCAD+, each object in a drawing exists on a 

layer. When you draw an object, it is created on the current layer. 
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You can control the visibility of layers in individual viewports. When you turn a layer off, objects 

drawn on that layer are no longer visible, and they do not print. Although a layer may be invisible, 

you can still select it as the current layer, in which case new objects are also invisible until you turn 

the layer back on. Objects on invisible layers can also affect the display and printing of objects on 

other layers. For example, entities on invisible layers can hide other objects when you use the Hide 

command to remove hidden lines. 

You can also freeze and thaw layers. Objects drawn on frozen layers do not display, do not print, 

and do not regenerate. When you freeze a layer, its objects do not affect the display or printing of 

other objects. For example, objects on frozen layers do not hide other objects when you use the 

Hide command to remove hidden lines. In addition, you cannot draw on a frozen layer until you 

thaw it, and you cannot make a frozen layer current. 

You cannot freeze the current layer. If you attempt to freeze the current layer, a dialog box 

prompting "Cannot freeze the current layer" appears. You also cannot freeze or thaw a viewport 

layer unless you are working in a Layout tab. 

You can lock or unlock layers. The objects on a locked layer are still visible and will print, but you 

cannot edit them. Locking a layer prevents you from accidentally modifying objects. 

Each layer has its own color, linetype, and lineweight. For drawings that use named print styles, 

layers can also have their own print style. Objects you draw on a particular layer are displayed in 

the color, linetype, and lineweight associated with that layer unless you override these settings.  

 

Commands Reference 

LAYER: Manages layers and layer properties 

System Variables Reference 

None 

 Create and Name Layers 

You can create an unlimited number of layers in every drawing and use those layers for organizing 
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information. When you create a new layer, it is initially assigned the color white (or black, 

depending on your system settings) and the linetype CONTINUOUS. By default, a new layer is also 

visible. After you create and name a layer, you can change its color, linetype, visibility, and other 

properties. 

Layers can have alphanumeric names up to 255 characters long. 

In many cases, the layer names you choose are dictated by corporate, industry, or client standards. 

The Layer Properties Manager sorts layers alphabetically by name. 

To create a new layer 

Choose Format > Layer from the main menu. 

Click the New Layer button. 

Type a name for the new layer. 

Click OK. 

Layers toolbar:  

Command line LAYER 

 

To change a layer name in the current drawing 

Choose Format > Layer from the main menu. 

In the Layer Properties Manager dialog box, click the name of layer you want to change. 

Type a new name and click OK. 

Layers toolbar:  

Command line LAYER 

NOTE You cannot rename the 0 layer. 

 

Setting the current layer 

When you start a drawing, objects are created in the current layer. By default, the layer 0 is set to 

the current layer, but you can also create a new one and make it current. Either frozen or 

xref-dependent layer cannot be set to the current layer. Any subsequent objects you create are 

associated with the current layer and use its color and linetype. 

To make a layer current 

Choose Format > Layer from the main menu. 

In the Layer Properties Manager dialog box, select a layer and then click the Set Current button to 

make the layer current. 
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Clicks OK. 

Layers toolbar:  

Command line LAYER 

 

Remove Layers 

You can remove unused layers from your drawing with PURGE or by deleting the layer from the 

Layer Properties Manager.  

 

Commands Reference 

LAYER: Manages layers and layer properties  

PURGE: Removes unused named items, such as block definitions and layers, from the drawing 

System Variables Reference 

CLAYER: Sets the current layer  

 Change Layer Settings and Layer Properties  

Everything in a drawing is associated with a layer, in the course of creating a drawing, you can 

modify what you draw by renaming layer name, modifying the properties of a layer (color and 

linetype), or placing objects from one layer to another. 

If you create an object on a wrong layer, you can reassign it to another layer. Unless the linetype, 

color or other properties of the object has been specified explicitly, the object acquires the 

properties of the new layer. 

You can change layer properties in the layer control on the Layers toolbar or in the Layer Properties 

Manager. Click the icons to change settings. However, layer names and colors can be changed only 

in the Layer Properties Manager. 

Controlling layer visibility 

A layer can be visible or invisible. Objects on invisible layers are not displayed and do not print. By 

controlling layer visibility, you can turn off unnecessary information, such as construction lines or 

notes. By changing layer visibility, you can put the same drawing to multiple uses. 

For example, if you are drawing a floor plan, you can draw the layout of light fixtures on one layer 

and the location of plumbing lines on another. By selectively turning layers on and off, you can print 

the electrical engineering drawings and the plumbing drawings from the same drawing file. For 

even more convenience, you can control the visibility of layers within individual viewports, so that 

layers that display in one viewport are invisible in other viewports in the same drawing. 
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When you turn a layer off, objects drawn on that layer are no longer visible. When you turn the 

layer back on, the objects on that layer are redisplayed. 

To turn layers on or off 

Choose Format > Layer from the main menu. 

Click the icon under "On" tab in the layer list. 

Click OK. 

Layers toolbar:  

Command line LAYER 

 

Freeze or thaw layers 

You can also freeze layers to improve the performance of operations such as zooming and panning 

or producing hidden lines or shaded images. When a layer is frozen, objects drawn on that layer are 

no longer visible. 

To freeze or thaw layers 

Choose Format > Layer from the main menu. 

Click the icon under "Freeze" tab in the layer list. 

Click OK. 

Layers toolbar:  

Command line LAYER 

 

Locking and unlocking layers 

Locking a layer makes it easy to refer to information contained on the layer, but prevents you from 

accidentally modifying its objects. When a layer is locked (but visible and thawed), its objects 

remain visible, but you cannot edit them. If you lock the current layer, you can still add new objects 

to it. You can also change the linetype and color associated with a locked layer. 

Unlocking a layer restores full editing capabilities. 

To lock or unlock layers 

Choose Format > Layer from the main menu. 

Click the icon under "Lock" tab in the layer list. 

Click OK. 

Layers toolbar:  

Command line LAYER 

 

Controlling layer printing 

Controlling layer printing is another way you can specify which objects print in your drawing. 

By controlling layer printing, you can turn off unnecessary information during printing. For example, 
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if you are drawing a floor plan, you can draw the layout of light fixtures on one layer and the 

location of plumbing lines on another. By selectively turning layers on and off when you print, you 

can print the electrical engineering drawings and the plumbing drawings from the same drawing 

file. By changing layer printing, you can put the same drawing to multiple uses. 

When you turn off printing for a layer, objects drawn on that layer are still visible, but they do not 

print. If you turn off a layer's visibility, objects drawn on that layer do not display or print. 

Controlling layer printing can be especially helpful if you want layer visibility on, but do not want to 

print objects on that layer. 

To turn layer printing on or off 

Choose Format > Layer from the main menu. 

Click the icon under "Plot" tab in the layer list. 

Click OK. 

Layers toolbar:  

Command line LAYER 

 

Setting the layer color 

Each layer in a drawing is assigned a color. ZWCAD+ uses the BYLAYER color as the default color 

setting for object creation so that new objects are drawn in the color of the layer on which they are 

inserted. 

To change the layer color 

Choose Format > Layer from the main menu. 

Click the icon under "Color" tab in the layer list to open Select Color dialog box, from which, you 

can specify the desired color. 

In the Select Color dialog box, select a color from one of the following tabs: 

Index Color — Click BYBLOCK, BYLAYER, or one of the 255 index colors. You can also type the color 

number in the Color box. 

True Color — Click a basic color in the left color panel, and then move the slider on the right to 

specify a color. There are more than 16 million true colors from which you can choose. 

Color Books — Select a color book from the Color Book pull-down list, and then click a desired 

color from the options displayed. 

Click OK. 

Layers toolbar:  

Command line LAYER 

NOTE You can also assign a specific color to an object, which overrides the layer's color setting. 

When you create a new object, use the Format > Color menu option to change the current color. 

For an existing object, double-click this object and then change the object's color on the Properties 

palette that pops up. 
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Setting a layer's linetype 

Each layer uses a default linetype (a repeating pattern of dashes, dots, or blank spaces). Linetype 

determines the appearance of objects both on the screen and when printed. 

It's a good idea to assign the BYLAYER linetype to any objects that you draw on that layer. 

ZWCAD+ uses the BYLAYER linetype as the default linetype setting for Object Creation. 

NOTE Only those linetypes already set in the drawing can be assigned to layers. 

To change the linetype assigned to one or more layers 

Choose Format > Layer from the main menu. 

Click the Linetype name in the layer list to open Select Linetype dialog box, from which, you can 

specify the desired linetype. 

Click OK. 

Layers toolbar:  

Command line LAYER 

NOTE You can also assign a specific linetype to an object, which overrides the layer's linetype 

setting. When you create a new object, use the Format > Linetype menu option to change the 

current linetype. For an existing object, double-click this object and then modify the object's 

linetype on the Properties palette that pops up. 

 

Setting a layer's lineweight 

Each layer uses a default lineweight. Lineweights determine the thickness of objects both on the 

screen and when printed. 

All new layers are assigned the DEFAULT lineweight, which is .25 millimeters or .01 inches. 

If you want a different lineweight assigned to a layer, you can easily change it using Layer Properties 

Manager. For example, you may want different lineweights on each layer of your drawing to show 

separate elements, such as walls, dimensions, structural steel, and electrical plans. Changing the 

lineweight assigned to a layer changes the lineweight of all objects drawn on that layer with the 

BYLAYER lineweight. 

When you create new objects, it's a good idea to assign the BYLAYER lineweight to any objects that 

you draw on that layer, unless you want to override the layer lineweight. ZWCAD+ uses the 

BYLAYER lineweight as the default lineweight setting when you create objects. 

To change the lineweight assigned to one or more layers 

Choose Format > Layer from the main menu. 

Click the Lineweight name in the layer list to open Lineweight dialog box, from which, you can 

specify the desired lineweight. 

Click OK. 

Layers toolbar:  

Command line LAYER 
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NOTE You can also assign a specific lineweight to an object, which overrides the layer's lineweight 

setting. When you create a new object, use the Format > Lineweight menu option to change the 

current lineweight. For an existing object, double-click this object and then modify the object's 

lineweight on the Properties palette that pops up. 

 

Setting a layer's print style 

If your drawing uses named print style tables, you can specify a print style for each layer. 

Named print style tables contain print styles that you set up to control what objects look like when 

they print, without actually changing the objects in the drawing. 

If your drawing uses color-dependent print style tables, you cannot specify a print style for a layer. 

These types of print style tables automatically determine printing requirements by the color 

assigned to a layer or an object. 

In drawings that use named print style tables, the default print style is Normal for all new layers. If 

desired, you can assign a print style using Layer Properties Manager. Changing the print style 

assigned to a layer changes the print style of all objects drawn on that layer with the BYLAYER print 

style. 

When you create new objects, it's a good idea to assign the BYLAYER print style to any objects that 

you draw on that layer, unless you want to override the layer print style. ZWCAD+ uses the BYLAYER 

print style as the default print style setting when you create objects. 

To change the print style assigned to one or more layers (only in a drawing that uses named print 

style tables) 

Choose Format > Layer from the main menu. 

Click the name of Plot Style in the layer list to open Select Plot Style dialog box, from which, you 

can specify the desired plot style. 

Click OK. 

Layers toolbar:  

Command line LAYER 

 

Commands Reference 

CHANGE: Changes the properties of existing objects  

CHPROP: Changes the color, layer, linetype, linetype scale factor, lineweight, thickness, and plot 

style of an object 

LAYER: Manages layers and layer properties 

PROPERTIES: Controls properties of existing objects 
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PURGE: Removes unused named items, such as block definitions and layers, from the drawing 

RENAME: Changes the names of objects 

System Variables Reference 

CLAYER: Sets the current layer 

 Filter and Sort the List of Layers 

Limits the display of layer name listed in the Layer Properties Manager and sorts them by name or 

by properties, such as color and visibility. 

You can use a layer filter limits the display of layer names in the Layer Properties Manager. 

The following properties can be included in the filter definition: 

Whether layers are set to be plotted 

Layer names, colors, linetypes, lineweights, and plot styles 

Whether layers are locked or unlocked 

Whether layers are turned on or off 

Whether layers are frozen or thawed in the current viewport or all viewports 

When setting filter conditions, you can also use wild-card characters to filter names by name. For 

example, typing nare* displays layer name preceded with nare, just click Add button if the filter 

name has been specified. 

You can also use invert filter to display layer names that do not be included filter definition. For 

example, if all the site plan information of a drawing is contained in multiple layers, which include 

the word lite as part of the layer name, you should firstly define the filter by way of specifying filter 

name and inputting *lite* in layer name option, and then click Invert Filter option to display all the 

information excluded from the site plan information. 

Name Layer Filters lists default filters and other saved filters created in the current drawing. The 

three default filters are shown as follows: 

Show all layers. 

Show all used layers. 

Show all Xref_dependent layers. 

The new created filters are displayed in the Name Layer Filters at the Layer Properties Manager. 

These filters are saved with the drawing. 

Sort Layers 

From the Layer Properties Manager, you can click column heading to sort layers by their properties 

in that column. The properties include layer name, visibility, color, lineweight, plotted style and 

linetype. And layer names can be sorted in descending or ascending alphabetical/numerical order. 

 

Commands Reference 
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LAYER: Manages layers and layer properties 

System Variables Reference 

MAXSORT: Sets the maximum number of symbol names or block names sorted by listing 

commands 

 Save and Restore Layer Settings 

You can save the current layer settings in a drawing and restore them later. 

Save Layer Settings 

Layer settings include: 

Layer states, such as on, frozen, locked, plot and freeze automatically in a new viewport. 

Layer properties, such as color, linetype, lineweight and plot style. 

You can save layer settings alternatively. For example, you can choose to save only Frozen/Thawed 

settings of the layers in a drawing, ignoring all other settings. When you restore the layer states, all 

settings remain as they are currently set except whether each layer is frozen or thawed. 

You can export named layer states to an LAS file for use in other drawings using the Layer States 

Manager. The layer states of xref cannot be exported. 

Restore Layer Settings 

You can not only restore the saved settings, but also edit, rename or delete named settings. Using 

Layer States Manager, you can import named layer states that were previously export to LAS files. 

Whatever layer states come from the drawing or LAS files, only saved settings can be restored and 

the unspecific layer settings remains the original settings. 

 

Commands Reference 

LAYER: Manages layers and layer properties 

System Variables Reference 

None 

5.9 Work with Colors 

An entity's color determines how it is displayed and, if you are using a color printer, how it prints. 

Entities are created in the current color specified for the drawing. 

Layers can also control the color of entities. When you open a new drawing, entities are created in 

the color BYLAYER, which adopts the color of the current layer. Initially, layer 0 is both the only layer 
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and the current layer. Its default color is white, so your entities appear as white. 

For entities and layers in ZWCAD+, there are three different types of colors: 

 Index colors 

 True colors 

Color books colors 

You can choose colors by selecting them from the Select Color dialog box. In the command bar or in 

some dialog boxes, you specify a color either by name or by number. 

All objects are created with the current color, which is displayed in the Color Control on the 

Properties toolbar. With the Color Control or the Select Color dialog box, you can also set the 

current color. 

Objects are created with the color assigned to the current layer. If the current color is set to 

BYLAYER. If the current color is not expected to be the color assigned to the current layer, you can 

specify another color instead. 

If the current color is set to BYBLOCK, objects are created using color 7 (white or black) until these 

objects are grouped into a block. Once the block is inserted into a drawing, it uses current color 

settings instead. 

 Use Index Colors 

There are 255 standard index colors and two additional color properties that are often referred to 

as colors (BYLAYER and BYBLOCK). You can use seven of the 255 standard index colors by name: red, 

yellow, green, cyan, blue, magenta, and white. (Numbers eight and nine are not named.) Each index 

color has a unique number from 1 to 255. The two additional color properties are BYLAYER and 

BYBLOCK. These color properties cause an entity to adopt the color either of the layer or of the 

block in which it is a member. BYLAYER is color number 256, and BYBLOCK is color number 0. In all 

commands for which you would use a color, you can indicate BYLAYER and BYBLOCK as well as by 

numbers 256 and 0, respectively. 

To select an index color 

Click Select Color in the desired dialog box, such as Layers, Properties, or Multiline Text. The Select 

Color dialog box opens. 

Click the Index Color tab. 

Click the color of your choice, or type the color number in the Color box. 

Click OK. 

 

Commands Reference 

COLOR: Sets the color for new objects 
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System Variables Reference 

CECOLOR: Sets the color of new objects 

 Use True Colors 

There are more than 16 million true colors from which you can choose. True colors are defined 

using 24 bit color. 

Even with so many colors available, you can quickly choose a color from the display of basic colors 

or by clicking the color palette. Alternatively, if you know the values used to define the desired 

color, you can enter the Hue, Saturation, and Luminance (HSL) values, or you can enter the Red, 

Green, Blue (RGB) values. 

To select a true color 

Click Select Color in the desired dialog box, such as Layers, Properties, or Multiline Text. The Select 

Color dialog box opens. 

Click the True Color tab. 

Select one of the following two color models: 

HSL color model 

RGB color model 

Specify the desired color. 

Click OK. 

 

Commands Reference 

COLOR: Sets the color for new objects 

System Variables Reference 

CECOLOR: Sets the color of new objects 

 Use Color Books 

ZWCAD+ uses color books to store collections of colors. For example, you can store a unique color 

scheme for a client in a color book and then use colors only from that color book for the client's 

drawings. 

You may have a color book given to you by a client, developed by a third party, or you can create 

your own. Each color book has an .acb extension and is saved in Extensible Markup Language (XML) 

format. By default, color books are stored in the ...Support\color folder under ZWCAD+ installation 

directory. 

To create a color book 

Start an XML editor program. 

Create a new XML file using the format below as a guide. 



 

 115 

<colorBook> 

<bookName>Color  

book sample</bookName> 

<colorPage> 

<pageColor><RGB8><red>0</red><green>0</green><blue>0</blue></R

GB8> 

</pageColor><colorEntry> 

<colorName>Orange</colorName> 

<RGB8><red>255</red><green>128</green><blue>0</blue></RGB8> 

</colorEntry> 

<colorEntry> 

<colorName>Light  

Green</colorName> 

<RGB8><red>128</red><green>192</green><blue>128</blue></RGB8> 

</colorEntry> 

<colorEntry> 

<colorName>Gray</colorName> 

<RGB8><red>128</red><green>128</green><blue>128</blue></RGB8> 

</colorEntry> 

</colorPage> 

</colorBook> 

NOTE Your color book can contain an unlimited number of colors using the <colorEntry> and 

</colorEntry> tags. 

Save the color book in XML format and with an .acb extension. 

 

To load a color book 

Save the color book in the folder where ZWCAD+ searches for color books. By default, this is the 

same folder where you installed ZWCAD+. 

To select a color book color 

Click Select Color in the desired dialog box, such as Layers, Properties, or Multiline Text. The Select 
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Color dialog box opens. 

Click the Color Books tab. 

Select a color book from the list. 

Click the desired color. 

Click OK. 

 

Commands Reference 

COLOR: Sets the color for new objects 

System Variables Reference 

CECOLOR: Sets the color of new objects 

5.10 Control Lineweights 

You can further differentiate objects in your drawing by controlling their lineweights both in the 

drawing display and in plotting. 

Topics in this section: 

 Overview of Lineweights 

Lineweights help differentiate the purpose of one line from another. Lineweights determine how 

thick or thin entities appear both on the screen and when printed. 

 Display Lineweights 

Display lineweights in both of model space and layer space. Lineweights are displayed differently in 

paper space layout than model space. Lineweights are useful for graphical representations of 

different objects and information. 

 Change the Lineweight of an Object 

You can change the current lineweight of an object by reassigning the object to another layer, by 

changing the lineweight of the layer the object is on, or by specifying a lineweight for the object 

explicitly. 

 Overview of Lineweights 

Lineweights help differentiate the purpose of one line from another. Lineweights determine how 

thick or thin entities appear both on the screen and when printed. 

By default, each drawing has three main lineweights: DEFAULT, BYLAYER, BYBLOCK, and many 

additional lineweights in millimeters (or you can use inches). 
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When you create an entity, it is created using the current lineweight. By default, the current 

lineweight for a new entity is BYLAYER. This means that the entity lineweight is determined by the 

current layer. When you assign BYLAYER, changing a layer's lineweight changes the lineweight of all 

the entities assigned that layer (if they were created using the lineweight BYLAYER). 

You can also select a specific lineweight (or DEFAULT) as the current lineweight, which overrides the 

layer's lineweight setting. Entities are then created using that lineweight (or the DEFAULT 

lineweight), and changing the layer lineweight has no effect on them. 

As a third option, you can use the lineweight BYBLOCK property, in which case new entities are 

drawn using the DEFAULT lineweight until you group them into a block. 

The entities then inherit the block's lineweight setting when you insert the block into a drawing. 

If you choose a lineweight that is less than .025 millimeter, it displays as one pixel when you create 

your drawing. When you print your drawing, it prints at the thinnest lineweight that is available for 

your printer. 

You cannot assign lineweights to planes, points, TrueType fonts, or raster images. 

 

Commands Reference 

LWEIGHT: Sets the current lineweight, lineweight display options, and lineweight units 

PLINE: Creates two-dimensional polylines 

System Variables Reference 

None 

 Display Lineweights 

Display lineweights in both of model space and layer space. Lineweights are displayed differently in 

paper space layout than model space. Lineweights are useful for graphical representations of 

different objects and information. 

Display Lineweights in Model Space 

In model space, a 0-value lineweight is displayed as a pixel, and other lineweights are display with a 

pixel width proportional to their real-unit value. 

In model space, lineweight display does not change with the zoom factor. A lineweight value that is 

represented by a width of several pixels is always displayed using the same number of pixels. Unless 

you use LWEIGHT command to open Lineweight Settings dialog box and change the display scale, 

the lineweight display scale keeps unchanged. In addition, the lineweight display scale does not 

affect the lineweight plotting value. 

Lineweight that are represented more than one pixels increase regeneration time. Turning off the 

display of lineweight optimizes performance of the program. 

In model space, press LWT button on the status toolbar to turn lineweight display on and off. 
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Display Lineweights in Layouts 

In paper space (layout tab), lineweights are displayed in exact plotting width. 

In plot preview and paper space, lineweights are displayed in real-world units, and lineweight 

changes with the scale factor. From the Plotting Scale tab of Plot dialog box, you can control the 

lineweight plotting and scaling in a drawing. 

In paper space, press LWT button on the status toolbar to turn lineweight display on and off. This 

change does not affect the lineweight plotting. 

 

Commands Reference 

LWEIGHT: Sets the current lineweight, lineweight display options, and lineweight units 

PLINE: Creates two-dimensional polylines 

LAYER: Manages layers and layer properties 

PEDIT: Edits polylines and three-dimensional polygon meshes  

PLOT: Plots a drawing to a plotter, printer, or file  

System Variables Reference 

LWDISPLAY: Controls whether the lineweight is displayed on the Model or Layout tab 

PLINEWID: Stores the default polyline width 

 Change the Lineweight of an Object 

You can change the current lineweight of an object by reassigning the object to another layer, by 

changing the lineweight of the layer the object is on, or by specifying a lineweight for the object 

explicitly. 

Set the Current Lineweight 

All objects are created in a drawing using the current lineweight. You can change the lineweight in 

the Lineweight control on the Properties toolbar, or in the Lineweight Settings dialog box. 

If the current lineweight is set to BYLAYER, objects are created in a drawing using the lineweight 

assigned to the current layer. 

If the current lineweight is set to BYBLOCK, objects are created using the default lineweight, until 

the objects are grouped into a block. When the block is inserted into a drawing, it acquires the 

current lineweight setting. 

To specify a lineweight for the current layer that is different from the current lineweight, open the 
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Layer Properties Manager and give a specific value. 

By default, the lineweight of an object is set to BYLAER, and the lineweight of a layer is set to 

DEFAULT. Lineweight that is assigned to objects is displayed as a solid fill drawn in the object's 

assigned color. 

To set the current lineweight 

Choose Format > Lineweight from the main menu. 

From the Lineweight list, choose the lineweight that you want to make current. 

Click OK. 

Command line LINEWEIGHT 

TIP On the status bar, click the LWT button to toggle the display of lineweights on and off. 

NOTE To see lineweights in your drawing, you may need to turn on lineweights. 

 

Change the Lineweight of an Object 

There are three choices for changing the lineweight of an object: 

If the lineweight of an object is set to BYLAYER, and you reassign the object to a different layer, the 

object acquires its lineweight from the new layer. 

If the lineweight of an object is set to BYLAYER, you can change the lineweight of the layer the 

object is on, and all objects assigned to BYLAYER on that layer are updated automatically. 

Specify a lineweight for an object to override the layer's lineweight. If you want to specify a 

lineweight to override the layer-determined lineweight of an object, change an existing object's 

lineweight from BYLAYER to a specific lineweight. 

In order to create subsequent objects using a new lineweight, you have to change the lineweight 

setting on the Properties toolbar from BYLAER to the specific one.  

 

Commands Reference 

LWEIGHT: Sets the current lineweight, lineweight display options, and lineweight units 

PLINE: Creates two-dimensional polylines 

LAYER: Manages layers and layer properties 

PEDIT: Edits polylines and three-dimensional polygon meshes  

PLOT: Plots a drawing to a plotter, printer, or file  

System Variables Reference 
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LWDISPLAY: Controls whether the lineweight is displayed on the Model or Layout tab 

PLINEWID: Stores the default polyline width 

5.11 Control the Display of Overlapped Objects  

Control how overlapping objects and some other objects are displayed and plotted. 

Polylines, Hatches, Gradient Fills, Lineweights, and Text 

You can simplify the display of certain kinds of objects, such as wide polylines, donuts, solid-filled 

polygons (2D solids), hatches, gradient fills and text, to improve the display performance and speed 

up of creating test plots. 

Turning Fill on and off 

You can reduce the time it takes to display or print a drawing by turning off the display of solid fill. 

When Fill is turned off, all filled entities, such as wide polylines and planes, display and print as 

outlines. When you turn Fill on or off, you must redraw the drawing before the change is displayed. 

To turn Fill on or off 

Choose Tools > Options from the main menu. 

Click the Display tab. 

Under Display Performance, select or clear the Apply Solid Fill check box. 

Choose View > Redraw from the main menu. 

Command line FILL 

 

 

Use Quick Text 

If a drawing contains a lot of text using complex fonts, only a rectangular frame defining the text is 

displayed or plotted when you turn on Quick Text mode. 
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Text entities require a considerable amount of time to display and print. You can reduce the time it 

takes to display or print a drawing by enabling Quick Text. For example, if you're doing a 

preliminary check print of a drawing, you may want to turn Quick Text on to speed up printing. 

When Quick Text is enabled, text entities are replaced by rectangular boxes that indicate the 

outline of the area occupied by the text. When you turn Quick Text on or off, you must regenerate 

the drawing before the change is displayed. 

To turn Quick Text on and off 

Choose Tools > Options from the main menu. 

Click the Display tab. 

Under Display Performance, select or clear the Show Text Boundary Frame Only check box. 

Click OK. 

To regenerate your drawing, do one of the following: 

Choose View > Regen from the main menu. 

Type REGEN in the command line and then press Enter. 

Command line QTEXTMODE 

 

Controlling the display of lineweights 

You can reduce the time it takes to display a drawing by turning off the display of lineweights. 

When you turn off lineweights, all entities display as outlines. You can also specify a lineweight 

scale. Specify a smaller scale to display thinner lines; specify a larger scale to display thicker lines. 

For example, a scale factor of 0.5 would display a .80 millimeter lineweight as .40 millimeter; a 

scale factor of 2 would increase the same lineweight to display at 1.6 millimeters. This can help you 

differentiate various lineweights that display in a drawing. Adjusting the lineweight display scale 

affects how the lineweights appear on your screen, not how they appear when printed. 

NOTE Setting the lineweight scale too high may result in slower system performance. 

You can also adjust the units for measuring lineweights, and the default lineweight. 

To control the display of lineweights 

Choose Format > Lineweight from the main menu. 

In Units for Listing, choose Millimeters or Inches. 

In Default, select the lineweight assigned to layers and entities that use the Default lineweight. 

In Adjust Display Scale, move the slider to the scale you want. By default, the slider begins at 1.00. 

Click OK. 

Command line LWEIGHT 
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TIP On the status bar, click the Show/Hide Lineweight button to turn the display of lineweights on 

or off. 

 

Update the Display 

New objects automatically apply the current settings to displays of solid fill and text. Except for 

lineweights, you must use the REGEN command to update the display of existing objects. 

Control How Overlapping Objects Are Displayed 

By default, newly created objects are in front of existing objects; all objects are displayed in the 

order they are created. To change the draw order, use DRAWORDER command. 

Note changing draw order is available only within the same space. 

 

Commands Reference 

DSETTINGS: Specifies settings for Snap mode, grid, and polar and object snap tracking 

FILL: Controls the filling of objects such as hatches, two-dimensional solids, and wide polylines 

LWEIGHT: Sets the current lineweight, lineweight display options, and lineweight units 

REGEN: Regenerates the entire drawing from the current viewport 

DRAWORDER: Changes the display order of images and other objects  

QSELECT: Creates a selection set based on filtering criteria 

SELECT: Places selected objects in the Previous selection set  

WBLOCK: Writes objects or a block to a new drawing file 

System Variables Reference 

FILLMODE: Specifies whether hatches (including solid-fill), two-dimensional solids, wide polylines, 

are filled in 

LWDISPLAY: Controls whether the lineweight is displayed on the Model or Layout tab 

QTEXTMODE: Controls how text is displayed 
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TEXTFILL: Controls the filling of TrueType fonts while plotting and rendering 

TEXTQLTY: Sets the resolution tessellation fineness of text outlines for TrueType fonts while 

plotting and rendering 

HPDRAWORDER: Controls the draw order of hatches and fills 

5.12 Extract or Calculate Geometric Information from Objects 

Information about objects in your drawing are allowed to inquire by means of performing inquiry 

and calculation commands, you can also make useful calculations, such as area and circumference 

calculation. 

Topics in this section: 

 Calculate Areas 

You can calculate the area and perimeter of a polygon based on a series of points you specify or 

enclose with a circle or closed polyline. You can also determine the area of several combined 

objects and add or subtract the area of one or more objects from a total combined area.  

 Calculate Distances and Angles 

You can calculate the distance between any two points you select. 

 Display Information about Your Drawing 

You can display a variety of information about a drawing and the objects it contains. 

 Calculate Areas 

You can calculate the area and perimeter of a polygon based on a series of points you specify or 

enclose with a circle or closed polyline. You can also determine the area of several combined 

objects and add or subtract the area of one or more objects from a total combined area. 

Calculating areas defined by points 

You can find the area and perimeter of any closed region by specifying a series of points. The 

program calculates the area and perimeter of the space that is enclosed by an imaginary polygon 

consisting of straight line segments connecting each point. 

To calculate the area defined by points you specify 

Choose Tools > Inquiry > Area from the main menu. 

Specify the first point. 

Specify the second point. 

Continue specifying points in sequence to define the perimeter of the area you want to measure.  

To complete the selection, press Enter.  
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The area and perimeter of the region you defined are displayed. 

Inquiry toolbar:  

Command line AREA 

 

Select the points (A, B, C) that form a 

polygon. The area and perimeter of the 

region are then calculated. 

 

Calculating areas of closed objects 

You can find the area of any closed object. In addition, the program calculates either the 

circumference or the perimeter of the object, depending on the type of object you select. 

To calculate the area of a closed object 

Choose Tools > Inquiry > Area from the main menu. 

On the command line, type o (object). 

Select the closed object. 

Inquiry toolbar:  

Command line AREA 

 

Calculating combined areas 

You can find the total area of several combined regions by specifying points or by selecting objects. 

You can also subtract the areas of objects or polygons from a running total. 

To add areas to calculate a combined area 

Choose Tools > Inquiry > Area from the main menu. 

On the command line, type a (add). 

Using one of the following methods, identify the first area: 

Specify points defining a polygon, and then press Enter. 

Type o (object), select the objects you want to add, and then press Enter to complete the selection. 

To complete the command, press Enter. 

Inquiry toolbar:  

Command line AREA 
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To subtract areas when calculating a combined area 

Choose Tools > Inquiry > Area from the main menu. 

On the command line, type a (add). 

Using one of the following methods, identify the first area: 

Specify points defining a polygon, and then press Enter. 

Type o (object), select the objects you want to add, and then press Enter to complete the selection. 

On the command line, type s (subtract). 

Using one of the following methods, identify the area to be subtracted: 

Specify points defining a polygon, and then press Enter. 

Type o (object), select the objects you want to subtract, and then press Enter to complete the 

selection. 

To complete the command, press Enter. 

Inquiry toolbar:  

Command line AREA 

 

To calculate the area of the gasket using the Area command, 

first add the area of the entire gasket (A), and then subtract 

the areas of the two circles (B and C) 

 

Commands Reference 

DIST: Measures the distance and angle between two points 

ID: Displays the coordinate of a location 

AREA: Calculates the area and perimeter of objects or of defined areas 

LIST: Displays database information for selected objects 

MASSPROP: Calculates the mass properties of regions or 3D solids 

PROPERTIES: Controls properties of existing objects 
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UNITS: Controls coordinate and angle display formats and precision 

CAL: Evaluates mathematical and geometric expressions 

System Variables Reference 

DISTANCE: Sets the display size for point objects  

AREA: Stores the last area computed by the AREA command 

PERIMETER: Stores the last perimeter value computed by the AREA or LIST commands 

 Calculate Distances and Angles 

You can calculate the distance between any two points you select. The following information is 

displayed: 

The distance between the points, measured in drawing units. 

Their angle in the xy plane. 

Their angle measured from the xy plane. 

The change (delta) in the x, y, and z distances between the two points. 

To calculate the distance between two points and their angle 

Choose Tools > Inquiry > Distance from the main menu. 

Specify the first point. 

Specify the second point. 

Inquiry toolbar:  

Command line DIST 

 

Use the Distance command to calculate the distance (A) 

between two points (B and C), the angle in the xy plane (D), 

the angle from the xy plane, and the delta x (E), delta y (F), 

and delta z distances between the two points. 
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TIP To use specific points on selected objects, use object snaps to select 

the precise points on the objects. 

 

Commands Reference 

DIST: Measures the distance and angle between two points 

ID: Displays the coordinate of a location 

AREA: Calculates the area and perimeter of objects or of defined areas 

LIST: Displays database information for selected objects 

MASSPROP: Calculates the mass properties of regions or 3D solids 

PROPERTIES: Controls properties of existing objects 

UNITS: Controls coordinate and angle display formats and precision 

CAL: Evaluates mathematical and geometric expressions 

System Variables Reference 

DISTANCE: Sets the display size for point objects  

AREA: Stores the last area computed by the AREA command 

PERIMETER: Stores the last perimeter value computed by the AREA or LIST commands 

 Display Information about Your Drawing 

You can display a variety of information about a drawing and the objects it contains, including: 

Information in the drawing database about selected objects. 

The current drawing status. 

The time spent working on the drawing. 

This information is displayed in the Prompt History window and in the command bar. 

Displaying information about objects 

You can display information about the selected objects. The information varies, depending on the 

type of objects you select. All of the listings display the following information: 

Object type. 
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Layer. 

Color. 

Linetype. 

The location of the object (its xyz coordinates relative to the current user coordinate system [UCS]). 

The current space (model space on the Model tab or paper space on a Layout tab). 

The size of the object (the information varies, depending on the object type). 

To display information about an object 

Choose Tools > Inquiry > List from the main menu. 

Select one or more objects. 

Press Enter. 

Inquiry toolbar:  

Command line LIST 

TIP To return to the drawing window, press F2. 

 

Displaying the drawing status 

You can display information about the current status of a drawing, including: 

Drawing name. 

Limits. 

Insertion base point. 

Snap and grid settings. 

Current layer, color, and linetype. 

Current settings for various modes (fill, grid, orthogonal, snap, blips, and so on). 

To display the drawing status 

Choose Tools > Inquiry > Status from the main menu. 

Command line STATUS 

 

Tracking time spent working on a drawing 

You can display information about the amount of time you have spent working on a drawing, 

including: 

The date and time the drawing was created. 

The date and time the drawing was most recently saved. 

The total amount of time spent working on the drawing. 

The time spent working on the drawing during the current editing session. You can turn the elapsed 

time timer on and off or reset it to zero. 

To display the timer information 

Choose Tools > Inquiry > Time from the main menu. 

You can do one of the following: 

Type on to turn the elapsed timer on. 

Type off to turn the elapsed timer off. 
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Type d (display) to redisplay the timer information. 

Type r (reset) to reset the elapsed timer to zero. 

Press Enter to exit the command. 

Command line TIME 

 

Commands Reference 

ID: Displays the coordinate of a location 

LIST: Displays database information for selected objects 

PROPERTIES: Controls properties of existing objects 

TIME: Displays the current time and the last updated time, total editing time, elapse time and the 

time that the current drawing were created 

STATUS: Displays the information of the current drawing 

System Variables Reference 

LUPREC: Controls the number of decimal places shown for coordinate display and linear units in 

commands 

PICKFIRST: Controls whether you select objects before (noun-verb selection) or after you issue a 

command 

5.13 Specify Intervals on Objects 

You can divide a line, arc, circle, polyline, ellipse, or spline into a number of equal segments or mark 

off intervals of a specific length along an object. (Note that divide is not the same as break.) For 

example, you may want to place station-point markers every 50 feet along the centerline of a 

roadway or divide the plan view of a window into three equal width sections of glass, placing a 

mullion at each division point. 

To specify measurements and divisions, use these commands: 

For the length of the segments, use the Measure command. 

For the number of equal length segments, use the Divide command. 

You can measure or divide arcs, circles, lines, polylines, ellipses, and splines. With either command, 

you can identify the segments by placing either a block or point object at the end of each interval. 

If you use points, you can snap to the ends of intervals using the point object snap. The appearance 

of the point object is determined by the current point display type, which you control in the Point 

Style dialog box of Format menu. 

To use a block as the marker, the block must already be defined in the current drawing. You can 

further indicate whether to rotate the block to align perpendicularly to the object you are 
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measuring or dividing. 

 

Block not aligned with object Block aligned with object 

ZWCAD+ begins measuring or dividing based on the point at which you select the object and the 

type of object with which you are working. For most objects, measuring starts from the endpoint 

closest to the point you used to select the object.  

The starting point for measurements or divisions depends on the selected object type. Generally, it 

includes the following cases: 

For lines or open polylines, the starting point is the endpoint that is closest to the selection point. 

For closed polylines, the starting point is the polyline start point. 

For circles, it is at the angle from the center point which is equivalent to the current snap angle. For 

example, if the snap angle is set to 0, the circle starts at the three o'clock position and continues 

counterclockwise. 

By default, the point marker is displayed as a single dot, and you may not be able to the measure 

intervals. You can change the appearance of point markers using system variable PDMODE. In 

addition, you can change the style of point markers in the Point Style dialog box with the DDPTYPE 

command. And the system variable PDSIZE controls the size of point markers. 

Divide an Object into Equal Segments 

Places point markers on selected objects. The markers divide the selected objects into a specified 

number of equal lengths. The objects that can be separated include lines, arcs, circles, ellipses, 

splines and polylines. Actually, this operation does not separate the object; it only identifies the 

location of divisions so that you can use them as geometric reference points. 

 

To divide an object into segments and mark them using point objects 

Choose Draw > Point > Divide from the main menu. 

Select the object. 

Specify the number of segments, and then press Enter. 

Command line DIVIDE 
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When you select the object by pointing, divisions are 

marked beginning from the end closest to the point at 

which you select the object (A) 

Blocks or point objects (B) are placed 

along the object to mark it in equal 

intervals 

 

To divide an object into segments and mark them using blocks 

Choose Draw > Point > Divide from the main menu. 

Select the object. 

On the command line, type b (block). 

Type the name of the block you want to insert as the marker. 

Enter y to align the blocks with the measured object. Enter n to use a rotation angle of 0 degrees. 

Specify the number of segments, and then press Enter. 

Command line DIVIDE 

 

Specify Measured Intervals on Objects 

Use MEASURE to mark an object at specified intervals with either points or blocks. The last 

segment of a measured object may be shorter than the interval you specify. 

 

To measure intervals along an object and mark them using point objects 

Choose Draw > Point > Measure from the main menu. 

Select the object. 

Specify the segment length, and then press Enter. 

Command line MEASURE 

 

When you select the object by pointing, 

intervals are measured from the end 

Blocks or point objects (B) are 

placed along the object at the 
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closest to the point at which you select 

the object (A) 

specified interval 

 

To measure intervals along an object and mark them using blocks 

Choose Draw > Point > Measure from the main menu. 

Select the object. 

On the command line, type b (block). 

Type the name of the block you want to insert as the marker. 

Enter y to align the blocks with the measured object. Enter n to use a rotation angle of 0 degrees. 

Specify the segment length, and then press Enter. 

Command line MEASURE 

 

Commands Reference 

BLOCK: Creates a block definition from objects you select 

DDPTYPE: Specifies the display style and size of point objects 

DIVIDE: Places evenly spaced point objects or blocks along the length or perimeter of an object 

MEASURE: Places point objects or blocks at measured intervals on an object 

WBLOCK: Writes objects or a block to a new drawing file 

System Variables Reference 

PDMODE: Controls how point objects are displayed  

PDSIZE: Sets the display size for point objects 
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6 Coordinates and Coordinate System 

 

 

Topics in this section: 

Coordinates 

Use several methods input coordinates in drawing. 

Control the User Coordinate System 

Use the user coordinate system for convenient coordinate entry and to establish drawing planes. 

6.1 Coordinates 

When a command prompts you for a point, you can specify a point in a drawing using mouse or 

other pointing devices, or you can enter a coordinate value at the command prompt. Coordinate 

values include 2D coordinate and 3D coordinate values. You can type 2D coordinate as either 

Cartesian (X, Y) or polar coordinates. You can also locate points with Cartesian, cylindrical or 

spherical coordinates. 

A Cartesian coordinate system has three axes of X, Y and Z. Different coordinate systems (2D or 3D) 

determine different coordinate representation ((x, y) or (x, y, z)). A coordinate value indicates the 

point's distance (in units) and its direction along the X, Y and Z axes relative to the coordinate 

system origin (0, 0) or (0, 0, 0). In addition, you can type a relative coordinate by moving the cursor 

to specify a direction and then entering a distance directly. 

With both polar and Cartesian coordinates, you can type absolute coordinates based on the origin, 

or relative coordinates based on the last point specified. 

The coordinate can be measured in scientific, decimal, engineering, architectural, or fractional 

notation. And the angle can be measured in grads, radians, surveyor's units, or degrees, minutes, 

and seconds. You can control these unit formats in "Drawing Units" dialog box. 

Display Coordinates on the Status Bar 

ZWCAD+ displays the current cursor location as a coordinate on the status bar at the bottom of the 

ZWCAD+ window. 

 

System variable COORDS controls the types of coordinate display. 

When COORDS is set to 0, updates only when you specify a point. 

When COORDS is set to 1, updates as you move the cursor. 

When COORDS is set to 2, updates absolute coordinate as you move the cursor, and displays the 

angle from the last point when prompt for distance and angle; this option is available only when 

you create lines or other objects that prompt for more than one point. 
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Topics in this section: 

 Enter 2D Coordinates 

When working in two dimensions, you specify points on the xy plane. You can specify any point as 

an absolute coordinate (or Cartesian coordinate), using the exact x coordinate and y coordinate 

locations relative to the origin (the (0,0) coordinate point at which the two axes intersect), or as a 

relative coordinate in relation to the previous point. You can also specify points using relative or 

absolute polar coordinates, which locate a point using a distance and an angle. 

 Use Three-dimensional Coordinates 

Specifying coordinates in three dimensional space is similar to working in two dimensions, except 

that you also use the z axis to locate coordinates. Three dimensional coordinates are represented in 

the format x,y,z (2,3,6). 

 Use Coordinate Filters 

Point filters provide a method of locating a point in a drawing relative to another point without 

specifying the entire coordinate. 

 Enter 2D Coordinates 

When working in two dimensions, you specify points on the xy plane. You can specify any point as 

an absolute coordinate (or Cartesian coordinate), using the exact x coordinate and y coordinate 

locations relative to the origin (the (0,0) coordinate point at which the two axes intersect), or as a 

relative coordinate in relation to the previous point. You can also specify points using relative or 

absolute polar coordinates, which locate a point using a distance and an angle. 

Entering absolute Cartesian coordinates 

The 2D plane is a XY plane, also called construction plane. The 2D plane is similar to a flat sheet of 

grid paper. If you want to use Cartesian coordinate values to specify a point, enter an X value and Y 

value separated by a comma (X, Y). The X value of a Cartesian coordinate is the positive or negative 

distance, in units, along the X axis. The Y value of a Cartesian coordinate is the positive or negative 

distance, in units, along the Y axis. The origin (0, 0) indicates where the X, Y axes intersect. 

To enter absolute Cartesian coordinates, type the coordinate location of the point in the command 

bar. For example, to use absolute Cartesian coordinates to draw a line from the origin (0,0) to a 

point 3 units to the right and 1 unit above the origin, start the Line command and respond to the 

prompts as follows: 

Specify first point: 0,0 

Specify next point or [Undo]: 3,1 
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Drawing a line using the absolute Cartesian coordinate method. 

Entering relative Cartesian coordinates 

Another, simpler method is to use relative Cartesian coordinates: you specify a location in the 

drawing by determining its position relative to the last coordinate you specified. To use relative 

Cartesian coordinates, type the coordinate values in the command bar, preceded by the at symbol 

(@). The coordinate pair following the @ symbol represents the distance along the x axis and the y 

axis to the next point. For example, to draw an 8.5 unit square with its lower left corner at (4,5) 

using relative Cartesian coordinates, start the Line command, and then respond to the prompts as 

follows: 

Specify first point: 4,5 

Specify next point or [Undo]: @8.5,0 

Specify next point or [Close/Undo]: @0,8.5 

Specify next point or [Close/Undo]: @-8.5,0 

Specify next point or [Close/Undo]: C 
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Drawing a square using the relative Cartesian coordinates method; enter C to close. 

The first relative coordinate (@8.5,0) locates the new point 8.5 units to the right (along the x axis) 

from the previous point of (4,5); the second relative coordinate (@0,8.5) locates the next point 8.5 

units above (along the y axis) the previous point, and so on. Entering C (for Close) draws the final 

line segment back to the first point specified when you started the Line command. 

Entering polar coordinates 

Using relative polar coordinates makes drawing a square tilted at a 45 degree angle a simple task. 

Polar coordinates base the location of a point on a distance and angle from either the origin 

(absolute coordinate) or from the previous point (relative coordinate). 

To specify polar coordinates, type a distance and an angle, separated by the open angle bracket (<). 

For example, to use relative polar coordinates to specify a point 1 unit away from the previous 

point and at an angle of 45 degrees, type @1<45. 

To draw the square from the example in the previous section, "Entering relative Cartesian 

coordinates", this time tilted at a 45 degree angle, start the Line command, and then respond to 

the prompts as follows: 

Specify first point: 4,5 

Specify next point or [Undo]: @8.5<45 

Specify next point or [Close/Undo]: @8.5<315 

Specify next point or [Close/Undo]: @8.5<225 

Specify next point or [Close/Undo]: C 
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Drawing a tilted square using the relative polar coordinates method; enter C to close. 

NOTE Angles increase counterclockwise or decrease clockwise. Thus, an angle of 315 degrees is 

the same as 45 degrees. 

 

Commands Reference 

ID: Displays the coordinate of a location 

LIST: Displays database information for selected objects 

GRID: Displays a dot grid in the current viewport 

SNAP: Restricts cursor movement to specified intervals 

UCS: Manages user coordinate systems 

UCSICON: Manages defined user coordinate systems 

UNITS: Controls coordinate and angle display formats and precision  

System Variables Reference 

BLIPMODE: Controls whether marker blips are visible 

COORDS: Controls when coordinates are updated on the status line 

LASTPOINT: Stores the last point entered, expressed as a UCS coordinate for the current space; 

referenced by the at symbol (@) during keyboard entry  

ELEVATION: Stores the current elevation relative to the current UCS for the current viewport in 

the current space  

 Use Three-dimensional Coordinates 
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Specifying coordinates in three dimensional space is similar to working in two dimensions, except 

that you also use the z axis to locate coordinates. Three dimensional coordinates are represented in 

the format x,y,z (2,3,6). 

Using the right hand rule 

To visualize how ZWCAD+ works with three dimensional space, use a technique known as the right 

hand rule. Hold up your right hand in a loose fist with your palm facing you. Extend your thumb in 

the direction of the positive x axis and your index finger upward in the direction of the positive y 

axis. Then extend your middle finger straight toward you in the direction of the z axis. These three 

fingers are now pointing in the positive x, y, and z directions, respectively. 

You can also use the right hand rule to determine the positive rotation direction. Point your thumb 

in the positive direction of the axis about which you want to rotate, and then curl the rest of your 

fingers toward your palm. These fingers are curling in the positive rotation direction. 

 

The right hand rule helps you determine the positive direction of the x, y, 

and z axes and the positive rotation direction. 

Entering x,y,z coordinates 

When working in three dimensions, you can specify x,y,z coordinates as absolute distances in 

relation to the origin (the (0,0,0) coordinate point at which the three axes intersect) or as relative 

coordinates based on the last point selected. For example, to specify the coordinate (3,4,2), just 

specify a point 3 units along the positive x axis, 4 units along the positive y axis, and 2 units along 

the positive z axis. 

Entering spherical coordinates 

When working in three dimensional space, you can use spherical coordinates to specify a three 

dimensional point by entering its distance from either the origin (absolute distance) or the last 

point (relative distance), along with its angle in the xy plane and its angle up from the xy plane. In 

spherical format, you separate each angle with the open angle bracket (<). You can enter the 

coordinate values using the following format: X < [angle from X axis] < [angle from XY plane] 

Thus, to draw a line from the origin to a point 10.2500 drawing units away, at an angle of 45 

degrees from the x axis and 35 degrees from the xy plane, start the Line command, and then 
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respond to the prompts as follows: 

Specify first point: 0,0,0 

Specify next point or [Undo]: 10.2500<45<35 

 

When you draw a line from a start point (A) to an endpoint (B) using 

spherical coordinates, you specify its length (C, in this case 10.2500 units), 

the angle in the xy plane (D, in this case 45 degrees), and the angle from the 

xy plane (E, in this case 35 degrees). 

Entering cylindrical coordinates 

When working in three dimensional space, you can also use cylindrical coordinates to specify a 

three dimensional point. You specify a point by entering its distance from either the origin 

(absolute distance) or the last point (relative distance), its angle in the xy plane, and its z coordinate 

value. 

In cylindrical format, you separate the distance and angle with the open angle bracket (<) and 

separate the angle and z value with a comma. For example, to draw a line from the last point to a 

point 7.4750 units away, at an angle of 27 degrees from the x axis in the xy plane and 3 units up in 

the z direction, start the Line command, and then respond to the prompts as follows: 

Specify first point: Press ENTER 

Specify next point or [Undo]: @7.4750<27,3 
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When you draw a line from a start point (A) to an endpoint (B) using 

cylindrical coordinates, you specify its length (C, in this case 7.4750), the 

angle in the xy plane (D, in this case 27 degrees), and the distance in the z 

direction (E, in this case 3 units). 

 

Commands Reference 

ID: Displays the coordinate of a location 

LIST: Displays database information for selected objects 

GRID: Displays a dot grid in the current viewport 

SNAP: Restricts cursor movement to specified intervals 

UCS: Manages user coordinate systems 

UCSICON: Manages defined user coordinate systems 

UNITS: Controls coordinate and angle display formats and precision  

System Variables Reference 

BLIPMODE: Controls whether marker blips are visible 

COORDS: Controls when coordinates are updated on the status line 

LASTPOINT: Stores the last point entered, expressed as a UCS coordinate for the current space; 

referenced by the at symbol (@) during keyboard entry  

ELEVATION: Stores the current elevation relative to the current UCS for the current viewport in 

the current space  
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 Use Coordinate Filters 

Point filters provide a method of locating a point in a drawing relative to another point without 

specifying the entire coordinate. Using a point filter, you can enter partial coordinates, and then the 

program prompts you for the remaining coordinate information. To use xyz point filters, respond to 

the prompt for a coordinate with a filter in the following form: 

.coordinate 

Where coordinate is one or more of the letters x, y, and z. The program then prompts you for the 

filtered coordinate(s). For example, if you type .xy, the program prompts you to select a point 

whose xy coordinate you want, and then prompts you for the z coordinate. The 

filters .x, .y, .z, .xy, .xz, and .yz are all valid filters. 

Using point filters in two dimensions 

You can use point filters when you work in two dimensions to locate points in relation to existing 

entities. For example, to draw a circle centered in a rectangle, start the Circle command, and then 

respond to the prompts as follows: 

Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: .y 

of: mid 

of (select the left side of the rectangle) 

of (need XZ): mid 

of (select the top of the rectangle) 

Specify radius of circle or [Diameter]: (specify radius of circle) 

 

You can use point filters to center the circle by separately 

selecting the midpoints of two sides of the rectangle (A and B) 
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and then specifying its radius. 

Using point filters in three dimensions 

You can use point filters when you work in three dimensional space to locate points in two 

dimensions and then specify the z coordinate as the elevation above the xy plane. For example, to 

begin drawing a line from a point with a z coordinate 3 units above the center of a circle, insert the 

circle, and then start the Line command and respond to the prompts as follows: 

Specify first point: .xy 

of: cen 

of (select a point on the circle) 

of (need Z): 3 (locates the starting point 3 units above the center of the circle) 

Specify next point or [Undo]: (specify the length of the line) 

 

You can use point filters to draw a line by first selecting a point in 

the xy plane (A), specifying the z coordinate (B), and then 

specifying the length of the line (C). 

 

Commands Reference 

ID: Displays the coordinate of a location 

LIST: Displays database information for selected objects 

GRID: Displays a dot grid in the current viewport 

SNAP: Restricts cursor movement to specified intervals 
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UCS: Manages user coordinate systems 

UCSICON: Manages defined user coordinate systems 

UNITS: Controls coordinate and angle display formats and precision  

System Variables Reference 

BLIPMODE: Controls whether marker blips are visible 

COORDS: Controls when coordinates are updated on the status line 

LASTPOINT: Stores the last point entered, expressed as a UCS coordinate for the current space; 

referenced by the at symbol (@) during keyboard entry  

ELEVATION: Stores the current elevation relative to the current UCS for the current viewport in 

the current space  

6.2 Control the User Coordinate System 

You can use the user coordinate system for convenient coordinate entry and to establish drawing 

planes. 

Topics in this section: 

 Coordinate System 

Many commands in ZWCAD+ require that you specify points as you draw or modify entities. 

 Control the User Coordinate System in 3D 

When working in three dimensional space, you can define a UCS with its own 0,0,0 origin and 

orientation separate from the WCS. You can create as many user coordinate systems as you want, 

and then save and recall them as you need them to simplify construction of three dimensional 

entities. 

 Define and Name User Coordinate Systems 

A drawing can contain as many coordinate systems as you want and can be named appropriate 

names so you can remember how they are used in your drawing for recalling them later. 

 Set the Current User Coordinate System 
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When you draw new objects, they are created in relation to the current coordinate system.  

 Use UCS Presets 

ZWCAD+ lets you select a preset UCS. The six planes defined by looking along the x,y,z axes align 

the UCS with the top, left, front, bottom, right, or back, based on either the WCS or the current UCS 

in effect when you select the tool. You can also select the previous UCS, align the UCS to the 

current view, or select the WCS. 

 Control the User Coordinate System 

You can use the user coordinate system for convenient coordinate entry and to establish drawing 

planes. 

 Coordinate System 

Many commands in ZWCAD+ require that you specify points as you draw or modify entities. 

You can do so by selecting points with the mouse or by typing coordinate values in the command 

bar. The program locates points in a drawing using a Cartesian coordinate system. 

Understanding how coordinate systems work 

The Cartesian coordinate system uses three perpendicular axes—x, y, and z—to specify points in 

three dimensional space. Every location in a drawing can be represented as a point relative to a 

(0,0,0) coordinate point, referred to as the origin. To draw a two dimensional entity, you specify 

horizontal coordinate positions along the x axis and vertical coordinate positions along the y axis. 

Thus, every point on a plane can be represented as a coordinate pair composed of an x coordinate 

and a y coordinate. Positive coordinates are located above and to the right of the origin; negative 

coordinates are located to the left and below the origin. 

 

The three perpendicular axes of the 

Cartesian coordinate system 

When you work in two dimensions, you need enter only the x and y coordinates; the program 
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assumes that the z axis value is always the current elevation. When you work in three dimensions, 

however, you must also specify the z axis value. When you look at a plan view of your drawing (a 

view from above, looking down), the z axis extends straight up out of the screen at a 90 degree 

angle to the xy plane. Positive coordinates are located above the xy plane, and negative 

coordinates are below the plane. 

 All ZWCAD+ drawings use a fixed coordinate system, called the World Coordinate System (WCS), 

and every point in a drawing has a specific x,y,z coordinate in the WCS. You can also define arbitrary 

coordinate systems located anywhere in three dimensional space. These are called user coordinate 

systems and can be located anywhere in the WCS and oriented in any direction. 

You can create as many user coordinate systems as you want, saving or redefining them to help you 

construct three dimensional entities. By defining a UCS within the WCS, you can simplify the 

creation of most three dimensional entities into combinations of two dimensional entities. 

To help you keep your bearings in the current coordinate system, the program displays a coordinate 

system icon. When you begin a new drawing, you are automatically in the WCS, indicated by the 

letter W in the icon. When you display a drawing in plan view, you see the coordinate system icon 

from the top, with the z axis directed straight toward you. When you display a three dimensional 

drawing in a view other than plan view, the coordinate system icon changes to reflect your new 

viewpoint. 

TIP The visible portions of the axes are the positive directions. 

 

WCS icon Plan UCS icon 3D View WCS icon 

Understanding how coordinates are displayed 

The current position of the cursor is displayed as x,y,z coordinates in the status bar and, by default, 

updates dynamically as you move the cursor. You can toggle the coordinate display to static mode 

by pressing F6, so that it updates only when you select a point in the drawing. 

 

Commands Reference 

UCS: Manages user coordinate systems  

UCSICON: Manages user coordinate systems 

UCSMAN: Manages defined user coordinate systems 
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System Variables Reference 

ERRNO: Displays the number of the appropriate error code when an AutoLISP function call causes 

an error that ZWCAD+ detects  

PUCSBASE: Stores the name of the UCS that defines the origin and orientation of orthographic 

UCS settings in paper space only  

UCSFOLLOW: Generates a plan view whenever you change from one UCS to another 

UCSNAME: Stores the name of the current coordinate system for the current viewport in the 

current space  

UCSORG: Stores the origin point of the current coordinate system for the current viewport in the 

current space  

UCSXDIR: Stores the X direction of the current UCS for the current viewport in the current space 

UCSYDIR: Stores the Y direction of the current UCS for the current viewport in the current space 

UCSICON: Displays the UCS icon for the current viewport using bitcode 

UCSVP: Determines whether the UCS in active viewports remains fixed or changes to reflect the 

UCS of the currently active viewport  

 Control the User Coordinate System in 3D 

When working in three dimensional space, you can define a UCS with its own (0,0,0) origin and 

orientation separate from the WCS. You can create as many user coordinate systems as you want, 

and then save and recall them as you need them to simplify construction of three dimensional 

entities. 

For example, you can create a separate UCS for each side of a building. Then, by switching to the 

UCS for the east side of the building, you can draw the windows on that side by specifying only 

their x and y coordinates. When you create one or more user coordinate systems, the coordinate 

entry is based on the current UCS. 
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UCS aligned with the front wall of the house  

To define a UCS, you can use any of the following methods: 

Specify a new origin and points on the positive x and y axes. 

Specify a new origin and point on the positive z axis. 

Align the UCS with an existing entity. 

Rotate the current UCS around any of its axes. 

Align the UCS with its z axis parallel to the current viewing direction. 

Align the UCS xy plane perpendicular to the current view. 

When you define a new UCS, the UCS icon changes to indicate the origin and orientation of the 

new UCS. 

To define a UCS by specifying a new origin and points on the positive x and y axes 

Choose Tools > New UCS > 3 Point from the main menu. 

Specify a new original point. 

Specify a point on the positive x axis. 

Specify a point on the positive y axis. 

 

Define the new UCS by selecting the origin 

(A), a point on the positive x-axis (B), and a 

point in the positive y direction (C) 

UCS toolbar:  

Command line UCS 

 

Commands Reference 

UCS: Manages user coordinate systems  

UCSICON: Manages user coordinate systems 

UCSMAN: Manages defined user coordinate systems 
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System Variables Reference 

ERRNO: Displays the number of the appropriate error code when an AutoLISP function call causes 

an error that ZWCAD+ detects  

PUCSBASE: Stores the name of the UCS that defines the origin and orientation of orthographic 

UCS settings in paper space only  

UCSFOLLOW: Generates a plan view whenever you change from one UCS to another 

UCSNAME: Stores the name of the current coordinate system for the current viewport in the 

current space  

UCSORG: Stores the origin point of the current coordinate system for the current viewport in the 

current space  

UCSXDIR: Stores the X direction of the current UCS for the current viewport in the current space 

UCSYDIR: Stores the Y direction of the current UCS for the current viewport in the current space 

UCSICON: Displays the UCS icon for the current viewport using bitcode 

UCSVP: Determines whether the UCS in active viewports remains fixed or changes to reflect the 

UCS of the currently active viewport  

 Define and Name User Coordinate Systems 

A drawing can contain as many coordinate systems as you want and can be named appropriate 

names so you can remember how they are used in your drawing for recalling them later. 

NOTE Coordinate system names created or renamed in ZWCAD+ can have up to 

31 characters and cannot include spaces. ZWCAD+ will, however, display 

longer coordinate system names and names containing spaces. 

Define new user coordinate systems 

Choose Tools > New UCS from the main menu. 

Choose which type for creating UCS. 

Create UCS depending on the prompts. 

UCS toolbar:  

Command line UCS 
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To change a user coordinate system name in the current drawing 

Choose Tools > Named UCS from the main menu. 

Right-click the desired UCS name, and then select Rename from the shortcut menu that pops up. 

Type a new name. 

Click OK. 

UCS toolbar:  

Command line DDUCS 

 

Commands Reference 

UCS: Manages user coordinate systems  

UCSICON: Manages user coordinate systems 

UCSMAN: Manages defined user coordinate systems 

System Variables Reference 

ERRNO: Displays the number of the appropriate error code when an AutoLISP function call causes 

an error that ZWCAD+ detects  

PUCSBASE: Stores the name of the UCS that defines the origin and orientation of orthographic 

UCS settings in paper space only  

UCSFOLLOW: Generates a plan view whenever you change from one UCS to another 

UCSNAME: Stores the name of the current coordinate system for the current viewport in the 

current space  

UCSORG: Stores the origin point of the current coordinate system for the current viewport in the 

current space  

UCSXDIR: Stores the X direction of the current UCS for the current viewport in the current space 

UCSYDIR: Stores the Y direction of the current UCS for the current viewport in the current space 

UCSICON: Displays the UCS icon for the current viewport using bitcode 
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UCSVP: Determines whether the UCS in active viewports remains fixed or changes to reflect the 

UCS of the currently active viewport  

 Set the Current User Coordinate System 

When you draw new objects, they are created in relation to the current coordinate system. 

Set the current UCS 

Choose Tools > Named UCS from the main menu. 

Select the desired UCS, and then click the Set Current button. 

Click OK. 

UCS toolbar:  

Command line DDUCS 

 

Commands Reference 

UCS: Manages user coordinate systems  

UCSICON: Manages user coordinate systems 

UCSMAN: Manages defined user coordinate systems 

System Variables Reference 

ERRNO: Displays the number of the appropriate error code when an AutoLISP function call causes 

an error that ZWCAD+ detects  

PUCSBASE: Stores the name of the UCS that defines the origin and orientation of orthographic 

UCS settings in paper space only  

UCSFOLLOW: Generates a plan view whenever you change from one UCS to another 

UCSNAME: Stores the name of the current coordinate system for the current viewport in the 

current space  

UCSORG: Stores the origin point of the current coordinate system for the current viewport in the 

current space  

UCSXDIR: Stores the X direction of the current UCS for the current viewport in the current space 
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UCSYDIR: Stores the Y direction of the current UCS for the current viewport in the current space 

UCSICON: Displays the UCS icon for the current viewport using bitcode 

UCSVP: Determines whether the UCS in active viewports remains fixed or changes to reflect the 

UCS of the currently active viewport  

 Use UCS Presets 

ZWCAD+ lets you select a preset UCS. The six planes defined by looking along the x,y,z axes align 

the UCS with the top, left, front, bottom, right, or back, based on either the WCS or the current UCS 

in effect when you select the tool. You can also select the previous UCS, align the UCS to the 

current view, or select the WCS. 

When you select a UCS, the cursor orientation and UCS icon change to reflect the new UCS. 

The display does not change, however, unless you select the Change View To Plan View Of The 

Selected UCS check box. 

After you align the UCS to a preset UCS, you can use "Named UCS" from the Tools menu to save the 

current UCS. 

To select a preset UCS 

Choose Tools > Named UCS from the main menu. 

Switch to Orthographic UCS tab, select the desired UCS, and then click the Set Current button. 

Click OK. 

UCS toolbar:  

Command line DDUCS 

 

Commands Reference 

UCS: Manages user coordinate systems  

UCSICON: Manages user coordinate systems 

UCSMAN: Manages defined user coordinate systems 

System Variables Reference 

ERRNO: Displays the number of the appropriate error code when an AutoLISP function call causes 

an error that ZWCAD+ detects  



 

 152 

PUCSBASE: Stores the name of the UCS that defines the origin and orientation of orthographic 

UCS settings in paper space only  

UCSFOLLOW: Generates a plan view whenever you change from one UCS to another 

UCSNAME: Stores the name of the current coordinate system for the current viewport in the 

current space  

UCSORG: Stores the origin point of the current coordinate system for the current viewport in the 

current space  

UCSXDIR: Stores the X direction of the current UCS for the current viewport in the current space 

UCSYDIR: Stores the Y direction of the current UCS for the current viewport in the current space 

UCSICON: Displays the UCS icon for the current viewport using bitcode 

UCSVP: Determines whether the UCS in active viewports remains fixed or changes to reflect the 

UCS of the currently active viewport  

 Control the User Coordinate System 

You can use the user coordinate system for convenient coordinate entry and to establish drawing 

planes. 

Control the User Coordinate System (UCS) in 2D 

In ZWCAD+, there are two coordinate systems: world coordinate system (WCS) and user coordinate 

system (UCS). WCS is a fixed coordinate system, where the X axis is horizontal and the Y axis is 

vertical. The origin (0, 0) is the intersection of the X and Y axes in the lower-left corner of the 

drawing. You can define a UCS based on a WCS. UCS can be moved, which helps you modify 

particular sections of your drawing easily. At the same time, you can rotate UCS to specify points in 

3D or rotated views. When you rotate UCS, Snap, Grid, and Ortho modes all rotate in line with the 

new UCS. 

Actually, you enter coordinate value in the current UCS. There are several methods for relocating 

UCS, shown as follows: 

Move the UCS by defining a new origin. 

Align the UCS with an existing object or with the current viewing direction. 

Rotate the current UCS around any of its axes. 

Restore a saved UCS. 

You can name a defined UCS and then restore it when needed. The UCS Previous option can reverse 

up to last 10 coordinate systems in the current session. You can delete a named UCS whenever you 

do not need it. A UCS can also be restored to coincide with the WCS. 
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Use World and User Coordinate Systems in 3D 

It is helpful for creating 3D model by controlling the UCS. 

Use World and User Coordinate Systems 

In 3D space, there is both a fixed WCS and a movable UCS. 

 When you work in 3D, the movable UCS can help you enter coordinate, establish drawing planes, 

and set views easily. Neither moving nor rotating UCS changes your viewport. The only changes are 

the orientation and tilt of the coordinate system. 

When you work in 3D, you can simplify the creation of 3D objects by relocating the UCS. To relocate 

the UCS, change the location of the origin point and the orientation of the XY plane and the Z axis. 

In 3D space, you can locate and orient a UCS anywhere. 

Only one UCS can be made the current coordinate system at any given time, and all coordinate 

input and display is relative to the current UCS. If you open multiple viewports, the current UCS 

applies to all of them. If the system variable UCSVP is on, you can save a UCS along with a viewport, 

and automatically restoring the UCS each time when you make the viewport current. 

To draw in 3D space, you need to specify X, Y, and Z coordinate value in either the WCS or UCS. The 

following figure displays the X, Y, and Z axes of the WCS. 

 

Generally, the WCS and the UCS are coincident with each other, which means that their axes and 

origin points are overlapped exactly. No matter how many times you relocate the UCS, you can 

always use the World option of the UCS command to make it coincident with the WCS. 

Control the User Coordinate System in 3D 

You can relocate the UCS by changing the location of the origin point and the orientation of the XY 

plane and the Z axis. In 3D space, you can locate and orient a UCS anywhere. In addition, you can 

define, save, and recall as many UCSs as you like. Both entering coordinate and drawing are 

processed in the current UCS. 

With the UCS's relocation, you can acquire the exact placement of a 3D point by aligning the 

coordinate system with existing geometry. 

In the current session, if multiple viewports are active, you can assign a different UCS to each 
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viewport. If the system variable UCSVP is on, you can save a UCS along with a viewport, and 

automatically restoring the UCS each time when you make the viewport current. When the system 

variable UCSVP is on, each UCS may have a different origin and orientation dependent on the 

construction. 

Define the UCS Location 

You can define a UCS in several ways: 

Specify a new origin, new XY plane, or new Z axis. 

Align the new UCS with an existing object. 

Align the new UCS with the current viewing direction. 

Rotate the current UCS around any of its axes. 

Apply a new Z-depth to an existing UCS. 

Apply a UCS by selecting a face. 

Use UCS Presets 

On the Orthographic UCS tab of the UCS dialog box, the system lists several preset coordinate 

system, from which you can choose the desired one. 

After specifying a UCS, you can control whether choosing a preset option shifts the UCS relative to 

the current UCS orientation or relative to the default WCS. If you use the Restore, World, or 

Previous option of the UCS command, the settings you made are not available. 

Change the Default Elevation 

The CHANGE command is used to specify an elevation and thickness of extrusion for a new object. 

You can define a drawing plane of the current UCS by establishing the current elevation, which can 

be applied to individual viewports in conjunction with the system variable UCSVP. Whether a UCS is 

saved or restored in each viewport are determined by this variable. When UCSVP is set to 1, the 

different UCS settings are saved in individual viewports, and the elevation settings are saved along 

with each viewport both in model space and in paper space layouts. 

Generally, the elevation is set to 0, and you can control the XY plane of the current UCS using UCS 

command. 

Change the UCS in Paper Space 

Just as you define a new UCS in model space, you can also define a new UCS in paper space; 

however, the UCSs in paper space are only available for 2D manipulation. Although you can enter 

3D coordinates in paper space, 3D viewing commands are not available, such as PLAN and VPOINT. 

The system can store the last 10 coordinate systems that were created in model space and the last 

10 in paper space, and you can restore to the desired one using the Previous option of the UCS 

command. 

Save and Restore UCS Locations by Name 

You can save named UCS locations, each having a different origin and orientation, for various 

construction requirements. You can relocate, save, and recall as many UCS orientations as you 
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require. 

Assign User Coordinate System Orientations to Viewports 

You can create multiple viewports to display different views of your model. For example, you can 

specify top, front, right side, and isometric views for viewports. You can also define a different UCS 

for each view to facilitate modifying objects in different views. When you make a viewport current, 

you can use the same UCS you used the last time that the viewport was current. 

The system variable UCSVP controls the UCS in each viewport. When UCSVP is on in a viewport, the 

system saves the viewport with the UCS last used in that viewport and restores the UCS as the 

viewport is made current again. When UCSVP is set to 0 in a viewport, its UCS is coincident with the 

UCS in the current viewport. 

For example, you can set up three viewports: a top view, front view, and isometric view. If UCSVP is 

set to 0 in the isometric viewport, the Top UCS can be applied to both the top viewport and the 

isometric viewport. When the top viewport is made current, the isometric viewport's UCS reflects 

the UCS top viewport. Likewise, if you make the front viewport current, the isometric viewport's 

UCS is switched to match that of the front viewport. 

The following figure indicates the instance illustrated above. In which the drawing 1 reflects 

isometric viewport of top-left or top viewports in current UCS. 

 

The second figure shows the change that occurs when the lower-left, or front, viewport is made 

current. The UCS in the isometric viewport is updated to reflect the UCS of the front viewport. 
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Control the Display of the User Coordinate System Icon 

By default, the UCS icon is displayed in the lower-left corner of the current viewport, which 

indicates the location and orientation of the current UCS. You can also control whether the UCS 

icon is displayed at the origin point. There are two types of UCS icons: 2D icon and 3D icon. 

 

Displaying 2D or 3D UCS icon is controlled by the UCSICON command. You can display the UCS icon 

at the UCS origin point to indicate the origin and orientation of the current UCS using the UCSICON 

command. 

A cross is displayed in the icon if the UCS icon is displayed at the corner of the current UCS; 

otherwise, there is no cross in the icon. 

If the drawing area has multiple viewports, each viewport displays its own UCS icon. 

There are various ways for displaying the UCS icon, shown as follows, which help you visualize the 

orientation of the drawing plane. 
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The UCSICON can also change the size and color of the UCS icon. 

 

Commands Reference 

UCS: Manages user coordinate systems  

UCSICON: Manages user coordinate systems 

UCSMAN: Manages defined user coordinate systems 

System Variables Reference 

ERRNO: Displays the number of the appropriate error code when an AutoLISP function call causes 

an error that ZWCAD+ detects  

PUCSBASE: Stores the name of the UCS that defines the origin and orientation of orthographic 

UCS settings in paper space only  

UCSFOLLOW: Generates a plan view whenever you change from one UCS to another 

UCSNAME: Stores the name of the current coordinate system for the current viewport in the 

current space  

UCSORG: Stores the origin point of the current coordinate system for the current viewport in the 

current space  

UCSXDIR: Stores the X direction of the current UCS for the current viewport in the current space 

UCSYDIR: Stores the Y direction of the current UCS for the current viewport in the current space 
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UCSICON: Displays the UCS icon for the current viewport using bitcode 

UCSVP: Determines whether the UCS in active viewports remains fixed or changes to reflect the 

UCS of the currently active viewport  
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7 Create Objects 

 

 

Topics in this section: 

Draw Linear Objects 

Create a line, the most basic object, can be one segment or a series of connected segments. 

Draw Curved Objects 

Curved objects are arcs, circles, polyline arcs, donuts, ellipses, and splines. 

Create 3D Objects 

3D objects can be represented by simulated surfaces (3D thickness), as a wireframe model, as a 

surface model, or as a solid model. 

Create Regions 

Regions are two-dimensional enclosed areas that have physical properties such as centroids or 

centers of mass. You can combine existing regions into a single, complex region to calculate area. 

Create Revision Clouds 

Revision clouds are polylines that consist of sequential arcs. They are used to call attention to parts 

of a drawing during the review stage. 

Create Break Lines 

Creates a polyline and inserts the breakline symbol. 

Create Wipeouts 

Wipeouts are unique entities that can help you hide areas of your drawing. 

7.1 Draw Linear Objects 

Draw linear objects, like a line, the most basic object, can be one segment or a series of connected 

segments. 

Topics in this section: 

 Lines 

In a simple line with connected segments, each segment is a separate line object. 

 Rays 

A ray is a line in three dimensional space that starts at a point and extends to infinity.  
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 Construction Lines 

A construction line is a line through a given point, oriented at a specified angle in three dimensional 

space and extending to infinity in both directions. 

 Multiple-Line Objects 

Multilines consist of several parallel lines, called elements. 

 Polylines 

A polyline is a connected sequence of line segments created as a single object. 

 Create Polylines from the Boundaries of Objects 

You can create a polyline from the boundaries of overlapping objects that form a closed area. 

 Polygons 

Polygons are closed polylines with between 3 and 1,024 equal-length sides. Creating polygons is a 

simple way to draw squares, equilateral triangles, octagons, and so on. 

 Rectangles 

With ZWCAD+, rectangles are closed polylines with four sides. You draw a rectangle by specifying 

its opposite corners.  

 Points 

You can draw a point object formatted as either a single dot or as one of 19 other possible display 

styles. 

 Traces 

Creating traces using TRACE command. 

 Freehand Sketches 

Sketching is useful for creating irregular boundaries. 

 Lines 

A line consists of two points: a start point and an endpoint. You can connect a series of lines, but 
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each line segment is considered a separate line object. 

To draw a line 

Choose Draw > Line from the main menu. 

Specify the start point. 

Complete the first line segment by specifying the endpoint. To undo the previous line segment 

during the Line command, enter u (undo) and then press ENTER. Specify the endpoints of any 

additional line segments. 

Press Enter to complete the command. 

To start a new line at the endpoint of the last line drawn, start the Line command again and press 

Enter directly at the "Specify first point:" prompt. 

Draw toolbar:  

Command line LINE 

 

Start point (A) and endpoint (B). 

 

If the last object you drew was an arc, you can also draw a line connect to and starting from the 

endpoint of the arc. 

To draw a line as a continuation from the end of an arc 

Choose Draw > Line from the main menu. 

Take the end of an arc as the start point of line. 

Specify the length of the line. 

Draw toolbar:  

Command line LINE 

 

Endpoint of previous arc (A) and length of the line (B). 
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Commands Reference 

LINE: Creates straight line segments 

RAY: Creates a semi-infinite line 

XLINE: Creates an infinite line 

System Variables Reference 

None  

 Rays 

A ray is a line in three dimensional space that starts at a point and extends to infinity. Because rays 

extend to infinity, they are not calculated as part of the drawing extents. The default method for 

drawing a ray is to select the start point of the ray and then specify its direction. 

To draw a ray 

Choose Draw > Ray from the main menu. 

Specify the start point. 

Specify the direction. 

To complete the command, press Enter. 

Command line RAY 

 

Start point (A) and direction (B). 

 

Commands Reference 

LINE: Creates straight line segments 

RAY: Creates a semi-infinite line 

XLINE: Creates an infinite line 

System Variables Reference 



 

 163 

None  

 Construction Lines 

A construction line is a line through a given point, oriented at a specified angle in three dimensional 

space and extending to infinity in both directions. Because construction lines extend to infinity, 

they are not calculated as part of the drawing extents. 

The default method for drawing a construction line is to select a point along the line and then 

specify the direction of the line. You can draw a construction line in any of the following ways: 

Horizontal draws the construction line parallel to the x axis of the current UCS. 

Vertical draws the construction line parallel to the y axis of the current UCS. 

Angle draws the construction line parallel to a specified angle. 

Bisect draws the construction line perpendicular to an existing object. 

Parallel draws the construction line parallel to an existing object. 

To draw a construction line 

Choose Draw > Construction Line from the main menu. 

Specify a point along the line. 

Specify the direction. 

To complete the command, press Enter. 

Draw toolbar:  

Command line XLINE 

 

Point along the infinite line (A) 

and the direction (B) 

You can also draw a construction line at a specific angle or at an angle relative to an existing object. 

 

Commands Reference 

LINE: Creates straight line segments 

RAY: Creates a semi-infinite line 

XLINE: Creates an infinite line 
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System Variables Reference 

None  

 Multiple-Line Objects 

Multilines consist of several parallel lines, called elements. 

You can determine the position of elements by specifying offset from the origin of each element. 

By default, multiline objects contain two elements. You should create and save new multiline styles 

by yourself or modify existing mline styles. 

 

Create Multiline Styles 

While creating new mlines, you can specify names of the new style together with inherited 

properties, and set the amount and properties such as color, linetype, offset and so on for each 

element directly. Meanwhile, take into account on whether to fill the background and endcaps. 

Both lines and arcs are available for specifying endcaps.  

Use Existing Multiline Styles 

When you start drawing a multiline, you can use the default style, which has two elements, or 

specify a style you created previously. The default style is the multiline style last used, or the 

STANDARD style if MLINE hasn't been used. 

You can also change the justification and scale of the multiline before you draw it. 

Justification determines whether the multiline is drawn below or above the cursor, or with its origin 

centered on the cursor. The default is below (top justification). 

Scale controls the overall width of the multiline using the current units. 

If you draw a multiline with scale of 2, then the width is twice of that defined by the multiline style. 

If the scale is set to minus, then draw the multiline in order of reversal offset line: the multi-line 

with the largest offset is drawn at the bottom in the way of left-to-right drawing. And the multi-line 

will be turned into single line once the scale is set to 0. 

If you are changing the multiline scale, you might need to make equivalent changes to linetype 

scale to prevent dots or dashes from being disproportionately sized. 

Multiline scale does not affect linetype scale. 

To draw a multi-line 

Choose Draw > Multiline from the main menu. 

Specify the start point. 
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Specify the endpoint. 

Press Enter to complete the command. 

Command line MLINE 

 

Commands Reference 

OFFSET: Creates concentric circles, parallel lines, and parallel curves 

MLINE: Creates multiple parallel lines 

MLSTYLE: Defines a style for multiple parallel lines  

System Variables Reference 

CMLSTYLE: Sets the multiline style that ZWCAD+ uses to draw the multiline 

 Polylines 

With ZWCAD+, a polyline is a connected sequence of arcs and lines that is treated as a single object. 

You can draw a polyline with any linetype and using a width that either remains constant or tapers 

over the length of any segment. When editing a polyline, you can modify the entire polyline or 

change individual segments. 

After you specify the start point of a polyline, the command line prompt several options as you 

draw, such as Arc, Halfwidth, Length, Undo and Width. You can specify different starting and ending 

widths to create a tapered polyline segment. 

After you draw at least one polyline segment, you can use the Undo tool in right click menu to 

remove the previous segment. After you draw two or more polyline segments, you can type c 

(close) in the command line to complete the command by drawing a segment that ends at the start 

point of the first polyline segment you drew. 

 

Curved polyline with 

tapered width. 

Polyline with straight segments Closed polyline 

To draw a polyline with straight segments 

Choose Draw > Polyline from the main menu. 

Specify the start point. 

Specify the endpoint of each segment. 

Press Enter to end, or enter c (close) to close the polyline. 
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Draw toolbar:  

Command line PLINE 

 

Polyline start point (A) and segment endpoints (B). 

 

With the Draw Arc option, you can continually draw arc segments until you select the Draw Line 

option to go back to drawing line segments. When you draw arc segments, the first point of the arc 

is the endpoint of the previous segment. By default, you draw arc segments by specifying the 

endpoint of each segment. Each successive arc segment is drawn tangent to the previous arc or line 

segment. If you type c (close) while in the Draw Arc option, the closing segment is created as an 

arc. 

You can also specify the arc using any of the following methods: 

Start point, center point, included angle 

Start point, center point, chord length 

Start point, center point, endpoint 

Start point, endpoint, included angle 

Start point, endpoint, direction 

Start point, endpoint, radius 

Center point, start point, endpoint 

Center point, start point, included angle 

Center point, start point, chord length 

With more unique functions, editing the polyline is different from that of single lines, such as 

adjusting width and curvature of polylines; the additional functions are shown as follows: 

Edit it with PEDIT command 

Use EXPLODE to convert it to individual line and arc segments 

Use SPLINE to convert a spline-fit polyline into a true spline 

Use closed polylines to create a polygon 

Create a polyline from the boundaries of overlapping objects 

Draw a line and arc combination polyline 

Polylines consist of multiple lines and arcs. When drawing a polyline, use the endpoint of previous 

line segment as the start point of next arc segment. You can specify angle, center, direction and 
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radius of circle for drawing arcs, and specify a center point and an endpoint as well. 

To draw a line segment followed by an arc polyline segment 

Choose Draw > Polyline from the main menu. 

Specify the start point. 

Specify the endpoint. 

At the command prompt, choose Arc. 

Specify the endpoint of the arc segment. 

To complete the command, Press ENTER. 

Draw toolbar:  

Command line PLINE 

 

You can edit entire polylines and individual segments using the Edit Polyline tool on the Modify II 

toolbar. You can convert polylines into arc and line entities using the Explode tool on the Modify 

toolbar. 

 

Create Closed Polylines 

When creating polylines with PLINE command, the Close option is only available if no less than two 

line or arc segments are drawn. A closed polyline object is drawn if you connect the start point of 

the polyline to endpoint of the last line or arc segment with a line or arc. 

Create Wide Polylines 

You can draw polylines of various widths by using the Width and Halfwidth options of PLINE 

command. The Width and Halfwidth options set the width of the next polyline segments you draw. 

You can set the width of individual segments and make them taper gradually from one width to 

another. 

Zero (0) width produces a thin line. Widths greater than zero produce wide lines, which are filled if 

Fill mode is on and outlined if Fill mode is off. The Halfwidth option sets width by specifying the 

distance from the center of the wide polyline to an outside edge. 
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If you chose Width option, prompts in command line require you to enter starting width and 

ending width. While entering different value results in a varying width from the start point to its 

end. Both the start point and endpoint are located at the center of Wide polyline.  

 

Commands Reference 

3DPOLY: Creates a polyline of line segments in 3D space 

BOUNDARY: Creates a region or a polyline from an enclosed area 

OFFSET: Creates concentric circles, parallel lines, and parallel curves 

PEDIT: Edits polylines and three-dimensional polygon meshes 

PLINE: Creates two-dimensional polylines 

System Variables Reference 

FILLMODE: Specifies whether hatches (including solid-fill), two-dimensional solids, wide polylines, 

are filled in  

HPBOUND: Controls the object type created by the BHATCH and BOUNDARY commands 

PLINEGEN: Sets how linetype patterns generate around the vertices of a 2D polyline 

PLINETYPE: Specifies whether optimized 2D polylines are used 

PLINEWID: Stores the default polyline width 

 Create Polylines from the Boundaries of Objects  

You can create a polyline from the boundaries of overlapping objects that form a closed area. A 

polyline created using the boundary method is a separate object, distinct from the objects used to 

create it. You can edit it using the same methods used to edit other polylines. 

To expedite the boundary selection process in large or complex drawings, you can specify a group 

of boundary candidates, called a boundary set. You create this set by selecting the objects you want 

to use define the boundary. 
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With the Boundary command, you can designate a specific area of a drawing for operations such as 

hatching and dimensioning. You create a boundary polyline by selecting an area inside a closed 

loop. The area you select can be bounded by a single closed object or by multiple objects that 

intersect. 

In cases where objects intersect, ZWCAD+ interprets the boundary as the closed loop closest to the 

point specifying the area. In the following figure, for example, the area point selected in the 

rectangle results in a boundary consisting of the closed loop nearest the point selection, as 

opposed to the closed loop formed by the rectangle itself. 

 

Selected point (A) Resulting boundary (B) 

To make boundaries more specific, you can create a boundary set. A boundary set specifies which 

objects are considered in determining the boundary path. This can make creating the boundary 

polyline faster if you are working with a complex drawing. 

In the following figure, the circle and triangle are the selected objects. If you select an area 

anywhere inside the circle or the triangle, the result is a polyline that bounds the shaded area. 

 

Selected objects (A and B) Point specified in the selected 

area (C), which results in a new 
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boundary around the shaded 

area. 

To draw a boundary polyline 

Choose Draw > Boundary from the main menu. 

Specify the objects that you want made available for the boundary polyline by doing one of the 

following: 

 Current viewport Define a boundary set with all entities in the 

current viewport. In addition, if this option is selected, any 

boundary set currently used will be canceled. 

Existing set Click New button to switch to the drawing area, and prompt users to select objects for 

defining boundary sets. Press Enter to return to the dialog box after selection. This option is only 

available after selecting objects by using the New button. 

Select the Island Detection option. 

Click Pick Points. 

In the drawing, click inside the area whose closed perimeter forms the boundary, not on the 

polyline itself. If desired, continue clicking inside additional closed perimeters. 

To complete the selection, press Enter. 

In the Boundary Creation dialog box, click OK. 

Command line BOUNDARY 

 

Commands Reference 

3DPOLY: Creates a polyline of line segments in 3D space 

BOUNDARY: Creates a region or a polyline from an enclosed area 

OFFSET: Creates concentric circles, parallel lines, and parallel curves 

PEDIT: Edits polylines and three-dimensional polygon meshes 

PLINE: Creates two-dimensional polylines 

System Variables Reference 

FILLMODE: Specifies whether hatches (including solid-fill), two-dimensional solids, wide polylines, 

are filled in  
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HPBOUND: Controls the object type created by the BHATCH and BOUNDARY commands 

PLINEGEN: Sets how linetype patterns generate around the vertices of a 2D polyline 

PLINETYPE: Specifies whether optimized 2D polylines are used 

PLINEWID: Stores the default polyline width 

 Polygons 

Creating polygons is a simple way to draw squares, equilateral triangles, octagons, and so on. 

Polygons are closed polylines with between 3 and 1,024 equal-length sides. 

However, you should keep one thing in mind that rectangles are created by RECTANG command 

rather than POLYGON. 

Variety of ways can be used for creating a polygon, for example, specify the center point or one of 

its edges to define a polygon after you have determined the edges of polygon. If you want to draw 

a polygon based on another object, the following methods are provided with some given 

qualifications: 

Specifying the radius of inscribed circle if the distance between the center of the polygon and the 

endpoint of each side (inscribed) is known 

Specifying the radius of circumscribed circle if the distance between the center of the polygon and 

the midpoint of each side (circumscribed) is known 

Specifying the length of an edge and where you want to place it 

To draw a polygon by vertex 

Choose Draw > Polygon from the main menu. 

Type 5 to specify five sides for the polygon. 

Specify the center of the polygon. 

Specify the vertex of the polygon. 

Draw toolbar:  

Command line POLYGON 

 

The center (A) and vertex 

(B) 

Resulting polygon.  
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Commands Reference 

BOUNDARY: Creates a region or a polyline from an enclosed area 

EXPLODE: Breaks a compound object into its component objects  

POLYGON: Creates an equilateral closed polyline 

RECTANG: Draws a rectangular polyline 

System Variables Reference 

FILLMODE: Specifies whether hatches (including solid-fill), two-dimensional solids, wide polylines, 

are filled in 

HPBOUND: Controls the object type created by the BHATCH and BOUNDARY commands 

PLINEWID: Stores the default polyline width 

POLYSIDES: Sets the default number of sides for the POLYGON command 

SNAPANG: Sets the snap and grid rotation angle for the current viewport 

 Rectangles 

With ZWCAD+, rectangles are closed polylines with four sides. You draw a rectangle by specifying 

its opposite corners. The rectangle is normally aligned parallel to the current snap and grid 

alignment, but you can use the Rotated option to align the rectangle to any angle. 

To draw a rectangle 

Choose Draw > Rectangle from the main menu. 

Specify one corner of the rectangle. 

Specify the opposite corner of the rectangle. 

Draw toolbar:  

Command line RECTANG 
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Opposite corners (A and B) Resulting rectangle 

You can edit each side of a rectangle individually using the Edit Polyline tool on the Modify II 

toolbar. You can convert the sides into individual line objects using the Explode tool on the Modify 

toolbar. 

TIP To control the line width of the rectangle, type w in the command line, 

then type the desired value of line width. After you change the width of 

the line, the new width setting remains in effect for subsequent rectangles 

until you change it again. 

 

Commands Reference 

BOUNDARY: Creates a region or a polyline from an enclosed area 

EXPLODE: Breaks a compound object into its component objects  

POLYGON: Creates an equilateral closed polyline 

RECTANG: Draws a rectangular polyline 

System Variables Reference 

FILLMODE: Specifies whether hatches (including solid-fill), two-dimensional solids, wide polylines, 

are filled in 

HPBOUND: Controls the object type created by the BHATCH and BOUNDARY commands 

PLINEWID: Stores the default polyline width 

POLYSIDES: Sets the default number of sides for the POLYGON command 

SNAPANG: Sets the snap and grid rotation angle for the current viewport 

 Points 

You can draw a point object formatted as either a single dot or as one of 19 other possible display 

styles. 

To draw a point  

Choose Draw > Point > Single Point from the main menu. 

Specify the location of the point. 
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Draw toolbar:  

Command line POINT 

 

To draw several points 

Choose Draw > Point > Multiple Point from the main menu. 

Specify the location of each point. 

Draw toolbar:  

Command line POINT 

 

Changing the size and appearance of point objects 

Changing the size and appearance of point objects affects all point objects already in the drawing, 

as well as all points that you subsequently draw. Positive values represent the absolute size of the 

point object measured in drawing units. Negative values represent a percentage relative to the 

drawing screen, so that points retain their visual size as you use the Zoom command to change the 

magnification of the drawing. 

To change the size and appearance of point objects 

Choose Format > Point Style from the main menu. 

Under Point Style, select the style you want. 

Under Point Size, specify the point size, or choose one of the options. 

Click OK. 

Command line DDPTYPE 

When you regenerate the drawing, all point objects change to reflect the new size and appearance 

settings. 

 

Commands Reference 

DDPTYPE: Specifies the display style and size of point objects 

POINT: Creates a point object 

System Variables Reference 

PDMODE: Controls how point objects are displayed  



 

 175 

PDSIZE: Sets the display size for point objects 

 Traces 

Creating traces using the TRACE command. 

The endpoints of a trace are on the center line and are always cut square. TRACE automatically 

calculates the correct bevels for connection to adjacent segments. 

Traces appear solid filled if Fill mode is on. When Fill mode is off, only the outline of a trace is 

displayed. 

 

Commands Reference 

TRACE: Draws a trace 

System Variables Reference 

FILLMODE: Determines whether the SOLID command creates filled-in entities 

 Freehand Sketches 

A freehand sketch consists of many straight line segments, created either as individual line objects 

or as a polyline. Before you begin creating a freehand sketch, you must set the length, or increment, 

of each segment. The smaller the segments, the more accurate your sketch, but segments that are 

too small can greatly increase the file size. 

After you specify the length of the sketch segments, move a pointing device to the drawing area on 

the screen and then right-click or enter p (pen) to begin sketching. 

Your freehand sketch is not added to the drawing until you "Record" the sketch into your drawing. 

This means that you temporarily save the segment that you've drawn and the segment length, and 

you can't continue sketching until you select eXit or press Enter. 

 

Create Sketches 

The SKETCH command controls the pen using the mouse or the Pen option at the command 

prompt. Move a pointing device to the drawing area on the screen and then right-click or enter p 

(pen) to begin sketching. Right-click or enter p (pen) again to lift the pen up and stop drawing. 
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You set the minimum length or increment of the segments. 

Before sketching, check the CELTYPE system variable to make sure the current linetype is BYLAYER. 

If you use a linetype with dots or dashes and set the sketch line segment shorter than the spaces or 

dashes, you won't see the spaces or dashes. 

To create a freehand sketch 

On the command line, enter SKETCH and press Enter. 

At the "Record increment" prompt, enter the minimum line segment length. 

Move the cursor to the drawing area, and then right-click or enter p (pen) to begin sketching. When 

you move the pointing device, ZWCAD+ draws temporary freehand line segments of the length you 

specified. Sketch doesn't accept coordinate input. During the command, freehand lines are 

displayed in a different color. 

Right-click or enter p (pen) again to lift the pen up and stop drawing, so that you can move the 

cursor around the drawing area without drawing.  

Enter R (Record) at any time to write into the drawing the line you're drawing and those already 

drawn. If the pen is moved, you can continue drawing after writing. If the pen is up, click to resume 

drawing.  

Press Enter to complete the sketch and write all lines into the drawing. 

 

Erasing freehand sketch lines 

You can erase temporary freehand sketch lines that have not yet been written into the drawing by 

choosing the Erase option at the command prompt. Those lines can be erased by mowing the pen 

along the path they were drawn. 

Once you record freehand lines, you can't edit them or erase them with the Erase option of SKETCH. 

Use the ERASE command if you have finished sketching. 

To erase freehand sketch lines 

While running the SKETCH command, enter E. If the pen was down, it moves up. 

Move the cursor to the end of the line you drew last and then move it back as far along the line as 

you want to erase. 

To end the erasure and return to the sketch Command prompt, enter E. If you want to change the 

current viewport while sketching, make sure the pen is up and all lines were written into the 

drawing. 

 

Commands Reference 

SKETCH: Creates a series of freehand line segments 

System Variables Reference 

SKETCHINC: Sets the record increment for the SKETCH command 
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SKPOLY: Determines whether the SKETCH command generates lines or polylines 

7.2 Draw Curved Objects 

Curved objects are arcs, circles, polyline arcs, donuts, ellipses, and splines.  

Topics in this section: 

 Arcs 

You can specify various combinations of center, endpoint, start point, radius, angle, chord length, 

and direction values to draw arcs. 

 Circles 

You can specify various combinations of center, radius, diameter, points on the circumference, and 

points on other objects to draw circles. 

 Ellipses and Ellipse Arcs 

The shape of an ellipse is determined by two axes that define its length and width. The longer axis 

is called the major axis, and the shorter one is the minor axis. 

 Splines 

A spline is a smooth curve that passes through or near a given set of points. You can control how 

closely the curve fits the points. 

 Donuts 

Donuts are filled rings or solid-filled circles that actually are closed polylines with width.  

 Arcs 

An arc is a portion of a circle. The default method for drawing an arc is to specify three points—the 

start point, a second point, and the endpoint. You can draw arcs using any of the following 

methods: 

Three points on an arc 

Start point, center point, endpoint 

Start point, center point, included angle 

Start point, center point, chord length 

Start point, endpoint, included angle 

Start point, endpoint, starting direction 

Start point, endpoint, radius 

Center point, start point, endpoint 
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Center point, start point, included angle 

Center point, start point, chord length 

As a tangent continuation of the previous arc or line 

Draw Arcs by Specifying Three Points 

You can draw an arc by specifying three points, which are separately the start point of the arc, a 

point anywhere on the arc and the endpoint of the arc. In the following example, the start point of 

the arc snaps to the endpoint of a line. The second point of the arc snaps to the middle circle in the 

illustration. 

 

To draw an arc by specifying three points 

Choose Draw > Arc > 3 Points from the main menu. 

Specify the start point. 

Specify a second point. 

Specify the endpoint. 

Draw toolbar:  

Command line ARC 

 

Start point (A), second 

point (B), and endpoint (C) 

 

Draw Arcs by Specifying Start, Center, End 

Under command line prompts for drawing arc, draw an arc by specifying center, start point and end 

point. 
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To draw an arc by specifying its start point, center point, and endpoint 

Choose Draw > Arc > Start, Center, End from the main menu. 

Specify the start point. 

Specify the center point. 

Specify the endpoint. 

Draw toolbar:  

Command line ARC 

 

Start point (A), center point 

(B), and endpoint (C) 

 

Draw Arcs by Specifying Start, Center, Angle 

Under command line prompts for drawing arcs, draw an arc by specifying start point and included 

angle. 

 

The included angle determines the endpoint of the arc. Use the Start, End, Angle method when you 

know both endpoints but cannot snap to a center point. 
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To draw an arc by specifying two points and an included angle 

Choose Draw > Arc > Start, End, Angle from the main menu. 

Specify the start point. 

Specify the end point. 

Specify an included angle. To draw an arc in a counterclockwise direction, enter a positive value for 

the included angle. To draw an arc in a clockwise direction, enter a negative value for the included 

angle. 

Draw toolbar:  

Command line ARC 

 

Start point (A), endpoint 

(B), and included angle (C) 

 

Draw Arcs by Specifying Start, Center, Length 

Draw an arc through specifying the center of the arc after picking the start point of arc, then specify 

the length of arc. Or using center, start, Length either, which is actually equal to specifying included 

angle. 

 

Draw Arcs by Specifying Start, End, Direction/Radius 

Draw an arc through specifying start, end radius/Direction, enter a length or click a line segment 
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using any pointing device either clockwise or counterclockwise. If use the second way, move the 

cursor to direct the arc upwards or downwards. As the following picture shows, move the cursor 

downwards to draw an arc up concaved. 

 

Draw Contiguous Arcs and Lines 

Immediately after you complete an arc, you can start a line tangent to the arc at an endpoint by 

executing the LINE command. Conversely, if you perform the ARC command after you completed a 

line, you can start an arc tangent to the line at an endpoint. 

 

You can connect sequentially drawn arcs in the same way. To create connected arcs using a menu, 

click Arc from the Draw menu, and then click Continue. In both cases, the resulting object is 

tangent to the previous one. You can use the shortcut menu to repeat the Continue option. 

To draw an arc tangent to an arc or line 

Choose Draw > Arc > Continue from the main menu. 

Specify the endpoint of the tangent arc. 

Draw toolbar:  

Command line ARC 

 

Endpoint (A) 

 

Commands Reference 

ARC: Creates an arc 
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LINE: Creates straight line segments 

OFFSET: Creates concentric circles, parallel lines, and parallel curves 

System Variables Reference 

ANGDIR: Sets the direction of positive angles 

LASTANGLE: Stores the end angle of the last arc entered relative to the XY plane of the current 

UCS for the current space 

 Circles 

The default method for drawing a circle is to specify a center point and radius. 

You can draw circles using any of the following methods: 

Center, Radius 

Center, Diameter 

Two points 

Three points 

Tangent, Tangent, Radius 

Tangent, Tangent, Tangent 

 

To draw a circle by specifying its center and radius 

Choose Draw > Circle > Center, Radius from the main menu. 

Specify the center point. 

Specify the radius of the circle. 

Draw toolbar:  

Command line CIRCLE 
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Center point (A) and radius (B) 

 

Draw a Circle Tangent to Other Objects 

The tangent point is a point where an object touches another object without intersecting it. To 

create a circle that is tangent to other objects, select the objects and then specify the radius of the 

circle. 

You can also turn on the Object Snap mode to set the snap point as Tangent, thus you can create 

circles that are tangent with other objects easily, three points method is available for creating 

circles with three tangent points. 

In the illustrations below, the red circle is the one being drawn, and points 1 and 2 select the 

objects to which it is tangent. 

 

To draw a circle tangent to existing objects 

Choose Draw > Circle > Tan, Tan, Radius from the main menu. 

Select the first tangent point on the object to be tangent with the circle. 

Select the second tangent point on the object to be tangent with the circle.  

Specify the radius of the circle. 

Draw toolbar:  

Command line CIRCLE 
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Radius of circle (A) and tangent lines (B) and (C) 

 

Commands Reference 

CIRCLE: Creates a circle 

OFFSET: Creates concentric circles, parallel lines, and parallel curves 

OSNAP: Sets running object snap modes 

System Variables Reference 

CIRCLERAD: Sets the default circle radius 

 Ellipses and Ellipse Arcs 

Drawing ellipses 

The default method for drawing an ellipse is to specify the endpoints of one axis of the ellipse, and 

then specify a distance representing half the length of the second axis. The endpoints of the first 

axis determine the orientation of the ellipse. The longer axis of the ellipse is called the major axis, 

and the shorter one is the minor axis. The order in which you define the axes does not matter. The 

program determines the major and minor axes based on their relative lengths. You can draw 

ellipses using any of the following methods: 

Center 

Axis, End 

To draw an ellipse by specifying the axis and endpoints 

Choose Draw > Ellipse > Axis, End from the main menu. 

Specify the first endpoint. 

Specify the second endpoint. 

Drag the pointing device away from the midpoint, and click to specify a distance for half the length 

of the second axis. 

Draw toolbar:  

Command line ELLIPSE 

 



 

 185 

First axis endpoint (A), second axis 

endpoint (B), and half-length of other axis 

(C) 

 

Drawing elliptical arcs 

An elliptical arc is a portion of an ellipse. The default method for drawing an elliptical arc is to 

specify the endpoints of one axis of the ellipse, and then specify a distance representing half the 

length of the second axis. Then you specify the start and end angles for the arc, measured from the 

center of the ellipse in relation to its major axis. 

To draw an elliptical arc by specifying the axis endpoints 

Choose Draw > Ellipse > Arc from the main menu. 

Specify the first endpoint. 

Specify the second endpoint. 

Specify the half length of the other axis. 

Specify the start angle of the arc. 

Specify the end angle. 

Draw toolbar:  

Command line ELLIPSE 

NOTE ZWCAD+ draws elliptical arcs in the direction you specify. Go to Format > Units menu option, 

under Angle tab, the default setting is counterclockwise. 

 

First axis endpoint (A), second axis 

endpoint (B), half length of other axis (C), 

start angle of arc (D), and end angle (E) 

 

Commands Reference 

ELLIPSE: Creates an ellipse or an elliptical arc  

System Variables Reference 
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ANGDIR: Sets the direction of positive angles 

PELLIPSE: Controls the ellipse type created with ELLIPSE  

 Splines 

Spline is a smooth curve that passes through a series of control points. You can control the fit 

tolerance among the curve and points, and apply the fitness to drawing irregular curves. A NURBS 

curve produces a smooth curve between control points. 

A NURBS curve produces a smooth curve between control points. 

 

Multiple points are required for drawing irregular splines and you can close the spline so that the 

start and endpoints are coincident and tangent. 

Tolerance in command line prompts describes how precisely the spline fits the set of fit points you 

specify. The lower the tolerance, the more closely the spline fits the points. If the value is set to 0, 

the spline curve passes through the fit point. 

If you set the tolerance value greater than 0, the spline will go through fit point within the specified 

tolerance range. 

Usually two ways of creating splines are provided: 

Create a spline converted from a polyline using Spline option of PEDIT command. 

Create a spline using SPLINE command, that is NURBS curve. 

To draw a spline 

Choose Draw > Spline from the main menu. 

Specify the first point of the spline. 

Specify the second point of the spline. 

Specify as many more points as you want. 

When you have finished, press Enter. 

Draw toolbar:  

Command line SPLINE 

 

You can add tangents to the spline, which are lines that give it shape. 

To add tangents to a spline 

Specify the starting tangent point. 

Specify the ending tangent point. 
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Spline Spline with starting tangent point (A) and 

ending tangent point (B) 

 

Specifying fit tolerance 

By default, a spline passes through all of the control points. When you draw a spline, you can 

change this by specifying the fit tolerance. The fit tolerance value determines how closely the 

spline fits the set of points you specify. For example, a spline fit tolerance value of 0 causes the 

spline to pass through the control points. A value of 0.01 creates a spline that passes through the 

start and endpoints and within 0.01 units of the intermediate control points. 

To specify the fit tolerance 

Choose Draw > Spline from the main menu. 

Specify the first point of the spline. 

Specify the second point of the spline. 

To accept the default of 0.0000, press Enter. To specify a different fit tolerance, enter F and press 

Enter, and then specify a new fit tolerance. 

Specify the additional points you need to draw a spline or a closed spline. 

Draw toolbar:  

Command line SPLINE 

 

Drawing a closed spline 

You can draw a closed spline, which is a spline for which the start point and endpoint are the same. 

Because the spline is closed, you specify only one tangent. 

To draw a closed spline 

Choose Draw > Spline from the main menu. 

Specify the first point of the spline. 

Specify the second point of the spline. 

Specify as many more points as you want. 

When you have finished, on the command line, type C and press Enter. 

To complete the command, specify the tangent point. 

Draw toolbar:  
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Command line SPLINE 

 

The start point and endpoint (A) of a closed spline. 

 

Commands Reference 

PEDIT: Edits polylines and three-dimensional polygon meshes 

PLINE: Creates two-dimensional polylines 

SPLINE: Creates a nonuniform rational B-spline (NURBS) curve 

SPLINEDIT: Edits a spline or spline-fit polyline 

System Variables Reference 

None 

 Dounts 

Donuts are solid, filled circles or rings created as closed, wide polylines. You can draw a donut using 

several ways. The default method is to specify the inside and outside diameters of the donut, and 

then specify its center. You can then create multiple copies of the same donut by specifying 

different center points until you press Enter to complete the command. 

Similar to the way of drawing circle, donuts are closed polylines with certain width with or without 

fill. The system variable FILLMODE controls whether to fill the donut or not. 

If system variable FILLMODE is set to 1, to create filled donuts; if system variable FILLMODE is set to 

0, to create donuts without filling. 

To create a donut, you specify its inside and outside diameters and its center. You can continue 

creating multiple copies with the same diameter by specifying different center points. To create 

solid-filled circles, just assign the same value for the inside radius and outside radius. 
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To draw a donut 

Choose Draw > Donut from the main menu. 

Specify the inside diameter of the donut. 

Specify the outside diameter of the donut. 

Specify the center of the donut. 

Specify the center point to draw another donut, or press Enter to complete the command. 

Command line DONUT 

 

Inside diameter (A) and outside diameter (B) 

 

Commands Reference 

DONUT: Draws filled circles and rings 

FILL: Controls the filling of objects such as hatches, two-dimensional solids, and wide polylines 

System Variables Reference 

DONUTID: Sets the default for the inside diameter of a donut 

DONUTOD: Sets the default for the outside diameter of a donut 

FILLMODE: Specifies whether hatches (including solid-fill), two-dimensional solids, wide polylines, 

are filled in 

7.3 Create 3D Objects 

With 3D models, you can 

View entities in three dimensions. 

Create three-dimensional entities. 

Edit entities in three-dimensional space. 

Edit three-dimensional solids. 
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Display hidden-line and shaded views of three-dimensional entities. 

ZWCAD+ supports three types of 3D modeling: wireframe, surface, and solid. Each type has its own 

creation and editing techniques. 

 Wire-frame models, which consist of lines and curves that define 

the edges of a three-dimensional entity. You can create a wire-frame 

model by drawing lines, arcs, polylines, and other two-dimensional 

entities anywhere in three-dimensional space. Wire-frame models have 

no surfaces; they always appear as outlines. Because you must 

individually draw and position each entity that makes up a wire-frame 

model, creating one can be exacting and time-consuming. 

 Surface models, which consist of both edges and the surfaces between 

those edges. You can create a surface model by applying elevation and 

thickness to two-dimensional planar entities or by using specific 

three-dimensional entity-creation commands. Surface models consist of 

individual planes forming a faceted, polygonal mesh. 

 3D solids, which are three-dimensional ACIS entities that consist of 

faces and edges. 3D solids appear to have volume and are easier to work 

with than wireframe and surface models. ZWCAD+ supports viewing and 

limited editing of 3D solids, including moving, rotating and scaling. 

 

You should notice that different editing manipulations result in different visual effects because of 

various model and creating methods. You should avoid mixing the models of different type when 

creating 3D objects. Limits are also applied to the conversion of model types, only solid-curve and 

curve--wireframe conversions are available.  

 

Topics in this section: 

 Set 3D Thickness and Elevation 

By default, the program creates new two dimensional objects with a zero elevation and thickness. 

The easiest way to create a three dimensional object is to change the elevation or thickness 
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property of an existing two dimensional object. 

 Create Wireframe Models 

A wireframe model is an edge or skeletal representation of a real-world 3D object using lines and 

curves.  

 Create Surfaces 

A mesh represents an object's surface using planar facets.  

 Create 3D Solids 

A solid object represents the entire volume of an object. Complex solid shapes are easier to 

construct and edit than wireframes and meshes. 

 Set 3D Thickness and Elevation 

By default, the program creates new two dimensional objects with a zero elevation and thickness. 

The easiest way to create a three dimensional object is to change the elevation or thickness 

property of an existing two dimensional object. 

The elevation of an object is its z coordinate position in relation to the xy plane in which the object 

is drawn. An elevation of 0 indicates that the object is drawn on the xy plane of the current UCS. 

Positive elevations are above this plane; negative elevations are below it. 

The thickness of an object is the distance it is extruded above or below its elevation. A positive 

thickness extrudes the object upward in the positive z direction of the object; a negative thickness 

extrudes it downward in the negative z direction. The thickness is applied uniformly to the entire 

object. You can extrude any two dimensional object into a three dimensional object by changing 

the thickness of the object to a nonzero value. For example, a circle becomes a cylinder, a line 

becomes a three dimensional plane, and a rectangle becomes a box. 

 

Two-dimensional entities Two-dimensional entities with 

thickness added 

You can create three dimensional objects using any of the following methods: 

Draw two dimensional objects in three dimensional space. 

Convert two dimensional planar objects into three dimensional objects by applying elevation and 
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thickness. 

Convert two dimensional planar objects into three dimensional objects by revolving or extruding. 

Create three dimensional objects, such as boxes, cylinders, cones, domes, spheres, and wedges. 

You can change the default elevation and thickness values to create new objects with an elevation 

and thickness already applied. 

To set the current elevation 

Type CHANGE on the command line, and then press Enter after selecting three dimensional 

objects. 

Enter P (Properties) and press Enter. 

Enter E (Elev) and press Enter. 

Specify a new elevation, and then press Enter. 

Command line CHANGE 

 

To set the current thickness 

Choose Format > Thickness from the main menu. 

Enter a new value for thickness, and then press Enter. 

Command line THICKNESS 

 

Commands Reference 

PROPERTIES: Controls properties of existing objects 

System Variables Reference 

BACKZ: Stores the back clipping plane offset from the target plane for the current viewport, in 

drawing units  

FRONTZ: Stores the front clipping plane offset from the target plane for the current viewport, in 

drawing units 

THICKNESS: Sets the current 3D thickness  

VIEWMODE: Stores the View mode for the current viewport using bitcode 

 Create Wireframe Models 

A wireframe model is an edge or skeletal composition of lines and curves that are used to define 3D 

objects. 
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Tips for Using Wireframe Models 

For the objects that are used to construct wireframe are required to be individually created and 

located, creating 3D wireframe models can be more difficult and time-consuming than creating 

their 2D views. The following tips are provided to help you work more effectively: 

Plan and organize models on layers so as to reduce the visual complexity of the model. Specifying 

different color for each layer can help with differentiate between objects in various views. 

Create construction geometry to define the basic shape of the model. 

Use multiple views, especially isometric views, to facilitate visualizing the model and selecting 

objects. 

To be adept at manipulating the UCS in 3D. Use the XY plane of the current UCS as a workplane to 

orient planar objects such as circles and arcs. The UCS is also used as the plane for trimming and 

extending, offsetting, and rotating objects. 

Use object snaps and grid snap carefully to ensure the precision of models. 

Use coordinate filters to drop perpendiculars and easily locate points in 3D based on the location of 

points on other objects. 

Create Wireframe Models 

You can create wireframe models by positioning any 2D planar object anywhere in 3D space, using 

the following methods: 

Specifying the 3D coordinate, which is X, Y, and Z location of the object. 

Setting the default workplane (the XY plane of the UCS) on which you will draw the object. 

Positioning an object by moving or copying to its proper 3D location after you create it.  

 

Commands Reference 

UCS: Manages user coordinate systems 

System Variables Reference 

ELEVATION: Stores the current elevation relative to the current UCS for the current viewport in 

the current space  

 Create Surfaces 

3D meshes use planar embedded surfaces as its surface. Defined from the vertex position of initial 

mesh network-axis and secondary network-axis (the direction of M and N), in which Vertex of initial 

mesh network-axis points to the M direction, and N direction points to secondary network-axis. 

Similar to the function of X and Y axis on XY plane, M and N are designated individually to the 

vertex position of row and column, Meshes are available both in 2D and 3D spaces, mainly used in 

3D spaces. 

Meshes can help solving the problem of using features like hide, shade and render other than 



 

 194 

physical properties (weight, quality, center of gravity) that is unavailable in using wireframe. You 

can also create irregular geometric drawings with meshes, such as a 3D topographical model of 

mountainous terrain. 

Either closed or open meshes can be created, the following pictures show each meshes open or 

closed individually in M and N direction: 

 

Various methods are used for creating mesh, both using keyboard way to specify mesh parameter 

or operating 3D command to draw planar mesh, the size of M and N of a mesh determines the 

number of lines drawn on each direction. 

Create 3D surfaces 

You can create a three dimensional face, which consists of a section of a plane in three dimensional 

space. You define a three dimensional face by specifying the x,y,z coordinates of three or more 

corners. After you specify the fourth point, the program continues to prompt you for additional 

faces by alternating prompts for the third point and fourth point to allow you to build a complex 

three dimensional object. Each three or four sided plane is created as a separate three dimensional 

face object. 

To create a three dimensional face 

Choose Draw > Surfaces > 3D Face from the main menu. 

Specify the first point of the three-dimensional face. 

Specify the second, third, and fourth points. 

Specify the third and fourth points for additional faces. 

To complete the command, press Enter. 

Surfaces toolbar:  

Command line 3DFACE 

TIP Any or all edges of a three dimensional face can be invisible to allow you to more accurately 

model objects with holes in them. As the program prompts you for the corner points, in the prompt 

box, choose Invisible to make the next edge invisible. 
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An example of a three dimensional model created using three dimensional faces. 

 

Create 3D Meshes 

3D command is widely used for creating objects as boxes, cones, dishes, meshes, pyramids, spheres, 

donuts and wedges. Before hiding 3D entities, all the meshes are displayed in wireframe. 

Use VPOINT to view the entity once you have created a 3D entity, or performed View-3D Orbit from 

View menu options to view the 3D entity in full perspective. The following picture displays entities 

as meshes with specified vertexes. 

 

Creating rectangular meshes 

You can create a three dimensional rectangular mesh consisting of four sided polygons. You 

determine the size of the mesh by specifying the number of vertices along the primary (M direction) 
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and secondary (N direction) mesh axes and then specifying the coordinates for each vertex. 

To create a rectangular mesh 

Choose Draw > Surfaces > 3D Mesh from the main menu. 

Specify the number of vertices along the primary mesh axis. 

Specify the number of vertices along the secondary mesh axis. 

Specify the coordinates for each vertex. 

Specifying the coordinates for the last vertex completes the mesh and ends the command. 

Surfaces toolbar:  

Command line 3DMesh 

TIP Although creating rectangular meshes manually can be exacting, they are useful for 

representing complex surfaces such as three dimensional terrain models. The 3D Mesh tool is most 

useful when combined with scripts or LISP programs that mathematically calculate the coordinates 

of the vertices. 

 

An example of a three dimensional terrain model created using rectangular meshes. 

 

The following picture shows the polygon mesh with coordinates specified for each vertex. 

 

Create Polygon Meshes 

You can create a polygon mesh consisting of faces connecting three or more vertices. 

You first determine the coordinates of each vertex and then define each face by entering the vertex 
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numbers for all the vertices of that face. As you create each face, you can control the visibility and 

color of each edge and assign each edge to specific layers. 

When creating meshes, a positive vertex means an invisible edge. The system variable SPLFRAME 

controls whether to show the invisible edges or not. If set SPLFRAME on, any assumed surfaces and 

invisible edges are displayed as those visible meshes. 

To create a polyface mesh 

Type PFACE and then press Enter. 

Specify the coordinates of each vertex. 

After each vertex that you specify, the next vertex number is displayed, and you are prompted for 

the coordinates of the vertex. Specify the coordinates, and then press Enter. Continue to specify 

the coordinates for each numbered vertex. 

To finish specifying vertex coordinates, press Enter. 

Specify the vertex numbers that define the first face. You specify the face by entering the vertex 

numbers that were defined when you specified coordinates in step 2. Each face can be composed 

of three or more numbered vertices. 

To finish defining the first face, press Enter. 

Specify the next face by entering its vertex numbers. 

To complete the command, press Enter. 

Command line PFACE 

TIP To make an edge invisible, type the vertex number as a negative value. 

 

Create Ruled Surface 

RULESURF creates a polygon mesh representing the ruled surface between two curves. The entities 

you select define the edges of the ruled surface. The entities include the point, line, spline, circle, 

arc or polyline. If the first entity is a closed one, the other one must be closed two or a point. If the 

first entity is a point, the other one should be a closed or open entity. There is only one point as a 

boundary curve on a ruled surface. 

 

If you select a closed polylines, the ruled surface begins at the last vertex and proceeds backward 

along the polyline segments. If you select open curves, selecting objects at the same side of the 

two objects to create ruled surface, selecting objects at different side of the two objects to create 

crossed ruled surface, shown as follows: 
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To create a ruled surface mesh 

Choose Draw > Surfaces > Ruled Surface from the main menu. 

Select the first defining object. 

Select the second defining object. 

Surfaces toolbar:  

Command line RULESURF 

 

Select the first (A) and second (B) defining objects The resulting ruled surface mesh 

 

Create Tabulated Surface 

Creates a polygon mesh defined by a path and a direction vector. The path curve defines the 

surface of the polygon mesh. The objects like a line, arc, circle, ellipse, or 2D or 3D polyline can be 

used as outline curves for defining polygons. Both lines and open 2D or 3D polylines are used as 

direction vector. 

Tabulated surface meshes are used as a serial of paralleled polygon on specified path, you should 

draw direction vector and original object before creating a Tabulated Surface. 
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To create an extruded surface mesh 

Choose Draw > Surfaces > Tabulated Surface from the main menu. 

Select the object to extrude. 

Select the extrusion path. 

Surfaces toolbar:  

Command line TABSURF 

 

Select the object to extrude (A) and the extrusion 

path (B) 

The resulting extruded 

surface mesh 

NOTE An extruded mesh is different from an extruded solid. If you want to extrude an object and 

convert it to a three dimensional solid, use the Extrude command. 

 

Create Revolved Surfaces 

Use REVSURF command to create a surface of revolution by rotating a profile of the object about 

an axis. The object to be revolved can be a line, arc, circle, ellipse, elliptical arc, closed polyline, 

polygon, closed spline or torus. REVSURF is useful for surfaces with rotational symmetry. 

 

You can create a surface of revolution, which is a three dimensional polygon mesh that 

approximates the surface generated by rotating a two dimensional profile around an axis. You 

select the two objects that define the profile and the axis. You also specify the starting angle and 

the number of degrees to revolve the profile. 

Revolving the profile 360 degrees creates a closed three dimensional mesh. The Number Of M 

Direction Surfaces value determines the mesh density (the number of mesh segments) in the M 

direction (around the axis of revolution). The N Direction Mesh Density value determines the mesh 

density (the number of mesh segments) in the N direction (along the axis of revolution). 

To create a revolved surface mesh 

Choose Draw > Surfaces > Revolved Surface from the main menu. 

Select the object to revolve. 
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Select the object to be used as the axis of revolution. 

Specify the starting angle. 

Specify the number of degrees to revolve the object. 

Surfaces toolbar:  

Command line REVSURF 

 

Select the object to be revolved (A) 

and the axis of revolution (B) 

The resulting revolved surface mesh 

 

Create Edge-Defined Surface Meshes 

You can create a surface called a Coons surface patch, a mesh connecting four edges. You select the 

entities that define the edges. Edge entities can be arcs, lines, or polylines. The four edge entities 

must form a closed loop and share endpoints. A patch is a bicubic surface (one curve extends in the 

M-direction and the other in the N-direction) interpolated between the four adjoining edges. You 

can select the edges in any order. The first edge you select determines the M-direction of the mesh. 

 

To create an edge defined Coons surface patch mesh 

Choose Draw > Surfaces > Edge Surface from the main menu. 

Select the first edge. 

Select the second, third, and fourth edges. 

Surfaces toolbar:  

Command line EDGESURF 
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Select the objects to be used as the four 

edges (A, B, C, and D) 

The resulting Coons surface patch mesh 

 

Commands Reference 

3DMESH: Creates a free-form polygon mesh 

EDGESURF: Creates a three-dimensional polygon mesh 

REVSURF: Creates a revolved surface about a selected axis 

RULESURF: Creates a ruled surface between two curves  

TABSURF: Creates a tabulated surface from a path curve and a direction vector 

System Variables Reference 

SURFTAB1: Sets the number of tabulations to be generated for the RULESURF and TABSURF 

commands 

SURFTAB2: Sets the mesh density in the N direction for the REVSURF and EDGESURF commands 

 Create 3D Solids 

Creates 3D solids in a drawing. A solid object represents the entire volume of an object. Complex 

solid shapes are also easier to construct and edit than wireframes and meshes. 

You can use the following methods to create solids: 

Combines one of the basic solid shapes such as box, cone, cylinder, sphere, torus, and wedge or by 

extruding a 2D object along a path or revolving a 2D object about an axis. 

Once you have created a solid in this manner, you can create more complex shapes by combining 

solids. You can join solids, subtract solids from each other, or find the common volume 

(overlapping portion) of solids. Solids can be further modified by filleting, chamfering, or changing 

the color of their edges. 
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Solids are displayed as wireframes until you hide, shade, or render them. Additionally, you can 

analyze solids for their mass properties (volume, moments of inertia, center of gravity, and so on). 

You can break a solid into mesh and wireframe objects using explode command. 

The ISOLINES system variable controls the number of tessellation lines used to visualize curved 

portions of the wireframe. The FACETRES system variable adjusts the smoothness of shaded and 

hidden-line objects. 

Create a Solid Box 

You can create rectangular boxes, or cubes. A box consists of six rectangular surface planes. The 

base of the box is always parallel with the xy plane of the current UCS. You position the box by 

specifying either a corner or the center of the box. You determine the size of the box by either 

specifying a second corner and the height; defining the box to be a cube and then providing its 

length; or specifying the length, width, and height. 

The length of the box is mapping to X axis of current UCS, and its width maps to Y axis, and height 

maps to Z axis. 

 

RECTANG or PLINE command creates a rectangle or closed polyline from which you can create a 

box using EXTRUDE. The 3D command creates a box shape defined by surfaces only. 

To create a box 

Choose Draw > Solids > Box from the main menu. 

Specify the first corner of the base. 

Specify the opposite corner of the base. 

Specify the height. 

Solids toolbar:  

Command line BOX 

 

First corner of the base (A), the opposite corner of the 

base (B), and the height (C) 

 

To create a box as a three dimensional surface 
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Choose Draw > Surfaces > 3D Surfaces from the main menu. 

On the command line, type B (Box). 

Specify the first corner of the base. 

Specify the opposite corner of the base. 

Specify the height. 

Surfaces toolbar:  

Command line AI_BOX 

 

Create a Solid Cone 

Draw a solid cone in current drawing using CONE command. By default, the cone's bottom lies on 

the XY plane of the current UCS. The cone height is parallel to the Z axis. The apex determines the 

height and orientation of the cone. 

 

You can draw a 2D circle and then use EXTRUDE to taper the circle at an angle along the Z axis to 

create a solid cone. 

To complete the truncation, you can subtract a box from the tip of the cone with the SUBTRACT 

command. The 3D command creates a conical shape defined by surfaces only. 

To create a cone 

Choose Draw > Solids > Cone from the main menu. 

Specify the center of the base of the cone. 

Specify the radius or diameter. 

Specify the height. 

Solids toolbar:  

Command line CONE 
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Center of the base (A), the 

radius of the base (B), and 

the height (C) 

 

To create a cone as a three dimensional surface 

Choose Draw > Surfaces > 3D Surfaces from the main menu. 

On the command line, type C (Cone). 

Specify the center of the base of the cone. 

Specify the radius or diameter. 

Specify the height. 

Surfaces toolbar:  

Command line AI_CONE 

 

Create a Solid Cylinder 

You can create cylinders defined by a circular base. The base of a cylinder is always parallel with the 

xy plane of the current UCS; the height of a cylinder is always parallel with the z axis. You position a 

cylinder by specifying the center of the base. You determine the size of a cylinder by specifying 

either the radius or diameter of the base and the height. 

 

You can draw a circle and then use EXTRUDE to create a solid cylinder. To construct a cylinder with 

special detail, such as grooves along its sides, you can create a 2D profile of its base with a closed 

PLINE and then use EXTRUDE to define its height along the Z axis. 

To create a cylinder 

Choose Draw > Solids > Cylinder from the main menu. 

Specify the center of the base of the cylinder. 

Specify the radius or diameter. 

Specify the height. 

Solids toolbar:  

Command line CYLINDER 
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Center of the base (A), radius of 

the base (B), and the height (C) 

 

To create a cylinder as a three dimensional surface 

Choose Draw > Surfaces > 3D Surfaces from the main menu. 

On the command line, type L (cyLinder). 

Specify the center, radius, and height as described previously. 

Command line AI_CYLINDER 

 

Spheres 

You can create spheres. The latitude lines of a sphere are always parallel with the xy plane of the 

current UCS; the central axis is always parallel with the z axis. You position a sphere by specifying its 

center point. You determine the size of a sphere by specifying either its radius or its diameter. 

 

To create a dome or dish, combine a sphere with a box and use SUBTRACT. If you want to create a 

spherical object with additional details, create a 2D profile and use REVOLVE to define a rotation 

angle about the Z axis. 3D command creates a spherical shape defined by surfaces only. 

To create a sphere 

Choose Draw > Solids > Sphere from the main menu. 

Specify the center of the sphere. 

Specify the radius or diameter. 

Solids toolbar:  

Command line SPHERE 
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Center (A) and radius (B) of the sphere The resulting sphere 

 

To create a sphere as a three dimensional surface 

Choose Draw > Surfaces > 3D Surfaces from the main menu. 

On the command line, type S (Sphere). 

Specify the center of the sphere. 

Specify the radius or diameter. 

Specify the number of longitudinal sections that are perpendicular to the xy plane. 

Specify the number of latitudinal sections that are parallel to the xy plane. 

Surfaces toolbar:  

Command line AI_SPHERE 

 

Dishes 

You can create a three dimensional dish. The latitude lines of a dish are always parallel with the xy 

plane of the current UCS; the central axis is always parallel with the z axis. You position a dish by 

specifying its center point. You determine the size of a dish by specifying either its radius or its 

diameter. 

To create a dish as a three dimensional surface 

Choose Draw > Surfaces > 3D Surfaces from the main menu. 

On the command line, type DI (DIsh). 

Specify the center and radius or diameter as described previously. 

Surfaces toolbar:  

Command line AI_DISH 

 

Domes 

You can create a three dimensional dome. The latitude lines of a dome are always parallel with the 

xy plane of the current UCS; the central axis is always parallel with the z axis. You position a dome 

by specifying its center point. You determine the size of a dome by specifying either its radius or its 
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diameter. 

To create a dome as a three dimensional surface 

Choose Draw > Surfaces > 3D Surfaces from the main menu. 

On the command line, type DO (DOme). 

Specify the center and radius or diameter as described previously. 

Surfaces toolbar:  

Command line AI_DOME 

 

Torus 

You can create a three dimensional donut or ring shaped object known as a torus. The diameter of 

a ring is always parallel with the xy plane of the current UCS. A torus is constructed by revolving a 

circle about a line drawn in the plane of the circle and parallel with the z axis of the current UCS. 

You position a torus by specifying its center point. You determine the size of a torus by specifying 

its overall diameter or radius and the diameter or radius of the tube (the circle being revolved). 

 

You can draw a torus with no center hole called self-intersecting torus because the radius of the 

tube is greater than the radius of the torus. To create a bipolar-depression solid, specify a positive 

tube radius greater than the radius of torus. 3D command creates a toroidal shape defined by 

surfaces only. 

To create a torus 

Choose Draw > Solids > Torus from the main menu. 

Specify the center of the whole torus. 

Specify the radius or diameter of the whole torus. 

Specify the radius or diameter of the body of the torus. 

Solids toolbar:  

Command line TORUS 
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Center (A) and radius of the whole 

torus (B), and the radius of the body 

(C) 

 

To create a torus as a three dimensional surface 

Choose Draw > Surfaces > 3D Surfaces from the main menu. 

On the command line, type T (Torus). 

Specify the center of the whole torus. 

Specify the radius or diameter of the whole torus. 

Specify the radius or diameter of the body of the torus. 

Specify the number of longitudinal sections that are perpendicular to the xy plane. 

Specify the number of latitudinal sections that are parallel to the xy plane. 

Surfaces toolbar:  

Command line AI_TORUS 

 

Wedges 

You can create three dimensional wedges consisting of five surface planes. The base of the wedge is 

always parallel with the xy plane of the current UCS with the sloped face opposite the first corner. 

The height is always parallel with the z axis. You position the wedge by specifying either a corner or 

the center of the wedge. You determine the size of the wedge by either specifying a second corner 

and the height; defining the wedge based on a cube having a given length; or specifying the length, 

width, and height. 

 

To create a wedge 

Choose Draw > Solids > Wedge from the main menu. 

Specify the first corner of the base. 
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Specify the opposite corner of the base. 

Specify the height. 

Solids toolbar:  

Command line WEDGE 

 

First corner of the base (A), the opposite corner of the base 

(B), and the height (C) 

 

To create a wedge as a three dimensional surface 

Choose Draw > Surfaces > 3D Surfaces from the main menu. 

On the command line, type W (Wedge). 

Specify the first corner of the base. 

Specify the opposite corner of the base. 

Specify the height. 

Surfaces toolbar:  

Command line AI_WEDGE 

 

Solids Extrude 

EXTRUDE extrudes the profiles of the selected object along the chosen path to create solids. 

The entities you can extrude are planar 3D faces, closed polylines, polygons, circles, ellipses, closed 

splines, donuts, and regions. You cannot extrude objects contained within a block or polylines that 

have crossing or self-intersecting segments. 

To extrude the objects that are lines or arcs intersect with polylines, you can use Join option of 

PEDIT command to convert them into multiple single polyline objects or convert them into regions 

before using PEDIT command. 

When an arc is part of a tapered extrusion, you need to set a small value to the angle of the arc, 

because larger angle may cause the outline to become a point before it attaches to the specified 

height. 
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To create an extruded solid 

Choose Draw > Solids > Extrude from the main menu. 

Select the object to extrude. 

Select the extrusion path, or specify the height. 

Solids toolbar:  

Command line EXTRUDE 

 

Select the object to extrude (A) and 

the extrusion Path (B) 

The resulting extruded surface mesh 

 

Solids Revolve 

REVOLVE command revolves a 2D object to the specified certain angle to form solids. The revolving 

axis can be X, Y axis of current UCS as well as lines, polylines. 

Similar to EXTRUDE, the REVOLVE command easily helps drawing the details of a drawing that is 

hard to implement by common outline. 

To revolve the objects that are lines or arcs intersect with polylines, you can use Join option of 

PEDIT command to convert them into multiple single polyline objects, and then perform REVOLVE 

command. 

Objects can be revolved are closed polylines, polygons, rectangles, circles, ellipses, regions and so 

on. On the contrary, the objects can't be revolved are 3D objects, objects that are included in a 

block, polylines with intersections and transections or unclosed polylines. 
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To create a revolved solid 

Choose Draw > Solids > Revolve from the main menu. 

Select the object to revolve. 

Do one of the following to define the axis of revolution: 

Specify a start point and an end point. 

Type o and press Enter to select an object that determines the axis. 

Type x and press Enter to select the x axis. 

Type y and press Enter to select the y axis. 

Specify the angle of revolution. 

Solids toolbar:  

Command line REVOLVE 

 

Select the object to revolve (A) and 

the axis (B) about which to revolve it, 

followed by the angle of revolution 

The resulting revolved solid 

 

Creating composite solids 

You can create composite three-dimensional solids by combining, subtracting, and finding the 

intersection of two or more solids. 

With UNION command, you can combine the total volume of two or more solids or two or more 
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regions into a composite object. 

 

To combine solids 

Choose Modify > Solids Editing > Union from the main menu. 

Select the objects to combine. 

Solids Editing toolbar:  

Command line UNION 

 

Select the objects to combine (A and 

B) 

The resulting combined solid 

 

Use SUBTRACT to remove the common area of one set of solids from another. 

 

To subtract solids 

Choose Modify > Solids Editing > Subtract from the main menu. 

Select the objects to subtract from one another. 

Solids Editing toolbar:  

Command line SUBTRACT 
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Select the objects to subtract (A 

and B) 

The resulting solid 

 

INTERSECT command creates a composite solid from the common volume of two or more 

overlapping solids. The common volume is used to create composite solid and the non-overlapping 

portions will be removed. 

 

Unlike INTERSECT command, INTERFERE compares the objects among two selected sets and 

creates composite entity with common volume of two or more solids without removing the original 

objects. 

To intersect solids 

Choose Modify > Solids Editing > Intersect from the main menu. 

Select the objects to intersect. 

Solids Editing toolbar:  

Command line INTERSECT 

 

Select the objects to combine (A 

and B) 

The resulting combined solid 
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Commands Reference 

3D: Creates three-dimensional polygon mesh objects 

BOX: Creates a three-dimensional solid box 

CIRCLE: Creates a circle 

CONE: Creates a three-dimensional solid cone 

CYLINDER: Creates a three-dimensional solid cylinder 

EXTRUDE: Creates unique solid primitives by extruding existing two-dimensional objects 

INTERFERE: Creates a composite 3D solid from the common volume of two or more solids 

INTERSECT: Creates composite solids or regions from the intersection of two or more solids or 

regions and removes the areas outside of the intersection 

PEDIT: Edits polylines and three-dimensional polygon meshes 

PLINE: Creates two-dimensional polylines 

RECTANG: Draws a rectangular polyline 

REVOLVE: Creates solids by revolving two-dimensional objects about an axis 

SPHERE: Creates a three-dimensional solid sphere 

SUBTRACT: Combines selected regions or solids by subtraction 

TORUS: Creates a donut-shaped solid  

UNION: Combines selected regions or solids by addition 

WEDGE: Creates a 3D solid with a sloped face tapering along the X axis 

System Variables Reference 

FACETRES: Adjusts the smoothness of shaded and rendered objects and objects with hidden lines 

removed 

ISOLINES: Specifies the number of isolines per surface on objects 
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7.4 Create Regions 

You can convert a closed object into a two dimensional region. After you create a region, you can 

modify it using the various three dimensional tools. For example, you can create a region from a 

square, and then extrude the square to create a three dimensional cube. 

You can create regions from closed objects, such as polylines, polygons, circles, ellipses, closed 

splines, and donuts. 

Creating regions typically has no visible effect on a drawing. However, if the original object had a 

width or lineweight, that information is lost when you create the region. 

Regions can be used for applying hatching and shading and extracting design information, such as 

the centroid, and using MASSPROP to analyze properties, such as area. 

 

Besides using closed 2D objects, you also have various options to create a region, such as 

connecting multiple loops or endpoints of open curves. However the closed area inside the 

unclosed objects will not form regions. For example, crossed arcs or intersected curves. 

BOUNDARY creates region by specifying inner points of closed area, to form a boundary with 

existing objects. If the objects are intersected with each other, ZWCAD+ takes the closed area 

nearest to the selected points as boundary. 

Meanwhile, a combined region is created through union, subtract or intersect among several areas. 

When using union, subtract or intersect for complex regions, you can fill the area and analyze its 

area as well. The following region objects show combined areas of union, subtract or intersect 

orderly: 

Objects combined using UNION: 

 

Objects combined using SUBTRACT: 
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Objects combined using INTERSECT: 

 

To create a region 

Choose Draw > Region from the main menu. 

Select the objects to create the region. 

Press Enter. 

The command bar displays a message that describes how many regions were created. 

Draw toolbar:  

Command line REGION 

 

Commands Reference 

BOUNDARY: Creates a region or a polyline from an enclosed area 

INTERSECT: Creates composite solids or regions from the intersection of two or more solids or 

regions and removes the areas outside of the intersection  

MASSPROP: Calculates the mass properties of regions or 3D solids 

REGION: Creates a region object from a selection set of existing objects 

SUBTRACT: Combines selected regions by subtraction 

UNION: Combines selected regions or solids by addition 
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System Variables Reference 

None 

7.5 Create Revision Clouds 

REVCLOUD creates a polyline of sequential arcs to form a cloud-shaped object. Revision Cloud 

helps mark your drawings by highlighting some important parts when review or redline drawings. 

You can create a revision cloud from scratch, or you can convert objects, such as a circle, ellipse, 

polyline, or spline, to a revision cloud. If DELOBJ is set to 1 (the default), the original object is 

deleted once you convert an object to a revision cloud. 

You can set the minimum and maximum default values for the arc lengths of a revision cloud. You 

should notice that the maximum arc length can't be more than 3 times as big as the minimum arc 

length. REVCLOUD stores the last used arc length as a multiple of the DIMSCALE system variable to 

provide consistency among drawings with different scale factors. 

Make sure that the entire area to be outlined with REVCLOUD before using the command. 

REVCLOUD can't be transparent used and real-time panning and zooming. 

 

 

Commands Reference 

REVCLOUD: Creates a polyline of sequential arcs to form a cloud shape 

System Variables Reference 

DIMSCALE: Sets the overall scale factor applied to dimensioning variables that specify sizes, 

distances, or offsets 

DELOBJ: Controls whether objects used to create other objects are retained or deleted from the 

drawing database 

7.6 Create Break Lines 

Creates a polyline and inserts the breakline symbol. Options are provided to control the relative 

size and appearance of the breakline symbol and an extension of the polyline beyond the selected 

start and end points. 

To use your own block for the breakline symbol, make sure that the block contains two point 

objects on the Defpoints layer. Those point objects determine the placement of the symbol and 
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how the line will be broken. 

 

NOTE Current settings of DIMSCALE are capable of controlling the terminal 

size of break line flexibly. 

 

Commands Reference 

BREAKLINE: Creates a polyline and inserts the breakline symbol 

System Variables Reference 

DIMSCALE: Sets the overall scale factor applied to dimensioning variables that specify sizes, 

distances, or offsets 

DELOBJ: Controls whether objects used to create other objects are retained or deleted from the 

drawing database 

7.7 Create Wipeouts 

Wipeouts are unique entities that can help you hide areas of your drawing. They display with the 

current background color, so the details behind the wipeout do not display or print. 

Wipeouts are similar to other entities — you can copy, mirror, array, erase, rotate, and scale them, 

and they can be used in both model space and paper space. 

If you want to print the wipeout entities located in a drawing, you must print to a raster-capable 

printer. Note that in some cases you may have unexpected results when printing drawings that 

contain wipeout entities, for example, if printing on colored paper. 

Drawing wipeouts using polygons and polylines 

Wipeouts are created using existing polygons, closed zero-width polylines made up of only line 

segments, or new polylines that you draw while using the WIPEOUT command. 

To draw a wipeout 

Choose Draw > Wipeout from the main menu. 

Specify the start point. 

Specify the endpoint of each segment. 

After specifying the last endpoint, press Enter. 

Command line WIPEOUT 
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Drawing without wipeout Drawing with wipeout 

 

To create a wipeout using an existing polygon or polyline 

Choose Draw > Wipeout from the main menu. 

Choose P (Polyline). 

Select the closed polyline to use for the wipeout. 

Choose one of the following: 

Yes — Creates the wipeout and deletes the polyline used to create the wipeout. 

No — Creates the wipeout and keeps the polyline used to create the wipeout. 

Command line WIPEOUT 

 

Turning wipeout frames on or off 

Each wipeout has a frame along its boundary. Wipeout frames can be turned on or off for any 

drawing. When wipeout frames are on, you can select and modify wipeouts. You may want to turn 

off wipeout frames when it's time to print. 

To turn wipeout frames on or off 

Choose Draw > Wipeout from the main menu. 

Choose F (Frames). 

Choose On or Off. 

Command line WIPEOUT 

 

Wipeout frames turned on Wipeout frames turned off 

 

Commands Reference 
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WIPEOUT: Wipeouts the objects inside the specified area 

System Variables Reference 

None 
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8 Modify Objects 

 

Topics in this section: 

Select Objects 

You have a wide range of options when you need to select objects for editing operations. 

Modify Objects 

Modify the size, shape, and location of objects. 

Modify Compound Objects 

Edit compound objects, such as blocks, dimensions, hatches, and polylines.  

Use Grips to Edit Objects 

Grips are small squares that are displayed at strategic points on objects that you have selected with 

a pointing device. You can drag these grips to edit objects directly and quickly. 

Modify the Properties of Objects 

Every object you draw has properties. For example, layer, color, linetype, and plot style.  

Modify 3D Solids 

Change its appearance by filleting, chamfering, sectioning, slicing, and separating. 

Use Windows Cut, Copy, and Paste 

Cut or copy objects to the Clipboard and then paste them from the Clipboard into ZWCAD+ or 

other applications. 

Correct Mistakes 

You can backtrack your recent actions using one of several methods. 

8.1 Select Objects 

You can create a selection set that consists of one or more objects before you modify them. 

Use any of the following methods to create a selection set: 

Choose a command or tool first, and then select objects. 

Select objects first, and then choose a command or tool (most objects). 

Select objects by pointing, and then use grips to modify them. 

 

Topics in this section: 

Select Objects Individually 

In response to the Select Objects prompt, you can select one or more objects individually. 

Select Multiple Objects 
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You can select multiple objects at one time using rectangular area or fence. 

Quick Selection 

You can use QSELECT to create a selection set includable or exclusive of the objects which are 

accord with the filtering criterion. 

Group Objects 

A group is a saved set of objects that you can select and edit together or separately as needed. 

Groups provide an easy way to combine drawing elements that you need to manipulate as a unit. 

 1.8.1.1 Select Objects Individually 

You can select one or more objects under the prompt of Select objects on the command line. The 

selected highlights on the screen and could be removed from the selection set. 

Select objects with pickbox 

You can select objects using mouse or other pointing device. The mouse or other pointing device is 

represented of square pickbox on the drawing area. When selecting object, the cursor square 

pickbox should be in the position of an object but not inside it. The size of pickbox can be changed 

on the Selection tab of Options dialog box. 

Remove Selection from Objects 

If an object is no longer needed in a selection set, you can deselect it to remove it from the 

selection set. 

To remove an object from the selection set 

Press Shift, and then select the object again. 

NOTE Pressing Shift while selecting objects using a crossing window removes all objects from the 

specified selection set. 

 

To remove all objects from the selection set 

Press Escape. 

 

Prevent Objects from Being Selected 

You can prevent objects from being selected by locking layer. Because locking layer means that you 

can do any operations except for editing objects on this layer. You can set the locked layer as the 

current layer and add objects as well as using requiring command (such as LIST) and Objects Snap. 

You can control whether you select objects first or type a command first, whether the selected 

objects are highlighted, how to define the selection area, how to create a selection set. 

Select Objects First 
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You can select objects first and then choose how to modify them. As you select each object, it is 

highlighted with small squares called grips, which appear at strategic points on the object. 

The locations of the grips depend on the type of object selected. For example, grips appear at the 

endpoints and midpoint of a line, at the quadrant points and center point of a circle, and at the 

endpoints, midpoint, and center of an arc. 

 

Examples of grip locations. 

After you select one or more objects, you can choose an object modification command, such as 

Copy or Move, from the Modify menu or toolbar. You can also click the right mouse button to 

display a shortcut menu containing the object modification commands appropriate for the selected 

objects, and then choose the command from the menu. 

Select a Command First 

After typing a command, the cursor becomes a pickbox and prompts you to select objects. There 

are several methods for selecting objects: 

Select objects using mouse or other pointing device. 

Click on the drawing area and drags the cursor to define a square selection area. 

Entering interrogation ? displays all selection methods, from which, you can specify the desired 

one. 

Use multiple methods together. For example, to select most of objects on the drawing, you can 

select all objects and then remove the undesired ones. 

When you choose an object-modification tool or command, the program prompts you to select 

objects. Typing ? and pressing ENTER, you can choose a selection method. You can select individual 

objects or use other techniques such as selection windows to select multiple objects. 

When you select objects, you add them to the selection set. After you select at least one object, 

you can remove objects from the selection set. To finish adding objects to the selection set, press 

Enter. Most object-modification commands then act on the entire selection set. 

Control the highlight of selected objects 

You can specify whether to display selected objects highlighted, which makes the selection set 

easier to see. By default, the highlighting feature is turned on. 

Setting system variable HIGHLIGHT to 0 turns off the highlighting feature, which can improve the 

computer's performance. The operation does not affect grips. 

Objects selection methods 

When you choose a command that requires you to select objects (when you're deleting or 



 

 224 

changing object properties, for example), you can use any of the following selection methods by 

choosing them at the command line prompt or entering them in the command bar: 

Window Selects objects contained entirely within a rectangular selection window. 

Last Selects the last selected object. 

Crossing Selects all objects contained within or crossing the boundary of a rectangular selection 

window. 

BOX Selects all objects inside or crossing a rectangle defined by two points. 

ALL Selects all objects in the current drawing. 

Fence Selects all objects crossing a selection box. 

WPolygon Selects all objects inside a defined polygon. 

CPolygon Selects all objects within or crossing a polygon defined by specifying points. 

Group Selects all objects in the specified group. 

Add Adds one or more objects to the selection set. 

Remove Removes one or more objects from the selection set. 

Multiple Selects multiple objects and highlights them. 

Previous Selects the previous selection set. 

AUto Switches to the "Auto" mode. Pointing to an object means selecting the object. 

SIngle You can only select an object for each time. 

Cycle Select 

When you want to select something behind other objects, Cycle Select can help you easily pick 

whatever you want. Click “Cycle Select” button on status bar or hold <Shift+Space> to turn on the 

Cycle Select mode, and then click the object you want to select. After that, you will see current 

selected object being highlighted. If it’s not the one you want, just keep clicking your mouse, then 

it will switch among overlapped objects until you find the correct one and press Enter or Space to 

confirm.  
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Commands Reference 

PROPERTIES: Controls properties of existing objects 

QSELECT: Creates a selection set based on filtering criteria 

SELECT: Groups objects into a selection set for use in subsequent commands 

LAYER: Manages layers and layer properties 

System Variables Reference 

HIGHLIGHT: Controls object highlighting; does not affect objects selected with grips  

PICKADD: Controls whether subsequent selections replace the current selection set or add to it  

PICKAUTO: Controls automatic windowing at the Select Objects prompt 

PICKBOX: Sets the object selection target height, in pixels 

PICKDRAG: Controls the method of drawing a selection window 

PICKFIRST: Controls whether you select objects before (noun-verb selection) or after you issue a 

command  

SELECTIONCYCLING: Turns on or off cycle select function 

 Select Multiple Objects 

You can select multiple objects at one time using rectangular area or fence. 

Specify a Rectangular Selection Area 

You can select all objects inside the rectangular selection area. When specifying the first corner, 

there are two methods to define a rectangular selection window: 

Drags the cursor from left to right to create an enclosed window selection. The objects entirely 

contained in the rectangular selection area are selected only. 

Drags the cursor from right to left to create a crossing selection. The objects contained or passing 

through the rectangular selection area are selected. 

The selected objects must be entirely contained in the window selection area when you use 

Window Selection. However, if the non-continuous (dash) linetype is only partially visible in the 

viewport and all of the visible vectors of the linetype are inside of the selection window, the entire 

object is selected. 

To create a Window 
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Click to select a point in the drawing. 

Click to the right of the first point to select a second point in the drawing. 

 

Window by selecting the first (A) and second (B) points. Resulting selection 

 

To create a Crossing Window 

Click to select a point in the drawing. 

Click to the left of the first point to select a second point in the drawing. 

 

Crossing Window by selecting the first (A) and 

second (B) points 

Resulting selection 

In addition to a rectangular window, you can define a selection window using other shapes such as 

a polygon, circle, or fence (a multi-segmented line that selects objects it crosses). 

 

Specify an Irregularly Shaped Selection Area 

You can select objects with an irregularly shaped area defined by the specified points. Under the 

prompt of SELECT command, you can select objects entirely enclosed by the selection area with the 

WPolygon, or the objects enclosed or crossed by the selection area with the CPolygon. 
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To select objects using WPolygon 

Activate an object modification command. 

On the command line, type WP (WPolygon). 

Specify the vertices of the polygon. 

To complete the selection polygon, press Enter. 

 

Window Polygon by specifying the vertices of the 

polygon (A, B, and C) 

Resulting selection 

 

Specify a Selection Fence 

It could be much easier to select objects in a complex drawing by using a selection fence. A 

selection fence appears like a polyline and chooses only the objects it passes through. 

To select objects using Fence 

Activate an object modification command. 

On the command line, type F (Fence). 

Specify the endpoints of the Fence segments. 

To complete the Fence, press Enter. 
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Fence by specifying the endpoints of the 

fence segments (A, B, and C) 

Resulting selection 

 

Use Other Selection Options 

Typing SELECT and entering ? displays all selection options, from which, you can choose a proper 

one. 

Remove Selection from Multiple Objects 

Under the prompt of Select objects, you can type R and choose a selection to remove objects from 

the selection set. You also can enter A to add objects to the selection set. 

Holding down SHIFT and selecting objects again, the selected objects would be removed from the 

selection set. 

 

Commands Reference 

PROPERTIES: Controls properties of existing objects 

QSELECT: Creates a selection set based on filtering criteria 

SELECT: Groups objects into a selection set for use in subsequent commands 

System Variables Reference 

HIGHLIGHT: Controls object highlighting; does not affect objects selected with grips 

PICKADD: Controls whether subsequent selections replace the current selection set or add to it 

PICKAUTO: Controls automatic windowing at the Select Objects prompt 

PICKBOX: Sets the object selection target height, in pixels 

PICKDRAG: Controls the method of drawing a selection window 

PICKFIRST: Controls whether you select objects before (noun-verb selection) or after you issue a 

command 

 Quick Selection 

You can use QSELECT to create a selection set includable or exclusive of the objects which are 

accord with the filtering criterion. The selection set created by the QSELECT command can be 



 

 229 

applied to the entire drawing and replaces or appends to the current selection set. 

You can enter QSELECT on the command line or click Quick Select button from the Properties 

palette to open Quick Select dialog box. With the specified filtering condition, you can quickly 

define the selection set. 

 

Commands Reference 

PROPERTIES: Controls properties of existing objects 

QSELECT: Creates a selection set based on filtering criteria 

SELECT: Groups objects into a selection set for use in subsequent commands 

System Variables Reference 

HIGHLIGHT: Controls object highlighting; does not affect objects selected with grips 

PICKADD: Controls whether subsequent selections replace the current selection set or add to it 

PICKAUTO: Controls automatic windowing at the Select Objects prompt 

PICKBOX: Sets the object selection target height, in pixels 

PICKDRAG: Controls the method of drawing a selection window 

PICKFIRST: Controls whether you select objects before (noun-verb selection) or after you issue a 

command 

 Group Objects 

A group is a saved set of objects which you can choose and modify together or separately as 

needed. Groups provide an easy way to edit the drawing units as a unit. You can add or remove 

objects to or from the groups as needed. 

The objects within a group can be edited as a unit, which resembles blocks. However, the groups 

are saved from session to session. And you can easily edit individual objects in groups, but in blocks, 

you have to explode blocks before you edit them. Groups cannot be shared with other drawings. 

Create Groups 

Entering GROUP command opens the Group dialog box, from which, you can give a name and 

description to create a group. If you copy a group, the default name is *Ax, and it is considered 

unnamed. When you select Display Unnamed Groups, the list displays all the unnamed groups. 

When you select an object from a group, the other objects of this group are also selected at the 
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same time. The objects can be members of more than one group, and the group can be nested in 

another group. You can restore a nested group to the original group configuration by ungrouping it. 

The named groups is not available when you insert a drawing as an external reference or a block. 

However, it is available if you band and then explode the external reference or explode the block. 

A group containing too much objects can degrade performance of system. 

To create a group 

On the command line, type GROUP. 

Under Create New Group, enter the name and description of the group. 

Click Selectable if you want all entities in the group to be selected when you select one entity of the 

group in the drawing. 

Click Select Entities and Create Group. 

Select the objects for the group, and then press Enter. 

In the Group dialog box, click OK. 

 

Select Objects in Groups 

You can type a group name to select a group at the prompt of Select entities. If the system variable 

PICKSTYLE is set to 1 or 3, you can select any objects of the group. 

When you select an object that is a member of more than one groups, all the objects from that 

groups containing the selected object are selected. 

Edit Groups 

You can add or remove group members and rename groups at the Group dialog box. You can also 

do the operation such as copy, mirror and arrange as well as giving description. 

You can remove members of a group from selecting objects on the drawing by clicking the Remove 

entities from Group button. If a group member is included in a deleted block, the object is removed 

from the drawing and also from the group. The group maintains defined even all the group 

members are removed. 

To modify a group and its objects 

On the command line, type GROUP. 

Select the group you want to modify. 

Under Modify Selected Group, do one or more of the following: 

Enter a new name, and then click Rename Group. 

Enter a new description, and then click Change Group Description. 

Select whether you want the group to be selectable in the drawing. 

Click Add Entities to Group, select the objects to add to the group, and then press Enter. 

Click Remove Entities from Group, select the objects to remove from the group, and then press 

Enter. 

In the Group dialog box, click OK. 

 

You can delete group definition by clicking Un-group entities button. The group is also removed 

from the drawing; however, the group members remain in the drawing. 

To ungroup objects 
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On the command line, type GROUP. 

Select the group to delete. 

Under Modify Selected Group, click Un-group Entities. 

Click OK. 

 

Exploding a group deletes it from a drawing; however, objects that were part of the group remain 

in the drawing. 

The group's member order can be changed (the order in which the objects were selected). There 

are two ways to reorder group members. 

Change the serial number of individual members or arranges of group members. 

Reverse the ranking of all members. The number of first object in each group starts from 0 rather 

than 1. 

To change the order of objects in a group 

On the command line, type group. 

Under Modify Selected Group, click Reorder Entities. 

In the Reorder Grouped Entities dialog box, select the group you want to reorder. 

To see the order of objects in the group, click Highlight. Follow the prompts that display to view the 

objects one by one. 

To reverse the order of all objects in the group, click Reverse Order. 

To change the order of specific objects or a range of objects: 

In Remove from Position, enter the current position of the object. 

In Place to Position, enter the new position of the object. 

In Number of Objects, enter the number of objects or range of objects to reorder. For example, if 

you are changing the order of only one object, enter 1. 

Click Reorder. 

NOTE The objects in a group are numbered 0, 1, 2, 3, and so on. 

Click OK, and then click OK again. 

 

Commands Reference 

GROUP: Creates and manages saved sets of objects called groups 

System Variables Reference 

PICKSTYLE: Controls the use of group selection and associative hatch selection 

8.2 Modify Objects 

You can easily modify the size, shape, and location of objects. You can either enter a command first 

and then select the objects to modify, or you can select the objects first and then enter a command 

to modify them.  

Topics in this section: 
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 Remove Objects 

There are several methods for removing objects from your drawing.  

 Copy Objects 

Create exact duplicates of objects at a specified distance from the original. 

 Mirror Objects 

Flip objects about a specified axis to create a symmetrical mirror image. 

 Offset an Object 

Offsetting an object creates a new object whose shape parallels the shape of a selected object. 

 Create an Array of Objects 

Create copies of objects in a rectangular or polar (circular) pattern called an array. 

 Move Objects 

You can move objects to a new place without changing the objects. 

 Rotate Objects 

Rotate objects around a specified point.  

 Align Objects 

Move, rotate, or tilt an object to align with another object. 

 Scale Objects 

Resize objects to make them longer or shorter in only one direction or to make them proportionally 

larger or smaller. You can also stretch certain objects by moving an endpoint, vertex, or control 

point. 

 Lengthen Objects 

You can change the length of entities or the included angle of arcs. 
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 Stretch Objects 

You can change the size of objects by stretching them. 

 Trim or Extend Objects 

Shorten or lengthen objects to meet the edges of other objects. 

 Create Breaks 

Create a gap in an object, resulting in two objects with a space between them. 

 Create Chamfers 

Chamfering creates a flattened or beveled corner where two lines meet. 

 Create Fillets 

Filleting connects two objects with a smoothly fitted arc of a specified radius. 

 Remove Objects 

Removes objects using one of the following methods: 

Delete objects with ERASE command. 

Cut the selected objects to the clipboard. 

Press DELETE to remove the selected objects. 

You can use ERASE command to delete objects, whatever the methods you use to select objects. 

To restore the deleted objects, use UNDO command. 

OOPS command can restore objects deleted with the ERASE, BLOCK or WBLOCK command. 

To delete mark of plus sign (point mark), perform REDRAW command to refresh screen. 

To delete unused named objects, such as block definition, dimension style, layer, linetype and text 

style, perform PURGE command. 

 

Commands Reference 

CUTCLIP: Copies objects to the Clipboard and removes the objects from the drawing 

ERASE: Removes objects from a drawing 

OOPS: Restores erased objects  

PURGE: Removes unused named items, such as block definitions and layers, from the drawing 
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REDRAW: Refreshes the display in the current viewport 

REDRAWALL: Refreshes the display in all viewports  

System Variables Reference 

None 

 Copy Objects 

You can copy one or more entities, making one copy or multiple copies within the current drawing. 

You can also copy entities between drawings. 

You can duplicate objects within the current drawing. The default method is to create a selection 

set and then specify a base point, and a displacement point, for the copy. 

While specifying two points, you can enter two coordinates to copy objects with the relative 

distance. The location of copies is determined by the relative coordinate. You do not have to enter 

coordinate with the @ as the relative coordinate is assumed. 

To copy objects at the specified distance, you can specify the distance directly when the Ortho 

Mode or Polar Tracking is on. 

Create only one copy of object one time 

Choose Modify > Copy from the main menu. 

Select the objects, and then press Enter. 

On the command line, type O (mOde). 

On the command line, type S (Single). 

Specify the base point. 

Specify the displacement point. 

Modify toolbar:  

Command line COPY 

 

Object to copy (A), base point (B), and displacement point (C) Result 

 

You can copy objects more than one time, until you press ENTER to exit COPY operation. 

Create multiple copies for selected object one time 

Choose Modify > Copy from the main menu. 
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Select the objects, and then press Enter. 

On the command line, type O (mOde). 

On the command line, type M (Multiple). 

Specify the base point. 

Specify the displacement point of the first copy. 

Specify the displacement point of the next copy. 

Continue specifying displacement points to place additional copies. 

To complete the command, press Enter. 

Modify toolbar:  

Command line COPY 

 

To make multiple copies of an object, select 

the object to copy (A), specify the base 

point (B), and then specify the 

displacement points (C, D, and E) 

Result 

 

Commands Reference 

COPY: Duplicates objects 

System Variables Reference 

None 

 Mirror Objects 

You can specify a baseline to create a mirror image using MIRROR command. The mirror image is 

symmetrical with the original one. So if you want to create a symmetrical objects, you only need to 

draw a half one, then create a full one using MIRROR command. 

When creating mirror objects using MIRROR command, you should specify a mirror line around 

which the mirror object is created. In the 3D space, this mirror line must be perpendicular to the XY 
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plane in which the mirror line is included. The mirror line can be determined through specifying 

two points, while you creating mirror objects, you can optionally choose to remove or retain the 

source entity as you need once the mirror objects are created. Like the picture shown below. 

Additionally, you should notice that mirror is only effective to such plans that parallel to XY plan of 

current UCS. 

 

System variable MIRRTEXT affects texts created with MIRROR command. When MIRRTEXT is on, the 

copy of text object is displayed in mirroring way as other objects do. When MIRRTEXT is off, the 

direction of text objects remains unchanged. Displaying as follows: 

 

By default, the MIRRTEXT is on. It affects text objects created with TEXT, ATTDER, METEXT 

command as well as attribute definition and variable attribute. Text as well as constant attributes 

that are included in an insert block are mirrored together with the block while mirroring. 

To mirror objects 

Choose Modify > Mirror from the main menu. 

Select the object, and then press Enter. 

Specify the first point of the mirror line. 

Specify the second point of the mirror line. 

On the command line, if you want to retain the original objects, type N; if you want to delete the 

original objects, type Y. 

Modify toolbar:  

Command line MIRROR 
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To mirror an object, select it (A), and then 

specify the first point (B) and second point 

(C) of the mirror line 

Result 

 

Mirror in 3D 

You can create a mirror image of selected objects in three dimensional space. You mirror the 

objects about a mirror plane that you define by either specifying three points; selecting an existing 

two dimensional planar object; aligning the plane parallel with the xy, yz, or xz plane of the current 

UCS; or aligning the plane with the current view. You can delete or retain the original objects. 

To mirror an object about a three dimensional plane 

Choose Modify > 3D Operation > 3D Mirror from the main menu. 

Select the objects, and then press Enter. 

At command line prompt, choose 3points, or press Enter to select the default. 

Specify the first point on the mirror plane. 

Specify the second and third points on the plane. 

At command line prompt, choose one of the following: 

Yes Delete the original objects. 

No Retain the original objects. 

Command line MIRROR3D 
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Select the object to mirror (A), and then 

specify the first point (B), second point 

(C), and third point (D) defining the 

mirror plane 

The resulting mirrored object 

 

Commands Reference 

MIRROR: Creates a mirror image copy of objects 

MIRROR3D: Creates a mirror image of objects about a plane 

System Variables Reference 

MIRRTEXT: Controls how the MIRROR command reflects text 

 Offset an Object 

You can use the offset feature to copy selected objects and align them offset to the original objects 

at a specified distance. You can make offset objects using arcs, circles, ellipses, elliptical arcs, lines, 

two dimensional polylines, rays, and infinite lines. 

Making offset copies of curved objects creates larger or smaller curves, depending on which side of 

the original object you place the copy. For example, placing an offset copy of a circle outside the 

circle creates a larger concentric circle; positioning the copy inside the circle creates a smaller 

concentric circle. 

You can perform TRIM or EXTEND command while the OFFSET command is active. The result is as 

follows: 

 

If the objects to offset are 2D polyline or spline, the system trims them automatically when the 

specified distance is larger than can otherwise be accommodated. Displaying as follows: 



 

 239 

 

To make an offset copy by specifying the distance 

Choose Modify > Offset from the main menu. 

Specify the distance by selecting two points or by entering a distance. 

Select the object to offset. 

Specify on which side of the object to place the parallel copy. 

Select another object to offset, or press Enter to complete the command. 

Modify toolbar:  

Command line OFFSET 

 

To make a parallel copy, specify the distance between 

copies by entering a distance or selecting two points (A 

and B), select the object to copy (C), and specify on 

which side to place the copy (D) 

Result 

 

To make an offset copy passing through a point 

Choose Modify > Offset from the main menu. 

On the command line, type T (Through). 

Select the object to offset. 

Specify the point for the object to pass through. 

Repeat steps 3 and 4, or press Enter to complete the command. 

Modify toolbar:  

Command line OFFSET 



 

 240 

 

To make a parallel copy passing 

through a point, select the 

object to copy (A) and then 

specify the through point (B) 

 

Commands Reference 

OFFSET: Creates a copy of selected object while offsetting it to a specified position or with 

specified displacement, and keeps the copy of offset object parallel to the source object.  

System Variables Reference 

OFFSETDIST: Sets the default offset distance 

OFFSETGAPTYPE: Controls how potential gaps between segments are treated when polylines are 

offset 

 Create an Array of Objects 

You can create copies of objects that array in rectangular or polar pattern. 

For rectangular arrays, you can specify the number of rows and columns as well as the interval; for 

polar arrays, you can specify the number of copies of the objects and determine whether the 

copies are rotated. 

 

Create Rectangular Arrays 

You should specify the number of rows and columns, offset distance and angle before you create 

rectangular arrays. 

To create a rectangular array 
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Choose Modify > Array from the main menu. 

In the Array dialog box, click Rectangular Array. 

Click the Select Objects button, and then select objects to array in your drawing. 

In the Array dialog box, specify the row and column offset distance and angle of offset. 

Click OK. 

Modify toolbar:  

Command line ARRAY 

 

To create a rectangular array, select the 

object to copy (A), type the number of rows 

and columns, and then specify the distance 

between each row (B) and column (C) 

 

Create Polar Arrays 

You can specify a center or base point to copy the selected objects to create a polar array. The polar 

array is drawn clockwise or counterclockwise depending on whether you type a positive or negative 

value. The radius is determined by the distance between the specified center point and a reference 

or base point on the last selected object. 

To create a polar array 

Choose Modify > Array from the main menu. 

In the Array tab, click Polar Array. 

Click the Select Objects button, and then select objects to array in your drawing. 

In the Array dialog box, choose Method and values you desired. 

Click OK. 

Modify toolbar:  

Command line ARRAY 
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To create a polar array, select the object to 

copy (A), specify the center point of the 

array (B), and then specify the number of 

items to array, the angle the array is to fill, 

and whether to rotate the items 

 

Array in 3D 

3DARRY command is designed to create 3D arrays in the 3D space. The arrays include both 

rectangular and polar array. Besides specifying the number of rows (X direction) and columns (Y 

direction), you have to give the number of layer (Z direction). 

To create a three dimensional rectangular array 

Choose Modify > 3D Operation > 3D Array from the main menu. 

Select the objects, and then press Enter. 

At command line prompt, choose Rectangular. 

Type the number of rows in the array. 

Type the number of columns. 

Type the number of levels. 

Specify the vertical distance between the rows. 

Specify the horizontal distance between the columns. 

Specify the depth between the levels. 

Command line 3DARRAY 
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To create a three dimensional rectangular array, 

select the object to copy (A), type the number of 

rows, columns, and levels, and then specify the 

distance between each row (B), column (C), and 

level (D) 

 

To create a three dimensional polar array 

Choose Modify > 3D Operation > 3D Array from the main menu. 

Select the objects, and then press Enter. 

At command line prompt, choose Polar. 

Type the number of copies to make, including the original selection set. 

Specify the angle the array is to fill, from 0 to 360 degrees. The default setting for the angle is 360 

degrees. Positive values create the array in a counterclockwise direction; negative values create the 

array in a clockwise direction. 

At command line prompt, choose one of the following: 

Yes Rotate objects as they are arrayed. 

No Do not rotate to retain the original orientation of each copy as it is arrayed. 

Specify the center point of the array. 

Specify a second point along the central axis of the array. 

Command line 3DARRAY 
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To create a three dimensional polar array, select the 

object to copy (A), type the number of items to 

array, specify the angle the array is to fill (B), and 

then specify the center point of the array (C) and a 

second point along the central axis of the array (D) 

 

Limit the Size of Arrays 

If there are a large number of rows and columns for a rectangular array, the system takes a long 

time to create the copies. By default, the number of array elements generate by one command is 

not over 100,000. The value is stored in the system variable MaxArray. It is ranges from 100 to 

10000000. If you want to change the value of MaxArray, you must type MaxArray with the 

capitalization shown. 

 

Commands Reference 

3DARRAY: Creates a three-dimensional array 

ARRAY: Creates multiple copies of objects in a pattern 

SETTINGS: Specifies settings for Snap mode, grid, and polar and object snap tracking 

UCS: Manages user coordinate systems 

UNITS: Controls coordinate and angle display formats and precision 
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System Variables Reference 

ANGBASE: Sets the base angle to 0 with respect to the current UCS 

ANGDIR: Sets the direction of positive angles 

SNAPANG: Sets the snap and grid rotation angle for the current viewport 

 Move Objects 

You can move objects to a new place without changing the objects. You can type a coordinate value 

for the new position in the Properties palette. 

The following image shows how to move an object. Perform MOVE command and then select 

object (1) to move; specify a base point (2) and Displacement point (3). The object is moved from 

point 2 to the point 3. 

 

In addition to specifying base point or displacement point on the drawing, you can also type 

coordinate value on the command line. The Vector option is also used to define a new position. 

To move entities 

Choose Modify > Move from the main menu. 

Select the objects, and then press Enter. 

Specify the base point. 

Specify the displacement point. 

Modify toolbar:  

Command line MOVE 
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To move an object, select it (A), and then 

specify the base point (B) and the 

displacement point (C) 

Result 

 

You can also move objects using grips. To move an object through dragging its grips, select the 

object to get its grips highlighted, and then click the desired grip and drag it to a new position. The 

grip you select depends on the type of object you're moving. For example, to move a line object, 

select the midpoint grip. To move a curved object, such as an arc, circle, or ellipse, select the center 

point grip. Not all objects can be moved using grips. 

To move an object using grips 

Select the object. 

Click a grip to select it. 

Drag the object to where you want to relocate it. 

Click to release. 

 

When all endpoints of selected objects are within a selection window, the STRETCH command is 

equivalent with the MOVE command. The Ortho or Polar Tracking can help you move objects along 

to the exact direction. 

 

From the picture above, the Door is contained entirely in the selection window, so the door can be 

moved to the specified location. And the wall lines are only partially within the selection area, as a 

result, the door moves with the wall. 

You can specify the distance the objects to move while the Ortho or Polar Tracking mode is on. 

 

Commands Reference 

MOVE: Displaces objects a specified distance in a specified direction 

PROPERTIES: Controls properties of existing objects 

STRETCH: Moves or stretches objects 

System Variables Reference 

None  
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 Rotate Objects 

You can rotate the selected objects around a specified point. 

You can specify the rotated angle by specifying a point on the drawing or entering the angle value 

directly. The direction that objects rotate depends on the value you enter is positive or negative. 

The rotated plane and direction of zero angle is determined by the azimuth of UCS. 

Rotate an Object by a Specified Angle 

You can rotate objects by specifying a base point or an angle. 

To rotate objects 

Choose Modify > Rotate from the main menu. 

Select the objects, and then press Enter. 

Specify the base point. 

Specify the rotation angle. 

Modify toolbar:  

Command line ROTATE 

 

To rotate an object, select the object to rotate (A), and then specify 

base point (B) and the rotation angle (C) 

 

Rotate an Object to an Absolute Angle 

You can also rotate objects by specifying an absolute angle. 

To rotate a selection set in reference to an Absolute Angle 

Choose Modify > Rotate from the main menu. 

Select the objects, and then press Enter. 

Specify the base point. 

On the command line, type R (Reference). 

Specify the reference angle. 

Specify the new angle. 

Modify toolbar:  

Command line ROTATE 
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To rotate an entity in reference to a base angle, select the entity (A), 

specify base point (B), select the reference angle and pick point (B) 

again (or type the @ symbol), specify the second point (C), and then 

specify the point representing the new angle (D) 

 

Rotate an Object in 3D 

With the ROTATE command, you can rotate 2D objects. The rotation direction is determined by the 

current UCS. The ROTATE3D command is used to rotate objects in the 3D space. 

With use of ROTATE3D, you can define the rotation axis by specifying two points; X,Y,Z axis; or the Z 

direction of the current view. The 3D objects can be rotated with either the ROTATE command or 

ROTATE3D command. 

To rotate an object about an axis in three dimensions 

Choose Modify > 3D Operation > 3D Rotate. 

Select the objects to rotate, and then press Enter. 

Choose one from the following options: Object, Last, View, Xaxis, Yaxis, Zaxis, 2points. 

Specify the rotation angle. 

Command line ROTATE3D 

 

Select the objects to rotate (A), specify the 

endpoints of the axis of rotation (B and C), 

and then specify the rotation angle (D) 

Result after rotating the 

objects 
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Commands Reference 

ROTATE: Moves objects about a base point 

ROTATE3D: Moves objects about a three-dimensional axis 

System Variables Reference 

None 

 Align Objects 

You can align objects with another through move or rotation. The following picture shows how to 

align the piping using Align command. 

 

Aligning in three dimensions 

You can align selected objects with other objects in three dimensional space. You select the objects 

you want to align, and specify one, two or three pairs of points to align the selected objects. 

To align an object with another 

Choose Modify > 3D Operation > Align from the main menu. 

Select the objects, and then press Enter. 

Specify the first source point. 

Specify the first destination point. 

Specify additional source and destination points if desired (up to three pairs). 

Command line ALIGN 
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Select the objects to align, and then specify 

the first source point (A), the first destination 

point (B), the second destination point (C), 

and the second destination point (D) 

The resulting mirrored object 

You can specify up to three pairs of source/destination points. 

 

Commands Reference 

ALIGN: Aligns objects with other objects in 2D and 3D 

System Variables Reference 

None 

 Scale Objects 

You can use SCALE command to zoom the selected objects. You can type a scale factor or specify a 

base point and distance to zoom objects. A scale factor that is greater than 1 enlarges the object; 

and a scale factor that is smaller than 1 shrinks the object. 

 

You can also scale objects by comparing the basic scale and new scale. The objects become larger if 

the new scale is large than the basic scale. 

The dimension will be scale along with the object to scale. 

To scale a selection set by a scale factor 
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Choose Modify > Scale from the main menu. 

Select the objects, and then press Enter. 

Specify the base point. 

Specify the scale factor. 

Modify toolbar:  

Command line SCALE 

 

To scale an object by a scale factor, select the object 

(A), and then specify the base point (B) and the scale 

factor 

Result 

 

You can also scale some objects using grips. To scale an object, you select the object, and then click 

a grip. You then change the size of the object by moving the grip. The grip you select depends on 

the type of object you're modifying. For example, to scale a circle, select a quadrant point grip. 

To scale an object using grips 

Select the object. 

Click a grip to select it. 

Drag the grip. 

Click to release. 

 

To scale using grips, select the object (A), click a grip 

(B), and scale the object by dragging the grip to its 

new location (C) 

Result 

 



 

 252 

Commands Reference 

LENGTHEN: Changes the length of objects and the included angle of arcs 

PEDIT: Edits polylines and three-dimensional polygon meshes 

PROPERTIES: Controls properties of existing objects 

SCALE: Enlarges or reduces selected objects proportionally in the X, Y, and Z directions 

SPLINEDIT: Edits a spline or spline-fit polyline 

STRETCH: Moves or stretches objects 

System Variables Reference 

None 

 Lengthen Objects 

You can change the length of entities or the included angle of arcs. The results are similar to 

extending and trimming. 

This command does not affect the closed entities. 

Use any of the following methods to change the length of an entity: 

Dynamically drag the endpoint or angle. 

Specify an incremental length or angle measured from an endpoint. 

Specify the new length as a percentage of the total length or angle. 

Specify a new length or included angle. 

You can change the length of arcs, lines, open polylines, ellipse arc and open spline. 

To change the length of an object by dragging 

Choose Modify > Lengthen from the main menu. 

On the command line, type DY (DYnamic). 

Select the object you want to change. 

Specify the new endpoint or included angle. 

Modify toolbar:  

Command line LENGTHEN 
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Select the object (A), and then select the 

new endpoint (B) 

Result 

 

Commands Reference 

LENGTHEN: Changes the length of objects and the included angle of arcs 

PEDIT: Edits polylines and three-dimensional polygon meshes 

PROPERTIES: Controls properties of existing objects 

SCALE: Enlarges or reduces selected objects proportionally in the X, Y, and Z directions 

SPLINEDIT: Edits a spline or spline-fit polyline 

STRETCH: Moves or stretches objects 

System Variables Reference 

None 

 Stretch Objects 

You can change the size of objects by stretching them. When you stretch objects, you must select 

the objects using either a crossing window or a crossing polygon. You then specify a displacement 

distance or select a base point and a displacement point. Objects that cross the window or polygon 

boundary are stretched; those completely within the crossing window or crossing polygon are 

simply moved. 

STRETCH stretches arcs, elliptical arcs, lines, polyline segments, 2D solids, rays, traces, and splines 

that cross the selection window. 

STRETCH moves only endpoints within the selection window, leaving those outside unchanged. The 

polyline is treated as the composition of line straight and arc when being stretched. STRETCH does 

not affect 3D solids, polyline width, tangent or curve-fitting information. 

When stretching objects, you have to specify a base point and displacement point. You should use 
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crossing selection to select the desired objects. With using grip edition, you can also stretch 

objects. 

 

To stretch an object 

Choose Modify > Stretch from the main menu. 

Select the objects using either a crossing window or a crossing polygon, and then press Enter. 

Specify the base point. 

Specify the second point of displacement. 

Modify toolbar:  

Command line STRETCH 

 

To stretch objects, select them using a crossing window (A) or crossing polygon, 

and then specify the base point (B) and displacement point (C) 

 

To stretch an object using grips, you select it to display its grips and then select a grip to make it the 

active grip. This becomes the base point. Then you move the active grip to a new location. The grip 

you select depends on the type of object you're modifying. For example, to stretch one corner of a 

rectangle, select the corner point grip. 

To stretch a line, select an endpoint grip. Not all objects can be stretched using grips. 

To stretch an object using grips 

Select the object. 

Click a grip to activate it. 

Drag the grip. 

Click to release. 
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To stretch an object using grips, select 

the object (A), select a grip (B), and drag 

the grip to its new location (C) 

Result 

 

Commands Reference 

LENGTHEN: Changes the length of objects and the included angle of arcs 

PEDIT: Edits polylines and three-dimensional polygon meshes 

PROPERTIES: Controls properties of existing objects 

SCALE: Enlarges or reduces selected objects proportionally in the X, Y, and Z directions 

SPLINEDIT: Edits a spline or spline-fit polyline 

STRETCH: Moves or stretches objects 

System Variables Reference 

None 

 Trim or Extend Objects 

You can connect edges of objects through trimming or extending. 

When trimming or extending objects, you have to specify cutting edges or boundary to extend, 

then you can select objects to cut or extend. Pressing ENTER at the prompt of selecting entities, all 

entities are the possible boundaries, which call hidden selection. 

If you want to select blocks as cutting edges, you can only use the single selection, Crossing, Fence, 

and Select All options. 

Trim Objects 

You can clip, or trim, objects so they end at one or more implied cutting edges defined by other 

objects. You can also trim objects to the point at which they would intersect an implied cutting 
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edge. When trimming objects, you first select the cutting edges and then specify the objects to trim, 

selecting them either one at a time or using the fence selection method. 

You can trim arcs, circles, lines, unclosed polylines, and rays. In which, arcs, circles, lines, polylines, 

rays, infinite lines, and viewports on a Layout tab can act as cutting edges. 

 

To trim an object 

Choose Modify > Trim from the main menu. 

Select one or more cutting edges, and then press Enter. 

Select the object to trim. 

Select another object to trim, or press Enter to complete the command. 

Modify toolbar:  

Command line TRIM 

 

To trim objects, select the cutting edge (A), 

and then select the objects to trim (B) 

Result 

 

Holding down SHIFT while selecting objects, system extends object to the nearest boundary instead 

of trimming selecting object. 

In this example, you clean up the intersection of two walls smoothly by trimming. 

 

Using variable selection methods while trimming several objects can help you select edges or 

objects more easily. 

In the following example, the cutting edges are selected using crossing selection. 
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To trim several objects using the fence selection method 

Choose Modify > Trim from the main menu. 

Select one or more cutting edges, and then press Enter. 

On the command line, type F (Fence). 

Specify the first point of the fence. 

Specify the second point of the fence. 

Specify the next fence point, or press Enter to complete the command. 

Modify toolbar:  

Command line TRIM 

 

Select the boundary edge (A), and then specify 

the first point (B) and second point (C) of the 

fence 

Result 

 

You can trim objects to the nearest point of other objects. Selecting objects and clicking objects to 

trim, system specifies the nearest objects as the cutting edges. The following picture shows that the 

crossing boundary is smooth after trimming. 

 

Extend Objects 
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You can extend objects so that they end at a boundary defined by other objects. You can also 

extend objects to the point at which they would intersect an implied boundary edge. When 

extending objects, you first select the boundary edges, and then specify the objects to extend by 

way of selecting them one by one or using the fence selection method. 

You can extend arcs, lines, two-dimensional polylines, and rays. Arcs, circles, ellipses, lines, splines, 

polylines, rays, infinite lines, and viewports on a Layout tab can act as boundary edges. 

In this example, you extend the lines precisely to a circle, which is the boundary edge. 

 

To extend an object 

Choose Modify > Extend from the main menu. 

Select one or more objects as boundary edges, and then press Enter. 

Select the object to extend. 

Select another object to extend, or press Enter to complete the command. 

Modify toolbar:  

Command line EXTEND 

 

To extend objects, select the boundary edge 

(A), and then select the objects to extend (B) 

Result 

 

To extend an object to an implied boundary 

Choose Modify > Extend from the main menu. 

Select one or more boundary edges, and then press Enter. 

On the command line, type E (Edge). 

On the command line, type E (Extend). 

Select the object to extend. 

Select another object to extend, or press Enter to complete the command. 

Modify toolbar:  

Command line EXTEND 
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Select the boundary edge (A), and then select 

the objects to extend (B) 

Result 

 

To extend several objects using the fence selection method 

Choose Modify > Extend from the main menu. 

Select one or more boundary edges, and then press Enter. 

On the command line, type F (Fence). 

Specify the first point of the fence. 

Specify the second point of the fence. 

Specify the next fence point, or press Enter to complete the command. 

Modify toolbar:  

Command line EXTEND 

 

Select the boundary edge (A), and then specify 

the first point (B) and second point (C) of the 

fence 

Result 

TRIM can also be used to extend objects. At the prompts of selecting entities, holding down SHIFT 

and selecting objects to extend. As a result, the objects are extending instead of trimming. 

 

Trim and Extend Wide Polylines 

System processes the center line if the object is 2D wide polyline. If the polyline is pyramid, the 

width of cutting edge keeps unchanged after trimming. 

When you extend a wide polyline, its centerline intersects the boundary edge. Because the end of 

the polyline is always cut at a 90-degree angle, part of the polyline may extend past the boundary 

edge. A tapered polyline continues to taper until it intersects the boundary edge. If this would 

result in a negative polyline width, the ending width changes to 0. 
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A tapered polyline (A) continues to taper until it 

intersects the boundary edge (B) 

Result 

The ends of wide polylines are always square. Trimming a wide polyline at an angle leads to 

portions of the end to extend beyond the cutting edge. Trimming a spline-fit polyline deletes 

curve-fit information and converts spline-fit segments to ordinary polyline segments. 

Trim or Extend in 3D 

You can trim or extend objects even the objects are in the different planes in 3D space. 

The system variable PROJMODE and EDGEMODE control the following project models: 

XY plane of the Current UCS. 

Current view plane. 

3D realty space (not projection). 

Attentively, when you trim or extend objects 3D space, the objects to cut or extend must be 

intersected with the boundary of 3D boundary. The objects to trim or extend may not concluding 

exactly if they do not intersect with each other when you work at the XY plane of the current UCS. 

 

Commands Reference 

EXTEND: Extends an object to meet another object  

LENGTHEN: Changes the length of objects and the included angle of arcs 

PROPERTIES: Controls properties of existing objects 

TRIM: Trims objects at a cutting edge defined by other objects 

System Variables Reference 

EDGEMODE: Controls how the TRIM and EXTEND commands determine cutting and boundary 

edges 

PROJMODE: Sets the current Projection mode for trimming or extending 
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 Create Breaks 

You can break arcs, circles, ellipses, lines, polylines, rays, and infinite lines. When breaking entities, 

you must specify two points for the break. By default, the point you use to select the entity 

becomes the first break point; however, you can use the First break point option to select a break 

point different from the one that selects the entity. 

 

To break an object 

Choose Modify > Break from the main menu. 

Select the object. 

Specify the second break point. 

Modify toolbar:  

Command line BREAK 

 

Select the object (A), and then specify the 

second break point (B) 

Result 

 

To select an object and then specify the two break points 

Choose Modify > Break from the main menu. 

Select the object. 

On the command line, type F (First point). 

Specify the first break point. 

Specify the second break point. 

Modify toolbar:  

Command line BREAK 



 

 262 

 

Select the object (A), and then specify the 

first (B) and second (C) break points 

Result 

TIP To break an object in two without removing a portion of the object, 

specify the same point for the first and second break points by typing the 

at sign (@) and pressingEnter instead of specifying the second break point. 

 

Commands Reference 

BREAK: Breaks the selected object between two points 

System Variables Reference 

None 

 Create Chamfers 

You can connect two nonparallel objects by extending or trimming them and then joining them 

with a line to create a beveled edge. You can chamfer lines, polylines, rays, and infinite lines. When 

creating a chamfer, you can specify how far to trim the objects back from their intersection 

(distance distance method), or you can specify the length of the chamfer and the angle it forms 

along the first object (distance angle method). 

When chamfering a polyline, you can chamfer multiple segments between two selected polyline 

segments, or you can chamfer the entire polyline. 

If two objects to chamfer on the same layer, the chamfer line lies on the layer as the object does; 

otherwise, the chamfer line lies on the current layer which controls the properties of the line. The 

mUltiple option can help you chamfer multiple objects at one time. 

 

Chamfer by Specifying Distances 
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The chamfer distance is the amount each entity is trimmed or extended to meet the chamfer line 

or to intersect the other. If both chamfer distances are 0, chamfering trims or extends the two 

entities until they intersect instead of creating a chamfer line. 

The default setting for the first distance is the last one you have specified, and the second distance 

is the same as the first one. However, you can reset the desired chamfer distance. 

To chamfer two objects using the distance-distance method 

Choose Modify > Chamfer from the main menu. 

On the command line, type D (Distance). 

Specify the first chamfer distance. 

Specify the second chamfer distance. 

Select the first object to chamfer. 

Select the second object to chamfer. 

Modify toolbar:  

Command line CHAMFER 

 

Select the first (A) and second (B) 

objects 

The chamfer is drawn, based on the first 

(C) and second (D) chamfer distances 

 

Trim and Extend Chamfered Objects 

If the objects to chamfer are two intersecting lines, and you select Trim option to chamfer objects, 

system automatically trims lines to the endpoint of chamfered line. If the selected lines are not 

intersecting with each other, system extends them to get intersectant. 

If you select No Trim, system creates chamfer directly and not to trim. 

Chamfer by Specify Length and Angle 

You can chamfer objects by specifying a start point and an angle. 

To chamfer two objects using the distance-angle method 

Choose Modify > Chamfer from the main menu. 

On the command line, type A (Angle). 

Specify chamfer length on the first line. 

Specify chamfer angle from the first line. 

Select the first object to chamfer. 

Select the second object to chamfer. 
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Modify toolbar:  

Command line CHAMFER 

 

Select the first (A) and second (B) 

objects 

The chamfer is drawn, based on the 

distance (C) and the angle (D) 

 

Chamfer Polylines and Polyline Segments 

You can create a chamfer line for two segments of a polyline that are adjacent or separated by no 

more than one arc segment. As shown in the illustration, if they separated by an arc segment, the 

arc is deleted and replaced with a chamfer line. 

 

To chamfer selected vertices in a polyline 

Choose Modify > Chamfer from the main menu. 

Select the polyline along the segment where you want to begin the chamfer. 

Select the polyline along the segment where you want to end the chamfer. 

Modify toolbar:  

Command line CHAMFER 

 

Select the 

polyline along the 

(A) and (B) 

Result after chamfering 
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segments 

 

Chamfer an Entire Polyline 

You can use Polyline option to create chamfer lines for each intersection of an entire polyline. To 

get the best results, keeps the first and second chamfer distance equal. 

To chamfer all vertices in a polyline 

Choose Modify > Chamfer from the main menu. 

On the command line, type P (Polyline). 

Select the polyline. 

Modify toolbar:  

Command line CHAMFER 

 

Original polyline Result after chamfering 

 

When chamfering an entire polyline, only accommodated chamfer distance can create a chamfer 

line. As shown in the illustration, some segments are too short to create a chamfer line. 

 

 

Commands Reference 

CHAMFER: Bevels the edges of objects 

System Variables Reference 

CHAMFERA: Sets the first chamfer distance 

CHAMFERB: Sets the second chamfer distance 
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CHAMFERC: Sets the chamfer length 

CHAMFERD: Sets the chamfer angle 

TRIMMODE: Controls whether selected edges for chamfers and fillets are trimmed 

 Create Fillets 

You can create a fillet using FILLIT command. This command can apply to the objects such as arcs, 

circles, ellipses, lines, polylines, rays, splines or construction lines as well as 3D solids. A fillet is an 

arc that connects two objects smoothly and has a specified radius. An inside corner is called a fillet; 

an outside corner is called a round. 

To fillet two objects 

Choose Modify > Fillet from the main menu. 

On the command line, type R (Radius). 

Specify the fillet radius. 

Select the first object. 

Select the second object. 

Modify toolbar:  

Command line FILLET 

 

Select the first (A) and second (B) objects Result after filleting 

 

Using FILLET command can help you create an arc that is tangent to the selected objects easily. You 

can also use Polyline option to create fillets for each corners of a polyline. 

When the objects to fillet are on the same layer, the fillet arc is created on that layer; otherwise, 

the fillet arc is created on the current layer that affects the properties of objects such as color and 

linetype. The Multiple option can create fillets for more than one set of objects until you exit the 

command. 

Set the Fillet Radius 

You can specify the radius of a fillet arc connecting two objects. The latest value is always the 
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current radius value. This setting is only available when you create a new fillet arc. When the radius 

is set to 0, the objects to fillet are trim or extend to get intersecting, but not create a fillet arc. 

 

Trim and Extend Filleted Objects 

While performing fillet, you can select Trim option to decide whether the selected edges are 

extended to the endpoints of fillet arcs. By default, all objects except of circles, ellipses, closed 

polylines and splines are trimmed or extended when performing filleting. 

When system variable TRIMMODE is set to 1, FILLET trims the intersecting lines to the endpoint of 

the fillet arc. If the lines do not get intersecting, system extends or trims them to get intersecting. 

 

Specify the Location of the Fillet 

When the objects to fillet are a line and an arc or a circle, there are several potential fillets and 

system creates the fillet with the endpoint of arc at the nearest the selected point. The location of 

fillets depends on the place of the objects you specify. As shown in the following picture: 
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Select objects (A and B) Result after filleting 

Fillet Line and Polyline Combinations 

If the objects to fillet are a line and a polyline, the line or its extension must be intersecting with 

one of the polyline segments. With Trim option on, the filleted objects join with the filleted arc to 

form a new polyline. 

 

Fillet an Entire Polyline 

You can use Polyline option to create fillets for each corners of a polyline. 

To fillet an entire polyline 

Choose Modify > Fillet from the main menu. 

On the command line, type P (Polyline). 

Select the polyline. 

Modify toolbar:  

Command line FILLET 
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Select the polyline (A) Result after filleting 

 

Before creating fillets, you should ensure the distance between each vertex is long enough to 

accommodate the fillet radius in order to insert a fillet arc. 

 

The fillet arcs replace arc segments when the fillet radius is greater than the radius of the arc. As 

shown in the illustration: 

 

When the fillet radius is set to 0, no fillet arcs are inserted. If two polyline segments are separated 

by one arc segments, system deletes this arc segment and extends the lines to intersect with each 

other. 

To fillet selected vertices in a polyline 

Choose Modify > Fillet from the main menu. 

Select the polyline along the segment where you want to begin the fillet. 

Select the polyline along the segment where you want to end the fillet. 

Modify toolbar:  

Command line FILLET 

 

Select the polyline Result after filleting 
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along the (A) and (B) 

segments 

 

Fillet Parallel Lines 

You can fillet parallel lines, rays, and infinite lines. The first entity must be a line or ray, the second 

entity can be a line, ray, or infinite line. The diameter of the fillet arc is always equal to the distance 

between the parallel entities. The current fillet radius is ignored. 

 

Original entities Result after filleting 

 

Commands Reference 

FILLET: Rounds and fillets the edges of objects  

System Variables Reference 

FILLETRAD: Stores the current fillet radius 

TRIMMODE: Controls whether selected edges for chamfers and fillets are trimmed 

8.3 Modify Compound Objects 

Editing compound objects, such as blocks, dimensions, hatches, and polylines.  

Topics in this section: 

 Disassociate Compound Objects 

Convert a compound object into individual elements. 

 Modify Polylines 

Changing the shape of polyline objects. You can also join separate polylines. 
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 Modify Multilines 

Changing the vertices, intersections, and other properties of the line elements. 

 Disassociate Compound Objects 

You can convert a complex entity, such as a block or polyline, from a single entity into its 

component parts. Exploding a polyline, rectangle, donut, polygon, dimension, or leader reduces it 

to a collection of individual line and arc entities that you can then modify individually. Blocks are 

converted to the individual entities, possibly including other, nested blocks that composed the 

original entity. 

With the following exceptions, exploding an entity usually has no visible effect on a drawing: 

If the original polyline had a width, the width information is lost when you explode it. The resulting 

lines and arcs follow the centerline of the original polyline. If you explode a donut, its width 

becomes 0. 

If you explode a block containing attributes, the attributes are lost, but the original attribute 

definitions are retained. The colors and linetypes of objects in exploded block references can be 

modified individually. 

Colors, linetypes, lineweights, and print styles assigned BYBLOCK may be different after exploding 

an entity, because they will adopt the default color, linetype, lineweight, and print style until 

inserted into another block. 

Explode Polylines 

You can explode polylines into simple line segments and arc segments, which neglects the width of 

a polyline. The exploded lines and arcs are placed along to the center line of the polyline. To be 

taken as a polyline object, the donut would be changed into two arcs that form a circle (with width 

as 0) after exploding. 

Explode Dimensions and Hatches 

You can explode a dimension or a hatch into individual objects (such as lines, texts, points and 2D 

solids). All associativity is lost after exploding. 

Explode Block References 

You can explode a block reference into individual objects. If a block to be exploded contains 

attributes, the attribute values are lost and leaving attribute definition. If you explode a block that 

contains polyline objects, you have to explode the polyline separately. 

To explode a block 

Choose Modify > Explode from the main menu. 

Select the block. 

Press Enter. 

Modify toolbar:  

Command line EXPLODE 
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Explode External References 

You can not explode external references or the dependent blocks as they are linked or attached to 

another drawing. 

 

Commands Reference 

EXPLODE: Explodes a compound object composed by multiple objects (blocks, polylines, etc.) into 

single objects 

System Variables Reference 

EXPLMODE: Controls whether the EXPLODE command supports nonuniformly scaled (NUS) blocks 

 Modify Polylines 

You can modify any type of two dimensional or three dimensional polyline. Objects such as 

rectangles, polygons, and donuts, as well as three dimensional objects such as pyramids, cylinders, 

and spheres, are all editable polylines 

You can edit a polyline by opening or closing it, by changing its overall width or the widths of 

individual segments, and by converting a polyline with straight line segments into a flowing curve 

or an approximation of a spline. In addition, you can use the Edit Polyline tool to edit individual 

vertices, adding, removing, or moving vertices. You can also add new segments to an existing 

polyline, change the linetypes of a polyline, and reverse the direction or order of the vertices. 

To modify a polyline, you first select the polyline, and then select a polyline editing option. The 

available options vary depending on whether the selected polyline is a two dimensional or three 

dimensional object. If the selected object is not a polyline, the Edit Polyline tool provides the 

option of turning it into one. You can convert only arcs and lines into polylines. If several arcs or 

lines are joined endpoint to endpoint, they can all be selected and turned into one polyline. 

To convert an object into a polyline 

Choose Modify > Object > Polyline from the main menu. 

Select the object. 

On the command line, type Y. 

On the command line, type another option, or press Enter to complete the command. 

Modify II toolbar:  

Command line PEDIT 
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Joined Polyline Segments 

If the ends of a line or arc connect or are close to each other, you can join them to an open polyline 

by trimming or extending. 

Modify Properties of Polylines 

If the properties of several objects being joined into a polyline are different, such as color and 

linetype, the new polyline inherits the properties of the first object that you selected. You can also 

set properties of the new polyline in the Properties palette. 

Additional Editing Options for Polylines 

You can use PEDIT to edit polylines: 

Close 

When you close a polyline, the program draws a straight polyline segment from the last vertex of 

the polyline to the first vertex. System considers the polyline open unless you close it using the 

Close option. 

To close an open polyline 

Choose Modify > Object > Polyline from the main menu. 

Select the polyline. 

On the command line, type C (Close). 

On the command line, type another option, or press Enter to complete the command. 

Modify II toolbar:  

Command line PEDIT 

 

Closing an open polyline adds a straight 

polyline segment between the first (A) 

and last (B) vertices 

Result 

Open 

If the polylines to be edited is closed, you can convert it into an open one by using OPEN option to 



 

 274 

delete the latest drawn segments of the polyline. 

Join 

You can add an arc, line, or polyline object to an existing open polyline, forming one continuous 

polyline object. To join an object to a polyline, that object must already share an endpoint with an 

end vertex of the selected polyline. 

When you join an object to a polyline, the width of the new polyline segment depends on the 

width of the original polyline and the type of object you are joining to it: 

A line or an arc assumes the same width as the polyline segment for the end vertex to which it is 

joined. 

A polyline joined to a tapered polyline retains its own width values. 

A polyline joined to a uniform-width polyline assumes the width of the polyline to which it is 

joined. 

To join an arc, line, or polyline to an existing polyline 

Choose Modify > Object > Polyline from the main menu. 

Select the polyline. 

On the command line, type J (Join). 

Select the arc, line, or polyline to join. 

On the command line, type another option, or press Enter to complete the command. 

Modify II toolbar:  

Command line PEDIT 

Width 

Specifies the uniform width for all segments of selected polylines. Using Width option while 

performing "Edit vertex", you can specify the width of start point and end point. 

 

You can change the width of an entire polyline, applying a uniform width to the polyline or 

assigning tapering width with gradient size. 

To apply a uniform width to an entire polyline 

Choose Modify > Object > Polyline from the main menu. 

Select the polyline. 

On the command line, type W (Width). 

Specify the new polyline width. 

On the command line, type another option, or press Enter to complete the command. 

Modify II toolbar:  
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Command line PEDIT 

To apply tapering width to a polyline 

Choose Modify > Object > Polyline from the main menu. 

Select the polyline. 

On the command line, type T (Taper). 

Specify the starting width. 

Specify the ending width. 

On the command line, type another option, or press Enter to complete the command. 

Modify II toolbar:  

Command line PEDIT 

Edit vertex 

You can use the Edit Vertices option to modify individual polyline vertices. When you select this 

option, the program switches into a special vertex editing mode and places an x on the first vertex. 

The x indicates the vertex you are editing. The Next and Previous options move the x to the next or 

previous vertex. You can edit only one vertex at a time. 

When editing vertices, you can modify the polyline in the following ways: 

Convert a polyline segment into a curve by specifying a new tangent angle. 

Break a polyline into two separate polylines. 

Insert a new vertex after the current vertex. 

Move the current vertex. 

Straighten the polyline segment between two vertices. 

Change the width of the polyline segment between two vertices. 

To move a polyline vertex 

Choose Modify > Object > Polyline from the main menu. 

Select the polyline. 

On the command line, type E (Edit vertex). 

On the command line, type N (Next). Repeat until the X maker reaches the vertex you want to 

move. 

On the command line, type M (Move). 

Specify the new location for maked vertex. 

On the command line, type another option, or type Exit to complete the command. 

On the command line, type another option, or press Enter to complete the command. 

Modify II toolbar:  

Command line PEDIT 



 

 276 

 

Select the polyline (A), move the current vertex 

marker to the vertex you want to move (B), and 

then specify the new vertex location (C) 

Result 

To taper the width of an individual polyline segment 

Choose Modify > Object > Polyline from the main menu. 

Select the polyline. 

On the command line, type E (Edit vertex). 

On the command line, type N (Next). Repeat until the X maker reaches the first vertex of the 

segment you want to taper. 

On the command line, type W (Width). 

Specify the starting width. 

Specify the ending width. 

On the command line, type another option, or type Exit to complete the command. 

On the command line, type another option, or press Enter to complete the command. 

Modify II toolbar:  

Command line PEDIT 

 

Select the polyline (A), move the current 

vertex marker to the first vertex of the 

segment you want to taper (B), and then 

specify the new starting and ending widths 

for that segment. 

Result 

Fit 

You can create an arc-fit polyline, a smooth curve joining each pair of vertices. The curve passes 

through all vertices of the polyline. 

To fit a curve to a polyline 

Choose Modify > Object > Polyline from the main menu. 

Select the polyline. 
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On the command line, type F (Fit). 

On the command line, type another option, or press Enter to complete the command. 

Modify II toolbar:  

Command line PEDIT 

Spline 

Converts a polyline into a spline. Specifies the vertices of the selected polyline as the control points 

or frame of a curve approximating a B-spline. The curve passes through the first and last control 

points unless the polyline is closed. 

 

Original polyline After applying Fit curve 
After applying 

Spline 

Decurve 

Straights splines fit curves with Fit option or splines created with Spline option. 

Ltype gen 

Changes the linetype of a polyline. When this option is off, linetypes are generated starting and 

ending with a dash line at each vertex. 

 

Commands Reference 

PEDIT: Edits polylines and three-dimensional polygon meshes 

System Variables Reference 

PEDITACCEPT: Suppresses display of the Object Selected Is Not a Polyline prompt in PEDIT 

SPLFRAME: Controls the display of splines and spline-fit polylines 
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SPLINESEGS: Sets the number of line segments to be generated for each spline-fit polyline 

generated by the Spline option of the PEDIT command  

SPLINETYPE: Sets the type of curve generated by the Spline option of the PEDIT command 

SURFTYPE: Controls the type of surface-fitting to be performed by the Smooth option of the PEDIT 

command 

SURFU: Sets the surface density for PEDIT Smooth in the M direction 

SURFV: Sets the surface density for PEDIT Smooth in the N direction 

 Modify Multilines 

You can use the methods such as common editing commands, a multiline editing command and 

multiline styles to edit multilines or their elements. 

Add and Delete Multiline Vertices 

You can use MLEDIT to add or delete vertices for a multiline. As shown in the illustration. 

 

Edit Multiline Intersections 

You can control the way two multilines intersect using MLEDIT. The ways include cross and T shape 

that can be closed, open or merged. 

 

Edit Multiline Styles 

You can use MLSTYLE to add multiline style or set multilines from the existing multiline style, such 

as the number of elements, color, linetype, lineweight and the offset of each element. You can also 

edit the end caps and background fill. 

The element and multiline properties of the STANDARD multiline style are not allowed to modify. 
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The current multiline style already used in the drawing is not allowed to modify too. You should 

edit multiline style before using it. 

If you create a new style without saving the previous one, the properties of the previous one are 

lost. To maintain the properties, you have better to save each multiline style to an MLN file before 

creating a new one.  

 

Commands Reference 

MLEDIT: Edits multiple parallel lines 

MLSTYLE: Defines a style for multiple parallel lines 

System Variables Reference 

None 

8.4 Use Grips to Edit Objects 

Grips are small squares displayed at the strategic points on objects while you selecting objects. 

As you select each entity, it is highlighted with small squares called grips, which appear at strategic 

points on the entity. 

The locations of the grips depend on the type of object selected. For example, grips appear at the 

endpoints and midpoint of a line, at the quadrant points and center point of a circle, and at the 

endpoints, midpoint, and center of an arc. 

 

Examples of grip locations 

To use grips for editing, you select an object to display the grips, and then click a grip to make it 

active. The grip you select depends on the type of object you're modifying and the editing 

operation you're performing. For example, to move a line object, drag it by its midpoint grip. 

To stretch the line, drag one of the endpoint grips. You do not need to enter a command when 

using grips. 

 

Topics in this section: 

 Control Status and Displaying of Grips 

You can turn the use of grips on and off and control the size and color of grips under different 

status. 
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 Grip Edit Mode 

One type of edit mode called grip mode is to perform manipulations such as stretch, move, rotate, 

scale or mirror by dragging grips on entities. 

 Multi-Grips Edit Mode 

It's also enabled to manipulate grip edit mode using multiple grips. You can press SHIFT to select 

multiple grips. Once you have selected multiple entities (called hot multi-grip selection), the part of 

entities among grips will not change. 

 Control Status and Displaying of Grips 

You can turn the use of grips on and off and control the size and color of grips under different 

status. 

To change grip settings 

Choose Tools > Options from the main menu. 

In the Options dialog box, click the Selection tab. 

In the Grip Size, specify the size. 

In the Grips, click Enable grips. 

Set the Unselected grip color, Selected grip color and Hover grip color separately, to assign colors 

for grips under different status. 

Click OK. 

You can use grips to modify objects, such as move, stretch, scale and copy. With the Grips on, the 

location of grips depending on the type of objects are displayed as follows: 

 

 

When you perform quadrant grips on circles, the distance is measured from the center point, but 

not the selected grip. For example, in Stretch mode, you can select a quadrant grip to stretch a 

circle, and then specify a distance at the prompt of "New circle radius". The distance is measured 

from the center point, but not the selected quadrant. If you select the center point, the circle 

moves. 

When a 2D solid is not lie on the current UCS, the object is stretched on the plane that the object is 

created, but not on the plane of the current UCS. 

The system variable GRIPOBJLIMIT is used to control the number of grips displayed on the selected 

object. The value of GRIPOBJLIMIT is not available when you add an object to the current selection 

set. 
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Control Grips in Blocks 

The system variable GRIPBLOCK is used to control whether the inserted block displays a single grip 

or all of grips. 

 

 

Commands Reference 

OPTIONS: Customizes the ZWCAD+ settings 

System Variables Reference 

GRIPBLOCK: Controls the assignment of grips in blocks 

GRIPCOLOR: Controls the color of non-selected grips 

GRIPHOT: Determines the color of selected grips. The range of value is from 1 to 255 

GRIPHOVER: Determines the color of grips when cursor hovers on them. The valid range of value 

is 1 to 255  

GRIPOBJLIMIT: Suppresses the display of grips when the initial selection set includes more than 

the specified number of objects  

GRIPS: Controls the use of selection set grips for the Stretch, Move, Rotate, Scale, and Mirror Grip 

modes 

GRIPSIZE: Sets the size of the grip box in pixels 

GRIPTIPS: Controls the display of grip tips when the cursor hovers over grips on custom objects 

that support grip tips 

 Grip Edit Mode 

One type of edit mode called grip mode is to perform manipulations such as stretch, move, rotate, 

scale or mirror by dragging grips on entities. Stretch is the default grip edit mode, select the grips 
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to edit when you want to stretch the selected entity, the grip is displayed in selected grip color, and 

then right click to select from manipulations menu. 

If you press ENTER or SPACE key after selecting grips, all the grip modes display from which you can 

choose to perform one of the grip editing manipulation. 

Grip Stretch Mode 

Stretch mode is default mode for grip editing. Once you have selected entities, click the grips on 

entities to display command line prompt as follows: 

Specify stretch point or [Base point/Copy/Undo/eXit]: 

Under the prompt, you can specify new position on the drawing area where the grip is expected to 

be stretched. You should notice that when stretching grips on the selected grips such as single text 

point, insertion point of block reference, midpoint of line, center of circle and grips on point object, 

the whole entity will be moved without changing the size and shape of grips. The type of entities 

determines whether the grips are capable of being stretched. For example, to stretch a corner of a 

rectangle, select the corner grips, to stretch a line, select the endpoint grips. Not all of the objects 

are enabled grip stretching. 

Stretch Entities using Grip Stretch 

Select entities to stretch. 

Click on grips of the entity to highlight the selected grip and activate the grip mode as Stretch. 

Dynamic input box displayed on screen showing the following manipulations: 

Specify "B(Base point)" option to locate the grip. 

Specify "C(Copy)" option to create a copy of the entity being stretched. 

Specify "U(Undo)" option to abort last stretch. 

Specify "X(eXit)" option to exit stretch manipulation. 

Specify target location for stretching directly. 

Move the pointing device to specify target location, the selected grip on entities will be stretched 

based on itself (or the new base point). 

 

To stretch an object using grips, select the 

object (A), select a grip (B), and drag the 

grip to its new location (C). 

Result 
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Grip Move Mode 

With grip move mode, you can move selected entities by moving its grips. The entity with specified 

grips will be highlighted and moved according to the specified orientation and position. 

Objects of various types need to be moved through different grips. For example, to move a line, use 

the midpoint as grip, to move curve objects, like arc, circle or ellipse, select center point or grip. 

Not all the entities are enabled grip moving. 

If you press ENTER or SPACE key after selecting grips, all the grip modes are displayed, choose 

Move and then command line prompts as follows: 

Specify move point or [Base point/Copy/Undo/eXit]: 

Move one or more Entities 

Select entities to move. 

Click on grips of the entity to highlight the selected grip and activate the grip mode as Stretch. 

Press ENTER to iterate grip mode until Move appears in command line. Dynamic input box 

displayed on screen showing the following manipulations: 

Specify "B(Base point)" option to locate the grip. 

Specify "C(Copy)" option to create a copy of the entity being moved. 

Specify "U(Undo)" option to abort last moving. 

Specify "X(eXit)" option to exit move manipulation. 

Specify target location for grips directly. 

Move the pointing device to specify target location, the selected grip on objects will be moved 

towards the orientation and displacement along the connecting line of the selected grip and the 

target point (or create a copy of the entity after moving). 

 

Grip Rotate Mode 

With grip rotate mode, you can rotate selected entities around the base point, .or rotate by the 

angle specified for rotating either. 

If you press ENTER or SPACE key after selecting grips on entities, choose Rotate from the grip 

editing mode and then command line prompts as follows: 

Specify rotation angle or [Base point/Copy/Undo/Reference/eXit]: 

Rotate Entities Using Grips 

Select entities to rotate. 

Click on grip of the entity to highlight the selected grip and activate the grip mode as Stretch. 

Press ENTER to iterate grip mode until Rotate appears in command line. Dynamic input box 

displayed on screen showing the following manipulations: 

Specify "B(Base point)" option to select base point for rotating. 

Specify "C(Copy)" option to create a copy of the entity being rotated. 

Specify "U(Undo)" option to abort last rotating. 
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Specify "X(eXit)" option to exit Rotate manipulation. 

Specify "R(Reference)" option to assign reference angle for rotation. (Final rotation angle=reference 

angle subtract from input angle. For example: reference angle = 20, input angle= 80, final rotation 

angle = 80 - 20 = 60). 

Specify rotation angle for grips directly. 

Move the pointing device and specify rotation angle, the entities rotate centered by the selected 

grip (or create a copy of the entity after rotation). 

 

Grip Scale Mode 

With grip scale mode, you can scale selected entities relative to base point. Drag the entity 

outwards the base grip to enlarge its size, and drag inwards to decrease the size. You can also 

specify a scale factor to scale selected entities. 

Grips are selected depend on the type of entity. For example, to scale a circle, use the quadrant 

point as grip. 

If you press ENTER or SPACE key after selecting grips, all the grip modes are displayed, choose Scale 

and then command line prompts as follows: 

Specify scale factor or [Base point/Copy/Undo/Reference/eXit]: 

Scale Entities Using Grips 

Select entities to scale. 

Click on grips of the entity to highlight the selected grip and activate the default grip mode as 

Stretch. 

Press ENTER to iterate grip mode until Scale appears in command line. Dynamic input box displayed 

on screen showing the following manipulations: 

Specify "B(Base point)" option to relocate the base grip for scaling. 

Specify "C(Copy)" option to create a copy of the entity being scaled. 

Specify "U(Undo)" option to abort last scaling. 

Specify "X(eXit)" option to exit scale manipulation. 

Specify "R(Reference)"option to assign reference scale factor. (For example: input scale factor as 5, 

to scale the entity to five-times that of its original size). Then dynamic input box displays on the 

screen, in which you are prompt to enter new length (if input 3, the entity will be scaled at the 

factor 3/5). 

Specify scale factor for grips directly. 

Move the pointing device to specify target grips, the entity will be scaled based on the selected 

grips with the factor you specified (or create a copy of the entity after scaling). 
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To scale using grips, select the object (A), 

click a grip (B), and scale the object by 

dragging the grip to its new location (C). 

Result 

 

Grip Mirror Mode 

With grip mirror mode, you can create mirrored copies of selected entities along temporary mirror 

line. 

If you press ENTER or SPACE key after selecting grips, all the grip modes are displayed, choose 

Mirror and then command line prompts as follows: 

Specify second point or [Base point/Copy/Undo/eXit]: 

Create Mirrored Copies Using Grips 

Select entities to mirror. 

Click on grips to highlight the selected grip and activate the default grip mode as Stretch. 

Press ENTER to iterate grip mode until Mirror appears in command line. Dynamic input box 

displayed on screen showing the following manipulations: 

Specify "B(Base point)" option to relocate the base grip. 

Specify "C(Copy)" option to create a copy of the entity being mirrored. 

Specify "U(Undo)" option to abort last mirroring. 

Specify "X(eXit)" option to exit mirror manipulation. 

Move the pointing device to specify second mirror point, the entity will be mirrored along the line 

connecting the selected grip on objects and the second mirror point (or create a copy of the entity 

after mirroring).  

 

Commands Reference 

OPTIONS: Customizes the ZWCAD+ settings 

System Variables Reference 
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GRIPBLOCK: Controls the assignment of grips in blocks 

GRIPCOLOR: Controls the color of non-selected grips 

GRIPHOT: Determines the color of selected grips. The range of value is from 1 to 255 

GRIPHOVER: Determines the color of grips when cursor hovers on them. The valid range of value 

is 1 to 255  

GRIPOBJLIMIT: Suppresses the display of grips when the initial selection set includes more than 

the specified number of objects  

GRIPS: Controls the use of selection set grips for the Stretch, Move, Rotate, Scale, and Mirror Grip 

modes 

GRIPSIZE: Sets the size of the grip box in pixels 

GRIPTIPS: Controls the display of grip tips when the cursor hovers over grips on custom objects 

that support grip tips 

 Multi-Grips Edit Mode 

It's also enabled to manipulate grip edit mode using multiple grips. You can press SHIFT to select 

multiple grips. Once you have selected multiple entities (called hot multi-grip selection), the part of 

entities among grips will not change. 

Using Multi-Grips edit mode is sorted into the following two cases: 

To move, rotate, scale or mirror entities, using multiple grips on them equals to use the last 

selected grip as base point (base grip or new selected base point). 

To stretch entities, multi-grips are selected depend on the type of entities, when you selected 

single text point, insertion point of block reference, midpoint of line, center of circle and grips on 

point object as hot grips, the entities will be moved rather than stretched. 

Multi-Grips Stretch Mode 

Select multiple grips of different entities to stretch separately depend on the entity types. 

Stretch Lines, Polylines and Dimensions Using Multiple Grips 

Select line, polyline and dimension entities to stretch. 

Press SHIFT while selecting grips on entities, the selected grips will be highlighted. 

Release SHIFT and click on one of the selected grips to use it as base grip and activate the default 

grip mode as Stretch. Dynamic input box displayed on screen showing the following manipulations: 

Specify "B(Base point)" option to locate the grip for stretching. 

Specify "C(Copy)" option to create a copy of the entity being stretched. 

Specify "U(Undo)" option to abort last stretch. 

Specify "X(eXit)" option to exit stretch manipulation. 

Specify target location for stretching directly. 
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Move the pointing device to specify target grips, the selected grips on entities will be stretched or 

moved towards the direction pointing from the base grip to the target location (single text point, 

insertion point of block reference, midpoint of line, center of circle and grips on point object). 

 

Multi-Grips Move Mode 

Move entities with multiple grips mode, use the last grip (base grip or reselected base point) as 

base point. 

Move Lines, Polylines and Dimensions Using Multiple Grips 

Select line, polyline and dimension entities to move. 

Press SHIFT while selecting grips on entities, the selected grips will be highlighted. 

Release SHIFT and click on one of the selected grips to use it as base grip. 

Press ENTER to activate the default grip mode as Stretch. Iterate grip mode until Move appears in 

command line. Dynamic input box displayed on screen showing the following manipulations: 

Specify "B(Base point)" option to locate the base point for moving. 

Specify "C(Copy)" option to create a copy of the entity being moved. 

Specify "U(Undo)" option to abort last moving. 

Specify "X(eXit)" option to exit move manipulation. 

Specify target location for moving directly. 

Move the pointing device to specify target location, the selected grips on entities will be moved at 

a specified displacement towards the direction pointing from the base grip to the target location. 

 

Multi-Grips Rotate Mode 

Rotate entities with multiple grips mode, use the last grip (base grip or reselected base point) as 

base point. 

Rotate Lines, Polylines and Dimensions Using Multiple Grips 

Select line, polyline and dimension entities to rotate. 

Press SHIFT while selecting grips on entities, the selected grips will be highlighted. 

Release SHIFT and click on one of the selected grips to use it as base grip. 

Press ENTER to activate the default grip mode as Stretch. Iterate grip mode until Rotate appears in 

command line. Dynamic input box displayed on screen showing the following manipulations: 

Specify "B(Base point)" option to locate the grip for rotating. 

Specify "C(Copy)" option to create a copy of the entity being rotated. 

Specify "U(Undo)" option to abort last rotation. 

Specify "X(eXit)" option to exit rotate manipulation. 

Specify "R(Reference)" option to assign reference angle for rotation. (Final rotation angle=reference 

angle subtract from input angle. For example: reference angle = 20, input angle= 80, final rotation 

angle = 80 - 20 = 60). 

Specify rotation angle for grips directly. 

Move the pointing device to specify rotation angle, the entities will be rotated based on the 

selected grip (or create a copy of the entity after rotation). 
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Multi-Grips Scale Mode 

Scale entities with multiple grips mode, use the last grip (base grip or reselected base point) as 

base point. 

Scale Lines, Polylines and Dimensions Using Multiple Grips 

Select line, polyline and dimension entities to scale. 

Press SHIFT while selecting grips on entities, the selected grips will be highlighted. 

Release SHIFT and click on one of the selected grips to use it as base grip. 

Press ENTER to activate the default grip mode as Stretch. Iterate grip mode until Scale appears in 

command line. Dynamic input box displayed on screen showing the following manipulations: 

Specify "B(Base point)" option to locate the grip for scaling. 

Specify "C(Copy)" option to create a copy of the entity being scaled. 

Specify "U(Undo)" option to abort last scaling. 

Specify "X(eXit)" option to exit scale manipulation. 

Specify "R(Reference)"option to assign reference scale factor. (For example: input scale factor as 5, 

to scale the entity to 5 times of its original size). Then dynamic input box displays on the screen, in 

which you are prompt to enter new length (if input 3, the entity will be scaled with the factor 3/5). 

Specify scale factor for grips directly. 

Move the pointing device to specify target grips, the entity will be scaled based on the selected 

grips with the factor you specified (or create a copy of the entity after scaling). 

 

Multi-Grips Mirror Mode 

Mirror entities and create their copies with multiple grips mode, use the last grip (base grip or 

reselected base point) as base point. 

Mirror Lines, Polylines and Dimensions Using Multiple Grips 

Select line, polyline and dimension entities to mirror. 

Press SHIFT while selecting grips on entities, the selected grips will be highlighted. 

Release SHIFT and click on one of the selected grips to use it as base grip. 

Press ENTER to activate the default grip mode as Stretch. Iterate grip mode until Mirror appears in 

command line. Dynamic input box displayed on screen showing the following manipulations: 

Specify "B(Base point)" option to relocate the base grip. 

Specify "C(Copy)" option to create a copy of the entity being mirrored. 

Specify "U(Undo)" option to abort last mirroring. 

Specify "X(eXit)" option to exit mirror manipulation. 

Move the pointing device to specify second mirror point, the entity will be mirrored along the line 

connecting the selected grip on objects and the second mirror point (or create a copy of the entity 

after mirroring).  

 

Commands Reference 

OPTIONS: Customizes the ZWCAD+ settings 
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System Variables Reference 

GRIPBLOCK: Controls the assignment of grips in blocks 

GRIPCOLOR: Controls the color of non-selected grips 

GRIPHOT: Determines the color of selected grips. The range of value is from 1 to 255 

GRIPHOVER: Determines the color of grips when cursor hovers on them. The valid range of value 

is 1 to 255  

GRIPOBJLIMIT: Suppresses the display of grips when the initial selection set includes more than 

the specified number of objects  

GRIPS: Controls the use of selection set grips for the Stretch, Move, Rotate, Scale, and Mirror Grip 

modes 

GRIPSIZE: Sets the size of the grip box in pixels 

GRIPTIPS: Controls the display of grip tips when the cursor hovers over grips on custom objects 

that support grip tips 

8.5 Modify the Properties of Objects 

Overview of Object Properties 

You can display information about the selected entities. The information varies, depending on the 

type of entities you select. All of the listings display the following information: 

Entity type. 

Layer. 

Color. 

Linetype. 

The location of the entity (its xyz-coordinates relative to the current user coordinate system [UCS]). 

The size of the entity (the information varies, depending on the entity type). 

The layer, color, linetype are the common properties that most of objects possess. There are a few 

properties that some individual objects possess, such as radius and area of a circle, length and 

angle of a line. 

Most of properties can be applied to an object by layer or applied to an object directly. 

If value BYLAYER is set to the property value, the object has the same value as the layer on which it 

is drawn. For example, if you set Yellow to the layer 0 and assign value BYLAYER to the lines that 

were drawn on the layer 0, its color is yellow too. 

You can also specify a new value to overwrite the layer's value. For example, yellow is assigned to 

the layer 0 and the value of lines is set to blue, the color of lines is blue. 

You can use the following methods to display or modify the object properties: 
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View or change properties in the Properties palette. 

View or modify layer controls on the Layer Properties Manager dialog box, might change Color, 

Linetype, Lineweight at the Properties toolbar as well. 

Use command LIST to view the information on the text window. 

Use command ID to display the coordinate of the specified point 

Properties palette  

The Properties palette shows all properties of the specified object. You can change them in this 

palette. 

When selecting multiple objects, the Properties palette shows the command properties of the 

selected objects. 

If none of the object is selected, the Properties palette displays the general properties of the 

current layer, View properties as well as the UCS information. 

By default, double-click an object opens Properties palette if the Properties palette is hidden. This 

operation is not available when the objects are block, hatch pattern, text, multiline, external 

reference or gradient fill. 

Change the Properties of Objects 

You can change the layer, thickness, linetype, color, and linetype scale of one or more entities. 

Depending on the type of entity or entities you select, you can also change other properties, such 

as the start point and endpoint of lines, the center point and radius of circles, and the vertices of 

polylines. 

You can modify all the properties of all entities simultaneously. For example, using the select 

command and the Select by Properties option, select all blue entities and change their color to 

green. 

In the Properties dialog box, changes that you make in the Layer, Color, Thickness, Lineweight, 

Linetype and Linetype Scale affect all selected entities.  

To modify properties of objects 

Choose Tools > Properties from the main menu. 

Select the objects. 

In the Properties palette, change the desired properties. 

Standard toolbar:  

Command line PROPERTIES 

NOTE The Properties palette settings that display when no objects are selected determine the 

properties of new objects when you draw them. 

 

Copy Properties Between Objects 

Using Match Properties, you can copy some or all properties of one object to other objects. 

The types of properties that can be copied include, but are not limited to: 
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color 

layer 

linetype 

linetype scale 

lineweight 

3D thickness 

By default, all applicant properties are copied along with the objects. You can also specify the 

desired properties to copy at the Property settings dialog box by typing MATCHPROP. 

 

 

Commands Reference 

ID: Displays the coordinate of a location 

LIST: Displays database information for selected objects 

MATCHPROP: Applies the properties of a selected object to other objects 

PROPERTIES: Controls properties of existing objects 

System Variables Reference 

LUPREC: Sets the number of decimal places displayed for all read-only linear units, and for all 

editable linear units whose precision is less than or equal to the current LUPREC value 

PICKFIRST: Controls whether you select objects before (noun-verb selection) or after you issue a 

command 

8.6 Modify 3D Solids 

You can edit three-dimensional solids in several unique ways, including: chamfer, fillet, section, and 

slice. You can also modify individual faces and edges of solids, as well as imprint, separate, shell, 

and check solids. You can edit three-dimensional ACIS solids, including: boxes, cones, cylinders, 

dishes, domes, spheres, torus, and wedges. 

Topics in this section: 
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 Fillet and Chamfer 

Add rounds and fillets to selected edges of 3D solids. 

 Section and Slice 

Create a cross section through a 3D solid. The result can be a two-dimensional object representing 

the shape of the section, or it can be a 3D solid chopped in half.  

 Modify Faces of 3D Solids 

You can edit a 3D solid object by performing operations on selected faces of the object.  

 Modify Edges of 3D Solids 

Change the color of selected edges or copy selected edges as separate objects. 

 Imprint, Separate, Shell, Check and Clean 3D Solids 

You can change the appearance of 3D objects, separate or create shells at the specified thickness 

for 3D objects by imprinting, separating or shelling. You can remove redundant edges, points, 

imprinted and unused objects through cleaning them. You can also check to see the selected 

objects are the available ShapeManager solids. 

 Fillet and Chamfer 

You can chamfer or fillet a three dimensional solid much like you chamfer or fillet a twodimensional 

object. 

Create fillers 

You can create fillets for the specified edges of 3D objects. At first, you need to specify the fillet 

radius, and then choose one method to create fillets. 

If you choose Edge, the system creates fillets for the two selected edges. If you select three or more 

edges which were around a vertex, the system creates a spheral vertex if the three fillets have the 

same radius. 

After specifying an arc radius, the system creates a sequence of fillets for the tangential sequence 

of edges, when you use Loop option and select an edge. 

In 3D space, as the selected objects are coplanar and the extrusion direction is not parallel with the 

Z axis, you can create a fillet. If the objects are on the same plane, there are two kind of extrusion 

direction shown as follows: 

If the objects are on the same plane with the same extrusion direction normal to that plane, the 

fillet arc is on that plane and has the same extrusion direction. 

For objects on the same plane with opposite or different extrusion directions, the fillet arc is 
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located on that object plane with an extrusion direction normal to the object plane and inclined 

towards the positive Z direction of the current UCS. For example, we assume two arcs A and B are 

on the same plane in 3D space but have opposite extrusion directions (0,0.65,0.86) and (0,–0.65,

–0.86) relative to the current UCS. The fillet arc adopts the extrusion direction (0,0.65,0.86). 

To fillet a solid 

Choose Modify > Fillet from the main menu. 

Select the edge of the solid to fillet. 

Specify the fillet radius. 

Select additional edges to fillet, and press Enter to fillet. 

Modify toolbar:  

Command line FILLET 

 

Create chamfer 

Using CHAMFER creates chamfers for the adjacent planes. While creating fillets, the system 

prompts you to specify distance for the first and second object. The first object is the base plane 

and the second one is other plane. 

After specifying the chamfer distance, you have to select edges to fillet. You can select all edges of 

the base plane through selecting an edge using Loop option. Get more details from the CHAMFER 

command. 

To chamfer a solid 

Choose Modify > Chamfer from the main menu. 

Select the edge of the base surface to chamfer.  

Do one of the following: 

To select a different surface, type N (Next) and press Enter. 

To use the current surface, press Enter. 

Specify the distance on first entity. 

Specify the distance on second entity. 

Do one of the following: 

Specify the edges to chamfer. 

To select all edges around the base surface, type L (Loop) and press Enter. 

Modify toolbar:  

Command line CHAMFER 

 

Commands Reference 

CHAMFER: Bevels the edges of objects 

FILLET: Rounds and fillets the edges of objects 



 

 294 

System Variables Reference 

CHAMFERA: Sets the first chamfer distance 

CHAMFERB: Sets the second chamfer distance 

CHAMFERC: Sets the chamfer length 

CHAMFERD: Sets the chamfer angle 

CHAMMODE: Sets the input method 

FILLETRAD: Stores the current fillet radius 

 Section and Slice 

You can section or slice a three dimensional solid. 

Section 

You can create a region using the intersection of solid objects and a plane with the SECTION 

command. After selecting objects, the system creates a region on the current layer and inserts 

them into the location of the section. 

Methods to define a section: 

Specifies three points to define a sectioning plane. 

Align the sectioning plane with a circle, ellipse, arc, 2D spline or 2D polyline object. 

Specifies a point lied on the sectioning plane and a point lied on the normal of the defined section. 

Align the sectioning plane with the plane of the current view. 

Specifies a point to determine the location of the sectioning plane on the XY, YZ or ZX plane, and 

aligns the sectioning plane with the XY, YZ, or ZX plane of the current UCS. 

To section an object 

Choose Draw > Solids > Section from the main menu. 

Select the objects to cross section. 

Do one of the following: 

Specify three points to define the cross section plane. (The first point defines the origin, while the 

second point defines the X axis and the third point defines the Y axis.) 

Type O and press Enter to select an object that defines the cross sectional plane. 

Specify an axis by typing Z and pressing Enter. 

Solids toolbar:  

Command line SECTION 

 

Slice 
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You can use SLICE command to slice a solid with a plane and retain the specify part or the entire 

solid. The sliced solids retain the layer and color's properties of the original ones. To slice a solid, 

you have to define a cutting plane, then select which part to retain. 

Methods to define a cutting plane: 

Specifies three points to define a cutting plane. 

Align the cutting plane with a circle, ellipse, arc, 2D spline or 2D polyline object. 

Specifies a point lied on the cutting plane and a point lied on the normal of the defined section. 

Align the cutting plane with the plane of the current view. 

Specifies a point to determine the location of the cutting plane on the XY, YZ or ZX plane, and aligns 

the cutting plane with the XY, YZ, or ZX plane of the current UCS. 

To slice a solid 

Choose Draw > Solids > Slice from the main menu. 

Select the objects to slice. 

Do one of the following: 

Specify three points to define the cross section plane. (The first point defines the origin, while the 

second point defines the x axis and the third point defines the y axis.) 

Type O and press Enter to select an object that defines the cross sectional plane. 

Specify an axis by typing Z and pressing Enter. 

Specify which side to retain, or type B to retain both sides. 

Solids toolbar:  

Command line SLICE 

 

Commands Reference 

SECTION: Uses the intersection of a plane and solids to create a region 

SLICE: Slices a set of solids with a plane 

System Variables Reference 

None 

 Modify Faces of 3D Solids 

You can modify faces of 3D solids through extruding, moving, rotating, offsetting, tapering, delete, 

copying or changing the color of the selected faces.  

Extrude Faces 

You can extrude one or more faces of 3D solids at the specified height and path. 

Negative value extrudes faces along to the positive normal; positive value extrudes faces along to 

the negative normal. After specifying the height, the system prompts you to specify the angle of 

taper for extrusion. If you specify the angular value is greater than 0, the plane tapers in from the 
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base object; if the value is negative, the face tapers out. By default, the value is of 0, which 

extrudes the face perpendicular. The extrusion stops when the tapered face shrinks into a point. 

If you select Path option, the selected face extrudes at the specified line or curve objects. The 

objects that can be specified as an extrusion path contains line, circle, arc, ellipse, ellipse arc, 

polyline and spline. These objects should not be coplanar with the object, nor should have areas of 

high curvature. Generally, one of endpoints of the selected extrusion path should lie on the center 

of the face to extrude, if not, the system will do it. 

To extrude a solid face 

Choose Modify > Solids Editing > Extrude Faces from the main menu. 

Select the face(s) to extrude, and press Enter. 

Do one of the following: 

Specify the height of extrusion. 

Type P and press Enter to select a path for extrusion. 

If you specified a height, specify a taper angle. 

Solids Editing toolbar:  

 

Select the entity to extrude, and then 

specify the face(s) to extrude (A), and 

the height of extrusion or path 

The resulting entity with the face extruded to 

position (B) 

 

Move Faces 

Moves face of a 3D solid at the specified distance. This command only changes the location of the 

face, leaving the direction unchanged. Using object snap help you specify the location exactly. 

To move a solid face 

Choose Modify > Solids Editing > Move Faces from the main menu. 

Select the face(s) to move, and press Enter. 

Specify a base point. 

Specify an end point. 
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Solids Editing toolbar:  

 

Specify the face(s) to move(A), the 

base point (B), and the end point 

(C) 

The resulting object with the face 

moved to the new position 

 

Offset Faces 

You can scale faces of 3D solids with the specified offset. Positive value enlarges objects; negative 

value shrinks objects. For example, you can enlarge or shrinks an aperture using offset. In addition 

to entering distance, you can also drag the cursor to determine the distance. 

To offset a solid face 

Choose Modify > Solids Editing > Offset Faces from the main menu. 

Select the face(s) to offset, and press Enter. 

Specify an offset distance. 

Solids Editing toolbar:  

 

Specify the face(s) to offset (A) and the The resulting object with the face offset 
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distance to offset to position (B) 

 

Delete Faces 

You can use SOLIDEDIT to delete the selected faces or fillets of 3D solids. 

To delete a solid face 

Choose Modify > Solids Editing > Delete Faces from the main menu. 

Select the face(s) to delete, and press Enter. 

Solids Editing toolbar:  

 

Specify the face(s) to delete (A) The resulting entity with the face deleted 

 

Rotate Faces 

You can use SOLIDEDIT to rotate the selected face of the specified 3D solid around a rotation axis. 

You can specify two points on the drawing or select an existing line as the rotation axis. X, Y or Z 

axis as well as the Z direction of the current view could be used as the rotation axis too. 

The system rotates faces at the specified angle on the current UCS, which the angle direction is 

stored in the system variable ANGDIR. 

To rotate a solid face 

Choose Modify > Solids Editing > Rotate Faces from the main menu. 

Select the face(s) to rotate, and press Enter. 

Specify a base point. 

Specify another point on the rotation axis. 

Specify the rotation angle. 

Solids Editing toolbar:  
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Specify the face(s) to rotate (A), the base point 

(B),a second point on tapered the rotation axis (C), 

and a rotation angle. 

The resulting object with the face to 

position (D) 

 

Taper Faces 

You can taper the selected face at the specified angle around a base line. The rotation direction 

depends on the sequence of specifying the base point. 

Positive angle tapers faces in and negative angle tapers faces out. The angle should not be too large 

in order to the tapered face shrinks into a point before reaching the specified height. 

To taper a solid face 

Choose Modify > Solids Editing > Taper Faces from the main menu. 

Select the face(s) to taper, and press Enter. 

Specify a base point. 

Specify another point along the axis. 

Specify a taper angle. 

Solids Editing toolbar:  

 

Specify the face(s) to taper (A), a base The resulting entity with the face 
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point(B), a second point along the taper 

axis(C), and a taper angle 

tapered to position(D) 

 

Color Faces 

You can assign color to the faces of 3D solids. The specified color of faces overwrites the color of 

the layer on which the faces drawn. 

To color a face 

Choose Modify > Solids Editing > Color Faces from the main menu. 

Select the face(s) to color, and press Enter. 

Specify a color. 

Solids Editing toolbar:  

 

Specify the face(s) to color (A) 
The resulting entity with the face 

colored 

 

Copy Faces 

You can copy faces of 3D solids to the specified location. The selected faces are seen as an 

independent region or solid object. After creating copies, you can perform one of the following 

methods: 

Base point: You must to specify two points on the drawing. The first one is a base point; the other 

one determines the location of the copy. 

Vector: You need to specify a point to determine the location of the copy. The base point is the 

original point (0,0,0). 

To copy a solid face 

Choose Modify > Solids Editing > Copy Faces from the main menu. 

Select the face(s) to copy, and press Enter. 

Specify a base point. 

Specify an end point. 
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Solids Editing toolbar:  

 

Specify the face(s) to copy (A), the 

base point (B), and the end 

point(C) 

The resulting entity with the face copied 

 

Commands Reference 

SOLIDEDIT: Edits faces and edges of 3D solid objects 

EXTRUDE: Creates unique solid primitives by extruding existing two-dimensional objects 

System Variables Reference 

ANGDIR: Sets the direction of positive angles 

 Modify Edges of 3D Solids 

You can copy edges of 3D solids to become an independent object or change its color. 

Copy Edges 

Copying edges of 3D solids is similar with copying faces of 3D solids. All edges are copied as the 

independent lines, arcs, ellipses or spline objects. However, the properties keep the same as the 

current layer. After you specifying the location of placing the copy, you can perform one of the 

following methods: 

Base point: You must to specify two points on the drawing. The first one is a base point; the other 

one determines the location of the copy. 

Vector: You need to specify a point to determine the location of the copy. The base point is the 

original point (0,0,0). 

To copy an edge 
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Choose Modify > Solids Editing > Copy Edges from the main menu. 

Select the edge(s) to copy, and press Enter. 

Specify a base point. 

Specify an end point. 

Solids Editing toolbar:  

 

Specify the edge(s) to copy (A), the 

base point (B), and the end point(C) 

The resulting entity with the edge copied 

 

Color Edges 

You can assign color to the edges of 3D solids. The specified color of edges overwrites the color of 

the layer on which the edges drawn. 

To color an edge 

Choose Modify > Solids Editing > Color Edges from the main menu. 

Select the edge(s) to color, and press Enter. 

Specify a color. 

Solids Editing toolbar:  

 

Commands Reference 

SOLIDEDIT: Edits faces and edges of 3D solid objects 

System Variables Reference 

None 

 Imprint, Separate, Shell, Check and Clean 3D Solids  

You can change the appearance of 3D objects, separate or create shells at the specified thickness 
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for 3D objects by imprinting, separating or shelling. You can remove redundant edges, points, 

imprinted and unused objects through cleaning them. You can also check to see the selected 

objects are the available 3D solids. 

Imprint 

You can create a new face of a solid face by executing imprinting operation. The following objects 

can be imprinted: arc, circle, line, 2D/3D polyline, ellipse, spline, region, 3D solid. To ensure the 

imprinting successfully, the objects to be imprinted must be intersected with one or more faces. For 

example, when a rectangular intersects with a 3D solid, you can imprint the intersecting curve. 

Then determine whether the original objects are removed or not. 

To imprint a solid objects 

Choose Modify > Solids Editing > Imprint from the main menu. 

Select the solid object you want to imprint. 

Select the object you want to imprint on the solid. 

Solids Editing toolbar:  

 

Separate 

You can separate the selected composed 3D solid into the several 3D solids with the unconnected 

objects. The composed 3D solid cannot share the common areas or cubage. The separated solids 

still lies on the original layer and keeps the color unchanged. All nested objects are separated into 

the simplest objects. 

To separate solids 

Choose Modify > Solids Editing > Separate from the main menu. 

Select the solid you want to separate. 

Solids Editing toolbar:  

 

Shell 

You can create a shell at the specified thickness. One 3D solid only create a shell, and the system 

have to move away the existing face before creating a new face. The tangent faces are seen as a 

face while moving. 

To shell a solid 

Choose Modify > Solids Editing > Shell from the main menu. 

Select the object you want to shell. 

Remove any faces you don't want to include. 

Specify an offset distance. 

Solids Editing toolbar:  
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Select the entity, and then select faces to 

remove (A) and (B), then specify an offset 

distance 

The resulting shelled entity 

 

Check 

You can check whether a selected object is a valid three dimensional ACIS solid. If it is a valid 3D 

solid, you can modify the object using the 3D solid editing commands; if not, you cannot edit the 

object using these commands. 

To check a solid 

Choose Modify > Solids Editing > Check from the main menu. 

Select the objects to check. 

Solids Editing toolbar:  

 

Clean 

You can remove redundant edges or vertices from solids when they are not needed. 

To clean a solid 

Choose Modify > Solids Editing > Clean from the main menu. 

Select the object you want to clean. 

Solids Editing toolbar:  

 

Commands Reference 

SOLIDEDIT: Edits faces and edges of 3D solid objects 

System Variables Reference 
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None 

8.7 Use Windows Cut, Copy, and Paste 

You can use the Clipboard to cut or copy objects from one drawing to another. Cutting removes the 

selected objects from a drawing and stores them on the Clipboard. Copying duplicates the selected 

objects from a drawing and places them on the Clipboard. 

Cut Objects 

You can use Window commands such as Cut, Copy and Paste to move or copy objects. With using 

Cut command, the objects on the clipboard can be pasted to a document or drawing as an OLE 

object. See more from the PASTECLIP and PASTESPEC command. The links is not available after 

executing Cut command. 

To cut objects to the Clipboard 

Select the objects you want to cut. 

Choose Edit > Cut from the main menu. 

Standard toolbar:  

Command line CUTCLIP 

 

Copy Objects 

You can copy the objects on the clipboard into the document created by other application. The 

copied objects can keep the height resolution as they are copied with the vector format. These 

objects store on the clipboard with the WMF (Windows Metafile Format) format. The copies keep 

unchanged at the other application even if the original drawing has changed. 

To copy objects to the Clipboard 

Select the objects you want to copy. 

Choose Edit > Copy from the main menu. 

Standard toolbar:  

Command line COPYCLIP 

 

Anything that you can copy to the Clipboard can be pasted into a drawing. The format in which the 

program adds the Clipboard contents to the drawing depends on the type of information in the 

Clipboard. For example, if you copy ZWCAD+ drawing entities to the Clipboard, the program pastes 

them into the drawing as ZWCAD+ entities. If you copy items to the Clipboard from other programs, 

they are pasted into the current drawing as embedded ActiveX objects. 

Paste Objects 

The system used all available formats to store information when you copy objects into the 

clipboard. The format that stores the most information was used when pasting the objects on the 

clipboard into the current drawing. 
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To paste objects from the Clipboard 

Choose Edit > Paste from the main menu. 

Standard toolbar:  

Command line PASTECLIP 

 

To change format to paste, you can select the desired format from the Edit menu. 

The WMF format contains the screen vector information, which can scale or plot the pasted objects 

without decreasing resolution. It can be applied to the application that supports WMF format. 

The color of objects keeps unchanged when pasting. However, you can use the system variable 

WMFBKGND and WMFFORGND to control whether the background or foreground is transparent or 

not, where the pasted objects lie on. 

When the objects to be pasted contain links or nest other objects, you can use PASTESPEC 

command to insert them from the clipboard into the ZWCAD+ drawing. When selecting ZWCAD+ 

Block, the objects are processed as a block. And you have to explore them before editing. 

Converting WMF format into ZWCAD+ Drawing format may lead to the scale factor changed. To 

avoid this situation, you can convert the selected objects to a block and then insert it into the 

ZWCAD+ drawing using INSERT. 

 

Commands Reference 

COPYBASE: Copies objects with a specified base point 

COPYCLIP: Copies objects to the Clipboard 

CUTCLIP: Copies objects to the Clipboard and removes the objects from the drawing 

PASTEBLOCK: Pastes copied objects as a block 

PASTECLIP: Inserts data from the Clipboard 

PASTEORIG: Pastes a copied object in a new drawing using the coordinates from the original 

drawing 

PASTESPEC: Inserts data from the Clipboard and controls the format of the data 

WMFIN: Imports a Windows metafile 

WMFOPTS: Sets options for WMFIN 

WMFOUT: Saves objects to a Windows metafile 
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System Variables Reference 

OLEHIDE: Controls the display of OLE objects 

WMFBKGND: Controls the background display when objects are inserted in Windows metafile 

(WMF) format 

WMFFOREGND: Controls the foreground color when objects are inserted in Windows metafile 

(WMF) format 

8.8 Correct Mistakes 

Various methods can be used to cancel errors until the latest correct operation if perform error 

manipulations. 

Undo a Single Action 

You can reverse to the last operation by pressing Undo button on the Standard toolbar or entering 

U on the command line. Some commands contain the Undo option, so you can enter u to reverse 

to the last operation without exiting the command. For example, when creating a line or polyline, 

you can enter U to undo the latest drawn line segment. 

Undo Several Actions at Once 

UNDO command helps aborting multiple operations at a time. 

When using UNDO command, system groups a number of operations assigned within BEgin and 

End so that you can cancel all the steps as a group object at a time. Use Mark and Back to enable 

users to cancel all the later operations since the marked step. If you use Back or Number of 

operations to undo option, the drawing will be redrawn if necessary. This may happen to the end of 

UNDO command, and the frequency of redrawing can be different based on the option you select, 

for example enter UNDO 3 to redraw once, while enter U command three times to redraw three 

times. 

Reverse the Effect of Undo 

You can use REDO to reverse the effects of previous UNDO or U command. This command is 

equivalent with the REDO button on the Standard toolbar. 

Undo or Redo Actions Using Undo or Redo button 

The Undo or Redo button on Standard toolbar are displayed in gray if there isn't any operations to 

undo or redo, at this moment this function is unavailable.  

The Undo button is available as soon as you have operated a certain commands, click left part of 

this button to undo last manipulation performed previously. There is a pull-down list beside the 

undo button, click here to pop-up a list in which all of the possible operations are displayed, 
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containing up to 6 commands within one list page, if more than 6 operations have been 

manipulated, you can drag the scroll bar on the right side of the list page to browse the commands. 

The Redo button is available once you have manipulated undo. Like performing Undo operation, 

click the Redo button to perform the last Undo operation, while click the pull-down arrow to 

pop-up a list in which all of the manipulations available to perform Redo are displayed. 

Move the mouse to select manipulations from the pull-down list of Undo and Redo button, 

highlight the items on which the mouse stays to illustrate how many items are selected among the 

manipulations from the top of the list page, and display a message at the bottom of the list to 

explain the number of items being selected. And then click the mouse or press ENTER directly to 

perform Undo or Redo command. Move the mouse to the top or button of the pull-down list box to 

enable it scrolling by itself, additionally you can press the direction key to select commands 

upwards or downwards.  

Once you select BEgin option when performing UNDO command, the manipulations displayed in 

the pull-down list beside the Undo button will be unavailable, at this time you can only undo the 

subsequent manipulations unless you perform the UNDO command again and select the End 

option.  

Erase Objects 

You can also use OOPS command to restore the deleted objects except for the objects deleted by 

PRUGE command. You can use OOPS to remove the selected block objects after performing BLOCK 

or WBLOCK. 

Cancel a Command 

You can click ESC to exit during performing command. 

 

Commands Reference 

ERASE: Removes objects from a drawing  

OOPS: Restores erased objects 

REDO: Reverses the effects of previous UNDO or U commands  

MREDO: Reverses the effects of several previous UNDO or U commands 

U: Reverses the most recent operation 

UNDO: Reverses the effect of commands 

System Variables Reference 
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UNDOCTL: Stores a bitcode indicating the state of the Auto and Control options of the UNDO 

command 
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9 Notes and Labels 

 

Topics in this section: 

Create Text 

Create text, multiline text (mtext) and text that includes one or more leader lines. 

Change Text 

Change text content, formatting, and properties such as scale and justification. 

Work with Text Styles 

When you enter text into your drawing, the current text style determines the text font, size, angle, 

orientation, and other text characteristics.  

Check Spelling 

You can use the SPELL command to check the spelling of single-line text, multiline text, paragraph 

text, attributes, attribute definitions, and dimension text. 

Smart Voice 

Smart Voice provides designers a more convenient interactive way for drawings review. Users can 

use it to create, play and delete voice comments in the drawings. 

9.1 Create Text 

Create text, multiline text (mtext) and text that includes one or more leader lines. 

Topics in this section: 

Single-Line Text 

You can use single-line text to create one or more lines of text, where each text line is an 

independent object that you can relocate, reformat, or modify. 

Multiline Text 

A multiline text (mtext) object includes one or more paragraphs of text that can be manipulated as 

a single object. 

Leaders 

Create text that includes one or more leader lines. 

Multileader 

A note created by multileader can point to more than one part of the drawing. 

 Single-Line Text 

You can use TEXT command to create a single or multiline text. Each line text is an independent 
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object which can be modified. 

Before typing text, you can specify the text style and the way to align at the prompt of creating text. 

The text style is applied to both of a single and multiline text objects. The justification way 

determined which part of text justify with an insert point. 

Characters created by MTEXT can be applied with independent text styles, but the single line text 

cannot do that. 

Press ENTER if you have typed some characters, and then the command line prompts to input 

characters for the next row of text. While creating single line text, you are also enabled to extend 

or compress certain single line text object in specified space to meet with your need by means of 

selecting Align or Fit option from the TEXT command line prompt. 

To create text 

Choose Draw > Text > Single Line Text from the main menu. 

Specify the start point for the text. 

Specify the height of the text. 

Specify the text rotation angle. 

Type the text, and then press Enter at the end of each new line. 

To complete the command, press Enter again. 

Text toolbar:  

Command line TEXT 

TIP If you've already created text and want new text to appear immediately 

below the previous text, Choose Draw > Text > Single Line Text. When prompted 

for start point, press Enter. The new text will keep the same height and 

rotation angle as the previous text. 

 

Align Single-Line Text 

When you create text, you can set the text alignment before you specify the start point. 

You set the alignment by choosing Justify in the command line prompt. By default, text is left 

justified. 
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You can also align text so that it fits or aligns between two points. The Align option creates text that 

scales up or down while maintaining a constant height/width ratio; the Fit option expands or 

compresses the text to fit between the two points. 

 

Text aligned between two points 

maintains a constant height/width 

ratio 

Text fit between two points expands or 

compresses to fit 

To specify the line text alignment 

Choose Draw > Text > Single Line Text from the main menu. 

On the command line, type J (Justify) and press ENTER. 

Type an alignment option. For example, enter BR to align text at its bottom-right corner. 

Type the text, and then press Enter at the end of each new line. 

To complete the command, press Enter again. 

Text toolbar:  

Command line TEXT 
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Commands Reference 

STYLE: Creates, modifies, or sets named text styles 

TEXT: Creates a single-line text object 

System Variables Reference 

FONTALT: Specifies the alternate font to be used when the specified font file cannot be located 

FONTMAP: Specifies the font mapping file to be used 

MIRRTEXT: Controls how the MIRROR command reflects text 

QTEXTMODE: Controls how text is displayed 

TEXTEVAL: Controls the method of evaluation of text strings entered with the TEXT or -TEXT 

commands 

TEXTFILL: Controls the filling of TrueType fonts while plotting and rendering 

TEXTQLTY: Sets the resolution tessellation fineness of text outlines for TrueType fonts while 

plotting and rendering 

TEXTSIZE: Sets the default height for new text objects drawn with the current text style 

TEXTSTYLE: Sets the name of the current text style 

 Multiline Text 

Multiline text consists of one or more lines of text or paragraphs that fit within a boundary width 

that you specify. Each multiline text entity you create is treated as a single entity regardless of the 

number of individual paragraphs or lines of text it contains. 

When you create multiline text, you first determine the paragraph's boundary width by specifying 

the opposite corners of a rectangle. The multiline text automatically wraps so that it fits within this 

rectangle. The first corner of the rectangle determines the default attachment point of the 

multiline text. You can change the location of the attachment point in reference to the rectangle, 

and you can determine the direction in which text flows within the rectangle. 

After defining the text frame, the system opens the In-Place Text Editor, which is comprised of a 

text frame and the Text Formatting toolbar. You can type text in the text frame and change the style 

from the Text Formatting toolbar. 

The text style can control the style of characters, such as default fronts, line spacing, aligned way 

and color. STANDARD is the default text style. 

You can change the value of text objects in the Properties palette that includes the Justify, Direction 
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and so on. 

You can also assign the underline, color or other fonts to the current text to overlap the default 

style. Stacked characters (such as fractions and tolerance), special characters and Unicode 

characters used for TrueType fonts can be create in the text frame. At the same time, you can also 

control the appearance of text object and create a list by specifying the tap and characters to 

retract. 

To create multiline text 

Choose Draw > Text > Multiline Text from the main menu. 

Select the first corner of the text area. 

Select the second corner of the text area. 

In the Multiline Text window, type the text you want. 

To create paragraphs, press Enter and continue typing. 

On the toolbar, make format changes as follows: 

To change the font of the selected text, select a font from the list. 

To change the height of the selected text, enter a new value in the Height box. 

To format text in a TrueType font with boldface or italics, or to create underlined text for any font, 

click the corresponding button on the toolbar. SHX fonts do not support boldface or italics. 

To apply color to the selected text, choose a color from the Color list. Click Select Color to display 

the Select Color dialog box. 

To save your changes and exit the In-Place Text Editor, use one of the following methods: 

Click OK on the toolbar. 

Press <Ctrl + Enter>. 

Text toolbar:  

Command line MTEXT 

TIP You can paste text from the Clipboard into the In-Place Text Editor. 

 

Justify Multiline Text 

When you create multiline text, you can set the text alignment by specifying the attachment point 

location in relation to the multiline text boundary and the direction in which text flows within the 

boundary. You can set the multiline text alignment either at the command line prompt displayed 

after you specify the first corner of the multiline text boundary or from the In-Place Text Editor. You 

can specify the attachment point at the top left, top center, top right, middle left, middle center, 

middle right, bottom left, bottom center, or bottom right. The multiline text can flow left to right, 

right to left, top to bottom, or bottom to top. 

The system provides nine justifications, shown as the following illustrations: 



 

 315 

 

Format Characters Within Multiline Text 

During creating multiline text, you can assign a new value to the selected objects to overlap the 

default setting. But the changes only affect the selected texts, leaving the current text style 

unchanged. 

In addition to specifying an underlines, bold, color and fonts for a single or multiple characters, you 

can also specify a different text height. The text height displayed in the In-Place Text Editor is the 

one you specified, the height of the actual characters is displayed with the new height as well. The 

text high is measure in drawing unit. 

Indent Multiline Text and Use Tabs 

On the In-Place Text Editor, you can control the appearance of text objects and create a list by 

specifying the tap stops and indenting text. The setting of tap stops and indent made before typing 

text are applied to all the texts. You can also assign the settings to the selected paragraphs. 

The arrowheads on the ruler are used to define the indent of text. The above one is designed to 

specify the first line indent, while the other one is designed to specify the paragraph indent. 

While you dragging the indent mark on the ruler, the L mark is displayed to represent the tab stops. 

You can delete custom tabs by moving the L mark away from the ruler. 

Specify the Line Spacing 

The line spacing of multiline texts is the distance between the baseline of one line of text and the 

baseline of the next line of text. You can right-click in the textbox and choose Paragraph to specify 

the desired line space when the cursor stays on the text frame. The single line space is the 1.66 

times the height of the text characters. 



 

 316 

You can specify either At Least, Mutiple or Exactly option to specify the line spacing. At Least 

increases line spacing automatically when the characters are too large to fit the line spacing you 

had specified. Mutiple sets the line spacing according to the text height, instead of setting the value 

of the line spacing. If the text height is not the same in a line, the line spacing is fixed by the biggest 

text height. Exactly specifies the exact line spacing for each line. 

Exactly style may result the text in lines situated above or below lines with large font characters to 

overlap the larger characters. 

Create Stacked Characters 

Stacked text is text or fraction applied to mark tolerance or measure units. Before creating stacked 

text, you have to use special characters to indicate the stacked place for the selected text. The 

following contents present the special characters and illustrate how to create stacked text: 

Slash (/): Stacks text vertically and separates them with a horizontal line. 

Pound sign (#): Stacks text diagonally and separates them with a diagonal line. 

Carat (^): Creates a tolerance stack, which is stacked vertically as well as not separated by a line. 

 

You can also use Stack button on the Text Formatting toolbar to create stacked text. 

Import Text from External Files 

You can input text (TXT and other) contents into the drawing from an external file by selecting 

Import Text option from the right click menu of the In-Place Text Editor, and display the text in the 

drawing that imported from external file as mtext object.  

Importing text from external files provides users with infinite flexibility while manipulating, you can 

operate from creating text file for standard annotations firstly, and then insert these text into the 

drawing as mtext objects for subsequent editing and resetting its formats.  

Text imported from external files (TXT and other) uses current text style. Additionally, the external 

files imported into the In-Place Text Editor retain its source document style for text height, and 

retain the original setting for line break and enter symbol. 

To Import Text file 

Select Draw > Text > Multiline Text from the main menu. 

Specify two corners of the multiline textbox separately to define the width of mtext object.  

Right click on the In-Place Text Editor, and then select Import Text from the shortcut menu that 

pops up. 

Select the desired text file from the Select File dialog box, and then click Open. The text contents of 



 

 317 

the text file will be inserted into the position where the cursor stays within the In-Place Text Editor.  

Modify text contents to be inserted on your demand. 

Click OK on the In-Place Text Editor to save the modification and exit the editor. 

Text Toolbar:  

Command line: MTEXT 

If you drag an external file into the drawing directly, it will be displayed as OLE object. Additionally, 

if you use clipboard to copy text from other applications and paste it into current drawing directly, 

the text will be displayed as OLE objects.  

 

Commands Reference 

MTEXT: Creates multiline text 

PROPERTIES: Controls properties of existing objects 

DDEDIT: Edits text, dimension text, attribute definitions, and feature control frames 

STYLE: Creates, modifies, or sets named text styles  

System Variables Reference 

MTEXTED: Controls the appearance of the Multiline Text Editor 

QTEXTMODE: Controls how text is displayed 

TEXTFILL: Controls the filling of TrueType fonts while plotting and rendering 

TEXTQLTY: Sets the resolution tessellation fineness of text outlines for TrueType fonts while 

plotting and rendering 

TEXTSIZE: Sets the default height for new text objects drawn with the current text style 

TEXTSTYLE: Sets the name of the current text style 

TSPACEFAC: Controls the multiline text line spacing distance measured as a factor of text height 

TSPACETYPE: Controls the type of line spacing used in multiline text 

TSTACKALIGN: Controls the vertical alignment of stacked text 

TSTACKSIZE: Controls the percentage of stacked text fraction height relative to selected text's 
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current height 

 Leaders 

A leader is a line or spline with arrowhead at one end, and annotations (Mtext, blocks as well as 

tolerance) at the other end. 

Generally, you place an arrowhead at the first point. An annotation, created as dimension text, is 

placed immediately adjacent to the last point. 

Create a Leader Line 

You can use LEADER or QLEADER to create a leader and control the appearance. The color of a 

leader is controlled by the color of the current dimension line. The scale is controlled by the global 

dimension scale specified on the current dimension style. The appearance of a leader is control by 

the setting of the first arrowhead on the current dimension style. 

 

Add Text to a Leader 

There are two methods to add text to a leader: 

Type text on the command line 

Create multiline text using the In-Place Text Editor  

When creating text, you can assign the style to an individual character and attach the copies of the 

current annotation to the leader. 

When the value of variable system DIMGAP is negative, the system creates a box next to the text, 

which the distance between them is determined by the value of DIMGAP. 

The text is placed automatically at the endpoint of a leader at the specified value, which is stored in 

the "Offset from dim line" on the Text tab of Modify Dimension Style dialog box. If the dimension is 

tolerance, the future control frame is placed at the endpoint of a leader as well. A block is inserted 

at the specified location with the specified scale value. 

To create a leader and an annotation 

Choose Dimension > Leader from the main menu. 

Specify the starting point of the leader. 

Specify the endpoint of the leader line segment. 

Specify additional leader line segment endpoints. 

After you specify the last endpoint, press Enter. 

Type the annotation, and press Enter to enter the next line of annotation text. 

Press ENTER to complete the command. 

Command line LEADER 
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Specify the starting point of the 

leader (A) and the endpoint of the 

leader line segment (B) 

Result 

The following picture shows the text is above the leader. You can set the Text Placement from the 

Text tab in the Modify Dimension Style dialog box. 

 

 

Commands Reference 

LEADER: Creates a line that connects annotation to a feature  

QLEADER: Creates a leader and leader annotation 

DDEDIT: Edits text, dimension text, attribute definitions, and feature control frames 

DIMSTYLE: Creates and modifies dimension styles  

MTEXT: Creates multiline text 

OPTIONS: Customizes the ZWCAD+ settings  

PROPERTIES: Controls properties of existing objects 

PURGE: Removes unused named items, such as block definitions and layers, from the drawing 

STYLE: Creates, modifies, or sets named text styles 
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TEXT: Creates a single-line text object 

System Variables Reference 

DIMASZ: Controls the size of dimension line and leader line arrowheads 

DIMCLRD: Assigns colors to dimension lines, arrowheads, and dimension leader lines 

DIMLDRBLK: Specifies the arrow type for leaders 

DIMSCALE: Sets the overall scale factor applied to dimensioning variables that specify sizes, 

distances, or offsets  

DIMTAD: Controls the vertical position of text in relation to the dimension line 

DIMGAP: Sets the distance around the dimension text when the dimension line breaks to 

accommodate dimension text  

FONTALT: Specifies the alternate font to be used when the specified font file cannot be located 

FONTMAP: Specifies the font mapping file to be used  

MTEXTED: Sets the primary and secondary text editors to use for multiline text objects  

QTEXTMODE: Controls how text is displayed 

TEXTFILL: Controls the filling of TrueType fonts while plotting and rendering 

TEXTQLTY: Sets the resolution tessellation fineness of text outlines for TrueType fonts while 

plotting and rendering 

 Multileader 

Multileader is usually composed of four part, arrowhead, leader, leader landing and content. Each 

multileader can contain more than one leader line, and each leader line can be composed of one or 

more segments. Leader content can be set to Mtext or block. That is, a note created by multileader 

can point to more than one part of the drawing. 

You can create a multileader by Arrowhead First or Content First. The Multileader Style Manager is 

also provided for style managing. You can create different styles of multileaders in the same view 

by setting multileader style. 
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Multileader Toolbar 

Functions of the buttons on multileader toolbar are described in the table below: 

Icon Name Function Description 

 

Multileader Creates a multileader object. 

 

Add Leader Adds leaders to the selected multileader object. 

 

Remove Leader  Removes the leader from the multileader object. 

 

Multileader Style  
Open "Multileader Style Manager ”dialog box, in 

which you create, modify or delete multileader style. 

  

Create multileader  

Enter MLEADER command, according to prompt to create multileaders on any location in the 

drawing. 

Steps for creating multileader with MText. 

Select [Dimension → Multileader]. 

Specify leader arrowhead's location. 

Specify leader landing's location. 

Enter multitext in text box as leader content, and then click "OK" button to complete the 

multileader creating. 

Steps for creating multileader with Block. 
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Select [Dimension → Multileader]. 

Enter O (option) and set the multileader content type to block, then exit. 

Specify leader arrowhead's location. 

Specify the location of the multileader to finish drawing. 

Multileader style  

The leader type of the multileader can set to spline or straight. 

 

The content of the multileader can set to MText or Block. 

 

More details of multileader style settings, you can modify on Leader Format in Modify Multileader 

Style dialog 

  

Multileader toolbar:  

Command line: MLEADER 

  

 

Commands Reference 
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MLEADER: Create multileader. 

MLEADERSTYLE: Create, modify or remove multileader style. 

MLEADEREDIT: Add or remove leaders to multileader object. 

System Variables Reference 

CMLEADERSTYLE: Setup the current multileader style.  

9.2 Change Text 

All of text objects can be moved, rotated, deleted and copied, just as like other objects. You can 

change the properties at the Properties panel. 

You can also modify the contents of existing text and create a mirror image. The system variable 

MIRRTEXT controls whether the text is reversed or not when you mirror object. 

Change single-line text 

You have two methods to modify single-line text: 

To modify only the content of text, use DDEDIT command. 

To change text style, location, size and content, use PROPERTIES command to open Properties 

palette, from which, you can make the relevant settings. 

To edit text 

Type DDEDIT and then press Enter. 

Select the single line text. 

In the Edit Text box, edit the text and then press Enter. 

Text toolbar:  

Command line DDEDIT 

 

To change text properties 

Select a single line text object. 

Right-click the selected object and then click Properties on the shortcut menu. 

In the Properties palette, enter any new text in the Text Contents, and then change formatting and 

other properties as needed. 

Standard toolbar:  

Command line PROPERTIES 

 

You can also move, scale or rotate text through grips as like other objects. The grip of a single-line 

text is displayed at the lower-left corner of the baseline and the alignment point. As shown in the 

following picture: 
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Different grips generate different effect even though with the same command. 

Change Multiline Text 

You can change the properties of multiline text in the Properties palette. 

To edit multiline text 

Type DDEDIT and then press Enter. 

Select the multiline text. 

Edit the text in the In-Place Text Editor. 

Click OK. 

Text toolbar:  

Command line DDEDIT 

 

To change multiline text properties 

Select a multiline text object. 

Right click the selected object and then click Properties on the shortcut menu. 

In the Properties palette, enter any new text and change formatting and other properties as 

needed. 

Standard toolbar:  

Command line PROPERTIES 

Double-clicking opens the In-Place Text Editor, from which, you can modify the contents and 

formats of text. 

 

Change Text Location 

You can move or change the line width through grips as well. 

Generally, the location of grips is displayed at the four grips of the text, in some cases, at the 

justification point. 

You can also replace the text by entering the coordinate on the Properties palette. 

Find and Replace Text 

Within the In-Place Text Editor, right-click and select Find and Replace to replace the selected 

characters. The content of text is replaced, but the properties of the text remains. 
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Change Text with a Leader 

You can change the size of a leader by stretching or scaling it. Stretch changes the distance between 

the endpoint and the annotation. Scale only updates the scale of the selected objects. For example, 

when scaling a leader, the location of the annotation keeps unchanged. A leader can be used as the 

boundary for trimming or extending, but not be trimmed or extended. 

 

Commands Reference 

DDEDIT: Edits text, dimension text, attribute definitions, and feature control frames 

FIND: Finds, replaces, selects, or zooms to specified text 

PROPERTIES: Controls properties of existing objects 

TEXT: Creates a single-line text object 

STYLE: Creates, modifies, or sets named text styles 

LEADER: Creates a line that connects annotation to a feature 

QLEADER: Creates a leader and leader annotation 

System Variables Reference 

MIRRTEXT: Controls how the MIRROR command reflects text 

TEXTFILL: Controls the filling of TrueType fonts while plotting and rendering 

TEXTQLTY: Sets the resolution tessellation fineness of text outlines for TrueType fonts while 

plotting and rendering 

MTEXTED: Sets the primary and secondary text editors to use for multiline text objects 

9.3 Work with Text Styles 

The text style is applied to the text objects. You can use text style to control the text font, size, 

angle, direction and other features. By default, the current text style is STANDARD, and you have to 

make other text styles current when you want to apply them. 

The STANDARD text style has the following default properties: 

Setting Default Description 

Style name STANDARD Name with up to 255 characters 



 

 326 

Font name txt.shx File associated with a font (character style) 

Big Font None 
Special shape definition file used for a non-ASCII character set, such as 

Kanji 

Height 0 Character height 

Width factor 1 Expansion or compression of the characters 

Obliquing angle 0 Slant of the characters 

Backwards No Backwards text 

Upside down No Upside-down text 

Vertical No Vertical or horizontal text 

You can modify the current text style or create a new text style directly. You can also delete the 

created text style but not the default STANDARD text style. 

Create new text styles 

When you apply some settings that the STANDARD does not have to the text, you have to create a 

new text style or change the current text style. 

Before creating a text style, you have to specify a name which can be up to 255 characters. The 

name can contain characters, underscore, hyphen, dollar sign and other special characters that are 

not used by Microsoft Windows or ZWCAD+. 

You can also modify the current text style at the Text Style dialog box. 

Some style settings have different effects on single-line and multiline text objects. For example, the 

Upside Down and Backwards options are not available for multiline text objects.  

You can also rename an existing text style except for the STANDARD. 

Except for the STANDARD text style, all text styles can be removed using PRUGE command or 

deleted from the Text Style dialog box. 

Certain formatting applied to individual characters within multiline text may not be retained. The 

formatting not to be retained includes bold, font, height and obliquing. The formatting that can be 

retained includes color, stack and underscore. 

To create a text style 

Choose Format > Text Style from the main menu. 

Click New, type a new text style name, and then click OK. 

Under Text Measurements, specify the Text Height, Width Factor, and Oblique Angle. 

Under Text Font, select the name, style, language, and bigfont you want to use. 

Under Text Generation, select the check boxes you want to indicate the direction for printed text to 

appear. 

Click Apply, and then click OK. 

Text toolbar:  

Command line STYLE 

 

Assign Text Fonts 
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Each character set is consisted of text characters, which shape is defined by fonts. In addition to 

TrueType font, you can use compiled SHX font in ZWCAD+. One font can be used for multiple text 

styles as long as you make other settings different. The following illustration shows the same font 

used by different text styles that use different settings. 

 

You can specify the desired font from the Text Font field to the current or a new created text font at 

the Text Style dialog box. 

Use TrueType Fonts 

TrueType fonts always appear filled in the drawing. By default, the system plots the filled-in fonts, 

which is controlled by the system variable TEXTFILL. 

Use Unicode and Big Fonts 

ZWCAD+ supports the Unicode character-encoding standard. A Unicode font contains 65,535 

characters and shapes for many languages. You can enter characters that are not available from the 

keyboard through escape sequence. The escape sequence is of \U+nnnn, where nnnn represents 

the Unicode hexadecimal value for the character. All of SHX shape fonts are Unicode fonts. 

ZWCAD+ also supports the big font in order to accommodate alphabet text files consisted of 

thousands of ASCII characters. 

When you use –SYTLE command to specify fonts, you can specify two fonts separated by a 

comma. The first one is common font and the second is big font. The specification shown as follows: 

(specify font and big font on the command line) 

Enter this ... To specify this ... 

[font name],[big font name]  Both normal fonts and Big Fonts 

[font name],  Only a normal font (Big Font unchanged) 

,[big font name] Only a Big Font (normal font unchanged) 

[font name] Only a normal font (Big Font, if any, removed) 

ENTER (null response) No change 

You should not enter a long file name consisted of commas. The comma is interpreted as a 

separator. 

Replace Font 

If the font to be contained in the drawing can't be obtained from current system, ZWCAD+ process 

it by replacing these fonts with another specified one. 
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Specify fonts to replace 

If the font to be contained in the drawing can't be found in current system, ZWCAD+ replaces these 

fonts with another specified font automatically. Otherwise, system uses "simplex.shx" font to 

override those unknown fonts instead. To modify the replace fonts by system default, you can 

modify the system variable FONTALT which is applied for specifying new font file name. However 

the FONTALT value will be mapped to another font if big font is used currently. Default font file for 

this system variable is "txt.shx"and"bigfont.shx". 

Edit Font Mapping File 

Font mapping file is the list file for fonts and their corresponding replace fonts. If the specified fonts 

can't be found in current system, you can obtain from a font mapping file to replace them with 

specified fonts. 

Sometimes, to ensure partial specific fonts or enable fonts conversion in current drawing, you can 

create font mapping file with any text editor. 

With these font mapping files, you can stipulate and manage fonts uniformly or use them directly 

when off-line printing. If encountering font objects created by other fonts, you can specify replace 

fonts to apply in platform through font mapping. It's also available for users to set a font mapping 

file to convert each font to corresponding font, for example, when editing drawings, the SHX which 

is easy drawing can be used for replacing other fonts in the drawing, and subsequently switched to 

more complex fonts when printing. 

Font mapping file is a type of common ASCII text file with an extension name as .fmp, containing 

text file name without extensions or path in each line, the font file name with extension .ttf behind 

the font file is replace font, the two file names are separated by a semicolon. System uses 

zwcad.fmp (used for ZWCAD+ only) as default font mapping file. Any ASCII text editor is available 

for changing text for replacing specified fonts from the font mapping file. 

For example, you can input the following contents in font mapping file, to replace timesnr.pfb font 

file with times.ttf font file: timesnr;times.ttf. 

If you can't find specified font file when opening a drawing, system determines how to find the 

replace font specific to the font type (single text, Mtext). 

If the text is single text, system processes it with the following procedures: 

Search for replace font file in ZWCAD+ .fmp file. 

Iterate font style table, search for the font file in the same format. 

Use default font ZWCAD.fnt. 

Pop-up font file dialog box, in which user can specify replace font file, otherwise uses ZWCAD.fnt as 

default font. 

If big fonts are being used, search for corresponding font files in font mapping table (zwcad.alt). 

Search for corresponding codepage in font mapping table (zwcad.ini), and then search for replace 

font file in font mapping table through this codepage. 

If the corresponding text can't be found no matter which font is applied, use the mapping font file 

found in zwcad.ini, if still unfound, use zwcad.fnt. 

If text object is mtext, system handles it by subsection through language set so as to judge whether 

the font file corresponding to this font file is capable of displaying this text object. If the font file 

corresponding to this text object isn't existed in current system, the text style corresponding to this 
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text will be used for displaying this text. Even if the text style corresponding to this text can't be 

found, Chinese system will take Song typeface as default, while other language systems take 

current font style as default. If the corresponding font file exists but not display, system reads the 

specified font in system configured file (zwcad.alt). If the replacing font is corrupted or useless in 

some cases, the fonts will not be replaced. 

Set Text Height 

Text height is the size of characters, which is measured in drawing unit. With the same height 

setting, the displaying height of TrueType font is usually lower than the one of SHX font. When the 

font is not of TrueType font, the value represents the size of the uppercase letters. 

When the text height is set to 0 in the text style, the system prompts you to type a height value 

while creating single-line text each time. So you can set text height to 0 in the text style in order to 

specify a new height before creating text. 

For TrueType fonts, the value of text height represents the height of a capital letter plus an ascent 

area. The ascent is reserved for accent marks and other marks used in non-English languages. The 

relative portion of text height assigned to capital letters and ascent characters is determined by the 

font designer at the time the font is designed; consequently, it varies from font to font. 

When you apply a text height to all text in the In-Place Text Editor, the whole multiline text object is 

scaled, including its width. 

Set Text Obliquing Angle 

The obliquing angle determines that the text slant forward or backward. The obliquing angle ranges 

from the -85 to 85. Positive value slants forward; negative value slants backward. As shown the 

following picture: 

 

Set Horizontal or Vertical Text Orientation 

The text directions include horizon and vertical. Only if the associated font supports dual 

orientation, you can create the vertical text. Each sequent text line is drawn to the right of the 

preceding line. Generally, the rotation angle for vertical text is 270 degrees. You cannot create 

vertical text when the font is TrueType. 
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To specify a line text style 

Choose Draw > Text > Single Line Text from the main menu. 

On the command line, type S (Style) and press ENTER. 

Type the name of a previously defined text style, and then press Enter. To display a list of available 

text styles, type a question mark (?), and then press Enter. 

Specify the text insertion point. 

Specify the text height. 

Specify the rotation angle. 

Type the text line, and then press Enter. 

To complete the command, press Enter again. 

Text toolbar:  

Command line TEXT 

 

To specify a multiline text style 

Choose Draw > Text > Multiline Text from the main menu. 

Specify the first corner of the Multiline Text box. 

On the command line, type S (Style) and press ENTER. 

Type the name of a previously defined text style, and then press Enter. 

Specify the opposite corner of the Multiline Text box. 

Type the text. 

Click OK. 

Text toolbar:  

Command line MTEXT 

 

Commands Reference 

PURGE: Removes unused named items, such as block definitions and layers, from the drawing 

STYLE: Creates, modifies, or sets named text styles 

QTEXT: Controls the display and plotting of text and attribute objects 
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OPTIONS: Customizes the ZWCAD+ settings 

System Variables Reference 

FONTALT: Specifies the alternate font to be used when the specified font file cannot be located 

FONTMAP: Specifies the font mapping file to be used 

TEXTSIZE: Sets the default height for new text objects drawn with the current text style 

TEXTSTYLE: Sets the name of the current text style 

QTEXTMODE: Controls how text is displayed 

TEXTFILL: Controls the filling of TrueType fonts while plotting and rendering 

TEXTQLTY: Sets the resolution tessellation fineness of text outlines for TrueType fonts while 

plotting and rendering  

9.4 Check Spelling 

You can use the SPELL command to check the spelling of text in your drawings, use various spelling 

dictionaries, and create custom spelling dictionary. It is comprised of the following items. 

Checking the spelling of text 

You can use the SPELL command to check the spelling of single-line text, multiline text, paragraph 

text, attributes, attribute definitions, and dimension text. 

Checking the spelling of text 

Type SPELL on the command line and press Enter. 

Select one or more text entities. 

In the Check Spelling dialog box, misspelled words display one at a time. Do one of the following for 

each found word: 

Keep text unchanged — Click Ignore to keep the found word unchanged in the drawing, or click 

Ignore All to keep all instances of the found word unchanged in the drawing. 

Change text — Select or type a word in the Suggestions box, then click Change to change the 

found word in the drawing to the new text, or click Change All to change all instances of the found 

word in the drawing. 

Click Add if you want to add the currently found word to a list of custom spelling words. 

The Check Spelling dialog will recognize the added word as spelled correctly the next time the word 

is checked for spelling. 

Command line SPELL 
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Work With Spelling Dictionary 

Most drawings contain text that is not recognized as spelled correctly, even though it is spelled 

correctly. For example, if your company name Zaffer, Inc. appears in all of your drawings, the 

company name will appear as misspelled every time you check the spelling of drawing text. You can 

easily add words to a custom dictionary so that any word in the custom dictionary is recognized as 

spelled correctly. 

The custom dictionary is independent of any spelling dictionary you have chosen to use. You can 

check the spelling of text using one dictionary, check the spelling of the same or other text using a 

different dictionary, and in both cases your custom dictionary is used. 

TIP You can also add custom words to the custom dictionary directly during spell checking of text. 

In the Check Spelling dialog, click Add to add the currently found word to the custom dictionary. 

To download and install a new dictionary 

Execute SPELL on the command line, select one or more text entities, and then in the Check 

Spelling dialog box, click Change Dictionaries. 

Click Download. 

From the web page that displays (or from a different web page), download the desired dictionary. 

Unzip the contents of the downloaded file to \MyDocuments\HunSpell, or the location where you 

installed spelling dictionaries for ZWCAD+. 

Click Change Dictionaries again, which will load the newly installed dictionary. 

In Main Dictionary, select the desired dictionary. 

Click OK. 

Command line SPELL 

 

To use a dictionary already installed on your computer 

Copy the existing dictionary (DIC file) to \MyDocuments\HunSpell, or to the location where you 

install spelling dictionaries for ZWCAD+. Or add the folder of the existing dictionary to the list of 

folders where ZWCAD+ searches for dictionaries. Choose Tools > Options from the main menu, and 

then click Files and add the folder location to the corresponding paths. 

Execute SPELL on the command line, select one or more text entities, and then in the Check 

Spelling dialog box, click Change Dictionaries. 

In Main Dictionary, select the desired dictionary. 

Click OK. 

 

Create custom spelling dictionary 

The SPELL command compares text found in the drawing with correctly spelled words in an 

installed dictionary (DIC file). There are many different dictionaries that can be used with ZWCAD+, 

including dictionaries in many different languages. You can download and install a new dictionary 

or use a dictionary already installed on your computer. 

To create and manage a custom dictionary 

Type SPELL on the command line and press Enter. 

Select one or more text entities. 
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In the Check Spelling dialog box, click Change Dictionaries. 

To add a custom word, type a word in Custom Dictionary Words, and then click Add. 

To delete a custom word, select a word in Custom Dictionary Words, and then click Delete. 

Click OK. 

Command line SPELL 

 

Commands Reference 

ATTDEF: Configures the attribute definition 

MTEXT: Creates multiline text objects 

SPELL: Checks the spelling of single-line text, multiline text, paragraph text, attributes, attribute 

definitions, and dimension text 

TEXT: Creates single-line text objects 

System Variables Reference 

DCTCUST: Stores the file name and path of  the custom dictionary 

DCTMAIN: Stores the file name and path of the main dictionary 

9.5 Smart Voice 

Smart Voice provides designers a more convenient interactive way for drawings review. The 

traditional ways include face to face interaction, or adding text annotations in the drawings (such as 

adding cloud lines, leads, texts, etc.). However, the former one requires both of the designers in the 

same place, which is inconvenient for recording and subsequent accessing to the interactive 

content; while the latter one is less efficient, you need to enter a lot of text and may lead to 

misunderstanding. As to the Smart Voice function, it can help create voice comments in drawings, 

which is more conducive to the communication between designers. 

Besides, a lot of other usages can be derived from the smart voice function, such as: 

Auxiliary description for design intent 

Auxiliary tool for design thinking recording 

Auxiliary tool for review comments description 

Effects enhancement tool for design demonstration 

 

Create voice object 

Choose Tools » Smart Voice » Smart Voice from the main menu. 

Input S(Settings) in command line to specify the way you insert the voice object. 



 

 334 

Mouse over the generated record button, press and hold the left mouse button to start recording. 

Release the mouse to stop recording and the Record icon will change into the Play icon. 

Command line: SMARTVOICE 

You can use the following three ways to insert voice objects: 

Insert into Point: Specify a point of absolute location to insert the voice object; 

Insert into Region: Bind the voice object to a region, the region will be highlighted in a dashed 

frame when you mouse over it; 

Bind to Entity Object: Bind the voice to an object, the object will be highlighted in a dashed frame 

when you mouse over it. 

 

Voice playback 

Mouse over the UI icon of the recorded voice object, click the left mouse button to play the voice. 

 

Delete voice object 

Mouse over the UI icon of the inserted voice object, a Delete button will show in the upper right 

corner, click it to delete the voice object. 

 

 

Commands Reference 

SMARTVOICE：Creates smart voice object 

VOICESHOW：Displays or hides voice object 

VOICEMAN：Displays Voice Manager dialog box in which you can play, search, delete and set the 

voice object 

System Variables Reference 

None 
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10 Dimensions and Tolerances 

 

 

Topics in this section: 

Overview of Dimensioning 

You can create five basic types of dimensions: linear, angular, radial, diametral, and ordinate. 

Use Dimension Styles 

Dimensions that you insert are created using the current dimension style. You can create, save, 

restore, and delete named dimension styles. 

Create Dimensions 

You can create all of the standard types of dimensions. Including linear, radial, angular, and ordinate 

dimensions. 

Modify Existing Dimensions 

You can modify all components of the existing dimension objects in a drawing either individually or 

by using dimension styles.  

Add Geometric Tolerances 

You can add geometric tolerances that show acceptable deviations of form, profile, orientation, 

location, and runout of a feature. 

Table 

Table is a cell collection composed of rows and columns. 

10.1 Overview of Dimensioning 

You can create five basic types of dimensions: linear, angular, radial, diametral, and ordinate. 

You can create dimensions for existing entities by selecting them, or you can create dimensions by 

selecting points within a drawing. For example, you can create a linear dimension either by 

selecting the entity to be dimensioned or by specifying the first and second extension line origins. 

Dimensions indicate the measurement values of objects (e.g. length or width), distance or angles 

among objects, or the distance between feature point and the specified origin. You can create 

dimensions that can be horizontal, vertical, aligned, rotated, coordinate, baseline, or continued. 
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When you create a dimension, the program draws it on the current layer, using the current 

dimension style. Each dimension has an associated dimension style, which controls the appearance 

of the dimension, such as the types of arrowheads, text style, and colors of various components. 

You can modify existing dimension styles by changing any of the dimension variable settings, and 

the new dimension style is visible soon after you confirm the modification. 

You can use the QDIM command to create or edit a series of non-associative dimensions. 

Parts of a Dimension 

Dimensions have several distinct elements: dimension text, dimension lines, arrowheads, and 

extension lines. 

 

Dimensions can also contain other optional components. A leader is a line leading from a feature of 

the drawing to an annotation. Leaders begin with an arrowhead, and you can use them to place a 

dimension away from the dimension line or to add notes. When you create a radial dimension, you 

can add a center mark, which is a small cross that marks the center of a circle or an arc, or you can 

add centerlines, which are crossing lines that extend out from the center of a circle or an arc. 
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Leader Center mark Centerlines 

Dimension text: a character string that usually indicates the measurement value, includes prefixes, 

suffixes, tolerances, etc.  

Dimension line: indicates the direction and extent of a dimension. For linear dimensions, it displays 

as a line, for angular dimensions, it displays as an arc segment.  

Arrowhead: usually displayed at both end of the dimension line. You can specify various sizes and 

shapes for arrowheads or tick marks.  

Extension line: extends from the object to the dimension line, in order to define dimension ranges.  

Center mark: a small crossing tag that marks the center of a circle or arc.  

Centerline: a crossing dashed line that marks the center of a circle or arc.  

 

Commands Reference 

DIMANGULAR: Creates an angular dimension 

DIMDIAMETER: Creates diameter dimensions for circles and arcs 

DIMEDIT: Edits dimensions 

DIMLINEAR: Creates linear dimensions 

DIMORDINATE: Creates ordinate point dimensions 

DIMRADIUS: Creates radial dimensions for circles and arcs 

DIMSTYLE: Creates and modifies dimension styles 

PROPERTIES: Controls properties of existing objects 

QDIM: Quickly creates a dimension 

EXPLODE: Breaks a compound object into its component objects 

LIST: Displays database information for selected objects 

OPTIONS: Customizes the ZWCAD+ settings 

System Variables Reference 

None 

10.2 Use Dimension Styles 

You can control the appearance of dimensions by changing settings. For convenience and to help 
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maintain dimensioning standards, you can store these settings in dimension styles.  

Topics in this section: 

 Overview of Dimension Styles 

Dimensions that you insert are created using the current dimension style. You can create, save, 

restore, and delete named dimension styles. 

 Control Dimension Elements 

You can modify the appearance of dimension lines, extension lines, arrowheads, and center marks. 

 Control Dimension Text 

You can control the settings affecting the appearance of dimension text. Any changes you make 

affect the current dimension style.  

 Control Dimension Values 

Set the display format of dimension values. 

 Set the Scale for Dimensions 

Set the scale for dimensions. Setting dimension scale depends on the method you use to lay out 

and plot drawings. 

 Overview of Dimension Styles 

Dimensions that you insert are created using the current dimension style. You can create, save, 

restore, and delete named dimension styles.  

DIMSTYLE command is available when you want to display information about the current 

dimension style and all of the named dimension styles. 

Dimension styles provide a way for you to change various settings that control the appearance of 

dimensions. You can then save those settings for reuse. If you don't define a dimension style before 

creating dimensions, the program uses the Standard dimension style, which stores the default 

dimension variable settings. You can get Modify Dimension Style dialog started through clicking 

Modify button on Dimension Style Manager dialog, for further modification about each dimstyle 

settings. 

You can change the following settings in the Dimension Style Manager. 

Extension lines, dimension lines, arrowheads, center marks or lines, and the offsets between them 

The positioning of the parts of the dimension in relation to one another and the orientation of the 

dimension text 

The content and appearance of the dimension text 

The units of the dimension value 
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With the Compare button of the Dimension Style Manager, you can list the difference between any 

two named dimension styles. 

If there is a dimension contained in the xref being inserted, then dimension style applied in this 

dimension is also existing in current drawing. You can compare externally referenced dimension 

styles with other styles, but not allowed to modify them or make them current. An externally 

referenced dimension style can be used as a template to create a new dimension style in the 

current drawing. 

To create a dimension style 

Choose Dimension > Style from the main menu. 

In the Dimension Style Manager dialog box, click New. 

Type the name of the new dimension style, and choose which style started with and what kind of 

dimension used for. 

Click Continue. 

In the New Dimension Style dialog box, click one of the other tabs, and then change the dimension 

settings as necessary. Repeat this step for each tab, as needed. 

To end the command, click OK. 

Dimension toolbar:  

Command line DIMSTYLE 

 

To select a dimension style 

Choose Dimension > Style from the main menu. 

Select a dimension style from the Styles list. 

Dimension toolbar:  

Command line DIMSTYLE 

 

To rename a dimension style 

Choose Dimension > Style from the main menu. 

In the Styles list of Dimension Style Manager dialog box, do one of the following: 

Double click the required style. 

Right click on the required style name, and then choose Rename. 

Type the new name. 

Click Close to exit. 

Dimension toolbar:  
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Command line DIMSTYLE 

 

To delete a named dimension style 

Choose Dimension > Style from the main menu. 

In the Styles list of Dimension Style Manager dialog box, right click on the required style name, and 

then choose Delete. 

Click Close to close. 

Dimension toolbar:  

Command line DIMSTYLE 

 

To display information about the current style 

Choose Dimension > Style from the main menu. 

In the Dimension Style Manager dialog box, click Compare. 

In the Compare Dimension Style dialog box, choose the same dimension style from the Compare 

and With pulldown list. All properties for specified dimension style will be displayed. 

If you want to know the different information between two styles, choose one style in the Compare 

box, choose the other in the With box, and then you will see difference in the following tab. 

Click Close to close. 

Dimension toolbar:  

Command line DIMSTYLE 

 

Commands Reference 

DIMSTYLE: Creates and modifies dimension styles  

System Variables Reference 

None 

 Control Dimension Elements 

You can modify the appearance of dimension lines, extension lines, arrowheads, and center marks. 
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Modify Dimension Lines 

On the Lines and Arrows tab of the Modify Dimension Style dialog box, you can set the color of 

dimension lies, lineweight, ticks beyond extend line, baseline spacing, and visibility. 

Only when the arrowheads are assigned as oblique stroke arrowheads, architectural tick, Integral, 

dot small or none arrowheads, you can set the displacement explains how far the dimension line 

extends beyond the extend lines, otherwise this setting is not available. 

You can also set the baseline spacing to control the spacing between successive dimension lines. 

If text splits a dimension line, you can specify whether each part of the dimension line is visible or 

not. 

Modify Extension Lines 

Extension lines have the following properties: color, lineweight, distance beyond extension lines, 

offset from start of extension lines, and visibility. You can set these properties on the Lines and 

Arrows tab of the Modify Dimension Style dialog box. 

If extension lines are unnecessary or there is not enough space to display extension lines, you can 

suppress one or both of them. 

The distance beyond extension lines means that how far the extension lines extend beyond the 

dimension line. 

Start offset is the distance between the extension line origin and the start of the extension line, 

also called extension origin offset. Shown as follows: 

 

The first extension line lies on the side where you specified the first extension line origin. If you 

create a dimension for a line, you do not specify the extension line origin. Because the endpoint of 

the line closet to the specified point becomes the origin of the first extension line. Generally, the 

extension lines are perpendicular to the dimension line. However, if there is not space, you can 

make them oblique, shown as the figure above. 

You can control settings affecting dimension lines, extension lines, and center marks. Any changes 

you make affect the current dimension style. The image tile on the right side of the Modify 

Dimension Settings dialog box shows the appearance of the dimensions based on the current 

dimension style settings. 
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A Extend beyond dim lines. 

B Baseline spacing. 

C Offset from origin. 

To set the color for dimension lines 

Choose Dimension > Style from the main menu. 

In the Dimension Style Manager dialog box, select the style you wish to change and choose Modify. 

In the Modify Dimension Style dialog box, click the Lines and Arrows tab. 

Make your selections under the Dimension Lines. 

Click OK. 

Choose Close to exit. 

Dimension toolbar:  

Command line DIMSTYLE 

 

Choose Dimension Arrowheads 

You can control the appearance and size of arrowheads or hook marks placed at the ends of 

dimension lines. Any changes you make affect the current dimension style. The appearance of 

selected arrowhead is display in the preview frame placed at the upper right corner of the Modify 

Dimension Style or New Dimension Style dialog box. 

You can specify different arrowheads for both ends of a dimension line and for leader lines. The 

First arrow is toward the first extension line; The Second arrow is toward the second extension line. 

Blocks defined in the drawing also display in the three Arrowhead lists as user defined arrows. You 

can use these blocks to create and assign your own arrowheads. The Arrow Size value determines 

the size of the arrowhead, measured in drawing units. You can also use tick marks instead of 

arrowheads. 

To choose an arrowhead 

Choose Dimension > Style from the main menu. 

In the Dimension Style Manager dialog box, select the style you want to change and click Modify 
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button. 

In the Modify Dimension Style dialog box, click the Lines and Arrows tab. 

Make your selections under the Arrowheads. 

Click OK. 

Choose Close to exit. 

Dimension toolbar:  

Command line DIMSTYLE 

NOTE You can also specify leader arrow types using the DIMLDRBLK system variable. 

Customize Arrowheads 

The default arrowheads are stored as block definitions. If you select User Defined as your 

arrowhead type, you'll be prompted to assign a name for an existing block definition. 

The overall dimension scale factor determines the arrowhead size. If you assign the User Define 

Arrowhead to the arrowhead in the Dimension Style Manager dialog box, the block is inserted 

where the arrowheads would normally go when you create a dimension. The X and Y scale factors 

of the object are set to "arrowhead size overall scale. You can trim the dimension line with text gap 

x overall scale units at each end. If you want to trim the dimension line, insert the rightmost block 

with a zero rotation angle for horizontal dimensioning. And rotate the leftmost block at 180 

degrees about its insertion point. 

If you use paper-spacing scale, the scale factor is calculated before you applied it to the arrowhead 

size value. 

Center marks 

While you are creating dimensions for circle or arc entities, you can setup type and size for the 

center mark. Three types of marks are provided here: None, Mark, and Line. 

 

Commands Reference 

DIMSTYLE: Creates and modifies dimension styles 

BLOCK: Creates a block definition from objects you select 

WBLOCK: Writes objects or a block to a new drawing file 

System Variables Reference 

DIMCLRD: Assigns colors to dimension lines, arrowheads, and dimension leader lines 

href="">DIMDLE: Sets the distance the dimension line extends beyond the extension line when 

DIMCLRD.htm
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oblique strokes are drawn instead of arrowheads 

DIMDLI: Controls the spacing of the dimension lines in baseline dimensions 

DIMGAP: Sets the distance around the dimension text when the dimension line breaks to 

accommodate dimension text  

DIMLWD: Assigns lineweight to dimension lines 

DIMSD1: Controls suppression of the first dimension line 

DIMSD2: Controls suppression of the second dimension line 

DIMSOXD: Suppresses drawing of dimension lines outside the extension lines 

DIMTOFL: Controls whether a dimension line is drawn between the extension lines even when the 

text is placed outside  

DIMEXE: Specifies how far to extend the extension line beyond the dimension line 

DIMEXO: Specifies how far extension lines are offset from origin points 

DIMLWE: Assigns lineweight to extension lines 

DIMSE1: Suppresses display of the first extension line 

DIMSE2: Suppresses display of the second extension line 

DIMASZ: Controls the size of dimension line and leader line arrowheads 

DIMBLK: Sets the arrowhead block displayed at the ends of dimension lines or leader lines 

DIMBLK1: Sets the arrowhead for the first end of the dimension line when DIMSAH is on  

DIMBLK2: Sets the arrowhead for the second end of the dimension line when DIMSAH is on 

DIMSAH: Controls the display of dimension line arrowhead blocks 

DIMTSZ: Specifies the size of oblique strokes drawn instead of arrowheads for linear, radius, and 

diameter dimensioning  

 Control Dimension Text 

You can control the settings affecting the appearance of dimension text. Any changes you make 

affect the current dimension style. The preview frame on the upper right corner of the Modify 
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Dimension Style dialog box shows the appearance of the dimensions based on the current 

dimension style settings. 

Fit Dimension Text Within Extension Lines 

When there is no enough space between extension lines to accept both of dimension text and 

arrowheads, you have to adjust one or both of their placement. By default, the system fits them 

best depending on the available space. You can also specify other methods to place them on the Fit 

tab of the Modify Dimension Style dialog box. If there is no room for placing text and arrowheads, 

however, you want to keep them together, and then they are both placed outside. If there is room 

for only text or arrowheads, you can specify either text only or arrowheads only to be placed 

between the extension lines. 

You can also choose the "Place text manually when dimensioning" option to place dimension text 

manually. 

The following illustrations show how system applies a "best fit" for arrowheads and text. 

 

If there is no space for text between the extension lines, the system creates a leader automatically 

to place text. You can set the relationship between them on the Text tab of the Modify Dimension 

Style dialog box. 

If you choose the "Always draw dim line between ext lines" option on the Fit tab of the Modify 

Dimension Style dialog box, system creates a line between the extension lines as dimension line 

even if neither the arrow heads nor the text are outside of the extension lines. Shown as follows 

 

To format dimensions 

Choose Dimension > Style. 

In the Dimension Style Manager dialog box, select the style you wish to change and choose Modify. 

In the Modify Dimension Style dialog box, click the Fit tab. 

Under Fit Options and Text Placement, select an option. 

Click OK. 

Choose Close to exit. 

Dimension toolbar:  
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Command line DIMSTYLE 

NOTE You can also specify how dimension text and arrows are arranged using the DIMATFIT 

system variable. You can specify how dimension text is moved using the DIMTMOVE system 

variable. 

 

Fit Diameter Dimension Text 

You can create various diameter dimensions based on text placement, fit options and the selection 

of "Always draw dim lines between ext lines" option on the Fit tab. Shown as follows: 

 

Control the Location of Dimension Text 

ZWCAD+ provides three justification settings: Horizontal, Aligned with dimension line, and ISO 

Standard. You can also specify other location for the text. Most of settings are interdependent. 

 

Align Dimension Text 

Whether the text is inside or outside the extension line, it has no effect on the justification of 

dimension text. You can choose whether the text is align with the dimension lines or remains 

horizontal. The following figures show the combination of these two options. The default 

justification is horizontal. 

 

To align dimension text with the dimension line 
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Choose Dimension > Style. 

In the Dimension Style Manager dialog box, select the style you wish to change and choose Modify. 

In the Modify Dimension Style dialog box, click the Text tab. 

Make your selections. 

Click OK. 

Choose Close to exit. 

Dimension toolbar:  

Command line DIMSTYLE 

 

Control the Location of Dimension Text 

You can place dimension text vertically or horizontally, and give the offset the text from the first 

extension line. 

Position Dimension Text Vertically 

The vertical text placement is the position of the text relative to the dimension. You can place text 

above, below, or centered within the dimension line, or use the JIS dimensions. 

Above places dimension text above the dimension line; Outside places dimension text on the side 

far from the point you specify for the dimension line; Centered places dimension text medially 

within the dimension line; JIS places dimension text according to the Japan industry standard. 

In the ANSI standards, centered dimension text splits the dimension line. In the ISO standards, 

centered text places above or outside the dimension line. In the following illustrations, ISO 

standards allow angular dimension text to display in any of the ways shown. 

 

The justification and other settings may affect the vertical alignment of text. If you select Horizontal 

Alignment, text inside the extension lines and centered within the dimension is placed horizontally, 

as shown in the leftmost figure above. 

Position Dimension Text Horizontally 

The position of text along the horizon is relation to the extension lines. The settings include 

Centered, At Ext Line 1, At Ext Line 2, Over Ext Line1, and Over Ext Line2. The following illustrations 

show the examples of Center and Over Ext Line 1applying to dimension text. 



 

 348 

 

As you create dimensions, the order you specified the extension line origins determines which 

extension line is first. For angular dimensions, the order is defined around the counterclockwise. In 

the following figures, the first extension line origin is 1 and the second one is 2. 

 

If the "Place text manually when dimensioning" option on the Fit tab of the Modify Dimension 

Style dialog box is chosen, as you create dimensions, you can place the dimension anywhere inside 

or outside the extension lines along the dimension line. This option is useful when the space 

between the extension lines is limited. 

Control the Appearance of Dimension Text 

Dimension text could be comprised of user-supplied text, prefixes and suffixes provided by the 

dimension style, and generated measurements. For example, you can add a radium symbol as a 

prefix to a measurement, or add an abbreviation for a unit beyond the text, such as cm. 

You can also set the text style and formats of color, height for the dimension text. 

Control the Text Style in Dimensions 

You can set the text style for dimension text on the Text tab of the Modify Dimension Style dialog 

box. You can also specify a dimension text color and a height irrelevant to the height value set by 

current text style. Choose the "draw frame around text" creates a frame when you create 

dimension text. 

The text styles applied to dimensions are the same as the one applied to all text created in your 

drawing. 

Supply User Text to Dimensions 

Besides of the prefixes and suffixes specified for primary and alternate units, you can provide your 

own text. Because the prefix, suffix, and user-supplied text can be treated as a single text string, 

they can be used to represent tolerance stacks and the changes can be applied to font, text size, 

and other characteristics using the text editor. 
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The separator symbol \X is used to separate user text above and below the dimension line. 

Text prior to this symbol is aligned with and below the dimension line. Text following this symbol is 

aligned with and below the dimension line. 

For example, if you select Text while creating dimensions, and then input user text "<> ZWCAD+ \X 

WELCOME", thus the user text is separated above and below the dimension line. In which, <> 

stands for main units, \X separates the text by a dimension line. 

 

Commands Reference 

DIMSTYLE: Creates and modifies dimension styles 

DIMTEDIT: Moves and rotates dimension text 

System Variables Reference 

DIMCLRT: Assigns colors to dimension text  

DIMFRAC: Sets the fraction format when DIMLUNIT is set to 4 (Architectural) or 5 (Fractional)  

DIMGAP: Sets the distance around the dimension text when the dimension line breaks to 

accommodate dimension text  

DIMTFAC: Specifies a scale factor for the text height of fractions and tolerance values relative to 

the dimension text height, as set by DIMTXT  

DIMTXSTY: Specifies the text style of the dimension 

DIMTXT: Specifies the height of dimension text, unless the current text style has a fixed height 

DIMJUST: Controls the horizontal positioning of dimension text 

DIMTAD: Controls the vertical position of text in relation to the dimension line 

DIMTIH: Controls the position of dimension text inside the extension lines for all dimension types 

except ordinate 

DIMTOH: Controls the position of dimension text outside the extension lines  

DIMTVP: Controls the vertical position of dimension text above or below the dimension line 

DIMUPT: Controls options for user-positioned text 
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DIMATFIT: Determines how dimension text and arrows are arranged when space is not sufficient 

to place both within the extension lines  

DIMLWD: Assigns lineweight to dimension lines 

DIMTIX: Draws text between extension lines 

DIMTOFL: Controls whether a dimension line is drawn between the extension lines even when the 

text is placed outside 

 Control Dimension Values 

Set the display format of dimension values. 

Dimension Units 

You can determine the appearance and format of the primary and alternate dimension units. The 

preview frame on the upper right corner of the Modify Dimension Style dialog box shows the 

appearance of the dimensions based on the current dimension style settings. 

On the Primary Units of the Modify Dimension Style dialog box, you can set the primary units for 

linear and angular dimensions, including unit format, numeric precision and so on. These settings 

control the display of dimension values. For linear dimension, you can also specify the prefix or 

suffix. The specified prefix replaces the prefixes used for diameter and radius dimensions (Ø  and R, 

respectively). 

 

To round off dimensions 

Choose Dimension > Style from the main menu. 

In the Dimension Style Manager dialog box, select the style you wish to change and choose Modify. 

In the Modify Dimension Style dialog box, click the Primary Units tab. 

In the Linear Dimensions and Angular Dimensions fields, type or select the nearest value to which 

you want to round off dimensions. 

Click OK. 

Choose Close to exit. 

Dimension toolbar:  

Command line DIMSTYLE 

NOTE You can also specify units for linear dimensions using the DIMLUNIT system variable. You 

can specify fraction formats using the DIMFRAC system variable. 
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Alternate Units 

You can create a dimension in two systems of measurement simultaneously in a drawing. This 

feature is helpful when you want to add feet and inches dimensions in a drawing created using 

metric units. The alternative units appear in a square brackets ([]) in the dimension text. Alternative 

units can be applied to linear dimensions only. 

If you turn alternative-units dimensioning on when editing a linear dimension, the measurement is 

multiplied by a specified alternate scale value. This value indicates the number of alternate units 

per current unit of measurement. The default fault value for imperial units is 25.4, which 

represents that each inch is equivalent of 25.4 millimeter. The default value for metric units is 

0.0394, which represents that each millimeter is equivalent of 0.0394 inch. The precision for 

alternate units determines the number of decimal places. 

For example, for imperial units, if you specify the default value of 25.4 to the alternate scale setting, 

and 0.00 to the alternate precision, the dimension is shown as the following figure. 

 

To create an alternate dimension 

Choose Dimension > Style. 

In the Dimension Style Manager dialog box, select the style you wish to change and choose Modify. 

In the Modify Dimension Style dialog box, click the Alternate Units tab. 

Click the Display Alternate Units check box. 

Make your selections. 

Click OK. 

Choose Close to exit. 

Dimension toolbar:  

Command line DIMSTYLE 

 

Round Off Dimension Values 

Except of angle dimensions, all other dimension values can be rounded off. For example, if you 

specify a round-off value of 0.75, all distance are rounded to the nearest 0.75 unit. The number of 

decimal places is determined by the precision set for primary and alternate units and lateral 

tolerance values. 



 

 352 

 

Suppress Zeros in Dimensions 

Control how to deal with leading and trailing zero in the numeric portion of dimension text. If you 

suppress leading zero in decimal dimensions, 0.700 becomes .700; if you suppress trailing zero, 

0.7000 becomes 0.7. If you suppress both leading and trailing zeros, 0.7000 becomes .7 and 0.0000 

becomes 0. 

The following paragraph shows the effect of selecting zero feet and zero inches using architectural 

units style. If feet are included with a fractional inch, the number of inches is always indicated as 

zero and ignores any option you select. So, the dimension 4'-3/4" becomes 4'-0 3/4". 

Option Effect Examples 

No options selected Includes zero feet and zero inches 
0'-0 1/2" 0'-6" 1'-0" 1'-0 

3/4" 

0 Inches selected Suppresses zero inches (includes zero feet) 0'-0 1/2" 0'-6" 1' 1'-0 3/4" 

0 Feet selected  Suppresses zero feet (includes zero inches) 1/2" 6" 1'-0" 1'-0 3/4" 

0 Feet and 0 Inches selected Suppresses zero feet and zero inches 1/2" 6" 1' 1'-0 3/4" 

Display Lateral Tolerances 

Lateral tolerance represents a value that the amount a measured distance can vary. You can control 

the degree of accuracy needed for a future by specifying tolerances in manufacturing. A feature is 

some aspect of a part, such as a line, axis, point, or surface. 

You can append tolerances to the dimension text directly. These dimension tolerances indicate the 

largest and smallest permissible size. You can also apply geometric tolerances to indicate deviations 

of form, profile, location, orientation, and runout. 

You can specify exact measurements to lateral tolerances theoretically. They are called basic 

dimensions and have a box drawn around them. 

Deviation tolerances represent with the plus and minus values that are appended to the dimension 

values. If the deviation tolerances are equal, the ± signs precede them and they are known as 

symmetrical. Otherwise, the plus value locates above the minus value. Shown as the following 

figures. 
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If you apply the tolerance as a limit, ZWCAD+ calculates a maximum and minimum value using the 

positive and negative values provided. These values replace the original dimension values. The 

upper tolerance locates above the lower if you specify deviation tolerances. 

 

The vertical placement of tolerance values that is relative to the main dimension text can be 

specified. For example, you can align the tolerances with the top, middle, or bottom of the 

dimension text. 

 

You can also control how to suppress zero for tolerance values, as you can with the primary and 

alternate units. The effect of suppressing zero in lateral tolerance is the same as suppressing zero in 

the primary and alternate units. 

 

Commands Reference 

DIMSTYLE: Creates and modifies dimension styles 

System Variables Reference 

DIMALT: Controls the display of alternate units in dimensions 

DIMALTD: Controls the number of decimal places in alternate units 

DIMALTF: Controls the multiplier for alternate units 

DIMALTTD: Sets the number of decimal places for the tolerance values in the alternate units of a 
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dimension 

DIMALTU: Sets the units format for alternate units of all dimension style family members except 

angular 

DIMALTZ: Controls the suppression of zeros for alternate unit dimension values 

DIMAPOST: Specifies a text prefix or suffix (or both) to the alternate dimension measurement for 

all types of dimensions except angular 

DIMAUNIT: Sets the units format for angular dimensions 

DIMDEC: Specifies a text prefix or suffix (or both) to the alternate dimension measurement for all 

types of dimensions except angular 

DIMLFAC: Sets a scale factor for linear dimension measurements 

DIMLUNIT: Sets units for all dimension types except Angular 

DIMPOST: Specifies a text prefix or suffix (or both) to the dimension measurement 

DIMTDEC: Sets the number of decimal places to display in tolerance values for the primary units in 

a dimension 

DIMRND: Rounds all dimensioning distances to the specified value 

DIMAZIN: Controls the suppression of zeros in tolerance values 

DIMZIN: Controls the suppression of zeros in the primary unit value 

DIMALTTZ: Sets the number of decimal places for the tolerance values in the alternate units of a 

dimension 

DIMGAP: Sets the distance around the dimension text when the dimension line breaks to 

accommodate dimension text  

DIMLIM: Generates dimension limits as the default text 

DIMTFAC: Specifies a scale factor for the text height of fractions and tolerance values relative to 

the dimension text height, as set by DIMTXT 

 Set the Scale for Dimensions 

Set the scale for dimensions. Setting dimension scale depends on the method you use to lay out 

and plot drawings. 
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Dimension scale has effects on the size of dimension geometry relative to the objects in the 

drawing. In addition to text height and arrowhead size, dimension scale affects offsets in dimension 

as well, such as the extension line origin offset. When you create dimensions, it's recommended to 

set the size and offset to values that represent their actual plotted size. However, the tolerances, 

measured lengths, coordinates, and angles cannot be applied to the overall scale factor. 

The method you lay out your drawing determines how to set the dimension scale. The method of 

creating dimensions in a drawing layout is shown as follows: 

Dimension in model space for plotting in model space. If you want to create dimensions that are 

scaled correctly for plotting, you have to set the system variable DIMSCALE to the inverse of the 

desired plot scale. For example, if the plot scale is 1/4, you have to set DIMSCALE to 4. 

Dimension in model space for plotting in paper space. If you want to create dimensions that are 

scaled automatically for display in a paper space layout, you have to set the DIMSCALE to 0. This 

method is useful when you encounter the following situations: the dimensions in a drawing need to 

be referenced by other drawings (xrefs); when you create isometric dimensions in 3D isometric 

views. To prevent the dimensions in one layout viewport from being displayed in other layout 

viewports, it's recommended to create a dimensioning layer for each layout viewport that is frozen 

in all other layout viewports. 

Dimension in layouts. You can create dimensions in paper space by selecting model space objects 

or by specifying object snap locations on model space objects. The dimensions created in a paper 

space layout do not need additional scaling: there is no need to change the default value of 

DIMLFAC and DIMSCALE. 

 

Commands Reference 

DIMSTYLE: Creates and modifies dimension styles 

System Variables Reference 

DIMLFAC: Sets a scale factor for linear dimension measurements 

DIMSCALE: Sets the overall scale factor applied to dimensioning variables that specify sizes, 

distances, or offsets  

10.3 Create Dimensions 

You can create dimensions by: 

Selecting the entity to dimension and specifying the dimension line location. 

Specifying the extension line origins and the dimension line location. 

When you create dimensions by selecting an entity, the program automatically places the extension 

line origins at the appropriate definition points based on the type of entity you select. For example, 

the definition points are located at the endpoints of arcs, lines, and polyline segments. When you 

create dimensions by specifying the extension line origins, the points you specify determine the 

definition points. To establish these points precisely, use entity snaps. 
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Topics in this section: 

 Create Linear Dimensions 

Linear dimensions annotate linear distances or lengths and can be oriented horizontally, vertically, 

or aligned parallel to an existing entity or to the selected extension origin points.  

 Create Angular Dimensions 

Angular dimensions are used to measure the angle between lines or three points. You can 

dimension objects including circles, arcs, and lines.  

 Create Radial Dimensions 

You can create radial dimensions and jogged dimensions for circles or arcs to measure their radial.  

 Create Diameter Dimensions 

You can create diameter dimensions for circles or arcs to measure their diameters. Creating 

diameter dimensions resembles creating radial dimensions. 

 Create Ordinate Dimensions 

Ordinate dimensions are used to measure the perpendicular distance from an origin point called 

the datum to a feature, such as a hole in a part. Ordinate dimensions are comprised of a leader line 

with an X or Y value. 

 Create Quick Dimension 

Creates or edits a series of dimensions quickly by typing QDIM command. 

 Arc Length Dimension  

Arc length dimension is available for measuring the arc length of arc or polyline arc segment. 

 Create Linear Dimensions 

Linear dimensions annotate linear distances or lengths and can be oriented horizontally, vertically, 

or aligned parallel to an existing entity or to the selected extension origin points. After you create a 

linear dimension, you can add a baseline dimension or a continued dimension. A linear baseline 

dimension inserts an additional dimension from a common first extension line origin of a previous 

linear dimension. A linear continued dimension continues a linear dimension from the second 
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extension line of a previous linear dimension. 

TIP To select precise ordinate points, use entity snaps. 

Create Horizontal and Vertical Dimensions 

As you create linear dimensions, the system automatically applies a horizontal or vertical 

dimension depending on the specified extension line origins or the location where you select an 

object. However, you can create a dimension by specifying it be horizontal or vertical. 

In the following illustration, by default, a horizontal dimension is created unless you specify a 

vertical one. 

 

To create a horizontal or vertical dimension 

Choose Dimension > Linear from the main menu. 

Press Enter, and then select the object to dimension. 

Or, you can insert the dimension by specifying the first and second extension line origins. 

Specify the dimension line location. 

Dimension toolbar:  

Command line DIMLINEAR 

 

Create Aligned Dimensions 

In the aligned dimensions, the dimension line is parallel to the line passing through the extension 

line origins. The aligned dimension is also parallel to the objects you specify. The following figure 

shows two examples of aligned dimension. Select the object (1), and then specify the location of 

the aligned dimension. The system creates the extension lines automatically. 

 

To create an aligned dimension 

Choose Dimension > Aligned from the main menu. 

Press Enter, and then select the object to dimension. 
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Or, you can insert the dimension by specifying the first and second extension line origins. 

Specify the dimension line location. 

Dimension toolbar:  

Command line DIMALIGNED 

 

To insert an aligned dimension by selecting 

the entity, select the entity (A) to 

dimension, and then select the dimension 

line location (B). 

Result 

 

To insert an aligned dimension by selecting 

the extension line origins, select the first 

extension origin (A), select the second 

extension origin (B), and then specify the 

dimension line location (C). 

Result 

 

Create Baseline and Continued Dimensions 

Both baseline and continued dimensions are multiple linear dimensions. Baseline dimensions are 

measured from the dame baseline and continued dimensions are placed end to end. 

Before creating either baseline or continued dimension, you have to create a linear, aligned, or 

angular dimension. If no dimension in the current session, the system prompts for selecting linear, 

aligned, or angular dimension. If there are dimensions in the current session, you can create 

baseline or continued dimensions incrementally from the most recently created dimension. Unless 

you specify another point as the origin, both baseline and continued dimensions are always 

measured from the previous extension line. 

The following illustration shows the baseline and continued dimensions. 
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To create a linear baseline dimension 

NOTE Before you can use this procedure, you must first create a dimension. 

Choose Dimension > Baseline from the main menu. 

Specify a second extension line origin or press Enter to select a dimension as baseline. 

Select the next extension line origin. 

Continue selecting extension line origins as required.  

To end the command, press Enter twice. 

Dimension toolbar:  

Command line DIMBASELINE 

The program automatically places the new baseline dimension above or below the previous 

dimension line. The distance between two dimension lines is determined by the Baseline Spacing 

value on the Lines and Arrows tab of the New Dimension Style or Modify Dimension Style dialog 

box. 

 

To add a baseline dimension to an existing linear 

dimension, select the existing dimension (A), select 

the next extension line origin (B), and select as 

many additional points as you want (C). 
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Result 

 

To create a linear continued dimension 

NOTE Before you can use this procedure, you must first create a dimension. 

Choose Dimension > Continue from the main menu. 

To select a starting dimension, press Enter. 

Select the next extension line origin, and then press Enter. 

Or press Enter, and then select an existing dimension to continue. 

To add continued dimensions, continue selecting extension line origins. 

To end the command, press Enter twice. 

Dimension toolbar:  

Command line DIMCONTINUE 

 

To add a continued dimension to an existing linear 

dimension, select the existing dimension (A), select 

the next extension line origin (B), and select another 

extension line origin (C). 
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Result. 

 

Create Rotated Dimensions 

You can create rotated dimensions at a rotated angle you specify using DIMLINEAR Rotated option. 

An example of a rotated dimension is shown in the following illustration. In this illustration, the 

specified angle of the rotated dimension is equal to the angle of the slot. 

 

Create Dimensions with Oblique Extension Lines 

By default, the extension lines are perpendicular to the dimension line. However, if the extension 

lines conflict with other objects in a drawing, you can use Dimension-Oblique menu option to 

change their angles measured from the X axis of the current UCS to the extension line. This option 

is only applied to the existing dimensions, ignoring the dimensions to be created. 

 

 

Commands Reference 

DIMALIGNED: Creates an aligned linear dimension 

DIMBASELINE: Creates a linear, angular, or ordinate dimension from the baseline of the previous 

dimension or a selected dimension  

DIMCONTINUE: Creates a linear, angular, or ordinate dimension from the second extension line 

of the previous dimension or a selected dimension 

DIMEDIT: Edits dimensions 
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DIMLINEAR: Creates linear dimensions 

DIMSTYLE: Creates and modifies dimension styles 

QDIM: Quickly creates a dimension 

System Variables Reference 

DIMDLI: Controls the spacing of the dimension lines in baseline dimensions 

DIMEXO: Specifies how far extension lines are offset from origin points 

 Create Angular Dimensions 

Angular dimensions are used to measure the angle between lines or three points. You can 

dimension objects including circles, arcs, and lines. You can also create an angular dimension 

directly with three specified points. By selecting the circle and specifying the angle endpoints, you 

can create the angular dimension to measure the angle between two radii of a circle. For other 

objects, you choose the objects and specify the dimension location. You can also create an angular 

dimension by specifying the angle vertex and endpoints. 

When you create the angular dimension, you can modify the text contend and alignment before 

placing the dimension line. 

With the existing angular dimensions, you can also create baseline and continued angular 

dimensions. Baseline and continued dimensions should not be over 180 degrees. To acquire 

baseline and continued dimensions that are larger than 180 degrees, you have to stretch the 

position of the extension line of an existing baseline or continued dimension using grid editing. 

Dimension Lines 

Angular dimension lines are typically represented with arc segments. To create an angular 

dimension for two nonparallel lines, the dimension line arc spans the angle between the two lines. 

As you specify the dimension line arc location, if the dimension line arc does not intersect one or 

two extension lines being dimensioned, the system automatically draws them. The dimension line 

arc is always less than 180 degrees. However, for the circles and arcs, the dimension line arc can be 

up to 360 degrees. 

To dimension an angle between two lines 

Choose Dimension > Angular from the main menu. 

Select one line. 

Select the other line. 

Specify the dimension line location. 

Dimension toolbar:  

Command line DIMANGULAR 
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Select one line (A), select the other line (B), 

and then specify the dimension line location 

(C). 

Result 

 

Dimension Circles and Arcs 

If the object to be dimensioned is circle or arc, the dimension line arc is placed between the 

extensions. The dimension line arc is also drawn between the extension lines when you use three 

points to create an angular dimension. The quadrant of the dimensioned angle depends on the 

location that you specify for the dimension line arc. 

 

To dimension an angle encompassed by an arc 

Choose Dimension > Angular from the main menu. 

Select the arc. 

Specify the dimension arc location. 

Dimension toolbar:  

Command line DIMANGULAR 

 

To dimension the angle subtended by an 

arc, Select the arc (A), and then specify the 

dimension arc location (B). 

Result 
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Commands Reference 

DIMANGULAR: Creates an angular dimension 

DIMBASELINE: Creates a linear, angular, or ordinate dimension from the baseline of the previous 

dimension or a selected dimension  

DIMCONTINUE: Creates a linear, angular, or ordinate dimension from the second extension line 

of the previous dimension or a selected dimension 

System Variables Reference 

DIMADEC: Controls the number of precision places displayed in angular dimensions 

DIMAUNIT: Sets the units format for angular dimensions 

DIMDEC: Sets the number of decimal places displayed for the primary units of a dimension 

 Create Radial Dimensions 

You can create radial dimensions for circles or arcs to measure their radial. The radial dimension is a 

radial dimension line with an arrowhead that points to a circle or arc. To display centerlines or a 

center mark, set the system variable DIMCEN to nonzero. 

If the Text Placement on the Fit tab of the New Dimension Style or Modify Dimension Style dialog 

box is set to "Over the dimension line, with a leader", then the dimension is applied along with a 

leader line. 

Both center marks and lines apply only to radius and diameter dimensions. They are created only 

when you place the dimension outside the circle or arc. The size of the centerline is the distance of 

the centerline segment that extends outside the circle or arc, shown as the following illustration: 

 

To create a radial dimension 

Choose Dimension > Radius from the main menu. 

Select the arc or circle. 

Specify the dimension line location. 
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Dimension toolbar:  

Command line DIMRADIUS 

 

Select the circle (A), and then specify the 

dimension line location (B). 

Result 

 

Jogged Dimension 

Jogged dimension is namely jogged radius dimension, which is also called "scaled radius 

dimension". User can specify center position to place the origin of dimension for replacing center 

point of circle or arc within radius dimension. DIMJOGGED command is useful for creating 

dimensions in case that the center of circle or arc to be dimensioned is located outside the layout 

and can't be displayed in its actual position either. 

You can set the angle of jogged radius from "Other Items" tab either in "New Dimension Style" 

dialog box or "Modify Dimension Style" dialog box. 

For a jogged radius dimension having been created, you can modify its jog and center position by 

means of grip editing, Properties palette and executing STRETCH command. 

To create a jogged radius dimension 

Choose Dimension > Jogged from the main menu. 

Select a circle or an arc. 

Select center position as the dimension origin. 

Specify a point to position the jog symbol. 

Dimension toolbar:  

Command line DIMJOGGED 

 

Commands Reference 

DIMCENTER: Creates the center mark or the centerlines of circles and arcs  

DIMDIAMETER: Creates diameter dimensions for circles and arcs 
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DIMJOGGED: Creates jogged dimensions for circles, arcs, and polyline arc segments 

DIMRADIUS: Creates radial dimensions for circles and arcs 

QDIM: Quickly creates a dimension 

System Variables Reference 

DIMATFIT: Determines how dimension text and arrows are arranged when space is not sufficient 

to place both within the extension lines  

DIMCEN: Controls drawing of circle or arc center marks and centerlines by the DIMCENTER, 

DIMDIAMETER, and DIMRADIUS commands  

DIMJOGANG: Specifies the angle of the transverse segment of the dimension line in a jogged 

radius dimension 

DIMJUST: Controls the horizontal positioning of dimension text 

DIMTAD: Controls the vertical position of text in relation to the dimension line 

DIMTIH: Controls the position of dimension text inside the extension lines for all dimension types 

except ordinate 

DIMTMOVE: Sets dimension text movement rules 

DIMTOFL: Controls whether a dimension line is drawn between the extension lines even when the 

text is placed outside  

DIMTOH: Controls the position of dimension text outside the extension lines 

DIMUPT: Controls options for user-positioned text 

 Create Diameter Dimensions 

You can create diameter dimensions for circles or arcs to measure their diameters. Creating 

diameter dimensions resembles creating radial dimensions. 

You can create various diameter dimensions based on the location and size of circles or arc, and the 

settings of the dimension style. Either drawing a center mark or line is controlled by the dimension 

style. If the dimension line is created inside a circle or arc, the center mark or line is not drawn. The 

system variable DIMCEN controls whether the center mark or line is displayed. 

To create a diametral dimension 

Choose Dimension > Diameter from the main menu. 

Select the arc or circle. 
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Specify the dimension line location. 

Dimension toolbar:  

Command line DIMDIAMETER 

 

Select the circle (A), and then specify the 

dimension line location (B). 

Result 

 

Commands Reference 

DIMCENTER: Creates the center mark or the centerlines of circles and arcs  

DIMDIAMETER: Creates diameter dimensions for circles and arcs 

DIMRADIUS: Creates radial dimensions for circles and arcs 

QDIM: Quickly creates a dimension 

System Variables Reference 

DIMATFIT: Determines how dimension text and arrows are arranged when space is not sufficient 

to place both within the extension lines  

DIMCEN: Controls drawing of circle or arc center marks and centerlines by the DIMCENTER, 

DIMDIAMETER, and DIMRADIUS commands  

DIMJUST: Controls the horizontal positioning of dimension text 

DIMTAD: Controls the vertical position of text in relation to the dimension line 

DIMTIH: Controls the position of dimension text inside the extension lines for all dimension types 

except ordinate 
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DIMTMOVE: Sets dimension text movement rules 

DIMTOFL: Controls whether a dimension line is drawn between the extension lines even when the 

text is placed outside  

DIMTOH: Controls the position of dimension text outside the extension lines 

DIMUPT: Controls options for user-positioned text 

 Create Ordinate Dimensions 

Ordinate dimensions are used to measure the perpendicular distance from an origin point called 

the datum to a feature, such as a hole in a part. Ordinate dimensions are comprised of a leader line 

with an X or Y value. These dimensions are called datum dimensions. X or Y value is calculated in 

the current UCS, and leaders are drawn along the orthographic direction at the current UCS. The 

dimension values are the absolute values. By maintaining accurate offsets of the features from the 

datum, these dimensions can prevent escalating errors. 

 

X ordinate dimensions show the distance of a feature from the datum along the X axis. And Y 

ordinate dimensions show the distance along the Y axis. The system determines whether the 

dimension is X or Y ordinate dimension depending on the point you specify. If the distance is 

greater for the Y value, the system creates an X ordinate dimension. Otherwise, the system creates 

a Y ordinate dimension. 

 

X and Y ordinate values are determined by the absolute coordinate value of the current UCS. Before 

creating ordinate dimensions, it recommends you to reset the UCS origin to coincide with the 

datum. 
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In ordinate dimensions, the dimension text is always aligned with the ordinate leader line, ignoring 

the text orientation defined by the current dimension style. You can also supply your own text or 

accept the default one. 

To create an ordinate dimension 

Choose Dimension > Ordinate from the main menu. 

Select the point for an ordinate dimension. 

Specify the ordinate leader endpoint. 

Dimension toolbar:  

Command line DIMORDINATE 

 

Select the ordinate point (A), and then 

specify the ordinate leader endpoint 

(B). 

TIP To select precise ordinate points, use entity snaps. 

 

Commands Reference 

DIMORDINATE: Creates ordinate point dimensions 

System Variables Reference 
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None 

 Create Quick Dimension 

Creates or edits a series of dimensions quickly by typing QDIM command. 

To create a quick dimension 

Choose Dimension > Quick Dimension from the main menu. 

Select the geometry to dimension, and then press Enter. 

On the command line, it will display "Specify dimension line position, or 

[Continuous/Staggered/Baseline/Ordinate/Radius/Diameter/datumPoint/Edit/seTtings] 

<Continuous>:". 

You can perform the operation as desired. The default is Continuous. 

Dimension toolbar:  

Command line QDIM 

 

Commands Reference 

QDIM: Creates or edits a series of dimensions quickly 

System Variables Reference 

None 

 Create Arc Length Dimensions 

Arc length dimension is available for measuring the arc length of arc or polyline arc segment. 

ZWCAD+ creates arc length dimension by specifying extension line position directly after selecting 

arc by default. And use an arc symbol as arc length dimension logo, which is differing from linear 

dimension and angular dimension. 

Arc symbol of arc length dimension displays both in front of the dimension text and above it, which 

is adjustable from "Other Items" tab either in "New Dimension Style" dialog box or "Modify 

Dimension Style" dialog box. 
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Additionally, orthogonal or radial extension line is available for arc length dimension, only the 

included angle of the arc segment selected for creating arc length dimension is smaller than 90 

degree can display it's orthogonal extension line. 

To create an arc length dimension 

Choose Dimension > Arc Length from the main menu. 

Select an arc or polyline arc segment. 

Specify a point to position the arc length dimension. 

Dimension toolbar:  

Command line DIMARC 

 

Commands Reference 

DIMARC: Creates an arc length dimension for an arc or polyline arc segment  

DIMCENTER: Creates the center mark or the centerlines of circles and arcs  

DIMDIAMETER: Creates diameter dimensions for circles and arcs 

DIMJOGGED: Creates jogged dimensions for circles, arcs, and polyline arc segments 

DIMRADIUS: Creates radial dimensions for circles and arcs 

QDIM: Quickly creates a dimension 

System Variables Reference 

DIMARCSYM: Specifies the location of the arc symbol in an arc length dimension 

DIMATFIT: Determines how dimension text and arrows are arranged when space is not sufficient 

to place both within the extension lines  

DIMCEN: Controls drawing of circle or arc center marks and centerlines by the DIMCENTER, 

DIMDIAMETER, and DIMRADIUS commands  

DIMJOGANG: Specifies the angle of the transverse segment of the dimension line in a jogged 

radius dimension 

DIMJUST: Controls the horizontal positioning of dimension text 



 

 372 

DIMTAD: Controls the vertical position of text in relation to the dimension line 

DIMTIH: Controls the position of dimension text inside the extension lines for all dimension types 

except ordinate 

DIMTMOVE: Sets dimension text movement rules 

DIMTOFL: Controls whether a dimension line is drawn between the extension lines even when the 

text is placed outside  

DIMTOH: Controls the position of dimension text outside the extension lines 

DIMUPT: Controls options for user-positioned text 

10.4 Modify Existing Dimensions 

You can modify all components of the existing dimension objects in a drawing either individually or 

by using dimension styles.  

Topics in this section: 

 Modify Dimension Style 

You can modify all of properties of the existing dimension objects in a drawing using dimension 

styles. You can also create a dimension style override to temporarily change a dimensioning system 

variable without changing the current dimension style. 

 Make Dimensions Oblique 

Extension lines are normally created at a perpendicular angle to the dimension line. You can change 

the angle of the extension lines, however, so that they tilt relative to the dimension line. 

 Modify Dimension Text 

You can change the existing dimension text including text content, location and orientation. 

 Dimension Jogged 

The DIMJOGLINE command is available for adding or removing jog symbol for linear dimensions, 

showing a dimension value differs from its factual measured dimension value. Generally, the value 

displayed here is greater than the actual measurement value.  

 Dimension Inspection 
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You can add or remove dimension inspection for existing dimensions. For transmitting the 

frequency of inspecting the part being dimensioned, the dimension value and parts tolerance are 

ensured to be within specified range. 

 Adjust Dimension Space 

Adjusts the space among these paralleled lines with an equal value either default or specified. 

 Modify Dimension Style 

You can modify all of properties of the existing dimension objects in a drawing using dimension 

styles. You can also create a dimension style override to temporarily change a dimensioning system 

variable without changing the current dimension style. 

As you create dimensions, the system applies the default current dimension style to the dimensions. 

The created dimension remains this style unless you apply a new dimension style to it or set up 

dimension style overrides. 

You can also modify the current dimension style and apply it to existing dimensions. If a dimension 

style is changed, the dimension associated with that dimension style updates automatically. 

Override a Dimension Style 

Overriding a dimension style changes a dimensioning system variable without changing the current 

dimension. You can define dimension style overrides for the following situations: 

For individual dimensions, you may want to modify some properties of dimensions, such as 

suppressing a dimension's extension lines or modifying text and arrowhead placement so that they 

do not overlap drawing geometry, without creating a new dimension style. 

Set up overrides to the current dimension style. As you have create a dimension style override, all 

dimensions that are created in this dimension style include the overrides, until you delete overrides, 

save the overrides to a new style, or make another style current. For example, you can change the 

extension lines' color on the Lines and Arrows tab by clicking the Override button in the Dimension 

Style Manager, and keep the current dimension style unchanged. However, the new value for color 

is stored in the system variable DIMCLRE. The extension lines of the dimension you create will 

apply the new color. The dimension style overrides can be saved as the current dimension style. 

Dimension style includes some common dimension characteristics that are suited to be saved 

permanently, and some are applied on an individual basis that can be applied more effectively as 

overrides. For example, a single type of arrowhead is often used in a drawing, so it is suited to be 

saved as part of the dimension style. However, suppression of extension lines often applies in 

individual cases only and is more suited to a dimension style override. 

The overrides apply to the dimension you are creating and all subsequent dimensions that are 

created with it, until you reverse it or set another dimension style to current. 

 

Commands Reference 

DIMOVERRIDE: Overrides dimensioning system variables 
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DIMSTYLE: Creates and modifies dimension styles 

PROPERTIES: Controls properties of existing objects 

System Variables Reference 

DIMCLRD: Assigns colors to dimension lines, arrowheads, and dimension leader lines 

DIMSTYLE: Shows the current dimension style 

 Make Dimensions Oblique 

Extension lines are normally created at a perpendicular angle to the dimension line. You can change 

the angle of the extension lines, however, so that they tilt relative to the dimension line. 

To make oblique extension lines 

Choose Dimension > Oblique from the main menu. 

Select the linear dimension, and then press Enter. 

Type the obliquing angle, and then press Enter. 

Dimension toolbar:  

Command line DIMEDIT 

 

Select the dimension to be made oblique (A), 

and then type the obliquing angle. 

Result. 

TIP To align the oblique angle if you don't know the exact measurement, 

use snaps to pick two points on the entity. 

 

Commands Reference 
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DDEDIT: Edits text, dimension text, attribute definitions, and feature control frames 

DIMEDIT: Edits dimensions 

DIMTEDIT: Moves and rotates dimension text 

PROPERTIES: Controls properties of existing objects  

System Variables Reference 

DIMCLRT: Assigns colors to dimension text 

DIMDSEP: Specifies a single-character decimal separator to use when creating dimensions whose 

unit format is decimal  

DIMJUST: Controls the horizontal positioning of dimension text 

DIMTAD: Controls the vertical position of text in relation to the dimension line 

DIMTIH: Controls the position of dimension text inside the extension lines for all dimension types 

except ordinate 

DIMTMOVE: Sets dimension text movement rules 

DIMTOH: Controls the position of dimension text outside the extension lines 

DIMTVP: Controls the vertical position of dimension text above or below the dimension line 

DIMUPT: Controls options for user-positioned text 

MTEXTED: Sets the primary and secondary text editors to use for multiline text objects 

 Modify Dimension Text 

You can change the existing dimension text including text content, location and orientation. 

The existing text in a drawing can be rotated, moved to a new location, or replaced with new text. 

You can also move the text back to its home position using Dimension-Align Text-Home menu 

option. This default location is defined in the current dimension style. In the following figures, the 

home position is specified above and centered on the dimension line. 
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You can rotate the specified text at an angle using the Dimension-Align Text-Angle menu option, or 

change the angle and content in the Properties palette. 

When you move text, you have to select a single dimension to move first. You can move the 

dimension text anywhere along the dimension line. You can use grips to move text up or down, 

which does not change the current vertical alignment of the text placement relative to the 

dimension line. However, the dimension and extension lines are modified accordingly. The 

following figure shows the effect of moving text up and to the right. The text placement relative to 

the dimension still remains centered and vertical. 

 

To rotate dimension text 

On the command line, type DIMEDIT. 

Type R (Rotate). 

Type the new dimension text angle, and then press Enter. 

Select the dimension to be rotated, and then press Enter. 

Dimension toolbar:  

 

NOTE The dimension text angle is relative to the dimension line. If the 

dimension text rotation is set to zero, the text angle is defined by the 

dimension type and the dimension style. 
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To move dimension text 

On the command line, type DIMTEDIT. 

Select the dimension to reposition text. 

Select the new text position. 

Dimension toolbar:  

 

Select the dimension to be moved (A), and 

then select the new text position (B). 

Result 

 

To restore dimension text to its home position 

On the command line, type DIMEDIT. 

Type H (Home). 

Select the dimension text to restore, and then press Enter. 

Dimension toolbar:  

 

To replace existing dimension text with new text 

On the command line, type DIMEDIT. 

Type N (New). 

Type the new dimension text, and then press Enter. 

Select the dimension to be replaced, and then press Enter. 

Dimension toolbar:  

 

Commands Reference 

DDEDIT: Edits text, dimension text, attribute definitions, and feature control frames 

DIMEDIT: Edits dimensions 
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DIMTEDIT: Moves and rotates dimension text 

PROPERTIES: Controls properties of existing objects  

System Variables Reference 

DIMCLRT: Assigns colors to dimension text 

DIMDSEP: Specifies a single-character decimal separator to use when creating dimensions whose 

unit format is decimal  

DIMJUST: Controls the horizontal positioning of dimension text 

DIMTAD: Controls the vertical position of text in relation to the dimension line 

DIMTIH: Controls the position of dimension text inside the extension lines for all dimension types 

except ordinate 

DIMTMOVE: Sets dimension text movement rules 

DIMTOH: Controls the position of dimension text outside the extension lines 

DIMTVP: Controls the vertical position of dimension text above or below the dimension line 

DIMUPT: Controls options for user-positioned text 

MTEXTED: Sets the primary and secondary text editors to use for multiline text objects 

 Dimension Jogged 

The DIMJOGLINE command is available for adding or removing jog symbol for linear dimensions, 

showing a dimension value differs from its factual measured dimension value. Generally, the value 

displayed here is greater than the actual measurement value. 

Jogged line is composed by two paralleled lines and a connecting line with 40 degree between 

them. As for the height of jogged line, user can set it from "Other Items" tab either in "New 

Dimension Style" dialog box or "Modify Dimension Style" dialog box. 

After adding jog symbol to the linear dimension, the jog is default to be placed at the center point 

between first extension line and dimension text, or center point based on the dimension text. To 

relocate jog symbol, you can adjust the position of dimension text or specify new position to locate 

jog after reselecting dimension. 

To add a jog to linear dimension 

Choose Dimension > Jogged Linear from the main menu. 

Select a linear dimension. 

Specify a point on the dimension line to determine the jog symbol, or press ENTER directly to 
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position the jog symbol in default place. 

Dimension toolbar:  

Command line  DIMJOGLINE 

 

 

Commands Reference 

DDEDIT: Edits text, dimension text, attribute definitions, and feature control frames 

DIMEDIT: Edits dimensions 

DIMJOGLINE: Adds or removes a jog on the specified linear dimension 

DIMTEDIT: Moves and rotates dimension text 

PROPERTIESES: Controls properties of existing objects  

System Variables Reference 

DIMCLRT: Assigns colors to dimension text 

DIMDSEP: Specifies a single-character decimal separator to use when creating dimensions whose 

unit format is decimal  

DIMJUST: Controls the horizontal positioning of dimension text 

DIMTAD: Controls the vertical position of text in relation to the dimension line 

DIMTIH: Controls the position of dimension text inside the extension lines for all dimension types 

except ordinate 

DIMTMOVE: Sets dimension text movement rules 
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DIMTOH: Controls the position of dimension text outside the extension lines 

DIMTVP: Controls the vertical position of dimension text above or below the dimension line 

DIMUPT: Controls options for user-positioned text 

MTEXTED: Sets the primary and secondary text editors to use for multiline text objects 

 Dimension Inspection 

You can add or remove dimension inspection for existing dimensions. For transmitting the 

frequency of inspecting the part being dimensioned, the dimension value and parts tolerance are 

ensured to be within specified range. 

Dimension inspection can be added to any type of dimension objects, which is composed by a 

frame and internal text. You can specify the shape of inspection frame as round, angular or none. 

An inspection dimension contains utmost three kinds of information field: inspection tag, 

dimension value and inspection rate. Using a perpendicular line to divide the dimension 

information among each field. 

 

In which, inspection tag, used for mark the text of dimension inspection is located at the left side 

within the inspection frame. 

Dimension value here is the value before adding dimension inspection, which is located at the 

central part of the inspection dimension including tolerance, text and measurement value. 

Inspection rate which is expressed by percentage is located at the right side within the inspection 

frame, indicates required frequency of the part being created. 

To create an inspection dimension 

Choose Dimension > Inspect from the main menu. 

In the Inspection Dimension dialog box, click Select Dimensions button. 

Close the Inspection Dimension dialog box temporarily to switch to drawing area. 

Select dimensions to add dimension inspection, and then press ENTER to finish selection and 

return to the dialog box. 

Select a shape for frame from the Shape option. 

Click Label option to input label in the text box. 

Click Inspection Rate option to input a value in the text box. 

Click OK. 

Dimension toolbar:  
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Command line  DIMINSPECT 

 

To remove an inspection dimension 

Choose Dimension > Inspect from the main menu. 

In the Inspection Dimension dialog box, click Select Dimensions button. 

Close the Inspection Dimension dialog box temporarily to switch to drawing area. 

Select dimensions to remove dimension inspection, and then press ENTER to finish selection and 

return to the dialog box. 

Click Remove Inspection button. 

Click OK. 

Dimension toolbar:  

Command line  DIMINSPECT 

 

Commands Reference 

DDEDIT: Edits text, dimension text, attribute definitions, and feature control frames 

DIMEDIT: Edits dimensions 

DIMINSPECT: Adds or removes dimension inspections 

DIMJOGLINE: Adds or removes a jog on the specified linear dimension 

DIMTEDIT: Moves and rotates dimension text 

PROPERTIESES: Controls properties of existing objects  

System Variables Reference 

DIMCLRT: Assigns colors to dimension text 

DIMDSEP: Specifies a single-character decimal separator to use when creating dimensions whose 

unit format is decimal  

DIMJUST: Controls the horizontal positioning of dimension text 

DIMTAD: Controls the vertical position of text in relation to the dimension line 
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DIMTIH: Controls the position of dimension text inside the extension lines for all dimension types 

except ordinate 

DIMTMOVE: Sets dimension text movement rules 

DIMTOH: Controls the position of dimension text outside the extension lines 

DIMTVP: Controls the vertical position of dimension text above or below the dimension line 

DIMUPT: Controls options for user-positioned text 

MTEXTED: Sets the primary and secondary text editors to use for multiline text objects 

 Adjust Dimension Space 

Once you have created multiple paralleled linear dimensions or angular dimensions, you can adjust 

the space among these paralleled lines with an equal value either default or specified. 

Various methods are available for creating paralleled linear dimensions and angular dimensions. 

Either using DIMLINEAR and DIMANGULAR to create dimension one at a time or executing 

DIMBASELINE and DIMCONTINUE to place other linear dimensions or angular dimensions 

according to the linear dimension or angular dimension previously created. 

When using DIMBASELINE for creating baseline dimensions, the space between each dimension is 

the identical, which is controlled by system variable DIMDLI, but the variable is only applied to 

control dimension space for the subsequent dimension space. If you adjust dimension space by 

changing the size of dimension text is changed only, or adjusting the dimension scale other than 

changing the position of dimension line, then the dimension line is likely to be overlapped with 

text. 

DIMSPACE command is also available for adjusting the space among paralleled linear or angular 

dimensions or overlapped dimensions automatically in case that the original space is not equal 

values. 

It should be noticed when adjusting dimension space, the dimensions you select must be of the 

same type, for example, either all of linear dimensions or angular dimensions. Additionally, these 

dimensions must be paralleled, or share the same origin and placed at the extension line of one 

another. 

If you set the space value to 0 when adjusting space among dimensions, you can align selected 

dimensions at the dimension line. If you specify the space as Auto, dimension space among them is 

default to twice of the text height. To modify the text height, you can set from the Text tab on the 

Modify Dimension Style dialog box. 
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Commands Reference 

DDEDIT: Edits text, dimension text, attribute definitions, and feature control frames 

DIMEDIT: Edits dimensions 

DIMINSPECT: Adds or removes dimension inspections 

DIMJOGLINE: Adds or removes a jog on the specified linear dimension 

DIMTEDIT: Moves and rotates dimension text 

DIMSPACE: Controls the distance between parallel linear dimensions or angular dimensions 

PROPERTIESES: Controls properties of existing objects  

System Variables Reference 

DIMCLRT: Assigns colors to dimension text 

DIMDSEP: Specifies a single-character decimal separator to use when creating dimensions whose 

unit format is decimal  

DIMJUST: Controls the horizontal positioning of dimension text 

DIMTAD: Controls the vertical position of text in relation to the dimension line 

DIMTIH: Controls the position of dimension text inside the extension lines for all dimension types 

except ordinate 

DIMTMOVE: Sets dimension text movement rules 
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DIMTOH: Controls the position of dimension text outside the extension lines 

DIMTVP: Controls the vertical position of dimension text above or below the dimension line 

DIMUPT: Controls options for user-positioned text 

MTEXTED: Sets the primary and secondary text editors to use for multiline text objects 

10.5 Add Geometric Tolerances 

Geometric tolerances in a drawing show acceptable deviations of form, profile, location, 

orientation, and runout of a feature. 

You can create geometric tolerances with or without leaders depending on you use the LEADER or 

the TOLERANCE command. 

Overview 

Each feature control frame consists of at least two compartments. The first compartment contains a 

geometric tolerance symbol that indicates the geometric characteristic to which the tolerance is 

applied, such as location, orientation, or form. For example, a form tolerance may indicate the 

flatness or roundness of a surface. The geometric tolerance symbols and their characteristics are 

shown in the following. 

Position :Location 

Concentricity or coaxiality  :Location 

Symmetry  :Location 

Parallelism  :Orientation 

Perpendicularity  :Orientation 

Angularity  :Orientation 

Cylindricity :Form 

Flatness :Form 

Circularity or roundness :Form 

Straightness :Form 

Profile of a surface :Profile 
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Profile of a line :Profile 

Circular runout :Runout 

Total runout :Runout 

The tolerance value can then be followed by primary, secondary, and tertiary datum reference 

letters, along with the material conditions of each datum. Datum reference letters are generally 

used as reference tolerances to one of up to three perpendicular planes from which a 

measurement is made, although datum reference letters can also indicate an exact point or axis. 

A feature control frame contains symbols that represent location, orientation, form, profile and 

runout that apply to a tolerance. Form tolerances control straightness, circularity, flatness and 

cylindricity; profiles control surface and line. 

Most of editing commands can change feature control frames, and these feature control frames can 

be snapped to with the object snap. You can also use grips to edit geometric tolerances. Unlike 

dimensions and leaders, geometric objects are not associated with geometric objects. 

 

Material Conditions 

The second compartment displays tolerance values. Depending on control type, you can add a 

diameter symbol prior to the tolerance value, and specify a material condition symbol behind this 

value. 

You can apply material conditions to features that can vary in size, shown as follows: 

At maximum material condition (symbol M, also known as MMC), a feature contains the maximum 

amount of material stated in the limits. At MMC, a hole has minimum diameter, whereas a shaft 

has maximum diameter. 

At least material condition (symbol L, also known as LMC), a feature contains the minimum amount 

of material stated in the limits. At LMC, a hole has maximum diameter, whereas a shaft has 

minimum diameter. 

Regardless of feature size (symbol S, also known as RFS) means a feature can be any size within the 

stated limits. 

Datum Reference Frames 

A datum reference consists of values and modifying symbols. A datum is a theoretically exact 

geometric reference that measures and verifies a theoretically exact point, axis, or plane. The 
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system provides up to three datum reference letters and relative symbols followed by the tolerance 

value. Two or three mutually perpendicular planes perform best when you applying these datum 

references. They are jointly called datum reference frame. 

The following illustration shows a datum reference frame that consists of three perpendicular 

planes. 

 

Projected Tolerance Zones 

Projected tolerance zones control the height of the fixed perpendicular part of the extension area, 

and control tolerance accuracy by positional tolerances. 

Before you set the symbol to projected tolerance zones, you set a height value to specify the 

minimum projected tolerance zone. The following illustration shows the projected tolerance zone 

height and symbol appearing in a frame. 

 

Composite Tolerances 

A composite tolerance consists of two tolerances that applied to the same geometric characteristic 

of a feature or for features that have different datum requirements. One tolerance is in relation to a 

pattern of features and the other tolerance to each feature within the pattern. The pattern 

tolerance is less restrictive than the individual feature tolerance. 
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In the illustration above, the axis formed by the point where datums A and B intersect called the 

datum axis. The position of the pattern is calculated from that axis. 

Before you create a dimension and add a composite tolerance for a drawing, you have to specify 

the first line of a feature control frame and then choose the same geometric characteristic symbol 

for the second line of the feature control frame. The specified geometric symbol compartment is 

extended over both lines. Then you can create a second line of tolerance symbols. 

 

Adding geometric tolerances 

Geometric tolerances indicate the maximum allowable variations in the geometry defined by a 

drawing. ZWCAD+ draws geometric tolerances using a feature control frame, which is a rectangle 

divided into compartments. 

To add a geometric tolerance 

Choose Dimension > Tolerance from the main menu. 

In the Geometric Tolerance dialog box, click the first square under Sym and select a symbol to 

insert.  

Under Tolerance 1, click the first black box to insert a diameter symbol.  

In the Text box, type the first tolerance value. 

To add a material condition (optional), click the second black box and click a symbol in the Material 

Conditions dialog box to insert it.  

Under Tolerance 2, repeat steps 3 through 5 to add a second tolerance value, if appropriate. 

Under Datum 1, Datum 2 and Datum 3, enter the datum reference letter.  

Click the black box to insert a material condition symbol for each datum reference.  

In the Height box, type a projected tolerance zone height value, if appropriate. 

To insert a projected tolerance zone symbol, click the Projected Tolerance Zone box, if appropriate. 
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In the Datum Identifier box, add a datum value.  

Click OK. 

In the drawing, specify the location of the feature frame. 

Dimension toolbar:  

Command line TOLERANCE 

 

Controlling dimension tolerance 

You can create dimensions as either tolerance or limits dimensions. When creating a tolerance 

dimension, you can control the upper and lower tolerance limits as well as the number of decimal 

places of the dimension text. The image tile on the right side of the Dimension Settings dialog box 

shows the appearance of tolerance and limits dimensions based on the current dimension style 

settings. 

 

Tolerance dimension. Limits dimension. 

To create a tolerance dimension 

Choose Dimension > Style from the main menu. 

In the Dimension Style Manager dialog box, select the style you wish to change and choose Modify. 

Click the Tolerances tab. 

Make your selections. 

Click OK. 

Choose Close to exit. 

Dimension toolbar 

Command line DIMSTYLE 

 

Commands Reference 

LEADER: Creates a line that connects annotation to a feature 

TOLERANCE: Creates geometric tolerances 

System Variables Reference 

None 
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10.6 Table 

Table is a cell collection composed of rows and columns. Tables can be created from table style. 

Meanwhile, you also can create table object according to the data in Microsoft Excel spreadsheet. 

The existing table can also be edited. Editorial content includes: To edit the text in table cell, insert 

row (column), delete row (column), merged cells, modified cell borders, and so on. 

You can control the appearance of the new table by modifying the table style. Table style includes 

table direction, background, text style and any other table characters.  

Table Toolbar 

When you work in the Classic interface, the Table toolbar displays after you select a table object (if 

you work in the Ribbon interface, then the Table Cell contextual tab displays). Functions of the 

buttons on the Table toolbar are described in the table below: 

Icon Name Function Description 

 

Insert Row above Insert a row above the specified row or cell. 

 

Insert Row below Insert a row below the specified row or cell. 

 

Delete Row(s) Delete the current selected row. 

 

Insert Column to Left 
Insert a column into the left side of the specified column 

or cell. 

 

Insert Column to 

Right 

Insert a column into the right side of the specified 

column or cell 

 

Delete Column(s) Delete the current selected column. 

 

Merge Cells 

Merge the specified multi-cell into one large cell. There 

are three kinds for merging cells. 

All: Merge the specified multi-cell into one cell.  

By Row: Merge the specified multi-cell into several cells 

by removing the vertical gridlines and leaving all the 

horizontal gridlines.  

By Column: Merge the specified multi-cell into several 

cells by removing the horizontal gridlines and leaving all 

the vertical gridlines. 

 

Unmerge Cells Separate the previously merged table cells. 
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Cell Borders 

Set border options for the selected table cell in "Cell 

Border Properties" dialog box.  

 

MIDDLECENTER Specify alignment of the cell contents. 

 

Match Cell Apply all properties of the selected cell to other cells. 

  

Edit and Modify Table 

Edit column & row  

Operating Steps: 

Select one cell in the table. 

Click "Insert Row above" button on the Table toolbar to insert a row above the selected cell. You 

can also click "Insert Row below" button to insert a row below the cell, click "Insert Column to Left" 

button to insert a column on the left side, and click "Insert Column to Right" button to insert a 

column to the right side.  

 

Merge and unmerge cells 

Operating Steps: 

Select one cell in the table. 

Hold down the SHIFT key, and select another cell to be merged. 

Click "Merge Cells" button on the Table toolbar, and select the way you want to merge the cells. 

You can use the following three methods for merging: All, By Row and By Column. Different merged 

cells will be generated according to different merging ways.  
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Change the appearance of cell borders 

Operating Steps: 

Select one cell in the table. 

Click "Cell Borders" button on the Table toolbar to open the "Cell Border Properties" dialog box. 

In this dialog box, set the lineweight and color properties of cell borders. 

Click OK to finish setting. 

 

Edit data format and alignment 

Operating Steps: 

Select one cell in the table. 

Click "Alignment" button on the Table toolbar to select alignment. Alignment includes Top Left, Top 

Center, Top Right, Middle Left, Middle Center, Middle Right, Bottom Left, Bottom Center and 

Bottom Right. 
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Match cell format 

Operating Steps: 

1. Click "Match Cell" button on the Table toolbar, and then use the format of 

a selected cell (source cell) to replace that of any other cell (destination 

cell). 

2. The mouse pointer becomes a brush. Then you can match the 

destination cells by clicking them. 

Table toolbar:  

Command line: MATCHCELL 

 

Commands Reference 

TABLE: Creates a table object 

TABLEDIT: Modifies the text in a table cell 

TABLESTYLE: Creates or modifies the specified table style 

System Variables Reference 
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CTABLESTYLE: Sets the name of the current table style 

TABLETOOLBAR: Controls the displays of the Table toolbar 
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11 Blocks , Attribute and Xrefs 

 

 

Topics in this section: 

Create and Insert Blocks 

Usually, blocks are several objects combined into one that you can insert into a drawing and 

manipulate as a single object. 

Define and Use Block Attributes 

An attribute is a particular object that you can save as part of a block definition. Attributes consist 

of text-based data. You can use attributes to track such things as part numbers and prices. Attribute 

values are either fixed or variable. 

Reference Other Drawing Files (Xrefs) 

You can attach an entire drawing to the current drawing as an external reference (xref). With xrefs, 

changes in the referenced drawing are reflected in the current drawing. 

Dynamic Blocks 

Dynamic Block is a kind of block contains parameters and actions. Currently, ZWCAD+ supports the 

display of dynamic blocks, the display and editing of dynamic block custom grips, and the editing 

and save of dynamic blocks. 

11.1 Create and Insert Blocks 

Usually, blocks are several objects combined into one that you can insert into a drawing and 

manipulate as a single object. A block can consist of visible objects such as lines, arcs, and circles, as 

well as visible or invisible data called attributes. Blocks are stored as part of the drawing file. 

Blocks can help you better organize your work, quickly create and revise drawings, and reduce 

drawing file size. After you create a block from multiple objects, you save it once, which also saves 

disk space. You can change the block definition to quickly revise a drawing, and then update all 

instances of the block. 

If you insert a block that contains objects originally drawn on layer 0 and assigned color and 

linetype BYLAYER, it is placed on the current layer and assumes the color and linetype of that layer. 

If you insert a block that contains objects originally drawn on other layers or with explicitly 

specified colors or linetypes, the block retains the original settings. 

If you insert a block that contains objects originally assigned color and linetype BYBLOCK, and the 

block itself has the color and linetype BYLAYER, those objects adopt the color and linetype of the 

layer onto which they are inserted. If the block is assigned an explicit color or linetype, such as red 

or dashed, those objects adopt those qualities. 

A procedure called nesting occurs when you include other blocks in a new block that you are 

creating. Nesting is useful when you want to combine and include small components, such as nuts 

and bolts, into a larger assembly and you need to insert multiple instances of that assembly into an 
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even larger drawing. 

 

Topics in this section: 

 Create Blocks 

A block can be composed of objects drawn on several layers with various properties. You can use 

several methods to create blocks. 

 Create Drawing Files for Use as Blocks 

Individual drawing files are easy to create and manage as the source of block definitions. You can 

insert them into other drawings as blocks. 

 Insert Blocks 

When you insert a block, you create a block reference and specify its location, scale, and rotation. 

 Control the Color and Linetype Properties in Blocks 

The objects in an inserted block can retain their original properties, can inherit properties from the 

layer on which they are inserted, or can inherit the properties set as current in the drawing.  

 Modify a Block Definition 

You can modify a block definition or a block reference already inserted in the drawing. 

 Create Blocks 

ZWCAD+ provides various methods to create blocks, and insert the block into a drawing more times 

as you need. With this method, you can create blocks as soon as possible. You can use several 

methods to create blocks: 

Combine objects to create a block definition in your current drawing. 

Create a drawing file and later insert it as a block in other drawings. 

Objects drawn on several layers with various colors, linetypes, and lineweight properties can be 

combined into a block. Once a block is inserted into the drawing, the block reference preserves 

information about the original layer, color, and linetype properties of the objects that are contained 

in the block although it is always displayed on the current layer. Whether to retain their original 

properties or inherit their properties such as color, linetype, or lineweight settings from the current 

layer for objects is controllable. To remove unused block definitions from a drawing, use PURGE 

command. 

When defining blocks, you should define the block name, objects to be contained in the block, the 

coordinate values of the base point to be used for inserting the block, and any associated attribute 

data. 
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The block definition in the illustration comprises a name, four lines, and a base point at the 

intersection of the two diagonal lines. 

 

The illustration shows a typical sequence for creating a block definition. 

 

To create a block for use within a current drawing 

Choose Draw > Block > Make from the main menu. 

In the Block Definition dialog box, enter a block name in the Name box. 

Click Pick button to specify a point as the insertion point for the block in the drawing area. 

Click Select button to select the objects for the block, and then press Enter after selection. 

To restore the original objects to the drawing while retaining the new block, click Retain. 

Click OK. 

Draw toolbar:  

Command line BLOCK 

 

Create Nested Blocks 

You can define blocks and other blocks as nested blocks so as to simplify the organization of 

complicated blocks. 

With nested blocks, you can build a single block out of several components. But you should notice 

that blocks that reference themselves cannot be inserted.  
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Commands Reference 

BLOCK: Creates a block definition from objects you select 

PURGE: Removes unused named items, such as block definitions and layers, from the drawing 

WBLOCK: Writes objects or a block to a new drawing file 

System Variables Reference 

None 

 Create Drawing Files for Use as Blocks 

You can create a block as a separate drawing file that you can insert into other drawings. 

To save a block as a separate drawing file 

On the command line, type WBLOCK. 

Under Source area, choose one of the following: 

Block: This option saves existing block object to a separate drawing file. When prompted, select an 

existing block name from the pulldown menu of this option. 

Entire drawing: This option immediately saves the entire drawing to a separate drawing file. 

Objects: This option saves those objects you select to a separate drawing file. When prompted, 

specify the insertion point for the block, and select the objects for the block. 

Under Destination area, type the name of the drawing file you want to create and choose the saved 

path. 

NOTE When saving the entire drawing as a separate drawing file, the program 

assigns the 0,0,0 coordinate as the insertion base point. You can change 

the base point by opening the drawing and redefining the block. 

 

Change the Base Point of Drawings to Be Used as Blocks 

When inserting a drawing file into another drawing as a block, by default, system uses the origin 

(0,0,0) of WCS as the base insertion point. To specify different insertion point, you can use BASE 

command. Next time you insert the same block, system uses the new insertion point by default. 
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Update Changes in the Original Drawing 

Once the drawing file has been inserted into another drawing as a block, the original drawing 

changes as well. But the block having been inserted will not change. If the block happens to change 

along with the original drawing, you should attach it as external reference but not as a block. 

Use Paper Space Objects in Blocks 

Objects created in paper space are not contained in the block when it is being inserted into the 

drawing. You can convert the objects in paper space as block or save as an individual drawing file 

before inserting into other drawings. 

 

Commands Reference 

BASE: Sets the insertion base point for the current drawing 

BLOCK: Creates a block definition from objects you select 

EXPORT: Saves objects to other file formats 

INSERT: Places a named block or drawing into the current drawing 

OOPS: Restores erased objects 

WBLOCK: Writes objects or a block to a new drawing file 

System Variables Reference 

None 

 Insert Blocks 

You can insert blocks and other drawings into the current drawing. When you insert a block, it is 

treated as a single object. When you insert a drawing, it is added to the current drawing as a block. 

You can then insert multiple instances of the block without reloading the original drawing file. If 

you change the original drawing file, those changes have no effect on the current drawing unless 

you redefine the block by reinserting the changed drawing. 

You can also insert blocks from another drawing into the current drawing. Both drawings must be 

open at the same time to do this. 

When you insert a block or drawing, you must specify the insertion point, scale, and rotation angle. 

The block's insertion point is the reference point specified when you created the block. 

When you insert a drawing as a block, the program takes the specified insertion point as the block 

insertion point. You can change the insertion point, however, by first opening the original drawing 

and redefining the block. 
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You can specify the scale of a block reference using different X, Y, and Z values. 

 

To insert a block 

Choose Insert > Block from the main menu. 

In the Insert Block dialog box, under Insert, click Block Name. 

In the Block Name box, select the name of the block you want to insert. 

If you want to use the pointing device to specify the insertion point, scale, and rotation, select 

Specify On-Screen. Otherwise, enter values in the Insertion Point, Scale, and Rotation boxes.  

If you want the objects in the block to be inserted as individual objects instead of as a single block, 

select Explode block upon insertion. 

Click Insert. 

Insert toolbar:  

Command line INSERT 

 

Insert a Drawing File as a Block 

You are required to specify insertion point, scaling and rotation angle while inserting the drawing 

file into the drawing. If external references are included in the block, the xrefs may not be normally 

displayed unless it has been inserted or attached into target drawing. You can redefine insertion 

point, scale factor and rotation angle each time you insert the drawing, as the following picture 

shows:  

 

To insert an entire drawing into the current drawing 

Choose Insert > Block from the main menu. 

In the Insert Block dialog box, under Insert, click From File. 

Type the path and the drawing file name, or click Browse to specify the file from the Insert Block 

dialog box. 

If you want to use the pointing device to specify the insertion point, scale, and rotation, select 

Specify On-Screen. Otherwise, enter values in the Insertion Point, Scale, and Rotation boxes.  

If you want the objects in the block to be inserted as individual objects instead of as a single block, 

select Explode block upon insertion. 
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Click Insert. 

Insert toolbar:  

Command line INSERT 

NOTE You can specify the insertion point, scale factors, and rotation angle in the Insert Block 

dialog box before inserting the block. You can also control whether the block is exploded back into 

its original component objects after insertion. If you want to explode the block immediately, select 

the Explode Upon Insertion check box. 

 

Insert Blocks at Intervals 

You can insert blocks at intervals along a selected geometric object. Use MEASURE to insert a block 

at measured intervals. Use DIVIDE to insert a block at proportional (evenly spaced) intervals. 

Insert Blocks with DesignCenter 

The block definitions created in a drawing file are displayed in DesignCenter. Use Design Center to 

insert blocks from the current drawing, right click the block, and select insert block by specifying its 

location, scale, and rotation. You cannot add blocks to a drawing in process of another command, 

and you can only insert or attach one block at a time. 

 

Commands Reference 

DIVIDE: Places evenly spaced point objects or blocks along the length or perimeter of an object  

INSERT: Places a named block or drawing into the current drawing 

MEASURE: Places point objects or blocks at measured intervals on an object 

System Variables Reference 

ATTDIA: Controls whether the INSERT command uses a dialog box for attribute value entry 

INSNAME: Sets a default block name for the INSERT command 

INSUNITS: Specifies a drawing-units value for automatic scaling of blocks or images dragged from 

DesignCenter and inserted into a drawing  

INSUNITSDEFSOURCE: Sets source content units value 
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INSUNITSDEFTARGET: Sets target drawing units value 

 Control the Color and Linetype Properties in Blocks 

Through controlling properties like color and linetype for objects on the block, the objects in an 

inserted block can retain their original properties, can inherit properties from the layer on which 

they are inserted, or can inherit the properties set as current in the drawing. When you insert a 

block, the color, linetype, and lineweight of objects in the block retain their original settings 

regardless of the current settings in the drawing. 

The following three choices are provided for you to determine how the color, linetype, and 

lineweight properties of objects are treated when a block reference is inserted. 

Objects in the block inherit their original color, linetype, and lineweight properties once inserted 

into the drawing. The properties of objects in the block can't be changed until redefined. For this 

choice, it is recommended that you set the color, linetype, and lineweight properties individually 

for each object in the block definition: which are different from BYBLOCK or BYLAYER color, linetype, 

and lineweight settings when creating these objects. 

Objects in the block inherit color, linetype, and lineweight properties that assigned to the current 

layer only. For this choice, before you create objects to be included in the block definition, set the 

current layer to 0, and set the current color, linetype, and lineweight to BYLAYER. 

Objects inherit color, linetype, and lineweight properties that have been definitely set, that is, the 

properties you have set to override the color, linetype, or lineweight assigned to the current layer. If 

you do not definitely specify layer properties for the objects, then use properties of the current 

layer. For this choice, before you create objects to be included in the block definition, set the 

current color or linetype to BYBLOCK.  

 

Commands Reference 

COLOR: Sets the color for new objects 

LAYER: Manages layers and layer properties 

LINETYPE: Loads, sets, and modifies linetypes 

System Variables Reference 

None 

 Modify a Block Definition 

You can redefine all instances of a block within the current drawing. To redefine a block that was 

created in the current drawing, you create a new block using the same name. You can update all 

the blocks in the current drawing by redefining the block. If the block was inserted from a separate 

drawing file that was subsequently updated, reinsert that block to update all other instances in the 

current drawing. 
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There are two methods of redefining block definitions, you can choose to modify block definition in 

current drawing or in original drawing. 

Modify the block definition in the current drawing. 

Modify the block definition in the source drawing and insert it into the current drawing again. 

Modify a Block Definition in the Current Drawing 

To modify a block definition already inserted into the drawing, you should first create a new block 

definition with a new name to replace the existing block definition, and all the references to that 

block in the drawing are immediately updated to reflect the new definition. 

To save time, you can insert and explode an instance of the original block and then use the 

resulting objects while creating the new block definition. 

To redefine a block in the current drawing 

Choose Draw > Block > Make from the main menu. 

In the Block Definition dialog box, type the name of the block you want to redefine in the Name 

box. 

Click Pick button to specify a point as the insertion point for the block in the drawing area. 

Click Select button to select the objects for the block, and then press Enter after selection. 

Click OK. 

Click Yes in the prompt box that displays to redefine the block in the current drawing. 

Draw toolbar:  

Command line BLOCK 

The block is immediately redefined, and all instances of the block in the drawing are updated. 

TIP To restore the original objects to the drawing while retaining the new block, click Retain. 

 

Update a Block Definition That Originated from a Drawing File 

To modify the original drawing directly before inserted into the drawing, blocks inserted into 

current drawing are not updated automatically unless the block definition from the drawing file is 

updated using INSERT command. 

Remove Block Definitions 

Too many block definitions in a drawing file may affect the drawing size. To reduce the size of a 

drawing, you can remove unused block definitions. Erasing a block reference from a drawing may 

delete the block reference but retain the block definitions in the block definition table. Using 

PURGE command can help removing unused block references from your drawing in order to reduce 

the drawing size. 

You should erase all references from a block before you can purge the block definition. 

Disassemble a Block Reference (Explode) 
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To modify one or more objects within a block separately, you can use Explode tool from Modify 

toolbar, and restore this block after you have modified these objects using one of the following 

method: 

Create a new block definition 

Redefine the existing block definition 

You can automatically explode block references as you insert them by selecting the Explode block 

upon insertion option in the Insert Block dialog box. Thus, the block reference will be automatically 

exploded with each object inserted into the drawing separately. 

To explode a block 

Choose Modify > Explode from the main menu. 

Select the block you want to explode. 

Press Enter. 

Modify toolbar:  

Command line EXPLODE 

 

Commands Reference 

BLOCK: Defines multiple objects as a whole to create block definition 

EXPLODE: Breaks a compound object (such as block, polyline and so on) into its component 

objects 

PROPERTIES: Displays the Properties dialog box, in which you can changes the relevant properties 

of existing entity 

System Variables Reference 

None 

11.2 Define and Use Block Attributes 

An attribute is a particular object that you can save as part of a block definition. Attributes consist 

of text-based data. You can use attributes to track such things as part numbers and prices. Attribute 

values are either fixed or variable. When you insert a block containing attributes, the program adds 

the fixed values to the drawing along with the block, and you are prompted to supply any variable 

values. 

After you insert blocks containing attributes, you can extract the attribute information to a separate 

file and then use that information in a spreadsheet or database to produce a parts list or bill of 

materials. You can also use attribute information to track the number of times a particular block is 

inserted into a drawing. 

Attributes can be visible or hidden. Hidden attributes are neither displayed nor printed, but the 

information is still stored in the drawing and written to a file when you extract it. 
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Define Attributes 

You add an attribute to a drawing by first defining it and then saving it as part of a block definition. 

To define an attribute, you specify the characteristics of the attribute, including its tag, prompt, and 

default text; insert coordinates and text formatting; and attribute flags (hidden, fixed, validate, 

defined, lock position and multiple lines). 

To define an attribute 

Choose Draw > Block > Define Attributes from the main menu. 

In the Define Attribute dialog box, type the tag, prompt, and default text. 

Under Insert Coordinates, specify the location of the attribute, or click Select to select a point in the 

drawing. 

Under Attribute Flags, select the optional attribute modes. 

Under Text, specify the text characteristics. 

To add the attribute to the drawing, do one of the following: 

Click Define to add the attribute and keep the dialog box active so you can define another 

attribute. 

Click Define and Exit to add the attribute and end the command. 

Command line ATTDEF 

 

Modify Attributes 

You can edit an attribute definition before you associate it with a block and before it is saved as 

part of a block definition. 

To edit an attribute definition 

On the command line, type DDEDIT. 

Select the attribute definition text to edit. 

Modify the attribute tag, prompt and default text in the Edit Attribute Definition that displays. 

Click OK. 

 

Define Block Attributes 

Attributes can be attached to a block. When selecting objects to be included in the block, you can 

select all the attributes and then choose the block to be attached. 

The order you select attributes determines the prompts displaying when inserting blocks. If you 

select attributes by crossing selection or window selection, the prompts for attributes are displayed 

by the order of creating attributes.  

Modify Block Attributes 

You can use the Block Attribute Manager to modify attributes in block definitions. For example, you 

can modify the following items:  

Attributes of blocks can be displayed after modification 

Text properties that define how attribute text is displayed in the drawing 
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Properties that define the layer that the attribute is on and the attribute line's color, weight, and 

type 

By default, attribute changes you make are applied to all existing block references in the current 

drawing. If constant attributes or nested attribute blocks are affected by your changes, use REGEN 

to update the display of those blocks in the drawing area. 

Redefine Block Attributes 

When you modify the block definitions, system prompts to select objects that are included in block 

definition, you can attach the attributes to the block by adding the desired attribute to selection set. 

Once the attributes of block definition have been modified, the inserted block reference may be 

affected by the following descriptions: 

Constant attributes with fixed value, are lost and replaced by any new constant attributes. 

Variable attributes remain unchanged, even if no attributes are included in the new block 

definition. 

New attributes do not appear in the existing block references. 

To edit an attribute attached to a block 

On the command line, type DDATTE. 

Select the block to edit. The Edit Attributes dialog box displays all the attributes attached to the 

block you select. 

Edit the attribute values as necessary. 

Click OK. 

 

Extract Block Attribute Data 

Enter EATTEXT to start Attribute Extraction wizard if the blocks in the drawing contain attributes. 

You can extract block information according to the wizard prompt and generate list so as to 

overview the attributes information of the blocks. You can get guide information from the wizard 

until you accomplish selecting drawings, blocks and block attributes. 

With the extract block attribute data function, you can easily create list using drawing data through 

extracting attribute information and export to external files. 

Export to exterior files 

When you want to save the extracted information to external files, you can save the external file as 

CSV, TXT, XLS and MDB format. 

 

Commands Reference 

ATTDEF: Creates an attribute definition 

ATTDISP: Globally controls attribute visibility 
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ATTEDIT: Changes attribute information 

ATTEXT: Extracts attribute data 

DDATTEXT: Extracts attribute data 

DDEDIT: Edits text, dimension text, attribute definitions, and feature control frames 

PROPERTIES: Controls properties of existing objects 

SELECT: Places selected objects in the Previous selection set 

System Variables Reference 

AFLAGS: Sets attribute flags for ATTDEF bitcode 

ATTDIA: Controls whether the INSERT command uses a dialog box for attribute value entry 

ATTMODE: Controls display of attributes 

ATTREQ: Determines whether the INSERT command uses default attribute settings during 

insertion of blocks 

11.3 Reference Other Drawing Files (Xrefs)  

You can link entire drawings to the current drawing as external references. Unlike inserting a 

drawing as a block, in which you add all the objects from the separate drawing into the current 

drawing, external references attach a pointer to the external file. The objects in the external 

reference appear in the current drawing, but the entities themselves are not added to the drawing. 

Thus, attaching an external reference does not significantly increase the size of the current drawing 

file. 

External references provide additional capabilities not available when you insert a drawing as a 

block. When you insert a drawing as a block, the objects are stored in the drawing. Any changes 

you make to the original drawing are not reflected in the drawing in which you inserted it. When 

you attach an external reference, however, any changes you make to the original drawing file are 

reflected in the drawings that reference it. These changes appear automatically each time you open 

the drawing containing the external reference. If you know that the original drawing was modified, 

you can reload the external reference anytime you're working on the drawing. 

External references are useful for assembling master drawings from component drawings. Use 

external references to coordinate your work with others in a group. External references help reduce 

the drawing file size and ensure that you are always working with the most recent version of a 

drawing. 

 

Topics in this section: 
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 Attach External References 

When you attach a drawing as an xref, you link that referenced drawing to the current drawing; any 

changes to the referenced drawing are displayed in the current drawing when it is opened. 

 Nest and Overlay External References 

Attached xrefs can be nested: that is, you can attach an xref that contains another xref. 

 Update Attached External References 

You can update an xref whenever you want to ensure that the most current version is being used. 

Updating also occurs when you open your drawing. 

 Edit External References 

You can perform several operations on referenced drawing files including attaching, updating, and 

detaching them. 

 Edit External References in Place 

By editing a reference in place, you can modify the reference within the visual context of your 

current drawing.  

 Attach External References 

When a drawing is attached to current drawing as external reference, it will be linked to the 

drawing, any changes to the referenced drawing may affect the external reference in current 

drawing. 

External references are inserted into the drawing as block definitions and used as single objects, 

But you should distinguish the external references and blocks. 

An xref can be attached to various drawing simultaneously. In the same way, you can attach 

multiple xrefs to the same drawing using full path or relative path that are partly defined. Even 

without saving path. 

You should notice that, xref must be object created in model space, when inserting xrefs, you can 

specify the insertion scale, position and rotation angle. 

When you attach an external reference, its layers, linetypes, text styles, and other elements are not 

added to the current drawing. Rather, these elements are also linked from the referenced file. 

There are two ways you can attach an external reference: 

An attachment is an inserted drawing that contains a link to the original file. Attachments can 

themselves contain other, nested reference files. When you attach an external reference, any 

nested references contained in the file also appear in the current drawing. 

An overlay is also an inserted drawing that contains a link to the original file. Overlays allow you to 

lay a drawing on top of another drawing, similar to the way you work manually with transparencies. 
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When a drawing that contains overlaid external references is itself attached or overlaid as an 

external reference in another drawing, the overlays do not appear as part of the external reference. 

Use overlaying when you want to see reference geometry in a drawing but you do not need to 

include that geometry in drawings that will be used by others (nested external references). 

To attach an external reference 

Choose Insert > Xref Manager from the main menu. 

Click Attach. 

In the Select Reference File dialog box, specify the drawing file to attach and then click Open. 

In the External Reference dialog box, under Reference Type, choose how you want to insert the 

drawing: 

 Attachment – Inserts a copy of the drawing and includes any other 

drawings that are externally referenced within the referenced 

drawing. 

Overlay – Lays a copy of a drawing over your original drawing; it does not include any nested 

external references from the externally referenced drawing. 

Make any additional selections. 

Click OK. 

If you marked Specify On-screen for any items, follow the prompts to attach the external reference. 

Reference toolbar:  

Command line XREF 

 

Notification of Attached Xrefs 

After inserting external references into the drawing, an xref icon displays at the lower right corner 

of status bar on ZWCAD+ application window. Click this icon shown below to display External 

Reference manager: 

 

If the original drawing to which the xref links has been changed and needs to reload, an 

exclamation mark appears on the xref icon. 

Attach External References 
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You can use the following methods to attach xrefs into a drawing: 

Attach xrefs to the current drawing using XATTACH command. 

Start Xref Manager using XREF command, and select the xref to be attached to the current drawing. 

Select the xref drawing you want to insert into the drawing from DesignCenter, and right click the 

drawing to select Attach Xref. 

Viewing the list of external references 

You can view a list of the external references that are linked to the current drawing two different 

ways using the Xref Manager: 

List View - Displays the external references in a list, which allows you to sort the list of references 

by name, status, size, type, date, or saved path. 

Tree View - Displays a hierarchical representation of the external references and the relationships 

between them. The tree view shows the level of nesting relationships of the attached external 

references. 

To view a list of external references 

Choose Insert > Xref Manager from the main menu. 

Click List View or Tree View. 

Reference toolbar:  

Command line XREF 

 

Visibility, Color, and Linetype 

You can control visibility, color, linetype and other properties by setting the layer on which the xref 

locates. You can also assign these changes as temporary or permanent. 

If the system variable VISRETAIN is set to 0, layer table stores in the xref has superiority, 

modifications based on layer made for xref of the current drawing are only available for current 

command. These changes will not be saved along with the drawing. When restart the drawing, 

layer table will be reloaded and changes are still remained in current drawing. 

If the system variable VISRETAIN is set to 1, modifications based on layer made for xref of the 

current drawing has superiority. Layer settings will be saved in layer table of current drawing. And 

in accordance with current tasks. 

Xref Clipping Boundaries 

You can control whether to display clipping boundary of xref through setting system variable 

XCLIPFRAME. 

 

Commands Reference 

BASE: Sets the insertion base point for the current drawing 
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REFCLOSE: Saves back or discards changes made during in-place editing of a reference (an xref or 

a block)  

REFEDIT: Selects a reference for editing 

REFSET: Adds or removes objects from a working set during in-place editing of a reference (an xref 

or a block) 

RENAME: Changes the names of objects 

XATTACH: Attaches an external reference to the current drawing  

XCLIP: Defines an xref or block clipping boundary and sets the front or back clipping planes 

XREF: Controls external references to drawing files 

System Variables Reference 

BINDTYPE: Controls how xref names are handled when binding xrefs or editing xrefs in place 

INDEXCTL: Controls whether layer and spatial indexes are created and saved in drawing files 

INSBASE: Stores the insertion base point set by BASE, which gets expressed as a UCS coordinate 

for the current space 

PROJECTNAME: Assigns a project name to the current drawing 

VISRETAIN: Controls the visibility, color, linetype, lineweight, and plot styles of xref-dependent 

layers  

XCLIPFRAME: Controls the visibility of xref clipping boundaries 

XEDIT: Controls whether the current drawing can be edited in-place when being referenced by 

another drawing 

XLOADCTL: Turns xref demand loading on and off and controls whether it opens the original 

drawing or a copy 

XLOADPATH: Creates a path for storing temporary copies of demand-loaded xref files 

XREFNOTIFY: Controls the notification for changed or missing xrefs 

 Nest and Overlay External References 
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Xrefs can be nested in another xref and attached to current drawing. 

Xrefs that are multiple nested can be attached into the drawing. In the process of attaching, you 

can select insertion position, scaling factor and rotation angle for xrefs. 

As the following illustration shows, master.dwg contains a.dwg and b.dwg. And drawing a.dwg 

contains c.dwg. Thus, In master.dwg, c.dwg is a nested xref. 

 

Specify the type of an xref, including attachment and overlay. Using overlay to exclude any nested 

xrefs rather than overlay xrefs. This type is typically used for sharing data in network. In Xrefs that 

are attached in overlay type, you can view relative methods directly between the drawing and 

other grouping drawings. 

In the following illustration, attach master.dwg to multiple drawings as xref. Users who are working 

with a.dwg need to view and use objects drawn on b.dwg without but not reference the drawing 

b.dwg because it would then appear twice in master.dwg. Instead, this may overlay b.dwg but mot 

make it included when a.dwg is referenced by master.dwg. 

 

Relative Saved Paths and Nested Xrefs 

You can specify saving path individually for the xrefs that are attached to the drawing in Xref 

Manager dialog box. You can select the saving path as full path, relative path or no path. 

If the xref to be attached is a nested xref, its relative saving path means the position relative to the 

host computer. 

 

Commands Reference 

XREF: Controls external references to drawing files 
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System Variables Reference 

None 

 Update Attached External References 

If the xref drawings are changed, you can update the xref to the latest version whenever you want. 

To update an xref, start Xref Manager using XREF command. The status of updated xrefs displayed 

in the list is "Needs reloading", and you can update these xrefs by clicking the Reload button. 

Once the xrefs are reloaded, system automatically updates each xref when you open the attached 

drawing file directly to show the latest xrefs. 

Opening external references 

From the Xref Manager you can quickly open the source drawing for any external reference. This is 

especially helpful if you are working with nested external references, which you cannot bind or 

detach. From the Xref Manager, open the source drawing, make changes, and then save and close 

the source drawing. When the Xref Manager displays again, simply reload the external reference. 

To open an external reference 

Choose Insert > Xref Manager from the main menu. 

Select the external reference to open. 

Click Open. 

Reference toolbar:  

Command line XREF 

 

Under the expedite network operations, users can update xrefs by reloading regardless of any 

changes happen to the original file of xrefs. But the variance path for the original file may cause the 

xrefs updating failed, you must specify actual saving path for the xrefs. 

 

Notification of Changed Xrefs 

After the xrefs having been attached to the drawing, system automatically checks whether the 

original drawing file are modified in certain intervals since it loaded or reloaded the last time. The 

xref icon located at the right lower corner of the status bar appears an exclamatory mark once the 

xref file has been modified, and needs to reload. You can click this icon to open xref Manager to 

reload the changed xrefs. 

Xref notification behavior is controlled by the XREFNOTIFY system variable. 



 

 413 

 

Update Xrefs with Demand Loading Turned On 

If system variable XLOADCTL is set to 0, turn off Xrefs with Demand Loading, load the whole 

drawing if click the load button. 

If system variable XLOADCTL is set to 1, turn on Xrefs with Demand Loading, all other users can't 

access the xref file when reloading the file with Demand Loading. 

If system variable XLOADCTL is set to 2, load a temporary copy of the latest version of the xref file 

to be loaded. 

Reloading external references 

When you open or print a drawing, any external references in the drawing are updated 

automatically. If a drawing is already open and a referenced drawing is modified, you can update 

the current drawing manually to display the latest version of the referenced drawing. You may also 

want to reload an external reference that has been unloaded temporarily. 

To reload an external reference 

Choose Insert > Xref Manager from the main menu. 

Select the external reference to reload. 

Click Reload. 

Reference toolbar:  

Command line XREF 

 

Commands Reference 

XREF: Controls external references to drawing files 

System Variables Reference 

INDEXCTL: Controls whether layer and spatial indexes are created and saved in drawing files 

TRAYICONS: Controls whether a tray is displayed on the status bar 

TRAYNOTIFY: Controls whether service notifications are displayed in the status bar tray 
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TRAYTIMEOUT: Controls the length of time (in seconds) that service notifications are displayed  

XEDIT: Controls whether the current drawing can be edited in-place when being referenced by 

another drawing 

XLOADCTL: Turns xref demand loading on and off and controls whether it opens the original 

drawing or a copy 

XLOADPATH: Creates a path for storing temporary copies of demand-loaded xref files 

XREFNOTIFY: Controls the notification for changed or missing xrefs 

 Edit External References 

Edit xrefs that are attached to the drawing, such as clipping, binding or detaching as well as 

specifying full path or relative path for xrefs. 

Clip External References and Blocks 

You can define a clipping boundary through XCLIP command once an xref has been attached to the 

drawing, the clipping boundary defined by users are allowed to display only a part of the xrefs and 

compress the displaying of the external geometric objects. 

The clipping boundary is composed of coplanar lines and polyline as well. But self-intersecting 

polylines are not available for creating clipping boundary. 

XCLIP can be used for generating or removing clipping boundaries, generating polylines from 

clipping boundary or undisplay the part being clipped for one or more xrefs or blocks. XCLIP only 

affects the single object of xref, retain the xref definitions unchanged. The part of xref or block 

inside the clipping boundary is still visible, while the remaining parts are invisible. The geometric 

drawing being referenced itself is unchanged, only its displaying way is edited. 

You can use XCLIP to do the following: 

Create new clipping boundary 

Remove existing boundary 

Generate polyline objects that are concurrent with vertex of clipping boundary. 

Turn on or off xref Clipping 

If xclip is turned on, all the clipping boundaries will be started to display the clipped part of an xref. 

If the xclip is turned off, the clipping boundaries will not displayed, only display the drawings in 

xrefs containing contents both inside or outside the clipping boundary. The clipping boundary can't 

be restored once removed. The xref having been clipped can be modified, moved, or copied as 

those unclipped xrefs. While modifying the xrefs, the clipping boundary moves together with the 

xrefs. If the xref attached to the drawing contain nested clipped xrefs, these xrefs will be displayed 

as it was after clipping. The nested xref is also clipped if superior xref has been clipped. 

Turning clipping boundaries on and off 

The clipping boundaries can be controlled whether to display or not through system variable 
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XCLIPFRAME. If set this system variable to 1, the clipping boundary can be selected and plotted as a 

part of the object. 

When a clipping boundary is turned off, the boundary does not display and the entire external 

reference is visible, provided that the geometry is on a layer that is on and thawed. However, 

deleting a clipping boundary is permanent. 

To turn clipping boundaries on and off 

Choose Modify > Clip > Xref from the main menu. 

Select the desired external references. 

Press Enter. 

To turn off clipping boundaries, choose OFF. To turn on existing clipping boundaries, choose ON. 

Enter an option and then press Enter. 

Reference toolbar:  

Command line XCLIP 

TIP When the XCLIPFRAME system variable is on (set to 1), you can select and print the clipping 

boundary frame. 

 

Clipping Boundary Options 

When clipping boundaries, you can specify a rectangular or polygonal window or use the polyline 

to define clipping boundary through New boundary option. If the selected clipping boundary is 

rectangular window, only xrefs within the rectangular window are displayed. The clipping boundary 

is parallel to current UCS, and the clipping boundary will be applied to the normal direction of its 

plane. 

To define a rectangular clipping boundary 

Choose Modify > Clip > Xref from the main menu. 

Select the external references to clip. If desired, you can also select blocks. 

Press Enter. 

Type N (New boundary) or press Enter directly to create a new clipping boundary. 

If prompted, press Enter to delete any existing boundaries. 

Choose R (Rectangular). 

Define the first corner of the clipping rectangle. 

Define the opposite corner of the clipping rectangle. 

The selected external references are clipped by the rectangle. 

Reference toolbar:  

Command line XCLIP 

TIP You can first select all external references, right click the selection, and then select Xref Clip 

from the shortcut menu. 

 

When using polyline to define clipping boundary, the clipping boundary is in accordance with the 

polyline. If the selected clipping boundary is polyline, it can't be self intersected. System takes the 
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open polyline as closed polyline if the arcs contained in the polyline have been smoothed. The 

clipping boundary created this way is located on the plane parallel to the UCS that puts the 

polyline. 

To define a clipping boundary using a polyline 

Draw a polyline where you want to clip external references. 

Choose Modify > Clip > Xref from the main menu. 

Select the external references to clip. If desired, you can also select blocks. 

Press Enter. 

Type N (New boundary) or press Enter to create a new clipping boundary. 

If prompted, press Enter to delete any existing boundaries. 

Choose S (Select polyline). 

Select the polyline to use as a clipping boundary. 

Reference toolbar:  

Command line XCLIP 

 

In addition to the rectangular clipping boundary and the clipping boundary using a polyline, you 

can also create a clipping boundary by specifying the vertices of a polygon, but you must note that 

the polygon sections cannot be intersected themselves. 

To define a polygonal clipping boundary 

Choose Modify > Clip > Xref from the main menu. 

Select the external references to clip. If desired, you can also select blocks. 

Press Enter. 

Type N (New boundary) or press Enter to create a new clipping boundary. 

If prompted, press Enter to delete any existing boundaries. 

Choose P (Polygonal). 

Define the first corner of the clipping polygon. 

Define the next corners of the clipping polygon, and then press Enter to end the selection. 

The selected external references are clipped by the polygon. 

Reference toolbar:  

Command line: XCLIP 

 

Clip Depth 

The front and back clipping planes for xrefs can be set before clipping the xref. To specify a clip 

depth, the xref must contain a clipping boundary. The clip depth is always calculated normal to the 

clipping boundary. When setting clip depth, you are prompted to specify a front and back point or 

distance relative to the clipped plane. Regardless of the current UCS, the clip depth is only available 

at the direction parallel to the clipping boundary. 
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Deleting a clipping boundary 

If you no longer need a clipping boundary for an external reference, you can delete it. 

To delete a clipping boundary 

Choose Modify > Clip > Xref from the main menu. 

Select the external references to clip. If desired, you can also select blocks. 

Press Enter. 

Choose D (Delete), and then press Enter. 

Reference toolbar:  

Command line XCLIP 

 

Binding an xref to a drawing 

External references are not part of the drawing. Rather, they are links to an externally referenced 

file. To provide a copy of a drawing containing external references to someone else, you must also 

provide all the external reference files. In addition, the user receiving the drawings must either 

recreate the same paths you used when linking the external references or change the paths for the 

external references. 

To provide a copy of a drawing that contains external references, it is often easier to first bind the 

external references to the drawing. Binding the external references makes them a permanent part 

of the drawing, which is similar to inserting a separate drawing as a block. You can bind external 

references that are attached directly to the current drawing; you cannot bind nested external 

references. Xrefs rely on the naming sentence of named objects from "Block name|Definition 

name"to"Block name$n$Definition name". Thus, you can create unique named objects for relative 

definition tables that are bind to all the xref in current drawing. 

If select Insert, the xref will be inserted to the drawing after converted to blocks as inserting 

reference drawings. Xref relies on named object, using the xref name removed from the names but 

not using the "Block name|Definition name" sentence. If internal named objects have the same 

name with binded xref names in the drawing to be inserted, new names will not be added in 

symbol table, and the binded xrefs rely on named objects adopts properties of named objects local 

defined. 
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To bind an existing external reference to a drawing 

Choose Insert > Xref Manager from the main menu. 

Select the external reference to bind. 

Click Bind. 

In the Bind Xrefs dialog box, choose one of the following: 

Bind Binds the external reference and creates a unique name for each named object, such as a 

layer or block, that is located in the external reference. For example, a layer named Electric in the 

external reference will be named Xref$0$Electric in the current drawing. If the current drawing 

already has a layer or block with the same name, the name is changed incrementally, for example, 

Xref$1$Electric. 

Insert Binds the external reference, but does not change the names of any named objects in the 

external reference. For example, a layer named Electric in the external reference will have the same 

name, Electric, in the current drawing. If the current drawing has a layer or block with the same 

name, the named object in the external reference takes on the properties of the named object in 

the current drawing. 

Click OK. 

Reference toolbar:  

Command line XREF 

 

Detach External References 

To detach the xref from the drawing, the selected xrefs will be removed from the xref list. 

Meanwhile, relative xref in current drawing will be removed as well. This can be also applied to 

xrefs directly attached to current drawing, but the nested xrefs can't be treated like this. 

You should distinguish with detach and remove, which are totally different concepts, removing an 

xref will not remove its relative layer definitions. Using Detach option to remove all the associated 

information of the xref. 

To detach an external reference 

Choose Insert > Xref Manager from the main menu. 

Select the external reference to detach. 

Click Detach. 

Reference toolbar:  

Command line XREF 

NOTE Only the external references that are attached directly to the current drawing can be 

detached; nested external references cannot be detached. 

 

Set Paths to Externally Referenced Drawings 

You can set saving path for the xrefs that are changed after attached to the drawing, when you 
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selecting saving path for the xrefs, three types are provided for you: Full path, Relative path and No 

path. 

Full Path 

Full path refers to the path that marked by local disk or network server driver. By default, the path 

for saving the xref files are Relative path, but this path lacks flexibility, once the file is changed, the 

path becomes invalid. 

Relative Path 

Relative path refers to path assigned by folders including current driver or original drawing file. 

User can move the original files among multiple drivers within the folder at the same hierarchy 

without affecting updating xrefs. 

You can't set the relative path in local disk or network server driver. The relative paths for xref 

original files are assigned as follows: 

\: Look in the root folder of the host drawing's drive 

path: From the folder of the host drawing, follow the specified path 

\path: From the root folder, follow the specified path 

.\path: From the folder of the host drawing, follow the specified path 

..\path: From the folder of the host drawing, move up one folder level and follow the specified path 

..\..\path: From the folder of the host drawing, move up two folder levels and follow the specified 

path 

If you have changed the path that include the xref drawings, such as moving the file or save it to a 

different path or disk, then all the relative paths of the xref must be changed individually so as to 

adapt to the new position of its parasitifer. 

No Path 

Specifies the path type of inserting xref as No path, the xref will not save the path information, if 

you want to search the original file of xref, you can search through the following ways: 

Search for the current folder of original drawing 

Search for the Xrefs File Search Path defined in File tab in Options dialog box. 

Search for the start folder assigned by shortcut of Windows applications 

No Path is useful when users want to move their drawings to another or an unknown folder 

hierarchy . 

To change the path for a single external reference 

Choose Insert > Xref Manager from the main menu. 

Select the external reference whose path you want to change. 

In Xref Found At, do one of the following: 

Enter a new filename or location. 

Click , select the xref under a new path in the Select New Path dialog box that displays, and 

then click Open. 

Choose Save Path, and then click OK. 
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Insert toolbar:  

Command line XREF 

NOTE You cannot recursively reference a drawing from the same original drawing. 

 

Commands Reference 

XCLIP: Defines an xref or block clipping boundary and sets the front or back clipping planes  

RENAME: Changes the names of objects 

XREF: Controls external references to drawing files 

System Variables Reference 

XEDIT: Controls whether the current drawing can be edited in-place when being referenced by 

another drawing 

XCLIPFRAME: Controls the visibility of xref clipping boundaries 

 Edit External References in Place 

Edit xrefs of current drawing without opening the xref drawings. 

Edit Selected Objects in Xrefs and Blocks 

You can edit or modify the visible text of xrefs attached to the drawing through edit in place. 

Because block references and xrefs are different types of reference files, editing and modifying the 

block references will be illustrated here. 

Generally, one or more xrefs and block references are contained in each drawing; the objects 

assigned to be edited must be block references so as to redefine. 

When you work with xrefs, you can modified the included objects, and save the modifications back 

to xrefs. This may be proper to use when making small changes to the current drawing. But for 

complex modifications, you should modify the xref drawing directly, and then update the attached 

xrefs in current drawing. Using edit in place for the xrefs may increase the size of the drawing and 

lower the capability of the computer. 

Understand the Working Set 

Objects contained in working set are components of selected references. ZWCAD+ extracts selected 

objects from the selected xrefs to edit in the current drawing, these objects having been extracted 

form a set called working set. Objects in working set can be changed and saved and the xrefs or 
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block definitions can be updated. 

When constructing working set, all the excluded objects of the working set may be fading 

displayed. 

Control the Fading of Objects 

When editing references in place, the selected objects are normally displayed except for other 

unselected xrefs or block references. The fading degree is controlled by system variable XFADECTL. 

This value set the displaying density of objects outside the working set. The greater the value, the 

more fading of the objects outside the working set displayed. 

 

Use the Refedit Toolbar 

Buttons on the Refedit toolbar are only available when you use edit in-place command, which 

contains the following buttons: 

Edit block or Xref 

Add objects to working set 

Remove objects from working set 

Discard changes to reference 

Save back changes to reference 

Add or remove objects from the working set 

When editing attached references, you can add or remove references by clicking at Add objects to 

working set or Remove objects from working set. 

If new objects are created when editing references, the new object may be taken as one of the 

objects in selected reference, and automatically add to working set, the objects outside the 

working set may be fading displayed. 

The objects to be edited in-place created in layer that the reference are locked are also editable. 

Before editing the references, you should unlock the layer on which the objects are located, and 

then modify this object. After modification, you can save the changes back to references. But the 

status of layer keeps unchanged regardless of lock. 

When saving the changes for the references, all the objects in working set are saved to references. 

Objects that are removed from the working set never contained in the reference, subsequently 

become other parts of the drawing. Objects that are added to the working set will be removed 

from its original position from the drawing. The objects being created or removed will be added or 

removed into the working set automatically. 
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Save Back Edited Xrefs and Blocks 

Changes to the references are optionally saved to the current drawing. 

If you choose saving the changes, system automatically regenerate the drawing, in addition, block 

definitions are redefined and all the blocks are regenerated as well. Thus, changes to the xrefs can 

be saved also, if the objects in working set inherit its original properties defined in external 

references, these objects retain new properties. If you remove some objects from the working set, 

these objects will be added into current drawing. 

If you discard the changes, the working set removed as well and return the block references to the 

original state. When editing references in-place, if objects excluded from the working set are 

removed and you discard the changes to the xref, the objects having been removed can't be 

restored. 

If you have saved the changes for the xref, you can get back the reference file and discard the 

changes, use UNDO command. 

If objects in current drawing inherit properties defined in xref, these objects will be displayed in 

new properties called binding properties. Additionally, you can specify how the xref names are 

displayed through system variable BINDTYPE. If the BINDTYPE is set to 0, the xref names will be 

added a prefix $#$, if the BINDTYPE is set to 1, keep the xref names unchanged. 

It should be noticed that you can't edit or change the referenced drawings when editing in-place, 

which are only readable. 

Edit Xrefs and Blocks with Nesting, OLE, or Attributes 

Edit in-place set limits for those nested xrefs in current drawing. When you editing nested xrefs, 

references together with their nested references are displayed in Reference Edit dialog box, you can 

also change all the nested references. But changes are available for one reference at a time. 

OLE objects included in reference you are editing can be displayed but not edited. 

If the block reference to be edited contains attributes, you can edit the attributes while editing the 

references by selecting "Display attribute definitions for editing" option on the Settings tab in 

Reference Edit dialog box. Attributes are invisible, but attributes definitions and selected geometric 

drawing can be edited together. The attributes of original references keep unchanged after saving, 

and new attribute definitions only affect the block subsequently inserted into the drawing.  

 

Commands Reference 

REFCLOSE: Saves back or discards changes made during in-place editing of a reference (an xref or 

a block)  

REFEDIT: Selects a reference for editing 

REFSET: Adds or removes objects from a working set during in-place editing of a reference (an xref 

or a block)  
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System Variables Reference 

BINDTYPE: Controls how xref names are handled when binding xrefs or editing xrefs in place 

REFEDITNAME: Displays the name of the reference being edited 

XEDIT: Controls whether the current drawing can be edited in-place when being referenced by 

another drawing  

XFADECTL: Controls the fading intensity percentage for references being edited in-place 

11.4 Dynamic Blocks 

Dynamic Block is a kind of block contains parameters and actions. It was built based on block. 

Dynamic block has the properties of block, which is uniquely flexible and intelligent. 

Currently, ZWCAD+ supports the display of dynamic blocks, the display and editing of dynamic 

block custom grips, and the editing and saving of dynamic blocks. 

The property of dynamic block is "block reference"; the dynamic block can be partially adjusted by 

using key points or via the Properties tab. 

You cannot perform "Non-uniform scaling" on dynamic block directly, if forced to operate, it will 

become a common block without "dynamic" characteristics. For example, the following operations 

will make dynamic blocks lose "dynamic" characteristics: 

Insert a dynamic block by using unequal XYZ scale factors in the Insert dialog box via command 

INSERT; 

Select a dynamic block, and then modify it by using unequal XYZ scale factors in the Properties; 

Modify a dynamic block by using unequal XYZ scale factors via command BSCALE; 

Refedit a dynamic block, and then save to exit. 

Grip Type of Dynamic Blocks 

Grip icons of dynamic blocks are as follows. 

Grip Name Grip Icon 

Standard grip 
 

Linear grip 
 

Rotate grip 
 

Flip grip 
 



 

 424 

Alignment grip 
 

Lookup grip 
 

 

 

Dynamic Block Grip Editing Function 

Dynamic block definition must contain at least one parameter. For dynamic block contains actions 

and parameters, the grips associated with the points, objects or regions in the block definition will 

be displayed. When you edit a grip, the associated action will be triggered, thereby changing the 

block reference display. You can perform manipulations such as stretch, move, flip, rotate, array, 

scale, align and lookup by dragging the grips of dynamic blocks. After you select a dynamic block 

with the appropriate parameters and actions, you can select the dynamic block grip (the grip color 

is light blue by default, it can be modified via the GRIPDYNCOLOR system variable) to edit, the 

grip will display in selected grip color, and then you can perform manipulations such as stretch, 

move, rotate, etc. on the selected dynamic block. 

Dynamic block grip editing functions are related to specific parameters, so the function of each grip 

is not listed separately, the specific relationship between them is as follows： 

Parameter Type Grip Type Corresponding Grip Editing Function 

Point 
 

Standard Move, Stretch 

Linear 
 

Linear Move, Scale, Stretch, Array 

Polar 
 

Standard Move, Scale, Stretch, Polar Stretch, Array 

XY 
 

Standard Move, Scale, Stretch, Array 

Rotate 
 

Rotate Rotate 

Flip 
 

Flip Flip 

Align 
 

Alignment None (The action is included in the parameter) 
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Visibility 
 

Lookup 
None (This is a hidden action controlled by the 

visibility state) 

Lookup 
 

Lookup Lookup 

Basepoint 
 

Standard None 

 

 

Use Grip Stretch Function on Dynamic Blocks 

Once you have selected a dynamic block contains stretch action, click the light blue grip on the 

dynamic block to display command line prompt as follows: 

Specify point Location or [Base point/Undo/eXit]: 

Under the prompt, you can specify a new position on the drawing area where the grip is expected 

to be stretched. Move the selected grip to the new position to stretch the object. 

Stretch dynamic block by using grip 

Select the dynamic block contains stretch action. 

Click on the light blue grip of the dynamic block to highlight the selected grip. 

Command line prompt appears, do either of the following: 

Specify "B(Base point)" option to locate the base point for stretching. 

Specify "U(Undo)" option to abort last stretch. 

Specify "X(eXit)" option to exit stretch manipulation. 

Specify target location for grip directly. 

After specify the target location, the selected dynamic block will be stretched. 

 

 

Use Grip Move Function on Dynamic Blocks 

You can move the selected dynamic block by moving its grip. The dynamic block will be moved 
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according to the specified orientation and position. 

Once you have selected a dynamic block contains move action, click the light blue grip on the 

dynamic block to display command line prompt as follows: 

Specify point Location or [Base point/Undo/eXit]: 

Move dynamic block by using grip 

Select the dynamic block contains move action. 

Click on the light blue grip of the dynamic block to highlight the selected grip. 

Command line prompt appears, do either of the following: 

Specify "B(Base point)" option to locate the base point for moving. 

Specify "U(Undo)" option to abort last moving. 

Specify "X(eXit)" option to exit move manipulation. 

Specify target location for grip directly. 

After specify the target location, the dynamic block will be moved towards the orientation and 

displacement along the connecting line of the selected grip and the target point. 

 

 

Use Grip Rotate Function on Dynamic Blocks 

You can rotate the selected entity by dragging its rotation grip. 

Once you have selected a dynamic block contains rotate action, click the light blue rotate grip on 

the dynamic block to display command line prompt as follows: 

Specify rotation angle or [Base point/Undo/eXit]: 

Rotate dynamic block by using grip 

Select the dynamic block contains move action. 

Click on the light blue grip of the dynamic block to highlight the selected grip. 

Command line prompt appears, do either of the following: 

Specify "B(Base point)" option to locate the base point for rotating. 

Specify "U(Undo)" option to abort last rotation. 

Specify "X(eXit)" option to exit rotate manipulation. 

Specify rotation angle for grip directly. 

After specify the rotation angle, the entity will be rotated centered by the selected grip (or the new 
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base point). 

 

 

Use Grip Scale Function on Dynamic Blocks 

You can scale the selected entity relative to the grip. Drag the entity outwards the base grip to 

enlarge its size, and drag inwards to decrease the size. 

Once you have selected a dynamic block contains scale action, click the light blue grip on the 

dynamic block to display command line prompt as follows: 

Specify point Location or [Base point/Undo/eXit]: 

Scale dynamic block by using grip 

Select the dynamic block contains move action. 

Click on the light blue grip of the dynamic block to highlight the selected grip. 

Command line prompt appears, do either of the following: 

Specify "B(Base point)" option to relocate the base point for scaling. 

Specify "U(Undo)" option to abort last scaling. 

Specify "X(eXit)" option to exit scale manipulation. 

Specify the target location for grip directly. 

After specify the target location, the dynamic block will be scaled towards the orientation and 

displacement along the connecting line of the selected grip (or the new base point) and the target 

point. 
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Use Grip Flip Function on Dynamic Blocks 

You can mirror the selected entity in the dynamic block about a specified reflection line by clicking 

its flip grip. 

Flip dynamic block by using grip 

Select the dynamic block contains flip action. 

Click on the light blue flip grip of the dynamic block，the entity in the dynamic block will be flipped. 

 

 

Use Grip Array Function on Dynamic Blocks 

You can array the objects in dynamic blocks by dragging and specifying the position of the grips. 

Once you have selected a dynamic block contains array action, click the light blue grip on the 

dynamic block to display command line prompt as follows: 

Specify point Location or [Base point/Undo/eXit]: 

Array dynamic block objects by using grip 

Select the dynamic block contains array action. 

Click on the light blue grip of the dynamic block to highlight the selected grip. 

Command line prompt appears, do either of the following: 

Specify "B(Base point)" option to locate the grip for arraying. 

Specify "U(Undo)" option to abort last arraying. 

Specify "X(eXit)" option to exit array manipulation. 

Specify target location for grip directly. 

After specify the target location, the dynamic block will array objects towards the orientation and 

displacement along the connecting line of the selected grip (or the new base point) and the target 

point. 
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Use Grip Align Function on Dynamic Blocks 

You can align the objects in dynamic blocks by dragging and specifying the position of alignment 

grip. 

Once you have selected a dynamic block contains align parameter, click the light blue alignment 

grip on the dynamic block to display command line prompt as follows: 

Specify point Location or [Base point/Undo/eXit]: 

Align dynamic block objects by using grip 

Select the dynamic block contains align action. 

Click on the light blue alignment grip of the dynamic block to highlight the selected grip. 

Command line prompt appears, do either of the following: 

Specify "B(Base point)" option to locate the grip for aligning. 

Specify "U(Undo)" option to abort last aligning. 

Specify "X(eXit)" option to exit align manipulation. 

Specify target location for grip directly. 

After specify the target location, the objects in the dynamic block will be aligned automatically. 

 

 

Use Grip Lookup Function on Dynamic Blocks 

You can change the dynamic block by using its lookup grips. The corresponding parameter of a 

lookup grip can be a lookup parameter or a visibility parameter. 

If the dynamic block contains a lookup parameter, then a list of available values will be displayed 
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when you click the lookup grip. You can choose a desired value from the list to change the dynamic 

block. As shown below: 

 

If the dynamic block contains a visibility parameter, then a list of all visibility states in the block 

reference will be displayed when you click the lookup grip in the drawing. You can choose a desired 

state from the list to change the display of dynamic block object. As shown below: 

 

 

Dynamic Block Properties Display 

In addition to use grip editing function to change the dynamic blocks, you can also change the 

dynamic blocks by modifying the values of custom properties items of the dynamic blocks (block 

reference display) in the Properties column. 

For a dynamic block added linear parameter, you can modify the dynamic block object by 

modifying the distance value in the custom properties. 

 

Commands Reference 

None 

System Variables Reference 

BTMARKDISPLAY: Controls the display of the value set markers 

GRIPBLOCK: Controls the assignment of grips in blocks 
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GRIPDYNCOLOR: Determines the color of custom grips for dynamic blocks 

GRIPOBJLIMIT: Suppresses the display of grips when the initial selection set includes more than 

the specified number of objects 

GRIPS: Controls the use of selection set grips for the Stretch, Move, Rotate, Scale, and Mirror Grip 

modes 

GRIPTIPS: Controls the display of grip tips when the cursor hovers over grips on custom objects 

that support grip tips 
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12 Hatches and Raster Images 

 

 

Topics in this section: 

Hatches 

You can use a process called hatching to fill an area with a selected pattern or solid color.  

Work with Raster Images 

You can view and manipulate raster images and associated file paths in ZWCAD+ drawings. 

12.1 Hatches 

You can use a process called hatching to fill an area with a selected pattern or solid color. 

Topics in this section: 

Overview of Hatch Patterns and Fills 

Fills an enclosed area or selected objects with a hatch pattern or gradient fill. 

Define Hatch Boundaries 

To create a hatch, you should define hatch boundaries first by means of selecting objects to be 

hatched or picking a point inside the desired object.  

Choose and Define Hatch Patterns 

You can use a predefined hatch pattern or solid fill, or you can create your own hatch patterns. 

SOLID 

With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled with a solid 

color. 

 Overview of Hatch Patterns and Fills  

Fills an enclosed area or selected objects with a hatch pattern or gradient fill. 

Filling the specified area with different material so as to distinguish project parts. These patterns 

are both predefined and user defined. 

Solid-filled areas can be created using the following three methods. 

 Hatches with solid patterns (BHATCH) 

 2D solids (SOLID) 

 Wide polylines, traces or donuts (PLINE, TRACE or DONUT) 

Gradient hatch refers to a kind of hatch pattern among different gradations within one or two 

colors. Which can be used to increase the drawing demonstration effects or use as background. 

To create a hatch, you should specify hatch area first which is so-called hatch boundary, various 

methods of creating hatch boundaries are provided as well as creating associative hatch for 

controlling the hatch pattern updated along with the boundary changes. If the specified boundary 
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is not a closed area, you can set maximum gap which is controlled by system variable HPGAPTOL 

when using the object as pattern boundary, any gap within this value range will be taken as closed 

boundary. But this gap is only available for lines and arcs, they'll be joined if extended. When 

creating hatch patterns, you can specify the draw order of the patterns to decide hatching before 

or after the boundaries, or set it in front or at back of all objects. 

Add Hatch Patterns and Solid Fills 

You can use BHATCH command to add hatch pattern to the drawing. When defining hatch patterns, 

you can specify the options in hatch dialog box: scale, angle, space, ISO pen width, associativity and 

double hatch. 

Create Associative Hatches 

If you select associative hatch properties when hatching the area, the hatched pattern updates 

automatically with the boundaries. By default, the hatch pattern created by BHATCH is associative. 

The associativity of a hatch pattern can be removed whenever you want. 

The objects that are outside the specified boundary will be ignored when creating hatches. 

If the text, properties or solid entities are connected to hatch patterns, only hatches the boundaries 

of these objects with the center retained as blank in order to form islands. 

Choose a Hatch Pattern 

User can select hatch patterns to distinguish different parts of the object and represent the object 

materials during hatching process. 14 ISO hatch patterns are provided, ISO pen width can be 

specified while selecting ISO hatch patterns. Pen width option is set to determine the pen width of 

the pattern. 

In Hatch and Gradient dialog box, the Pattern option in Type and Pattern area under Hatch tab 

contains all the pattern names defined in icad.pat file. You can define new hatch patterns in 

icad.pat, and apply them by restarting ZWCAD+ platform. 

Assign a Draw Order to a Hatch 

The draw order of hatching and boundaries can be controlled so as to view and select more easily. 

When creating hatch patterns, you can specify the draw order of the patterns to decide hatching 

before or after the boundaries, or set it in front or at back of all objects. The value will be stored in 

system variable HPDRAWORDER. 

Other settings of hatch pattern may not be influenced regardless of changing the draw order of 

hatch pattern. 

Edit Hatch Boundaries 

Hatch boundaries is capable of copy, move and stretch as well as other objects, but for large 

amount of object combinations, the geometric drawings for editing hatches may cause 

unpredictable results. It's suggested to abort hatch if necessary and remove the hatched blocks to 
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generate new ones. 

Create Custom Hatch Patterns 

You can define the angle and space of the current hatch by selecting User Defined type from the 

Type pull-down box, in Hatch tab of the Hatch and Gradient dialog box, so as to create customized 

pattern to hatch selected objects. 

 

Commands Reference 

BHATCH: Fills an enclosed area or selected objects with a hatch pattern or gradient fill 

BOUNDARY: Creates a region or a polyline from an enclosed area 

DONUT: Draws filled circles and rings 

FILL: Controls the filling of objects such as hatches, two-dimensional solids, and wide polylines 

HATCH: Fills a closed area or selected object with hatch pattern or gradient hatch pattern. 

HATCHEDIT: Modifies an existing hatch object 

PLINE: Creates two-dimensional polylines 

PROPERTIES: Controls properties of existing objects 

SOLID: Creates solid-filled triangles and quadrilaterals 

System Variables Reference 

FILLMODE: Specifies whether hatches (including solid-fill), two-dimensional solids, wide polylines, 

are filled in 

HPANG: Specifies the hatch pattern angle 

HPASSOC: Controls whether hatch patterns and gradient fills are associative 

HPBOUND: Controls the object type created by the BHATCH and BOUNDARY commands 

HPDRAWORDER: Controls the draw order of hatches and fills 

HPDOUBLE: Specifies hatch pattern doubling for user-defined patterns 
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HPNAME: Sets a default hatch pattern name of up to 34 characters without spaces  

HPSCALE: Specifies the hatch pattern scale factor, which must be nonzero 

HPSPACE: Specifies the hatch pattern line spacing for user-defined simple patterns, which must be 

nonzero 

PICKSTYLE: Controls the use of group selection and associative hatch selection 

 Define Hatch Boundaries 

To create a hatch, you should define hatch boundaries first by means of selecting objects to be 

hatched or picking a point inside the desired object. A hatch boundary can be any combination of 

objects, such as lines, arcs, circles, and polylines, that forms an enclosed area. 

To raise the speed of hatching a small area of a complex drawing, you can define a set of objects in 

the drawing. HATCH does not analyze objects that are not included in the boundary set. 

Island is a concept representative to the closed area inside the hatched object. You can hatch the 

island and also retain its original state.  

Objects can be hatched only if they are in a plane parallel to the XY plane of the current UCS. For 

the internal area of polylines with width and solid hatching, hatches can't be applied because of its 

unacceptable profiles. 

Control the Hatching in Islands 

You can specify methods of hatching objects in outermost boundary as normal, outer and ignore. 

Normal is the default hatch pattern, besides, you can view hatching results of different types in the 

Islands area on Hatch tab of the Hatch and Gradient dialog box. 

Normal 

Hatch the pattern from the outer boundary to inside. Hatching process will be stopped when 

encounter inner crossing points, and continue hatching until second inner crossing point appears. 

So if counter from outer boundary of hatch area, the area separated by odd number crossing points 

will be hatched, on contrary the area separated by even crossing points will not be hatched. 
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Outer 

Hatch the pattern from the outer boundary to inside. For the hatching starts from two points of 

each hatch line, system will hatch from the outer most layer of configuration, and keep the internal 

blank. Hatching process will be stopped when encounter inner crossing points. 

Ignore 

Ignore internal objects, only hatches outer objects. The following example displays the results of 

hatching a complex entity with Normal, Outer, Ignore pattern individually: 

 

You can also remove any islands from the hatch area. 

 

Define Hatch Boundaries in Large Drawings 

Generally, boundaries are defined by analyzing all the closed objects. It's time consuming to define 

boundaries through analyzing all the visible or partly visible objects when encounter complex 

drawings. In such cases you can save time hatching a small area in a complex drawing by defining a 

set of objects in the drawing to be used in determining the hatch boundary. 

Boundaries are also available for applying different hatch patterns to islands in different area of the 

drawing. To avoid selecting the undesired hatch area, it's required to enlarge the drawing. Once 

Existing set in Boundary set option on Other options tab is selected, the objects used for defining 

boundaries will be highlighted. 
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Create Unbounded Hatches 

You can define a hatch boundary composed by multiple points manipulated from the Boundary 

option of -HATCH or -BHATCH command. System inquires for whether to retain boundaries when 

finish hatching, if choose not to retain boundaries, then create hatch pattern without boundaries. 

For example, to define a boundary through specifying points, only a small part of the large area of 

the drawing will be hatched, hatching the large area without boundaries, shown as follows: 

 

Selecting objects for hatching 

A hatch boundary can be defined by means of selecting any object, for example, a circle or 

rectangle. You can assign hatching to a single object or several objects at the same time. 

You can add hatching to an area enclosed by selected objects to form the hatch boundary. The 

hatch is formed within the enclosed area, not the objects themselves. Once a hatch is created, it 

will be treated as a single object. And the object being hatched changes along with the hatch 

boundary if the hatch you create is associative. 

To select objects for hatching 

Choose Draw > Hatch from the main menu. 

From the Hatch and Gradient dialog box, click the Island detection option, and then choose one of 

the following islands: 

Normal Areas separated from the outside of the hatched by an odd number of intersections are 

hatched. 

Outer Only the outer object and its outer island are considered for hatching. 

Ignore The entire object is considered for hatching, inner area will be ignored. 
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Normal islands (A), with outer island (B), and with ignore islands (C). 

To keep any new objects that are created for drawing the boundary hatch, select the Retain 

Boundaries check box under Other options. Existing objects are always retained. 

In the Boundaries, click Select Objects button. 

In the drawing, click the objects to be hatched individually, and then press Enter when done. 

In the Hatch and Gradient dialog box, click OK. 

Draw toolbar:  

Command line BHATCH 

 

Select an area for hatching 

Choose Draw > Hatch from the main menu. 

From the Hatch and Gradient dialog box, click the Island detection option, and then choose one of 

the following islands: 

Normal Areas separated from the outside of the hatched by an odd number of intersections are 

hatched. 

Outer Only the outer object and its outer island are considered for hatching. 

Ignore The entire object is considered for hatching, inner area will be ignored. 

 

Normal islands (A), with outer island (B), and with ignore islands (C). 

To keep any new objects that are created for drawing the boundary hatch, select the Retain 

Boundaries check box under Other options. Existing objects are always retained. 

In the Boundaries, click Pick Points button. 



 

 439 

In the drawing, click inside the closed perimeter of a boundary, not on the boundary itself. If 

desired, continue clicking inside additional closed perimeters. 

To complete the selection, press Enter. 

In the Hatch and Gradient dialog box, click OK. 

Draw toolbar:  

Command line BHATCH 

 

Commands Reference 

BHATCH: Fills an enclosed area or selected objects with a hatch pattern or gradient fill 

BOUNDARY: Creates a region or a polyline from an enclosed area 

DONUT: Draws filled circles and rings 

HATCH: Fills a closed area or selected object with specified hatch pattern or gradient pattern. 

HATCHEDIT: Modifies an existing hatch object 

PLINE: Creates two-dimensional polylines  

SOLID: Creates solid-filled triangles and quadrilaterals 

System Variables Reference 

HPBOUND: Controls the object type created by the BHATCH and BOUNDARY commands 

PICKSTYLE: Controls the use of group selection and associative hatch selection 

 Choose And Define Hatch Patterns 

User can use predefined hatch pattern or solid hatch and create hatch pattern of your own. 

Create Solid-Filled Areas 

Methods of creating solid hatch: 

Hatches with solid patterns (BHATCH) 

2D solids (SOLID) 

Wide polylines, traces or donuts (PLINE, TRACE or DONUT) 



 

 440 

 

Create Gradient-Filled Areas 

Fills the area with gradient appearance, which is a type of solid hatch represents solid entity as 

well. 

Gradient hatch refers to a kind of hatch pattern among different gradations within one or two 

colors. Which can be used to increase the drawing demonstration effects or use as background. 

Like creating other hatch patterns, you can create gradient hatch as well as associative gradient 

hatch in the same way. But the color assigned in gradient hatch can't be controlled by print style. 

Use Predefined Hatch Patterns 

Fills the specified area with different material so as to distinguish project parts. User can select 

hatch patterns to distinguish different parts of the object and represent the object materials during 

hatching process. 14 ISO hatch patterns are provided, ISO pen width can be specified while 

selecting ISO hatch patterns. Pen width option is set to determine the pen width of the pattern. 

Create User-Defined Hatch Patterns 

When selecting hatch patterns, you can define simple patterns by changing angle and space of 

pattern lines based on current linetype. This is so-called User defined. 

Specifying a hatch pattern 

A hatch pattern consists of a repeating pattern of lines, dashes, and dots. You can select a hatch 

pattern from a set of predefined patterns, or you can define a pattern of your own. The hatch 

pattern you used most recently is the default pattern the next time you add hatching. The program 

supplies predefined standard hatch patterns, which are stored in the ICAD.pat and ICADISO.pat 

hatch pattern library files. 

NOTE The ICAD.pat hatch pattern library files are ANSI (American National Standards Institute) 

compliant patterns; the ICADISO.pat hatch pattern library files are ISO (International Standards 

Organization) compliant. 

To specify a predefined hatch pattern 

Choose Draw > Hatch from the main menu. 

From the Hatch and Gradient dialog box, click the Hatch tab. 

Under the Hatch – Type and pattern, in the Type list, click Predefined. With Predefined, you can 

apply a scale factor to make the pattern larger or smaller than the default size. 

For Scale, enter the scale factor as a percentage of the default. 

For Angle, enter the angle of the pattern in degrees (1-360). The default angle is clockwise, you can 
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change the angle of any hatch pattern by entering a numerical value. 

For ISO Pen Width, enter the pen width. This option is only available if you select existing ISO hatch 

pattern in the Pattern option. 

To copy the pattern properties from an existing hatch, choose Inherit Properties. 

To associate the hatch pattern to its boundary objects, under Other options, select the Associative 

check box. An associative hatch updates automatically if you move any of its boundaries. 

To continue, add a hatch by doing one of the following: 

In the Boundaries, click Select Objects button to select the objects you want to add a hatch. Repeat 

the procedures following step 2. 

In the Boundaries, click Pick Points button to select an area or boundary you want to add a hatch. 

Repeat the procedures following step 2. 

Draw toolbar:  

Command line BHATCH 

 

To specify a user-defined hatch pattern 

Choose Draw > Hatch from the main menu. 

From the Hatch and Gradient dialog box, click the Hatch tab. 

Under the Hatch – Type and pattern, in the Type list, click User Defined. 

For Spacing, enter the line spacing for the pattern. 

To copy the pattern properties from an existing hatch, choose Inherit Properties, and select a hatch 

pattern from a hatched object in the drawing. 

To associate the hatch pattern to its boundary objects, under Other options, select the Associative 

check box. An associative hatch updates automatically if you move any of its boundaries. 

To continue, add a hatch by doing one of the following: 

In the Boundaries, click Select Objects button to select the objects you want to add a hatch. Repeat 

the procedures following step 2. 

In the Boundaries, click Pick Points button to select an area or boundary you want to add a hatch. 

Repeat the procedures following step 2. 

Draw toolbar:  

Command line BHATCH 

 

To use a predefined library pattern 

Choose Draw > Hatch from the main menu. 

From the Hatch and Gradient dialog box, click the Hatch tab. 

Select a Predefined type. 

To select a predefined pattern, do one of the following: 

In the Pattern list, click the pattern name. 

Click the graphical representation of the hatch pattern. 

To continue, add a hatch by doing one of the following: 

In the Boundaries, click Select Objects button to select the objects you want to add a hatch. Repeat 

the procedures following step 2. 

In the Boundaries, click Pick Points button to select an area or boundary you want to add a hatch. 
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Repeat the procedures following step 2. 

Draw toolbar:  

Command line BHATCH 

NOTE Hatch patterns are memory intensive and can take a considerable amount of time to draw 

and display. To improve performance, add hatching as one of the last steps when you create a 

drawing, or insert hatches on a separate layer that you can freeze as you continue to work on your 

drawing. 

 

Commands Reference 

BHATCH: Fills an enclosed area or selected objects with a hatch pattern or gradient fill  

FILL: Controls the filling of objects such as hatches, two-dimensional solids, and wide polylines  

DONUT: Draws filled circles and rings 

PLINE: Creates two-dimensional polylines 

SOLID: Creates solid-filled triangles and quadrilaterals 

System Variables Reference 

HPBOUND: Controls the object type created by the BHATCH and BOUNDARY commands 

FILLMODE: Specifies whether hatches (including solid-fill), two-dimensional solids, wide polylines, 

are filled in  

HPANG: Specifies the hatch pattern angle 

HPDOUBLE: Specifies hatch pattern doubling for user-defined patterns 

HPSCALE: Specifies the hatch pattern scale factor, which must be nonzero 

HPNAME: Controls the object type created by the BHATCH and BOUNDARY commands 

HPSPACE: Specifies the hatch pattern line spacing for user-defined simple patterns, which must be 

nonzero 

 SOLID 

With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled with a solid 
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color. The default method is to specify the corners of the plane. After you specify the first two 

corners, the plane is displayed as you specify the remaining corners. The program prompts you for 

the third point and then the fourth point. 

To draw a quadrilateral plane 

Choose Draw > Surfaces > 2D Solid from the main menu. 

Specify the first point. 

Specify the second point. 

Specify the third point. 

Specify the fourth point. 

To complete the command, press Enter. 

Surfaces toolbar:  

Command line SOLID 

 

After you select the first two points (A) and (B), the sequence in which you 

select the third (C) and fourth (D) points determines the shape of the resulting 

quadrilateral plane. 

 

Commands Reference 

SOLID: Creates solid-filled triangles and quadrilaterals 

System Variables Reference 

None 

12.2 Work with Raster Images 

You can view and manipulate raster images and associated file paths in ZWCAD+ drawings. 

Topics in this section: 

 Attach, Scale, and Detach Raster Images 

You can add or remove references to raster images within drawing files, or you can change their 

relative size. 
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 Modify and Manage Raster Images 

Controls the properties such as displaying and clipping boundary of raster images. You can view and 

manipulate attached raster image and change its saving path in Image Manager. 

 ZwRasterImageTool 

You can use this tool to generate cache files for large images in batch, so as to quickly insert and 

operate these images in ZWCAD+. 

 Attach, Scale, and Detach Raster Images 

Raster images consist of a rectangular grid of small squares or dots known as pixels. 

As consists of multiple rectangular grids, raster images can be copied, moved, or clipped as well as 

a normal object in the drawing. You can change the position and size of the image by dragging its 

grips. You can also adjust the contrast, transparency, image quality and image frame visibility as 

well from the menu option "Modify-Object-Image". 

Image file formats ZWCAD+ supports most of the frequently used file formats, such as computer 

graphics, document management, engineering, mapping, and geographic information systems (GIS) 

and image file of bitonal, 8-bit gray, 8-bit color, or 24-bit color. 

Once you have inserted an image with transparent pixel, the drawing behind the transparent pixel 

will be displayed when you turn on the image transparency. If you insert a bitonal image, the 

background color pixel is processed by transparency, either gray or color images are assigned to 

support transparent pixels. 

Additionally, when inserting raster images, the file format depends on the content of the file rather 

than the extension name. The following table display all the image file formats supported by 

ZWCAD+: 

Type:  Description and versions: File extension: 

BMP Windows and OS/2 bitmap format .bmp 

ECW Enhanced Compression Wavelet .ecw 

JFIF or JPEG  Joint Photographics Expert Group .jpg or .jpeg 

PCX Picture PC Paintbrush Picture .pcx 

PNG Portable Network Graphic .png 

TGA True Vision Raster-Based Data Format .tga 

TIFF Tagged Image File Format .tif or .tiff 

GIF Graphic Interchange Format .gif 

Attach Raster Images 

Use IMAGEATTACH to select and attach raster images, or bitonal, 8-bit gray, 8-bit color, or 24-bit 

color image files to a drawing. Attaching an image creates an image definition, loads the image into 

memory, and displays the image. Similar to the attach xrefs, attaching a path of the raster image 
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that is not virtual part of the drawing file, the path linked to the image files can be changed or 

removed any time you want. The image file can be inserted as blocks as many times as you like 

once attached to the current drawing, you can clip the attached raster image and setup its lightness, 

contrast, fading and transparency. 

To attach a raster image 

Choose Insert > Raster Image from the main menu. 

Specify a file to attach, and then click OK. 

In the Image dialog box, in the Insertion point and Scale, click Specify on-screen. Specify an angle 

value in Rotation, and then click OK. 

Specify an insertion point. 

Specify a scale. 

Reference toolbar:  

Command line IMAGEATTACH 

 

Scale Raster Images 

To attach a raster image to current drawing, you can specify scale factor in the Image dialog box, 

otherwise to attach it by its original size. The raster image will be scaled by the specified factor, the 

scale factor is used without unit by default. 

If the attached image contains resolution information for defining DPI, the specified scale factor will 

be united with measure to scale attached raster image. If resolution information is not included, 

then the original width of the image will be taken as unit for the scale factor when attaching the 

image. 

Detach Raster Images 

Raster images can be detached if it no longer needs to use in the drawing, a specified image 

detached from the drawing together with its multiple copies, links and definitions, but the original 

image file will not be influenced. 

Unlike detaching an image file, removing the image directly from the drawing retains the image in 

Image manager. Only can detaching the image remove the links of the image that connecting the 

drawing. 

 

Commands Reference 

IMAGE: Manages images 

IMAGEATTACH: Attaches a new image to the current drawing 
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System Variables Reference 

None 

 Modify and Manage Raster Images 

Controls the properties such as displaying and clipping boundary of raster images. You can view and 

manipulate attached raster image and change its saving path in Image Manager. 

Show and Hide Raster Image Boundaries 

Controls whether to display image boundary in current view using IMAGEFRAME command. Raster 

image can be displayed without frame. Usually users select image entity by clicking image frame. 

Setting IMAGEFRAME to Off prevents you from accidentally selecting an image. 

Once hide the image frame, the image can't be selected by SELECT command, keep the clipped 

image displayed within specified frame. 

All the attached images update as soon as the visibility of raster image frame is set to display or 

hide. 

To turn image frames on or off for all images 

Choose Modify > Object > Image > Frame from the main menu. 

Do one of the following to toggle frames off and on: 

Type ON to display and print frames for all images in a drawing. 

Type OFF to hide all frames on the screen and during printing. 

Reference toolbar:  

Command line IMAGEFRAME 

 

 

Clip Raster Images 

You can get the desired part of the image displayed through imageclip, and also improve the 

redraw speed so as to define the display and plot area of the image. 

Two types of clipping boundary are provided as rectangle composed by lines and polyline. The 

vertex within an image boundary even if self-intersected vertex should be specified when you 

define new boundaries. Here rectangle boundary is the default pattern of clipping boundary. Only 
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one clipping boundary is assigned for each image instance, but multiple instances of the same 

image can be assigned with different boundaries. 

The clipped image can be displayed within clipping boundary, and also displayed inside its original 

boundary. 

You can remove the clipping boundary of an image and use the original frame of the image to 

display the clipped image instead. But the boundary of the image to be clipped must be visible. 

 

To clip an image in the shape of a rectangle 

Choose Modify > Clip > Image from the main menu. 

Select the edge of the image you want to clip. 

If prompted, type N (New boundary) to create a new clipping boundary. 

Choose Rectangular. 

Define the first corner of the clipping rectangle. 

Define the second corner of the clipping rectangle. The selected image is clipped so that only the 

interior of the rectangle is visible. 

Reference toolbar:  

Command line IMAGECLIP 

 

To clip an image in the shape of a polygon 

Choose Modify > Clip > Image from the main menu. 

Select the edge of the image you want to clip. 

If prompted, type N (New boundary) to create a new clipping boundary. 

Choose Polygonal. 

Select the points for the polygon, and then press Enter when the polygon is complete. The selected 

image is clipped so only the interior of the polygon is visible. 

Reference toolbar:  

Command line IMAGECLIP 

 

To turn clipping on or off for an image 

Choose Modify > Clip > Image from the main menu. 

Select the edge of the image for which you want to turn clipping on or off. 

Type ON or OFF. 
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Reference toolbar:  

Command line IMAGECLIP 

 

To remove clipping from an image 

Choose Modify > Clip > Image from the main menu. 

Select the edge of the image for which you want to remove clipping. 

Type D (Delete). 

Reference toolbar:  

Command line IMAGECLIP 

 

Change Raster Image Brightness, Contrast, and Fade 

Use IMAGEADJUST to adjust displaying result and lightness, contrast and fade that are related to 

the display and plot effect when plotting drawings. IMAGEADJUST does not affect the original 

raster image as well as other instances of the image. 

You can set lightness and contrast to better preview images of lower quality. 

To change the fade of the image, geometric lines will be clearly viewed and add watermark effects 

when plotting the image. 

If you attach a bitonal image into the drawing, you can't set the lightness, contrast, and fade. 

Bitonal images are displayed as background color of current screen, and plotted as white. 

Modify Color and Transparency for Bitonal Raster Images 

Bitonal raster Image contain a foreground color and a background color, so that the current color 

settings determine the foreground color of the bitonal image as attached into the drawing. 

Although the lightness, contrast, and fade are not adjustable for bitonal images, you can modify the 

foreground color of the image and control its transparency from the Properties palette. 

NOTE Bitonal images and their boundaries are always the same color. 

View Raster Image Information 

The raster images already attached to the drawing are displayed in list or tree view in Image 

Manager. You can click Details button to view the relevant information of the raster image. 

List View 

System defaults to use List view for displaying the name, status (load, unload or not found), size, 

type, last save date and time as well as saving path of the image file. 

Click on the column title to rank the images. If the original file of the inserted image is missing, the 

image status is displayed as "Not found". Images that are unloaded or not found in the Image 

Manager will not be displayed in the drawing. 
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Tree View 

Sorts the raster images in tree view and display the hierarchy of the images nested in xrefs and 

blocks. 

View Image FileDetails 

Click DETAIL button to preview a selected image and view image file details, including image name, 

saved path, active path (where the image is found), file creation date, file size, file type, color, color 

depth, image size (pixel width and height, resolution and default size). 

Assign Descriptive Names to Raster Images 

You can change the name of an image by double clicking the file listed on the Image Manager. You 

can assign the image name different from the file name, the image is attached into the drawing 

without extension name. 

To rename an image, any name within 255 characters including letters, numbers, spaces and all the 

special characters Microsoft® Windows® or ZWCAD+ can be used. 

If two raster images of the same name originated from different paths are attached to the drawing, 

system automatically distinguish them by adding numbers after the image name. 

Change File Paths of Raster Images 

The raster images already attached to the drawing are displayed in Image Manager and its saving 

path is displayed in "Image found at" option at the bottom of Image Manager. Where the saving 

path is the virtual path for searching the image file. 

If the original image attached to the drawing is not exist in the saving path or any defined searching 

path, the status of the image is displayed as Not found and the "Image found at" box is blank. 

If the specified extension name of the drawing is not found at the saving path, system searches for 

all the image file extension names. 

The path of the image can be removed, or directly edit the path in Image found at box and then 

select Save path to specify its relative path. This may be different from the path in Image found at 

box.  

To change the path for a raster image 

Choose Insert > Image Manager from the main menu. 

Select the desired file. 

Click the Browse button. 

In the Select Image File dialog box, select the file with its new name or in its new location, and then 

click Open. 

Click Save Path. 

Reference toolbar:  

Command line IMAGE 
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Load and Unload Raster Images 

If excessive raster images exist in current drawing, you can unload the undesired images so as to 

raise the capability of your computer. Once the raster image is unloaded from the drawing, it'll be 

displayed as image boundary disabled of plotting. And the links of the image does not change after 

unloaded. If too much images attached to the drawing cause memory lacking in process of opening 

the drawing, system automatically unload part of image files. 

Once unloaded, you can reload the images already unloaded from the drawing. If you close the 

unloaded drawing after saving it, this drawing file is only available by reloading it next time you 

open the drawing. 

To unload and reload a raster image 

Choose Insert > Image Manager from the main menu. 

Select the file you want to unload or reload. 

Do one of the following: 

To unload the image so only its outer edge displays, click Unload. 

To reload the image so its contents display and print, click Reload. 

Reference toolbar:  

Command line IMAGE 

 

Improve the Display Speed of Raster Images 

The display quality of images may affect its properties directly, the higher the quality, the longer it 

displayed. Any changes to the image display speed will be updated immediately rather than redraw 

the drawing. System plots the drawing at its high quality. 

You can adjust the display speed by setting the raster image quality. The image quality is sorted into 

high and draft levels, If the quality is set to draft, the image will be displayed with some granular 

materials, however with faster display speed. 

If the attached raster image uses true color (24 or 32 bit each pixel), you can adjust relevant options 

in Display tab on Options dialog box so as to improve the image quality. System takes a long time to 

redraw the drawing when it displayed at high quality. To improve the capability, it's suggested to 

reduce the color number set at the display option. 

In purpose of improve the redraw speed, you can hide the undesired images in current drawing 

operations through Show image option on the Properties palette. The hidden image will be neither 

displayed on the screen nor plotted, only displayed as a boundary. To hide an image, you may 

ignore the UCS of current viewport. 

To change the quality of all images in a drawing 

Choose Modify > Object > Image > Quality from the main menu. 

Do one of the following: 

Type H (High) to use high quality images. 

Type D (Draft) to use draft quality images, which require smaller amounts of system resources. 

Reference toolbar:  
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Command line IMAGEQUALITY 

 

Use Tiled Images 

Tiled image is a series of small parts of large images. Loading tiled images is faster than loading 

those untiled images due to the tiled images redraws its modified parts to save time in loading 

images. ZWCAD+ supports TIFF for tiled image file format which is also available for bitonal gray (1 

bit per pixel) and index color (8 bit per pixel), true color (24 or 32 bit per pixel). 

Tiled TIFF images can be saved by image scanners. But you must limit the pixel within the range 64 

× 64 to 512 × 512 when tiling images. You can get programs that support other tiled file 

formats from third party program developer. 

Suppress Highlighting When Selecting Images 

Generally, the image will be highlighted once selected. Set the "Highlight raster image frame only" 

option in "Display" tab on "Options" dialog box to turn on or off the highlight mode for the 

specified raster image. Besides, system variable IMAGEHLT is also available for controlling the 

highlight mode of the image frame. Set the IMAGEHLT to 0, only highlight the frame of the raster 

image. You should turn off highlight mode for the whole drawing so as to improve the capabilities 

of your computer. 

Change the Temporary Swap File Location of Raster Images 

Temporary swap file is useful when you want to reduce the memory space that image file occupies. 

Windows Temp folder is the default saving path provided by system, you can also specify a new 

Temporary File Search Path in Files tab on Options dialog box. 

 

Commands Reference 

IMAGE: Manages images 

IMAGEATTACH: Attaches a new image to the current drawing 

IMAGEFRAME: Controls whether image frames are displayed or hidden from view 

IMAGECLIP: Creates new clipping boundaries for an image object 

PROPERTIES: Controls properties of existing objects 

IMAGEADJUST: Controls the image display of the brightness, contrast, and fade values of images 

TRANSPARENCY: Controls whether background pixels in an image are transparent or opaque 
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OPTIONS: Customizes the ZWCAD+ settings 

IMAGEQUALITY: Controls the display quality of images 

System Variables Reference 

PROJECTNAME: Assigns a project name to the current drawing 

IMAGEHLT: Controls whether the entire raster image or only the raster image frame is highlighted 

 ZwRasterImageTool 

You can use this tool to generate cache files for large images in batch, so as to quickly insert and 

operate these images in ZWCAD+. 

Generate cache files for large images 

Run RasterImageProc.exe program under the installation directory to launch ZwRasterImageTool. 

Open the ZwRasterImageTool dialog box. 

Image paths needing to generate cache files can be chosen by Select Files or Select Directory. 

 You can use Select Files to select one or more image files. 

 Subfolders can be included in the Select Directory. 

When no image file or folder is selected, the value for Cache Path is empty. When you select an 

image file, the default value for Cache Path of a cache file is the path where the image file locates. 

When you select a folder, the default value for Cache Path of a cache file is the path where the 

folder locates. You can also specify a new cache path by clicking Select Directory. 

The naming rule of output cache file is NAME_MODIFIEDTIME_CREATE 

TIME_SIZE.ZWIMG. 

Click Start button to generate cache files. What will be displayed in the List box is as follows:  

Image path&image file name+status of generating cache files 

"Complete!" displays when all cache files have been generated 
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When you specify a new output path for cache files, the output path 

specified will be added to the RasterImage Cache File Search Path after all 

cache files have been generated. 

Note When there are more than 10 paths in the RasterImage Cache File Search Path, the following 

message is displayed after all cache files have been generated: RasterImage Cache Search Path 

More Than 10, it's affect the performance that Search RasterImage Cache. Please Clear it By 

Command "OPTION" items "RasterImage Cache Search Path". 

Click Quit button to quit the current operation and close the ZwRasterImageTool dialog box. 

Click ? button to open ZWCAD+ 2015 Help. 

 

Commands Reference 

OPTIONS: Customizes the ZWCAD+ settings  

System Variables Reference 

None 
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13 Layout , Plot and Publish Drawings 

 

 

Topics in this section: 

Create Multiple-View Drawing Layouts 

You can print your drawing directly from the Model tab where you created it, or you can create 

custom layouts for printing on Layout tabs. 

Plot Drawings 

Once you have completed a drawing, you can plot the drawing on paper or create a file for use with 

another application. In either case, you select the plot settings.  

Publish Drawings 

Publishing allows you to assemble a collection of drawings and plot directly to paper or publish to a 

DWF (Design Web Format) file. 

13.1 Create Multiple-View Drawing Layouts 

You can print your drawing directly from the Model tab where you created it, or you can create 

custom layouts for printing on Layout tabs. 

When printing from the Model tab, you can print your drawing exactly the way it appears, or you 

can modify the drawing before printing by adding dimensions, a legend, or a title block. 

You typically use the Layout tabs for printing if you require multiple print layouts. You may also 

want to use a Layout tab for printing even if you want your drawing printed only one way. For 

example, if you want to include large amounts of text on your printed drawing, you can add the 

text to a Layout tab so it does not clutter your drawing while you work on the Model tab. 

 

Topics in this section: 

 Overview of Layout 

A layout represents a plotted page on which one or more model views are displayed. ZWCAD+ 

provides two collateral working environments as Model tab and Layout tab. You can create 

thematic models on Model tab. 

 View Drawings in Paper Space and Model Space 

When you work in paper space on a Layout tab, you can still view your drawings in model space. 

First you need to create a layout viewport in paper space; this allows you to view your model space 

objects from paper space. 

 Specify Layout Settings 

Once created a drawing in Model tab, you can toggle to Layout tab and setup the layout for plotting, 

such as paper size, drawing orientation and so on. 
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 Create and Modify Layout Viewports 

When you begin working in a drawing on the Model tab, it consists of a single view of your model. 

You may have created additional views by dividing the drawing space into multiple windows; each 

window is a separate viewport on the Model tab. 

 Create Non-rectangular Layout Viewports 

Use Object and Polygonal options of MVIEW to create irregular viewports, Select Object option to 

convert objects created in paper space to viewports. While selecting Polygonal option to draw 

irregular polylines including arcs and lines which are enabled to either intersect or three vertexes at 

least, the polyline will be closed automatically to form irregular polygonal viewport. 

 Overview of Layout 

A layout represents a plotted page on which one or more model views are displayed. ZWCAD+ 

provides two collateral working environments as Model tab and Layout tab. You can create 

thematic models on Model tab. Multiple slides of the model can be set in Layout tab. 

Enable unlimited drawing area on Model tab. You can draw a picture at the scale of 1:1, and define 

which unit to be used as the measurement units of the drawing (here Inch is for brackets and 

metric is for bridges). 

Virtual drawing paper is accessible in Layout tab. When setting layouts, the drawing can be 

displayed as the paper size. A layout represents a plotted page which is so-called paper space. 

You can get the objects created in model space displayed on paper space by creating multiple 

viewports. And you can create dimensions as well as other geometric objects in layouts. Each 

viewport are capable of displaying objects in model space in specified proportion. 

System provides two layouts by default, called layout 1 and layout 2. You can create as many 

layouts as you want, with various page setup and size for each layout. If you are working with a 

template file, default layout configuration may be different. 

When you create a drawing, you do most of your work on the Model tab. Each drawing that you 

create can contain numerous layouts that simulate the paper on which you will print a copy of the 

drawing. Each of these layouts is created on a Layout tab. You can prepare a separate layout for 

each way you want to print your drawing. The layout allows you to organize different views to 

control which portion of your drawing prints and at what scale. 

Use these general steps to prepare your drawing for printing multiple layouts: 

On the Model tab, create your drawing. 

Create a new layout. You can use an existing Layout1 or Layout2 tab, or you can create a new 

Layout tab. 

Create at least one layout viewport on the Layout tab. Use each viewport to help control which 

portion of the drawing prints and at what scale. 

Specify additional settings for the layout, such as the scale of the drawing, print area, print style 

tables, and more. 

Print or plot your drawing. 

 

You can right click on Layout tab and select "New layout" to create a new layout, and also import 

layout from template. 
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Options on Shortcut menu are listed as follows: 

New layout: Creates new layouts 

From template: Imports layouts from the template file 

Delete: Removes specified layouts 

Rename: Renames a layout 

Move or Copy: Rearranges the layouts on layout tab and creates copies of the selected layout 

Work with Model Space and Paper Space 

Model space is generally used for designing drawings, creating and editing drawings. Preparations 

for plotting are usually working on paper space for the drawings on layouts are close to the plotting 

effects. 

When you start a drawing session, your initial working area is called model space. Model space is 

an area in which you create two dimensional and three dimensional objects based on either the 

World Coordinate System (WCS) or a user coordinate system (UCS). You view and work in model 

space while using the Model tab. 

Your view of this area is a single viewport that fills the screen. You can create additional views on 

the Model tab, called viewports, which can show the same or different two dimensional or three 

dimensional views, all of which are displayed in a tiled manner. You can work in only one of these 

viewports at a time on the Model tab, and you can print only the current viewport. 

ZWCAD+ provides an additional work area, called paper space. The contents of paper space 

represent the paper layout of your drawing. In this work area, you can create and arrange different 

views of your model similar to the way you arrange detail drawings or orthogonal views of a model 

on a sheet of paper. 

You view and work in paper space while using a Layout tab. Each view, or layout viewport, that you 

create in paper space provides a window of your drawing in model space. You can create one layout 

viewport or several. You can place layout viewports anywhere on the screen; their edges can be 

touching or not; and you can print them all at the same time. 

You do not need to use paper space to print your drawing, but it offers several advantages: 

Print the same drawing with different print settings that you save with each layout, for example, 

printer configuration files, print style tables, lineweight settings, drawing scale, and more. 

For a single layout, create multiple layout viewports that print the model at different views and 

scales. 

You can toggle the Model space and Paper space by clicking on the tabs, and create viewports on 

current layout tab to obtain model space for further manipulations. If the drawing is not required 

to plot multiple viewports, you can plot the drawing directly from Model space. 

Layout tab is enabled to make relevant plot settings. Paper space is provided in each layout option, 

and you are allowed to create viewports and specify page setup such as paper size, orientation and 

location that can be saved together with the layout. 

You can save and name the page setup and apply it to other layouts when setting pages. You can 

also create new layouts using existing layout template file (DWT or DWG). 

Click on the Model tab, you can view and edit objects in model space. Cross hairs are activated in 

the whole drawing. Shown as follows: 
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View and edit objects in model space from the Model tab. 

 

To view and edit objects of model space in viewport created in layout tab, you can double click 

layout viewport. The cross hairs and mark will be highlighted in current viewport. 

 

To change the current viewport for another one, click on the desired viewport and press CTRL+R to 

iterate all viewports. 

Create a model of your subject on the Model tab. 

Click a layout tab. 

Specify layout page settings such as plotting device, paper size, plot area, plot scale, and drawing 

orientation. 

Create a new layer to be used for layout viewports. 
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Create layout viewports and position them on the layout. 

Set the orientation, scale, and layer visibility of the view in each layout viewport. 

Turn off the layer containing the layout viewports. 

Plot your layout.  

 

Commands Reference 

LAYOUT: Creates and modifies drawing layout tabs 

MSPACE: Switches from paper space to a model space viewport 

MVIEW: Creates and controls layout viewports 

PSPACE: Switches from a model space viewport to paper space 

VPORTS: Creates multiple viewports 

VPLAYER: Sets layer visibility within viewports 

System Variables Reference 

CTAB: Returns the name of the current (model or layout) tab in the drawing 

CVPORT: Sets the identification number of the current viewport 

MAXACTVP: Sets the maximum number of viewports that can be active at one time in a layout 

PLOTROTMODE: Controls the orientation of plots 

 View Drawings in Paper Space and Model Space 

When you work in paper space on a Layout tab, you can still view your drawings in model space. 

First you need to create a layout viewport in paper space; this allows you to view your model space 

objects from paper space. 

Within a layout viewport you can modify the model space objects, but it is often more convenient 

to modify these objects on the Model tab. 

Zooming or panning the drawing in model space or paper space affects the entire drawing, unless 

you use multiple windows or viewports. 

To view a drawing in model space on the Model tab 

Do one of the following: 

Click the Model tab. 

Click the Model or Paper Space button on the status bar to switch to MODEL. 
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To view a drawing in paper space on a Layout tab 

Do one of the following: 

Click one of the Layout tabs. 

Type LAYOUT, choose Set option at the command prompt, and then press Enter. 

Type a name for the layout you want to make current, and then press Enter. 

Click the Model or Paper Space button on the status bar to switch to PAPER. 

While using a Layout tab, type PSPACE and then press Enter. 

While using a Model tab, click the layout viewport. 

 

The first time you switch to a Layout tab, your drawing seems to disappear. This is normal. You 

must create at least one layout viewport to see your model. 

To view a drawing in model space on a Layout tab 

Do one of the following: 

Click the desired Layout tab, and then create and view a layout viewport. 

Click the Model or Paper Space button on the status bar. 

While using a Layout tab, double click inside of the layout viewport. 

 

Commands Reference 

LAYOUT: Creates and modifies drawing layout tabs 

MSPACE: Switches from paper space to a model space viewport 

MVIEW: Creates and controls layout viewports 

PSPACE: Switches from a model space viewport to paper space 

VPORTS: Creates multiple viewports 

VPLAYER: Sets layer visibility within viewports 

System Variables Reference 

CTAB: Returns the name of the current (model or layout) tab in the drawing 

CVPORT: Sets the identification number of the current viewport 

MAXACTVP: Sets the maximum number of viewports that can be active at one time in a layout 

PLOTROTMODE: Controls the orientation of plots 

 Specify Layout Settings 
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Once created a drawing in Model tab, you can toggle to Layout tab and setup the layout for plotting, 

such as paper size, drawing orientation and so on. 

You can right click on the Layout tab to create new layouts or import from template files, and then 

click Modify button on the Page Setup dialog box to set the page. 

Select a Paper Size for a Layout 

The paper size here refers to the size of the drawing. When you start Plot dialog box in Layout tab, 

you can assign the paper type from pull down list of the Paper Size text box. The Paper size is 

directly previewed from the sketch with its size and units. The available paper types provided in the 

pull down list are decided by the current configuration. If you want to configure plotters to export 

raster images, you must specify output size by pixels. The paper size can be customized in the 

Plotter Configuration Editor. 

If you specified a system plotter, the paper size is decided by the default paper settings provided in 

the Windows control panel. If any changes have been set to the paper size in Plot dialog box, the 

new size will be saved in the layout to be used instead of the size in PCP. 

Determine the Drawing Orientation of a Layout 

The drawing orientation is sorted into Landscape and Portrait, which decide the plotting 

orientation of the drawing to be seen on a paper. If you select Landscape, plots the drawing using 

the length edge as horizontal. While selecting Portrait to plot the drawing using its minor edge as 

horizontal Changing the drawing orientation just like rotating the paper under the drawing. 

Once specified the drawing orientation, you can control whether to plot the top or the bottom of 

the drawing by selecting Plot Upsize-down option. 

The changes setup in Page Setup dialog box are still saved in layouts. Certain page settings can be 

replaced by customized plot settings, but the settings will not be saved in the layout unless you 

click Apply to Layout option. 

Additionally, changing the drawing orientation will not affect the position of plot origin which is 

located at left lower corner on the page once rotated. 

Adjust the Plot Offset of a Layout 

You can offset the geometry on the paper by entering a positive or negative value in the X and Y 

Offset boxes. Changing the plotting origin may change the position of drawing on papers. 

The plot origin locates at the left lower corner of plotting area with offset value of 0 relative to X 

and Y direction. The drawing will be moved relative to the left lower corner of the paper once you 

assigned positive or negative value to the plot offset. While a negative offset assigns the drawing 

plotted under the left lower corner of the paper and results in the plot area being clipped. 

Select Center on Paper if the specified plot area is part of the drawing rather than the whole layout, 

which changes the position of plot origin. 
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Set the Plot Area of a Layout 

You can set the area to be plotted in Plot dialog box. When creating new layouts, the default plot 

option is drawing limits which means plotting all the objects within the drawing paper. The plot 

origin is (0,0), located at the left lower corner of the page. ZWCAD+ provides the following methods 

to select a plot area:  

Display: Plots the contents displayed in current view. 

View: Plots a view saved previously with the VIEW command. You can select a named view from 

the list provided. This option is unavailable if there are no saved views in the drawing. 

Extents: Plots the portion of the current space of the drawing that contains objects. 

Limits/Layout: When printing from model space, the content of specified drawing limits will be 

printed. When you plot a layout, entities in the printable area will be printed. The printable area's 

origin coordinate is calculated from its (0,0) point, and its print area is determined by the size of the 

drawing paper.  

Window: Plots any portion of the drawing you specify within the rectangle window. Click the 

Window button to use a pointing device to specify opposite corners of the area to be plotted, and 

then return to the Plot dialog box. 

Set the Plot Scale for a Layout 

When you specify a scale to output your drawing, you can choose from a list of real-world scales, 

enter your own scale, or choose Fit to Paper to scale the drawing to fit onto the selected paper 

size. 

Usually, the objects in model space are displayed at the scale set in layout viewports. To plot the 

objects in model space with the scale specified in layouts, you assign the scale to 1:1. 

Set the Lineweight Scale for a Layout 

Even if plot scale of layouts is assigned, it's enabled to scale the lineweight at a certain scale. Scaling 

the lineweight is nothing to do with the plot scale when plotting drawings, which is mainly used for 

the lines included in the objects to be plotted. 

In most cases, you choose to plot layouts with default plotting scale of 1:1. However, to plot the 

layout scaled by paper size A on another paper size E, you should scale lineweights to fit the new 

plot scale. 
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Copy and Move Layouts 

You can right click on the Layout tab to select Move or Copy option, on the Move or Copy dialog 

box, select the target moving position and the place to put the copy of the layout and click Create a 

Copy to copy the selected layout, otherwise only the layout position will be moved. You should 

notice that Model tab can't be moved or copied. 

If multiple layouts are created in the drawing or too long a layout name to be displayed at the 

bottom of the drawing area, you can display the tab according to the arrowhead. The arrowhead 

with a vertical line represents the first and last tab individually. The current tab may not be 

displayed when moving the tabs. 

Save time by reusing layouts that you have already created. Within the same drawing, you may 

want to make a copy of a layout that contains most of the settings you want, and then make 

changes to the new copy. If you created layouts that you want to use again when you create new 

drawings, you can save the layouts as a drawing template. 

To make a copy of a layout 

Type LAYOUT and then press Enter. 

On the command line, type C (Copy). 

Type the name of the layout you want to copy, and then press Enter. 

Type a name for the new layout, and then press Enter. 

 

Creating a new layout 

In ZWCAD+, you can create multiple layouts for a single drawing. Each layout represents a sheet of 

paper. For each layout you can specify the print area, print styles, print scale, lineweight scale, pen 

mappings, and add viewports, dimensions, a title block, and other geometry specific to the layout. 

The objects you add to a layout in paper space do not appear in model space. 

When you create a new drawing, the drawing automatically contains two default layouts: Layout1 

and Layout2. You can start by using one of the default layouts, you can create your own, or you can 

create a new layout from another template (.dwt) file, drawing (.dwg) file, or drawing interchange 

(.dxf) file. Each drawing can contain up to 255 layouts. 

To create a new layout using the Layout1 or Layout2 tab 

Right click the Layout1 or Layout2 tab, and select New layout. 

If desired, rename the layout. 

 

To create a new layout using a new Layout tab 

Choose Insert > Layout > New Layout from the main menu. 

Type a unique name for your layout and then press Enter.  

The name can be up to 255 characters in length and can contain letters, numbers, the dollar sign 

($), hyphen (-), and underscore (_), or any combination. 

Set up at least one layout viewport. 

Layout toolbar:  

Command line LAYOUT 
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Create Layout from Template 

Right click on the Layout tab to select From template option to import DWG or DWT file directly, 

using information of existing template to create new layouts. 

Template layout instances are provides for designing new layouts including viewport objects. 

Objects of paper space and page setup of existing template are used by new layouts. Thus, layout 

objects will be displayed in paper space as well as viewport objects. User can retain existing objects 

imported from template and also delete objects. Any object from model space can't be imported 

while creating layout from template. 

System provides template file with extension name as .dwt. Layout templates from any drawing 

templates can be imported into the current drawing. 

To create a new layout from an existing file 

Choose Insert > Layout > Layout from Template from the main menu. 

In the Select Template From File dialog box, select the desired template file, and then click Open. 

In the Insert Layout(s) dialog box, select the layout(s) you want to insert, and then click OK. You can 

choose multiple layouts by holding down Ctrl while selecting layout names. 

Layout toolbar:  

Command line LAYOUT 

 

Save layouts 

Any drawing created in ZWCAD+ can be saved as template drawing file (.dwt) together with all the 

objects and layout settings. Using the SAveas option of LAYOUT command to save the layout as new 

DWT file. By default, template files are saved in the Templates Search Path located under the 

corresponding position in Files tab of Options dialog box. Like drawing template file, Layout 

template file go with the same extension name that contain some irrelevant information to the 

layouts. 

When saving a drawing containing new layouts as a template file, all the named objects used in the 

layout (such as blocks, layers and dimension styles) will be saved as well. The defined table options 

are imported as part of the layout settings together with template file. Once a template file is saved 

using the SAveas option of LAYOUT command, the define table options will not be inserted 

together with the layout. 

Use PURGE command to clear the undesired define table options. 

To save a layout as a drawing template 

Type LAYOUT and then press Enter. 

On the command line, type SA (SAveas). 

Type the name of the layout that you want to save, and then press Enter. 

In the Create Drawing File dialog box, specify a file name and location for the drawing template file 

you are saving.  

In Files of Type, select Drawing Template (*.dwt), and then choose Save. 

After you save a layout as a template, you can use the template when you create new drawings. 

You can also import the template's layouts into another drawing. 
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Create and Use Named Page Setups 

Once you have set plot device, plot style table and relevant page setup in the plot dialog, you can 

save the page as named page setup which is usually used for updating current setting of Plot dialog 

box. Applying different page setups to the same layout may obtain specific plot result. For example, 

you can create named page setups listed below to control scale factor and drawing size. 

Page setup name Description 

NoScaling Plot at scale 1:1, E-size sheet 

Scale 1 to 2  Plot at scale 1:2, C-size sheet 

Draft  Plot to the draft-quality plotter 

Final Plot to the high-quality plotter 

Fit-to-Paper Fit to Paper, A-size sheet 

Page setup is saved together with the drawing file, for the convenience of plotting without setting 

the page each time. If you want to plot the same layout for several times or specify output options 

for multiple layouts, you can use named page settings. 

Managing layouts in a drawing 

You can rename layouts, delete layouts, and view a list of all layouts available in a drawing. You can 

also change the order in which the Layout tabs appear; the Model tab is always stationary. 

If you want to rename, delete, or reorder a layout when the Layout tabs are hidden, you can type 

LAYOUT to make your changes or choose Screen Menu > Tabs to display the tabs. 

To rename a layout 

Right-click the layout tab for the layout you want to rename, and choose Rename from the shortcut 

menu.  

In the Rename Layout dialog box, enter the new name for the layout.  

Click OK. 

The name can be up to 255 characters in length and can contain letters, numbers, the dollar sign 

($), hyphen (-), and underscore (_), or any combination. 

 

To delete a layout 

Right-click the layout tab for the layout you want to delete, and click Delete on the shortcut menu. 

In the warning box, click OK to delete the layout.  

Any named views associated with the layout are deleted automatically when the layout is deleted.  

NOTE You cannot delete the Model tab or the last remaining Layout tab. To delete all geometry 

from the Model tab or a Layout tab, first select all geometry and then use the Erase command. 

 

To view a list of all layouts 

Type LAYOUT and then press Enter. 

On the command line, type ? and then press Enter to list all layouts. 
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Commands Reference 

LAYOUT: Creates and modifies drawing layout tabs 

PURGE: Cleans up the unused in the current drawing file, such as drawing blocks, layers, linetypes, 

text styles or the dimension styles 

System Variables Reference 

None 

 Create and Modify Layout Viewports 

When you begin working in a drawing on the Model tab, it consists of a single view of your model. 

You may have created additional views by dividing the drawing space into multiple windows; each 

window is a separate viewport on the Model tab. 

On a Layout tab, you must create at least one layout viewport to see your model. However, you can 

create multiple layout viewports that display unique views of your model located in model space. 

Each layout viewport is created as a separate entity that you can move, copy, or delete. 

Click any layout viewport to make it the current viewport, and then add or modify model space 

objects in that viewport. Any changes you make in one layout viewport are immediately visible in 

the other viewports (if the other layout viewports are displaying that portion of the drawing). 

Zooming or panning in the current viewport affects only that viewport. 

Create layout viewports 

The first time you switch to a Layout tab, all of your model space objects disappear. You must 

create at least one layout viewport on the Layout tab to see your work. 

You can create layout viewports anywhere inside the drawing area. You can control the number of 

viewports created and the arrangement of the viewports. 

To create layout viewports 

On the command line, type MVIEW. 

Type F (Fit), or create 2, 3 or 4 viewports by entering 2, 3 or 4 separately, or specify two opposing 

corners to create a custom viewport. 

Choose the viewport arrangement, typing H (Horizontal) or V (Vertical). 

Do one of the following: 

To arrange the viewports to fill the current graphic area, type F (Fit). 

To fit the viewports within a bounding rectangle, specify the corners of a rectangle. 

TIP When you create a layout viewport, the layout viewport border is created on the current layer. 

You can make layout viewport borders invisible by creating a new layer before you create layout 

viewports and then turning off that layer after you create the layout viewports. 

To select a layout viewport's borders, you must turn that layer back on before you can rearrange or 

modify the layout viewport. 
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You can create a single layout viewport, or you can 

divide the graphic area into two viewports arranged 

vertically (A) or horizontally (B); three viewports 

arranged left (C), right (D), above (E), below (F), 

vertically (G), or horizontally (H); or four equal 

viewports (I). 

 

Use layout viewports 

Create multiple viewports in layout tab to view objects created in model space, move and scale the 

objects as well. The multiple viewports created in layouts can be overlapped or separated. 

User can toggle to model space and edit objects in layout viewports within layouts. When ranking 

layouts in paper space, you can't edit the model. Methods to toggle to model space are shown as 

follows: 

Enter Model space by selecting Model tab. 

Double click inside the layout viewport. At the moment, the Model or Paper Space button on the 

status bar changes from to . 

Click Model or Paper Space button on the status bar to switch to MODEL. 

The layout viewport on which you double clicked will be set as current view and enter model space 

with its frame highlighted. Once a viewport has been changed, all the other viewports display the 

modifications simultaneously. Additionally, layout viewport owns the superiorities as: optionally 

freeze the layer in each layout viewport. Thus, you can display different objects in current viewport. 

Meanwhile, you can pan and scale the objects in viewports to display different views. 

With the grips displayed in the viewport frame, layout viewport is also available for changing the 

scale that geometrical drawings of model space display in viewports so as to adjust the viewport 

size. Each viewport can be scaled like other objects using SCALE command, which is only affective 

to the size of the viewport rather than the scale of the views. 
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Place Layout Viewports 

User can select to create a viewport fit to the entire layout, and also specify a rectangle area to 

create layout viewports. 

In the Viewports dialog box, viewports of various standards or named viewport configurations 

which determined by the pattern you view the drawing and the plotting results are inserted into 

layouts. 

Viewport configuration that are saved and named in model tab can be positioned in layouts as well. 

The viewport will be saved as soon as new viewports are ranked and named, and the new viewport 

names will be added to a list ranked by viewports. Grips on layouts will be displayed once selected, 

which are used for changing the display proportion of geometry objects created in model space 

within the viewports. Each viewport can be scaled like other objects using SCALE command, which 

is only affective to the size of the viewport rather than the scale of the views. To adjust the 

proportion of views within viewports, you can scale the view by modifying the scaling factor. You 

can also specify proportion in the Standard proportion option on Properties palette, and Customize 

option is also available for changing plot scale of viewport objects. 

Change the Properties of Layout Viewports 

Like common objects, layout viewports are characterized by object properties such as layer, color, 

linetype, linetype scale and lineweight. Which are all displayed and changed on properties palette. 

Viewports are created on the current layer so as to control the visibility of the boundaries. User can 

freeze or set plot configurations for layers in Layer Property Manager to avoid plotting the viewport. 

The visibility of the boundary is non-associative to the viewport if they are located in different 

layers. 

 

To modify layout viewport properties 

Click the border of the layout viewport whose properties you want to modify.  

Open the Properties palette through the menu option "Tools > Properties" or "Modify > 

Properties". 

In the Properties palette, select Standard Scale, and then select a new scale from the list. The scale 

you choose is applied to the viewport. 

NOTE You can select only layout viewports for modification. If you click a viewport on the Model 

tab, it makes that viewport active, not available for modification. 
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Lock the Scale of Layout Viewports 

Some proportions maybe required for displaying details of different hierarchy when creating 

viewports. If you want to scale the viewport once you have set the viewport scale, the scaling 

factor changes along with the viewport scales. You can lock the scale factor before scaling to retain 

the viewport proportion. 

Locks the scale set in the selected viewport. You can modify the geometric drawings in current 

viewport without changing the viewport scale once the scale is locked. While unlock viewport scale 

again will disable many commands used for viewing such as VPOINT, PLAN and VIEW. 

Control Visibility in Layout Viewports 

Various methods are available for controlling whether to display or hide the layout viewport. All 

these methods help limiting the regen and highlight different elements of the drawing having been 

set the Visibility. 

Screen Objects in Layout Viewports 

Screening means plotting with little ink. The screening objects will be displayed 

diminish on paper and screen. Whereas the screening value may not affect the color 

properties of the objects, only limit the concentration of ink for convenience of 

distinguish objects after plotting. 

To specify the screening value, you should specify the plot style first, and then 

define the screening value in plot style editor. The value can be assigned from 0 to 

100, if you specify the value to 100, screening will not take effect, that is to plot the 

drawing without screening. While using screening value as 0 to plot the object 

without ink, namely make the objects invisible. 

Turn Layout Viewports On or Off 

The new layout viewport is under status On by default, until you select turn off. The 

more objects in model space, the more layout viewports can be created. Thus 
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generating contents of each viewport may affect system capacity. User can control 

the status of viewport in Properties palette, to save space by turning off some 

viewports or limiting active viewports. The following figure shows the results with 

two viewports turned off. 

 

Once the viewport is turned off, you can copy the viewport without regen each 

viewport, and the closed viewport will not be plotted. To hide the viewport 

boundary which you are working on, you can create a specific layer for viewports 

and then close or freeze the layer. 

To turn layout viewports on or off 

Click the desired Layout tab. 

Type MVIEW and then press Enter. 

Type ON or OFF. 

Select the edge of the layout viewport to turn on or off, and then press Enter. 

 

Manage Layer Visibility in a Layout 

You can control the visibility of the layer in each layout viewport, and apply the default visibility 

settings to new viewports and layers. 

Freeze Specified Layers in a Layout Viewport 

Freeze or thaw layers on current layout viewports without affecting others. The 

frozen layers are invisible, either reloaded or plotted. You can freeze the layer to 
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control how the objects are displayed. For example, dimensions can be displayed in 

specific viewport, as the figure shows below, only the viewport with terrain drawing 

is frozen. 

 

Once frozen, the layer in the viewport is invisible. With the layer thawing, its visibility 

can be restored. User can control the frozen status of layers by clicking VP Freeze 

icon in Layer Properties Manager. 

Freeze or Thaw Layers Automatically in New Layout Viewports 

Freeze the layer containing those objects that are not expected to display or plot in 

paper space. For example, freeze the layer on which viewports are created if layout 

viewport boundaries are not expected to display. 

Freeze or Thaw Layers Automatically in New Layout Viewports 

The new created layout viewport is also acceptable for layer visibility settings. For 

example, freeze DIMENSIONS layer of all new viewports to limit displaying the 

dimensions. To create viewports with dimensions, you can change default settings 

for the current viewport. However, changing default settings of new viewport may 

not affect current viewport. 
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Freeze or Thaw Layers Automatically in New Layout Viewports 

User can create new layers frozen in all of the existing layout viewports by clicking 

Freeze icon in Layer Properties Manager. Likewise, cancel the Freeze icon to thaw 

layers in all viewports. You can also thaw layers by your decision, with this feature, 

you can create new layers displayed in single viewports. 

Modify Layout Viewports 

Once layout viewports are created in paper space, you can set the viewport as current in which you 

can edit model objects. Any changes to the layout viewports reflected to model space directly and 

all other viewports of the modified objects will be displayed. 

Change the layout viewport scale 

Specify proportion in the Standard proportion option on Properties tab to determine proportion of 

each viewport relative to paper space. That is to scale each viewport precisely. Scaling or extension 

for layout viewport boundaries will not change the scale of views in viewports. 

While working on layouts, the scale factor represents the ratio of actual size of model and the 

layout size. The ratio generated dividing the model space unit from drawing space unit. For 

example, a drawing with ratio of 1/3 means one drawing space unit equals to three model space 

units. 

Changing the plot scale of viewports is also available through ZOOM command or Viewport toolbar. 

To change the layout viewport scale 

Make sure you are on a layout tab in paper space. 

Click the border of the viewport whose scale you want to modify. 

Right-click and choose Properties from the shortcut menu that displays. 

In the Properties palette, select Standard Scale, and then select a new scale from the list. The scale 

you choose is applied to the viewport. 

 

Scale Linetypes in Layout Viewports 

Scaling linetypes is enabled to be manipulated based on both drawing units and paper space. 

System variable PSLTSCALE is used to setup linetype scaling factor for objects displayed in different 

proportion. If PSLTSCALE is set to 1, current linetype is set to dash line, and then draw lines in paper 

space. Create viewport with proportion of 1x, set this layout viewport as current and then draw 

lines using the dashes linetype. These two dashes are of the same appearance. If the viewport 

scaling factor is set to 2x, then the linetype scaling factor of dashes are consistent both in layout 

and layout viewports. 

Scaling drawing space units if the system variable PSLTSCALE is on, linetype scale is determined by 
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viewport scale. If you set system variable TILEMODE to 0, dashes length of objects in model space is 

based on drawing units. Linetypes keep the same even if various scaling factors are used for current 

views. Dash lines share the same length with that of paper space, thus, you can still use LTSCALE 

and CELTSCALE to control length of dashes. 

The following figure shows: linetype scale on the left has been adjusted to dashes scaled to paper 

space, regardless of the scale of views. The figure on the right matches the scale of linetype with 

each view. 

 

Rotate Views in Layout Viewports 

You can rotate the entire view within layout viewports using PLAN command to change current UCS. 

But the object to be rotated is the view rather than viewport boundary. Using ROTATE command 

only rotates single objects of the viewport. 

 

 

Commands Reference 

LINETYPE: Loads, sets, and modifies linetypes 

MOVE: Displays the plan view of a specified user coordinate system 

PLAN: Displays the plan view of a specified user coordinate system  

PROPERTIES: Controls properties of existing objects 
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UCS: Manages user coordinate systems 

ZOOM: Sets layer visibility within viewports 

System Variables Reference 

PSLTSCALE: Controls paper space linetype scaling 

 Create Non-rectangular Layout Viewports 

Use Object and Polygonal options of MVIEW to create irregular viewports, Select Object option to 

convert objects created in paper space to viewports. While selecting Polygonal option to draw 

irregular polylines including arcs and lines which are enabled to either intersect or three vertexes at 

least, the polyline will be closed automatically to form irregular polygonal viewport. 

To define viewport boundaries, the area in which selected objects are contained will be calculated, 

to set viewport objects on the corner of the boundary, and then clip the viewport according to the 

specified objects. 

 

Polygonal option is used for creating irregular viewports according to specified points. With the 

same command prompts as creating polyline. 

Redefine Viewport Boundary 

Boundaries of viewports can be redefined by VPCLIP command. 

Once selected the viewport to be clipped, you can specify existing objects as new boundary or 

specify new boundary point. You should notice that the boundary is neither displayed nor clipped if 

the layer on which the boundary of non-rectangular viewport locates. If you close the boundary 

layer rather than freeze it, the viewport will be clipped. 

Edit Non-rectangular Viewports Using Grips 

Like other geometrical objects, grips that are used to change the shape of non-rectangular 

viewports will be display once selected, with which you can edit the viewport as other objects. 

Such as move, rotate, scale and so on. To define viewport boundaries, the area in which selected 

objects are contained will be calculated, to set viewport objects on the corner of the boundary. 
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Some geometric drawings may not be displayed entirely for different shape of the boundaries. 

 

Scaling and Panning within Non-rectangular Viewports 

Geometric drawings in model space will be clipped according to viewport boundaries when scaling 

and panning within non-rectangular viewports. 

However, scaling or panning in rectangular viewports may not display objects outside the viewport 

boundaries. 

If using Extents option in ZOOM command for the objects to be clipped within non-rectangular 

viewports, system scales the drawing according to the extents of clipping boundary, not all the 

geometric drawings are visible in non-rectangular viewport. 

 

Commands Reference 

MVIEW: Controls the creation and display of layout viewports 

VPCLIP: Clips a selected viewport boundary in Layout tab to conform to a user-drawn boundary 

ZOOM: Sets layer visibility within viewports 

System Variables Reference 

None 

13.2 Plot Drawings 

When a drawing is completed, you can output it using several methods. You can plot the drawing 

on paper or create a file for use with another application. 

Topics in this section: 

 Overview of Plotting 

To understand relevant concepts to facilitate users setting properties for plotting. 
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 Plot Settings 

Before plotting a drawing, you must specify some plot settings. For example page setup, printer, 

plot area, paper size and so on. 

 Use Plot Styles 

You can control many aspects of how an object is plotted by using plot styles.  

 Plot Files to Other Formats 

Plots files of various formats, including DWF, PDF, PLT and other files. You can output drawings in 

any image formats with unique plotter driver.  

 Batch Plot 

With the PLTPLOT command, you can perform batch plot function to print multiple PLT or PRN files 

at one time in a specified printer. 

 Overview of Plotting 

To understand relevant concepts to facilitate users setting properties for plotting. 

Plotter Manager 

Plotter Manager is a window in which all the plotter configuration (PC5) files of user installation are 

listed. If you want to use ZWCAD+ default plotting properties other than that of Windows system 

configured, you can also create a new plotter configuration files for Windows system plotter. 

Plotter configuration settings contain port information, quality of raster images and vector 

drawings, drawing size and customized properties based on the plotter type. 

User can start an Add Plotter - Introduction Page dialog box by selecting Add New Plotters option 

from the Name pull-down box in Printer/Plotter area on Plot dialog box, which is available for 

creating plotter configuration using relevant information that is imported as this wizard required. 

Layouts 

Layout displays the results on a plotted page. You can create as many layouts as you need. Each 

layout is saved on its own layout tab and can be associated with a different page setup. 

All the elements to be displayed on a plotted page, such as title blocks and notes, are drawn in 

paper space in a layout. The objects in the drawing are created in model space. To view these 

objects in the layout, you should create layout viewports. 

Page Setups 

Specify page settings for the layout you create through Page Setup and Plot Setup dialog box, 
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controls whether to display layout tab or Model tab. Page setup can be applied to other layouts 

once it's saved with a given name. 

Plot Styles 

A plot style includes properties such as lineweight, color, hatch pattern, which controls how an 

object or layer is plotted. The Plot Style Manager shows all the plot style tables available in 

ZWCAD+. 

There are two plot style types: color-dependent and named. Use only one type of plot style table 

for plotting a drawing each time. 

For color-dependent plot style tables, an object's color determines how it is plotted. With an 

extension of .ctb, these plot style table files are disabled of assigning color-dependent plot styles 

directly to objects. Instead, to control how an object is plotted, you should change its color. For 

example, all objects assigned the color red in a drawing are plotted the same way. 

Named plot style tables use plot styles that are assigned directly to objects and layers. With an 

extension of .ctb, these plot style table files enable each object in a drawing to be plotted 

differently, independent of its color. 

 

Commands Reference 

OPTIONS: Customizes the ZWCAD+ settings 

PLOT: Plots a drawing to a plotter, printer, or file  

System Variables Reference 

None 

 Plot Settings 

When you create a drawing, you do most of your work on the Model tab. At any time you can print 

your drawing to see how it looks on paper. It's easy to startup printing, and then later create 

layouts and custom print settings to enhance your printed output. 

To start printing 

Choose File > Plot from the main menu. 

Set the printer and relevant parameters, and then click OK. 

Standard toolbar:  

Command line PLOT 

There are many options that you can set before printing, such as the scale of the drawing, print 

area, print style tables, and more. 

Before you print, you can set up many aspects of printing: 

Select and configure plotting device.  
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Specify paper size and orientation.  

Specify size of the paper used for plotting, including which portion of a drawing to print and the 

origin of the print area.  

Choose whether to print and scale lineweights. 

Choose whether to implement print style tables to control colors, pen widths, line types, and 

lineweights. 

Set Paper Size 

The paper size here refers to the size of the drawing, needing to be set before plotting regardless of 

which working space you select. You can assign the paper type from pull down list of the Paper Size 

text box in Printer/Plotter area. The available paper types provided in the pull down list are decided 

by current configuration. If you want to setup paper size, you should configure plotters first, all the 

available plotters are both system plotters of Windows configured and non-system driven. 

You can specify a printer or plotter to be used when printing any drawing. You can print your 

drawing on any printer or plotter that is compatible with Windows, including raster printers. 

To select a printer or plotter 

Choose File > Plot from the main menu. 

From the Name list in Printer/Plotter area, select a printer or plotter you want to use, and then 

click OK. 

Standard toolbar:  

Command line PLOT 

 

Default paper size used for creating new layouts through editing PC5 files associative to plotters can 

be assigned to the paper. With this technique, you can assign different paper size for Windows and 

ZWCAD+ separately. 

If you set the system variable PAPERUPDATE to 0, prompts display if the selected plotter doesn't 

support the paper size. If you set the system variable PAPERUPDATE to 1, the paper size will be 

updated automatically to default paper size that plotters provide. 

To select the paper size and orientation 

Choose File > Plot from the main menu. 

From the Paper Size list in Printer/Plotter area, select the desired paper size, and then click OK. 

Standard toolbar:  

Command line PLOT 

 

You can also adjust the orientation by printing a drawing upside down on the paper. Each layout in 

your drawing can specify whether to print upside down. 

Use a Custom Paper Size 

You can also add customized paper size to non-system plotters through Plotter Configuration Editor. 

Usually customized paper size is not able to add to Windows system plotter, but you can modify the 

plotted area according to the paper size associated to system plotters. 
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Position the Drawing on the Paper 

You can adjust the position of the drawing to be plotted on a paper before plotting. 

Set the Origin of Print Area 

You can specify the position of the drawing to be plotted on a paper by entering a positive or 

negative value in the X and Y Offset boxes. Select Center on Paper to locate the drawing at the 

center of the paper. 

The offset value makes a compensation to the page pitch by aligning the left lower corner of the 

title bar with that of the drawing paper. The offset are usually negative, determined by measuring 

the distance between the page edge and plot information. 

To specify the print area origin 

If necessary, click the desired Layout tab or the Model tab. 

Choose File > Plot from the main menu. 

Do one of the following in the Plot Offset area: 

To center the specified print area on the printed page, select the Center the Plot check box. 

To specify an origin for the print area, type the X and Y coordinates. 

Select Save Changes to Layout, and then click Apply to Layout. 

Standard toolbar:  

Command line PLOT 

 

Set Drawing Orientation 

The drawing orientation determines whether to plot a drawing portrait or landscape. 

If you select Landscape, plots the drawing using the length edge as horizontal. While selecting 

Portrait to plot the drawing using its minor edge as horizontal Changing the drawing orientation 

just like rotating the paper under the drawing. Meanwhile, selecting Plot upsize-down to control 

whether to locate the drawing upsize-down on paper. 

Set Plot Scale 

Plot scale of the drawing can be specified directly from the Scale pulldown list in Plot Scale area of 

Plot dialog box. You can also choose Custom to set desired plot scale, or choose Fit to Paper to 

scale the drawing to fit onto the selected paper size. 

Generally, you draw objects at their actual size. That is, you decide which unit to be applied to the 

size (an inch, a millimeter, a meter) and draw objects at a 1:1 scale. For example, if you select the 

measurement unit as millimeters, then every unit in your drawing represents a millimeter. When 

you plot the drawing, you either specify a precise scale or fit the image to the paper. Plotting is 

usually working under precise proportion. 

The plot scale set here represents the ratio of plot unit and actual unit used for drawing models. 

Set a Specific Scale 
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The plot scale together with plot unit and drawing unit must be specified before plotting. For 

example, if you select the paper size to mm, entering 1 under mm and 10 under Units blank 

produces a plotted drawing with each plotted unit represents 10 actual millimeters. 

The following figure shows an instance of plotting objects at three different scales. 

 

To automatically scale the drawing for printing 

If necessary, click the desired Layout tab or the Model tab. 

Choose File > Plot from the main menu. 

To scale the drawing to fit on one printed page, in Plot Scale, click Fit to Paper. 

Select Save Changes to Layout, and then click Apply to Layout. 

Standard toolbar:  

Command line PLOT 

 

To specify the scale factor yourself 

If necessary, click the desired Layout tab or the Model tab. 

Choose File > Plot from the main menu. 

In Plot Scale, do one of the following: 

Select a predefined scale. For example, choose 1:2 if you want 1 printed unit (inch or millimeter) to 

equal 2 drawing units. 

Select Custom, and then under User Defined Scale, type the ratio of printed units of measure 

(inches or millimeters) to drawing units. 

Select Save Changes to Layout, and then click Apply to Layout. 

Standard toolbar:  

Command line PLOT 

 

Scale the Drawing to Fit the Page 

To plot the view at the largest possible size that fits the paper. The height and width of the drawing 

will be adjusted according to the paper size. 

Any changes to the ratio of plotted units, drawing size, plotters, plot origin, plot orientation and 

plot area will be reflected to plot scale. 

Set Options for Plotted Objects 

The following options show plot patterns with instructions on how to plot objects. 
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Plot in Background. Specifies that the plot is processed in background. 

Plot Object Lineweights. Specifies that lineweights assigned to objects and layers are plotted. 

Plot with Plot Styles. Plots a drawing with specified plot styles. Plots lineweights automatically once 

selecting this option automatically. If you do not select this option, objects are plotted with their 

assigned properties and not with the plot style overrides. 

Plot Paperspace Last. Plots model space geometry first. Paper space geometry is usually plotted 

before model space geometry. 

Hide Paperspace Objects. Suppresses the plotting of objects that are located behind other objects 

regardless of how it's displayed on screen. This option is only available in the Layout tabs. 

Plot Stamp on. Horizontally or vertically placed the plot stamp information on a specified corner of 

drawing. The plot stamp settings can be saved to log file, also can not be saved. 

"Plot Stamp Settings" Button. The Plot Stamp dialog box will be opened by selecting the Plot Stamp 

on option in the Plot dialog box,. 

Save Changes to Layout. All the changes you make in the Plot dialog box will be saved to the layout 

if you click OK. 

To set lineweight options 

If necessary, click the desired Layout tab or the Model tab. 

Choose File > Plot from the main menu. 

Choose Plot Object Lineweights to plot the lineweights assigned to objects and layers.  

Select Scale Lineweights to print lineweights in proportion to the scale you set in the Plot Scale. If 

not selected, lineweights print at their assigned size without adjustments for the print scale. (A 

Layout tab must be active to scale lineweights.) 

Select Save Changes to Layout, and then click Apply to Layout. 

Standard toolbar:  

Command line PLOT 

NOTE Print styles can also affect how lineweights print. 

 

Specify the Area to Plot 

To determine where to plot the drawing, you must specify an area for the drawing. The following 

options under Plot Area are provided in The Plot dialog box. 

Display. Plots the contents displayed in current view. 

View. Plots a view saved previously with the VIEW command. You can select a named view from 

the list provided. This option is unavailable if there are no saved views in the drawing. 

Extents. Plots the portion of the current space of the drawing that contains objects. 

Limits/Layout. When printing from model space, the content of specified drawing limits will be 

printed. When you plot a layout, entities in the printable area will be printed. The printable area's 

origin coordinate is calculated from its (0,0) point, and its print area is determined by the size of the 

drawing paper. 

Window. Plots any portion of the drawing you specify within the rectangle window. Click the 

Window button to use a pointing device to specify opposite corners of the area to be plotted, and 

then return to the Plot dialog box. 
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To specify a portion of the drawing to print 

If necessary, click the desired Layout tab or the Model tab. 

Choose File > Plot from the main menu. 

Under Print Area, click one of the following: 

Display – Plots the current view on the screen. 

View – Plots the selected saved view. 

Extents – Plots the contents within the specified drawing extents. 

Limits/Layout – Plots the contents within the specified drawing limits or entities in the printable 

area. 

Window – Plots the portion of the drawing contained in the specified window. Click the Window 

button to use a pointing device to specify opposite corners of the area to be plotted, and then 

return to the Plot dialog box. 

Select Save Changes to Layout, and then click Apply to Layout. 

Standard toolbar:  

Command line PLOT 

 

Preview a Plot 

Viewing a drawing before printing gives you a preview of what your drawing will look like when it is 

printed. This helps you see if there are any changes you want to make before actually printing the 

drawing. If you are using print style tables, the preview shows how your drawing will print with the 

assigned print styles. 

System automatically generates preview results as soon as you setup relevant plotting properties. 

To preview a drawing before printing 

If necessary, click the desired Layout tab or the Model tab. 

Choose File > Plot Preview from the main menu. 

Do one of the following: 

To print the drawing, click Plot on the top left corner. 

To return to the drawing, click the Close Preview Window button or press Esc. 

Standard toolbar:  

Command line PREVIEW 

 

Printing a drawing 

The print setting options available under each tab on the Print dialog box were described in the 

previous sections. 

NOTE You cannot print a rendered image directly to a printer. To print a rendered image, you must 

first save the drawing to a different format and then print it from another graphics program. 

To print a drawing 

If necessary, click the desired Layout tab or the Model tab. 
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Choose File > Plot from the main menu. 

From the Plot dialog box, make any adjustments to the settings. 

Click OK. 

Standard toolbar:  

Command line PLOT 

NOTE Instead of using the print settings you saved with your layout, you can select Previous Plot 

form the Name pull down list in Page Setup area. 

 

Commands Reference 

PLOT: Plots a drawing to a plotter, printer, or file 

LAYER: Manages layers and layer properties 

LWEIGHT: Sets the current lineweight, lineweight display options, and lineweight units 

OPTIONS: Customizes the ZWCAD+ settings 

PROPERTIES: Controls properties of existing objects 

PREVIEW: Shows how the drawing will look when it is plotted 

ZOOM: Increases or decreases the apparent size of objects in the current viewport  

System Variables Reference 

PLOTROTMODE: Controls the orientation of plots 

 Use Plot Styles 

ZWCAD+ uses plot styles to change the appearance of your printed drawing without modifying the 

actual objects in your drawing. Assigning plot styles allows you to customize the Color, GrayScale, 

Screening, and Lineweight that are used to print your drawing. Plot styles help you control what 

your drawing looks like when it is printed. 

Because plot styles are saved in plot style tables, which are files located on your computer, disk, or 

server, you can reuse them to help eliminate the need to reconfigure your print settings each time 

you print a drawing. You can save plot styles in a named file for each of your clients. You can even 

share the file with coworkers, or store the files on a network to ensure that everyone in your office 

uses the same standards. 
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Understanding plot style tables 

A plot style table is a collection of plot styles that allows you to change the appearance of your 

printed drawing without modifying the actual objects in your drawing. Each plot style table is saved 

in a file that can be located on your computer, disk, or server. 

A drawing can use one type of plot style table at a time. There are two types of plot style tables: 

Color-dependent plot style tables (CTB) contain a collection of plot styles based on each of the 255 

index colors available in a drawing. True colors and color books are not applicable to 

color-dependent plot style tables. 

Named plot style tables (STB) contain a collection of plot styles that you define. They can vary 

regardless of color. 

With color independent plot style tables, you cannot assign plot styles to individual objects or 

layers. To use these plot styles, you assign a specific color to an entity or layer. When you specify a 

color-dependent plot style table at printing time, the entity colors and layer colors map to color 

based plot styles in the plot style table that you specify. If you specify a plot style for a specific 

entity, that plot style overrides any plot style assigned to the layer on which the entity resides. 

Sometimes a named plot style assigned to an entity or layer is not located in the plot style table 

that is assigned to a layout or drawing. This can happen if the plot style has been deleted from the 

named plot style table or if you assign a different named plot style table to the drawing that does 

not contain the named plot style. In this case, the entity is printed using its default properties. If 

you plan on interchanging named plot style tables within the same drawing, it's a good idea to 

coordinate the tables to use the same plot style names. 

If a new drawing is based on a template, the new drawing uses the same type of plot style table as 

the template. If a new drawing is created without a template, the type of plot style table is 

specified in the New Drawing Wizard; Every drawing is designed to use plot style tables, but you 

decide whether to implement them. 

Setup plot styles to determine how a drawing is plotted. 

Like color and linetype, plot style is also a kind of object property that reflected on the plotted 

objects or layer once you plot the object with the plot style assigned. A plot style controls an 

object's plotted properties, including color, dither, grayscale, pen, virtual pen, screening, linetype, 

adaptive, lineweight, line end, line join and fill style. 

If the plot styles conflict with the settings created for objects, use the plot style settings for plotting 

other than the settings created for objects. You can close these substitute settings on demand. 

Choose a Type of Plot Style Table 

A plot style table is a collection of plot styles assigned to a layout or the Model tab. There are two 

types of plot style tables: color-dependent plot style tables and named plot style tables. 

Color-dependent plot style tables (CTB) 

Color-dependent plot style table determines plotting characteristics such as lineweight using an 

object's color. This plot style plots objects with the same color in the same style. For example, every 

blue object in a drawing is plotted the same way. While color-dependent plot style table is provided 

for editing rather than adding or deleting plot styles. There are 256 plot styles in a color-dependent 
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plot style table, one for each color. 

Once a color-dependent plot style table is assigned to the drawing, you cannot assign a plot style to 

individual objects or layers. Instead, to assign plot style properties to an object, you should change 

the color of the object or layer. 

You can assign color-dependent plot style tables to layouts. You can use several predefined 

color-dependent plot style tables, edit existing plot style tables, or create your own. 

Color-dependent plot style tables are stored in the printstyle folder with extensions named as .ctb. 

Note that assigning the color-dependent plot style table to a layout is only available when the 

drawing has been set to use color-dependent plot style tables. 

Named plot style tables (STB) 

Named plot style tables contain user-defined plot styles. This plot style plots objects based on the 

plot style assigned to the object rather than the color. The named plot style tables can be assigned 

to objects or layouts as assigning other properties. 

Named plot styles can be assigned to objects or layers with the same way as any other properties. 

Assign Plot Style Tables to Layouts 

Controls the plotting style for objects in layouts using different plot styles assigned to each layout. 

The specified plot style tables affect both model space and paper space objects. 

If you specified named plot style for a drawing, each object in the drawing either is assigned a plot 

style directly or inherits a plot style from its layer. 

If an xref has been inserted into your current drawing, all defined plot style tables will be inserted 

as well.  

You can assign plot style tables globally for all layouts (including the Model tab), or individually for 

the Model tab or a Layout tab. Assigning a plot style table to an individual layout allows you to 

further customize the layouts you use to print a drawing. 

However, assigning different named plot style tables to various layouts may result in mismatched 

plot style names. In this case, objects are printed using their default properties. 

To assign plot style tables 

If necessary, click the desired Layout tab, or click the Model tab. 

Choose File > Plot from the main menu. 

Under Plot Style Table (pen assignments), select a plot style table in the one of the following: 

None — Applies no plot style table. Objects plot according to their own properties. 

Monochrome — Plots all colors as black. 

New — Creates a new plot style table. 

Select Save Changes to Layout, and then click Apply to Layout. 

Standard toolbar:  

Command line PLOT 

NOTE When your drawing was first created it was set up to use either color-dependent or named 
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plot style tables. 

 

Manage Plot Style Tables 

Color-dependent (CTB) and named (STB) plot style tables are stored in the printstyle folder by 

default. This folder is also known as the Plot Style Manager. 

Plot Style Manager is available to add, delete, rename, copy, and edit plot style tables. 

Creating new plot style tables 

ZWCAD+ offers several plot style tables to help you get started. If you want to customize your print 

output further, you can create your own plot style table. You can customize plot exporting pattern 

by import printer configuration file (PCP file). 

To create new plot style tables 

Choose File > Plot from the main menu. 

Under Plot Style Table (pen assignments), choose New to open the Add Plot Style Table wizard. 

On the last wizard page, you can click Plot Style Table Editor to set up the plot styles for the table.  

Standard toolbar:  

Command line PLOT 

 

Change Plot Style Settings 

Double-clicking a CTB or STB file in the Plot Style Manager to open the Plot Style Table Editor. The 

Plot Style Table Editor displays the plot styles contained in the specified plot style table. 

The General tab lists general information about the table. The Properties area on the Form View 

tab provides options for modifying colors or relevant properties of plot styles. 

If you are using a color-dependent plot style table, the color-dependent properties (e.g. color, 

dither, grayscale, pen, virtual pen, screening, linetype, adaptive, lineweight, line end, line join and 

fill style) are available from the Properties area. 

While all these plot style properties (e.g. color, dither, grayscale, pen, virtual pen, screening, 

linetype, adaptive, lineweight, line end, line join and fill style) are changed for each plot style from 

the Properties when using a named plot style table. 

In a named plot style table, the NORMAL plot style represents an object's default properties (no 

plot style applied). The NORMAL style can't be modified or deleted by yourself. 

Color 

The plot style color default to Use Object Color. With this setting, the object retains its layer or 

individually set color. The color overrides the object's color at plot time if you assign a plot style 

color for this plot style. 

System provides 255 Color Index (ZCI) colors, a true color, or a color book color in the plot style 

options. While the True color, plot styles should be synchronized with the same color setting for the 
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plotter configurations. However, system takes the latest color index as substitute color once the 

plotter is unable to update configuration to True color. 

Dither 

Enables dithering. A plotter uses dithering to approximate colors with dot patterns, giving the 

impression of plotting more colors than available in the ZWCAD+ Color Index (ZCI). If the plotter 

does not support dithering, the dithering setting is ignored. 

Dithering is usually turned off in order to avoid false line typing that results from dithering of thin 

vectors. Turning off dithering also makes dim colors more visible. When you turn off dithering, 

ZWCAD+ maps colors to the nearest color, resulting in a smaller range of colors when plotting. 

Dithering is available whether you use the object's color or assign a plot style color. 

Grayscale 

In case that the plotter supports grayscale, system converts the object's colors to grayscale when 

you select Convert to Grayscale. Light colors, such as yellow, are plotted with light gray values. Dark 

colors are plotted with dark gray values. 

If you set the Grayscale off, system uses the RGB values for the entity's colors. 

The grayscale is available for the entity color or a plot style color. 

Pen 

Specifies a pen to use when plotting objects that use this plot style. Available pens range from 1 to 

32.  

Virtual Pen 

Specifies a virtual pen number between 1 and 255. Many non-pen plotters can simulate pen 

plotters using virtual pens. For many devices, you can program the pen's width, fill pattern, end 

style, join style, and color/screening from the front panel on the plotter. 

Screening 

A color intensity setting determines the amount of ink ZWCAD+ places on the paper while plotting. 

Using valid values from 0 to 100. If set the value to 0, the color will be reduced to white. While 

assigning it to 100, the color will be displayed at its full intensity. 

Screening is effective only if the plotter is configured to plot colors or grayscale, with dithering 

enabled as well. 

Linetype 

Specifies which linetype to plot style table. The default setting is Use Object Linetype. 

Adaptive 

You can sets the Adaptive option whatever the linetype is object character or plot style. The option 
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can adjust the scale of the linetype to complete the linetype pattern. The line may be end at the 

middle of the linetype pattern if the Adaptive is set to OFF. 

Lineweight 

Uses Object Lineweight is the default setting for plot style lineweight. All the lineweight samples 

together with values are provided in the lineweight dropdown list. You can also modify an existing 

lineweight if the one you need is not available in the dropdown list. Clicks Edit Lineweights button 

to modify the existing lineweights. 

Line End 

Specifies the line end style to the plot style. The default setting is Use Object End Style. 

Line Join 

Specifies the style of the line joint. The default setting is Use Object Join Style. 

Fill Style 

Specifies the fill style for the polylines, torus and the objects filled with entities. The default setting 

is Use Object Fill Style. 

To modify plot style tables 

Choose File > Plot from the main menu. 

Under Plot Style Table (pen assignments), click the plot style table you want to modify, and then 

click Edit button. 

Click the General tab on Plot Style Table Editor, and then do any of the following: 

Enter a new plot style description. 

Select Apply Global Scale Factor to Non-ISO Linetypes to apply the scale factor to non-ISO linetypes 

used for any plot style in the current plot style table. 

Enter a scale factor to apply to non-ISO linetypes used for any plot style in the current plot style 

table. 

Click the Form View tab, and then do any of the following: 

Make changes to a color-dependent plot style by selecting it in the Plot list, and then make color, 

linetype, or lineweight changes for the plot style in Properties area. Your changes are saved 

automatically for the selected plot style. 

Make changes to a named plot style by selecting it in the Plot list, and then make color, linetype, or 

lineweight changes for the plot style in Properties area. Your changes are saved automatically for 

the selected plot style. 

Add a new plot style by clicking Add Style. Enter a new name, and then click OK. Select the options 

for the plot style. (Available for named plot styles only.) 

Delete a plot style by selecting it in the Plot list, and then click Delete Style. (Available for named 

plot styles only.) 

Click OK. 

Standard toolbar:  
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Command line PLOT 

 

Changing a drawing's plot style table type 

When your drawing was created, it was set up to use color-dependent plot style tables (.ctb files) or 

named plot style tables (.stb files). A drawing can use one type of plot style table at a time. If 

necessary, after a drawing is created you can convert the drawing to use the other type of plot style 

table. 

If you can't remember what type of plot style table is assigned to your drawing, use the 

PSTYLEMODE system variable to determine the plot style table type. 

To change a drawing to use named plot style tables 

Open the drawing that uses color-dependent plot style tables (.ctb files). 

Type CONVERTPSTYLES, and then press Enter. 

If you have already converted your individual color-dependent plot style tables to named tables, 

click OK in the prompt that displays. 

In the Select File dialog box, select a named plot style table (.stb file) that you want to use with the 

drawing. 

Click Open and a message is displayed to confirm that the drawing is converted.  

 

To change a drawing to use color-dependent plot style tables 

Open the drawing that uses named plot style tables (.stb files). 

Type CONVERTPSTYLES, and then press Enter. 

If you are sure you want to convert the drawing and lose all plot style assignments, click OK in the 

prompt that displays. 

NOTE Converting a drawing to use color-dependent plot style tables will remove all of the named 

plot style information from objects and layers. However, the named plot style tables are not 

deleted from your computer. 

 

Converting plot style tables 

You can convert a color-dependent plot style table to a named plot style table. You cannot convert 

a named plot style table to a color-dependent plot style table because color-dependent tables 

contain only plot styles that are named after the 255 colors to which they map. 

Converting a color-dependent plot style table to a named plot style table can be helpful in the 

following situations: 

You don't want to create a named plot style table from scratch. 

You want to create a named plot style table that has the same settings as a color-dependent plot 

style table, but with some new plot styles or other custom settings. 

You want to convert a drawing to use named plot style tables and you want to reuse most of plot 

styles already defined in a color-dependent plot style table. 

To convert a color-dependent plot style table to a named plot style table 

Type CONVERTCTB, and then press Enter. 
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In the Select File dialog box, select the color-dependent plot style table (.ctb file) that you want to 

convert. 

Click Open. 

Enter a name for the new named plot style table (.stb file). 

Click Save. 

The plot styles in the new table are named Style 1, Style 2, and so on. If want to use different plot 

style names, rename the plot styles before you assign them to objects and layers in your drawing. If 

you rename the plot styles after assigning them, they will not match when you print your drawing. 

 

Turning off plot style tables 

When you turn off plot style tables, objects print according to their own properties. However, all of 

the plot style information is saved so you can easily turn on plot styles again. Actual plot style table 

files are not deleted, and for drawings that use named plot style tables, objects and layers retain 

their assigned plot styles. 

To turn off plot style tables 

If necessary, click the desired Layout tab, or click the Model tab. 

Choose File > Plot from the main menu. 

Under Plot Style Table (pen assignments), select None. 

Select Save Changes to Layout, and then click Apply to Layout. 

Standard toolbar:  

Command line PLOT 

 

Commands Reference 

LAYER: Manages layers and layer properties 

OPTIONS: Customizes the ZWCAD+ settings 

PROPERTIES: Controls properties of existing objects 

CONVERTCTB: Converts Color-dependent plot style (CTB) into the named plot style (STB) 

CONVERTPSTYLES: Controls whether to change the plot style in the drawing as CTB or STB 

System Variables Reference 

CPLOTSTYLE: Controls the current plot style for new objects 

DEFLPLSTYLE: Specifies the default plot style for new layers 
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DEFPLSTYLE: Specifies the default plot style for new objects 

PSTYLEMODE: Indicates whether the current drawing is in a Color-Dependent or Named Plot 

Style mode 

PSTYLEPOLICY: Controls whether an object's color property is associated with its plot style 

 Plot Files to Other Formats 

Plots files of various formats, including DWF, PDF, PLT and other files. You can output drawings in 

any image formats with unique plotter driver. In such cases, Non-system plotter driver will be 

configured as output file format. Users are capable of controlling customized properties of each 

non-system plotter driver in plotter configure editor. You can also obtain specific help for each 

driver from the Help topic in plotter configuration editor. 

Plot to Raster File Formats 

Several raster file formats, including Windows BMP, TIFF, PNG, TGA and JPEG are supported by the 

non-system raster driver. The raster driver is most commonly used when plot to files for desktop 

publishing. 

Plot Adobe PDF Files 

Adobe PDF file can be created from drawing using PDF driver. 

EPS 

EPS format is housed PostScript file, a drawing file can be exported as EPS file using PLOT 

command. 

PostScript file formats are most available for desktop publishing applications. With plotting 

capability of high resolution, this file format is suited for raster images, such as GIF, PCX and TIFF. 

Once you have converted the drawing into PostScript format, you can use PostScript font. 

To export files as EPS from layout tab, you should execute from "File-Plot" menu to start the Plot 

dialog box. Choose ZWCAD Virtual Eps Plotter 1.0 from the Name pull-down list in Printer/plotter 

area, and then click OK to close the Plot dialog box. Next, the Browse for Plot File dialog box opens, 

in which users can specify the saving path and file name, and save the file with extensions .eps. 

Controllable Properties of PostScript 

When exporting drawing as EPS files in PostScript format, some objects will be rendered. Affects 

the following properties: 

Text, attribute definitions and attributes. If replace the font supportive of PostScript with the font 

with specified conversion text object, text will be plotted in specified PostScript font. Or else, 

render the text with frame character. 

Bold font and text control code. If the text with thickness over 0 or contain control code (such 
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as %%O or %%D). But rendered text will not be plotted as PostScript font. International symbol and 

special symbol exported as PostScript font. 

ISO 8859 Latin/1 character set, if use character value among 127 to 255 for text, explain this text 

according to ISO 8859 Latin/1. If this character appears in the text reflected to PostScript, 

re-mapping a version of generating code vector to display ISO character set. The text generated 

from re-mapping will be exported in PostScript compatible format. 

Circle, arc, ellipse, elliptic arc. Arcs and circles will be converted into corresponding PostScript path 

object if they have thickness. 

Fill solids. Plot the Fill solids in PostScript path. 

2D polyline. Exports the 2D (planar) polyline with unify width, PostScript restricts system settings as 

proximate lines combination with end seal and mitre. 

DWF 

Export ZWCAD+ drawings as Web DWF formats using DWFOUT or PLOT command. As a two 

dimension vector file, DWF publish ZWCAD+ drawings on Web or Intranet network. 

DWF file supports realtime panning or scaling and controls how the layers and named views are 

displayed. 

To export a drawing to a DWF file 

Choose File > Plot from the main menu. 

Choose DWF6 ePlot.pc5 for the Name option from the Printer/plotter area on the Plot dialog box. 

Click OK. 

Specify the location and the name for the DWF file in Browse for Plot File dialog box. 

Click Save. 

Command line DWFOUT  

 

Commands Reference 

PLOT: Plots a drawing to a plotter, printer, or file 

System Variables Reference 

None 

Plot Adobe PDF Files 

Adobe PDF file can be created from drawing using PDF driver. 

Portable Document Format (PDF) is a standard of electronic file change. PDF file can be used on any 

system operation like Windows, Unix and so on. More and more document is using PDF now, such 

as e-books, product introduction, network information, e-mails. PDF has become a standard for 

digitized information. 
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Note: The Adobe Reader R7 or higher version is needed on view the published 

PDF file. The version 9.3 is needed on Microsoft Windows 7. 

 

Steps for PDF printing: 

Choose File > Plot from the main menu. 

Choose DWG To PDF.pc5 for the Name option from the Printer/plotter area on the Plot dialog box. 

Click OK. 

Specify the location and the name for the PDF file in Browse for Plot File dialog box. 

Click Save. 

Standard Toolbar:  

Command：PLOT 

 

Steps for adding PDF plotter 

The drawing can be published as PDF file format if you adding PDF plotter though Add plotter 

wizard. Steps for adding PDF plotter as follow: 

Select File > Plotter Manager from the main menu. 

Select Next after you read the introduction in Add Plotter - Introduction Page. 

Select My Computer from the Add Plotter - Begin page, and click Next. 

In Add Plotter - Plotter Model page, select Adobe PDF from Manufactures option, and select PDF 

from Models option. Click Next to continue. 

Activate the Plot to File check box from Add Plotter - Ports page, and click Next.  

In Add Plotter - Plotter Name page, input your configuration file name, or use the default name and 

click Next. 

Click Finish in Add Plotter - Finish page to finish your adding. 

The new Plot Configuration file (PC5) is setup. 

Command: PLOTTERMANAGER 

 

Commands Reference 

PLOT: Plots a drawing to a plotter, printer, or file 

PLOTTERMANAGER: Add Plotter Wizard 

System Variables Reference 

None 
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Batch Plot 

With the PLTPLOT command, you can perform batch plot function to print multiple PLT or PRN files 

at one time in a specified printer. 

Select PLT files or PRN files by clicking the Add Sheets button on the Batch Plot dialog box to set the 

files you want to plot. Besides, you can also save the files listed on the current plot file list as a 

".TXT" file by using the Save Sheet List button on the Batch Plot dialog box, and then you can load 

the saved .TXT file to add all the files it includes to the current list in the future. 

The plot list displays name and path of the file, the PLT file or PRN file will be displayed together 

with its saving path. While the TXT file will be displayed without its file path. 

Before batch plotting, you can set all the files in the plot list, and also selective plot part of the files 

from the plot list.  

 

Commands Reference 

PLOT: Plots a drawing to a plotter, printer, or file 

PLTPLOT: Batch plot your PLT files 

System Variables Reference 

None 

13.3 Publish Drawings 

Publish multiple files to a separate single-sheet or multi-sheet PDF, DWF file or a printer in order to 

save and plot files. The paper name and page setup will be displayed as soon as you select files to 

the file list. Here, paper name refers to the name of the drawing to be plotted, with a dash joining 

the drawing name and layout name, page setup column displays the named page setup of layouts. 

You can click the page setup to select other page setup from the dropdown list. The model tab and 

layout tab are only applied to the corresponding tab. 

You can optionally click on model tab and layout tab in Add drawings include option in the course 

of importing files into the drawing list. And assemble a collection of drawings to publish and save 

the list as a Drawing Set Descriptions (DSD) file. A DSD file is created for illustrating these drawing 

files list and selected layout list. 

In the Publish dialog box, users can define the way to publish file list. You can choose to publish to 

Plotter named in page setup, DWF or PDF. 

Publish to Plotter named in page setup 

Plots all the drawing files on the publish list. You can set plot copies after publishing drawings to a 

specified plotter. 
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Publish to DWF/PDF 

Generates the drawing files that are published to the file list and saves them as a single-sheet or 

multi-sheet DWF, PDF file, and specifies the saving path for the output DWF or PDF file in the 

Publish Option dialog box. 

 

Commands Reference 

PLOT: Plots a drawing to a plotter, printer, or file 

PUBLISH: Creates a single-sheet or multi-sheet drawing set to publish it to a separate single-sheet 

or multi-sheet PDF, DWF file or a printer 

System Variables Reference 

None 
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14 Share Data Between Drawings and 

Applications 

 

 

Topics in this section: 

Save and View Slides 

You can save slides of a drawing to view later. A slide saves the current drawing in *.sld format 

exactly as it appears on the screen. A slide is not a drawing file. You cannot edit or print the slide; 

you can only view it. 

Link and Embed Data 

You can include data from other programs in ZWCAD+ drawings by using either embedding or 

linking. The method you choose depends on the type of object or file you want to include in your 

ZWCAD+ drawing and what you want to do with it after it is there. 

Work with Data in Other Formats 

You can work with many different types of files, including files created with other applications. 

Package a Set of Files for Internet Transmission 

With the application of etransmit, you can accomplish transmitting drawing files together with 

their associative files through Internet in forms of transmittal packages. The associative files 

included in the transmittal package are xrefs, fonts, raster images, etc. 

ZWCAD+ Syble 

ZWCAD+ Syble is used to synchronize drawings between user's local directory and cloud storage. 

When a drawing in the cloud is modified, the local drawing will be updated automatically to ensure 

that the users can always browse the latest drawing data in various client products provided by 

ZWCAD. 

14.1 Save and View Slides 

You can save slides of a drawing to view later. A slide saves the current drawing in *.sld format 

exactly as it appears on the screen. A slide is not a drawing file. You cannot edit or print the slide; 

you can only view it. 

You can use slides in the following ways: 

Make presentations by showing slides of your drawings. 

Reference a slide of a drawing while working on a different drawing. 

Present a number of slides as a slide show by using scripts. 

When you view a slide, it temporarily replaces the current drawing. When you refresh the display 

of the current drawing (by redrawing, panning, zooming, minimizing, maximizing, or tiling), the 

slide image disappears, and you are returned to the current drawing. 
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A slide does not include any invisible entities on layers.  

To create a slide 

Type MSLIDE and then press Enter. 

In the Create Slide File dialog box, specify the name of the slide file you want to create. 

Click Save. 

Command line MSLIDE 

The current drawing remains on the screen, and the slide is saved to the directory that you specify. 

You can view previously saved slides, and you can also view slides created using other CAD 

softwares. 

 

To view a slide 

Type VSLIDE and then press Enter. 

In the Select Slide File dialog box, specify the name of the slide file you want to view. 

Click Open. ZWCAD+ displays the slides in the current drawing window. 

Command line VSLIDE 

You can view previously saved slides, and you can also view slides created using other CAD 

softwares. 

 

Commands Reference 

MSLIDE: Creates a slide file of the current model viewport or the current layout 

VSLIDE: Displays the slide files 

System Variables Reference 

None 

14.2 Link and Embed Data 

You can include data from other programs in ZWCAD+ drawings by using either embedding or 

linking. The method you choose depends on the type of object or file you want to include in your 

ZWCAD+ drawing and what you want to do with it after it is there. 

Topics in this section: 

 Overview of Object Linking and Embedding 

The Object Linking can be used for merging data from different applications into a document.  

 Import OLE Objects 

Insert information of other applications that support OLE objects. 
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 Export OLE Objects from Drawings 

Export ZWCAD+ drawings into other applications that are supportive to OLE objects, and then 

embed the objects of the drawing into other documents. 

 Edit OLE Objects in Drawings 

You can modify an embedded or linked object in its original program from within ZWCAD+. 

 Embed Drawings 

When you embed a ZWCAD+ drawing, it becomes part of the other program's document file. When 

you edit the drawing, you edit only the version that is embedded in the other document. 

 Link Drawings 

When you link a ZWCAD+ drawing to another document, the other document contains only a 

reference to the ZWCAD+ drawing file, rather than the actual drawing. You link data in a saved 

ZWCAD+ file so that the other program can find the data and display it. 

 Overview of Object Linking and Embedding 

The Object Linking can be used for merging data from different applications into a document. For 

example, you can create ZWCAD+ drawing with a Microsoft WORD document included, and also 

create an Adobe PageMaker layout containing ZWCAD+ drawings. 

To use OLE, ensure your system supports OLE server and container applications. Source 

applications which are called server mainly used for creating embedded or linked OLE objects. 

Target applications are container used for accepting OLE objects. ZWCAD+ uses OLE as server and 

container applications. 

Even if ZWCAD+ objects such as circle or blocks are always taken as OLE objects, they can be varied 

in meaning. 

Link and embed information by inserting a document into another, meanwhile, edit objects in 

container applications using links and embed OLE objects. However, varied in storing information, 

the relationship between linking and embedding is similar to that of inserting blocks and creating 

xrefs in ZWCAD+ drawing. 

Embed Objects 

The embedded OLE objects come from copies of other documents, when embedding objects into 

files, the embedded objects have no relations with the original document, they are not updated by 

changing the current drawing. 

You can execute from "Insert-OLE Object" menu, and select Create from File without clicking on the 

Link option to embed objects. Once you have embedded OLE objects into the drawing, you can 

create applications of the object for editing, and the original OLE object keep unchanged while you 



 

 498 

editing information of the source document. 

 

Link Objects 

When inserting OLE objects, if you select Create from File and click Link option as well, you can 

insert the linked OLE object into ZWCAD+ drawing. Linking objects is a type of reference to the 

information of other document. To use a link object for the same information in multiple 

documents, you just modify the source object, and perform OLELINKS command to set automatic 

or manual update document containing OLE objects. 

You should keep accessing the source document and linked document. If move or rename the 

source object, you should rebuild links in the link file. 

 

 

Commands Reference 

INSERTOBJ: Inserts a linked or embedded object 

OLELINKS: Updates, changes, and cancels existing OLE links 

System Variables Reference 

OLEHIDE: Controls the display of OLE objects 

 Import OLE Objects 

Inserts information of other applications that support OLE objects. 

ZWCAD+ provides two ways of inserting OLE objects: embed and link. With the different that a link 

can be updated whenever you want, embedding is unable to update because in lack of links. 

You can use the following method to control visibility of the inserted OLE objects: 

Insert OLE objects to the drawing on current layer. Turn off the layer or freeze it to disable 

displaying OLE objects in the layer. 
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To embed an object from an existing file within ZWCAD+ 

Choose Insert > OLE Object from the main menu. 

In the Insert Object dialog box, click Create From File. 

Specify the file by doing one of the following: 

Type a path and file name in the File box. 

Click Browse to select a file. 

Select Display As Icon if you want that program's icon to appear in the drawing instead of the data. 

Click OK. 

Command line INSETOBJ 

 

To create a new embedded object from within ZWCAD+ 

Choose Insert > OLE Object from the main menu. 

In the Insert Object dialog box, click Create New. 

From the Object Type list, select the type of object you want to create, and then click OK. 

The program for creating that object opens within ZWCAD+. 

Create the object in the other program. 

Choose File > Exit to close the program. 

Command line INSETOBJ 

 

Link OLE Objects in Drawings 

If another program supports ActiveX, you can link its data to ZWCAD+ drawings. Use linking when 

you want to include the same data in many files. When you update the data, all links to other files 

reflect the changes. 

When you link data from another program, the ZWCAD+ drawing stores only a reference to the 

location of the file in which you created the data. You link data from a saved file, so ZWCAD+ can 

find the data and display it. 

Because linking adds only a reference to a file, the data does not significantly increase the file size 

of the ZWCAD+ drawing. However, links require some maintenance. If you move any of the linked 

files, you need to update the links. In addition, if you want to transport linked data, you must 

include all linked files. 

You can update a linked object automatically every time you open the drawing, or you can do so 

only when you specify. Anytime a link is updated, changes made to the object in its original file also 

appear in the ZWCAD+ drawing, and the changes also appear in the original file if they were made 

through ZWCAD+. 

Insert an OLE object together with links to update its displaying in drawings through changing 

source objects. For example, you may be required to insert a time table into an automatic update 
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drawing. 

When inserting OLE objects, you can display the object as icon, thus you can activate applications 

which are supportive to this object by double clicking this icon. 

To create a linked object from within ZWCAD+ 

Choose Insert > OLE Object from the main menu. 

In the Insert Object dialog box, click Create From File. 

Specify the file by doing one of the following: 

Type a path and file name in the File box. 

Click Browse to select the file using a file dialog box. 

Select the Link check box. 

Select Display As Icon if you want that program's icon to appear in the drawing instead of the data. 

Click OK. 

Command line INSETOBJ 

 

Update Links 

Display the links contained in current drawing in the Links dialog performed from OLELINKS 

command. With this command, you can setup methods to update links for each settings used for 

linking information, either automatic or manual. 

By default, the OLE links created in ZWCAD+ drawing are automatic update. 

Reconnect Links 

Source refers to the position where the linked documents are located. Once the position of 

document is changed or renamed, the link source must be changed as well. When replacing 

information or objects with links contained, the link source should be changed also. 

Break Links 

Select Break links option in Links dialog box, OLE objects in ZWCAD+ drawing will not be removed 

rather than its links. Thus, the OLE object never updates when changing its source. 

To link a file to a ZWCAD+ drawing 

Save the original file. 

Because a link consists of a reference to the original file, you must save the file before you can link 

to it. 

In the original file, select the data you want in the ZWCAD+ drawing. 

Choose that program's command to place data on the Clipboard. Usually, you choose Edit > Copy 

from the main menu. 

Display the ZWCAD+ drawing to which you want to link the file. 

In ZWCAD+, choose Edit > Paste Special from the main menu. 

In the Paste Special dialog box, select Paste Link. 

Click OK. 
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Embed OLE Objects in Drawings 

Embed an object into your ZWCAD+ drawing when you want to keep all the data you work with in 

one file or if you want to transfer the file to other computers. You can embed data from programs 

that support object linking and embedding. 

When you embed data from another program, ZWCAD+ becomes the container for that data. The 

object embedded in the ZWCAD+ drawing becomes part of the ZWCAD+ file. When you edit the 

data, you open its program from within the ZWCAD+ drawing. 

Any changes you make to the embedded data exist only in the ZWCAD+ drawing, so it is not 

necessary to keep that data in a separate file. If the data does exist in a separate file, the original 

file does not change when you modify the embedded object in ZWCAD+. Also, changes to the 

original file do not affect the embedded object in the ZWCAD+ drawing. 

To embed another program's object into a ZWCAD+ drawing 

Open the file that contains the data you want. 

In the file, select the data you want to embed in the ZWCAD+ drawing. 

Choose that program's command to place data on the Clipboard. Usually, you choose Edit > Copy 

from the main menu. 

In the ZWCAD+ window, display the drawing in which you want to embed the object. 

Choose Edit > Paste from the main menu, or click the Paste from Clipboard tool on the Standard 

toolbar. 

The data on the Clipboard is pasted into the drawing as an embedded object. The object appears in 

the center of the view, but you can select and move it by moving the cursor. 

 

The OLE objects that are supportive to other applications will not be updated along with the 

objects in source document when embedding into ZWCAD+ drawings. 

ZWCAD+ provides various methods to embed drawings: such as copy the object to clipboard, paste 

it to ZWCAD+ drawing files, and then embed it to ZWCAD+ drawing. You can embed a company 

icon created by other applications into ZWCAD+ drawings. 

With the embedding feature, you can also embed OLE objects into ZWCAD+ drawings without 

specifying links. A .txt file will be changed into mtext once embedded into the drawing, with its file 

name displayed together. 

Once embedded into current drawing, you can adjust the object's size according to the proportion 

of drawing unit. And also scaling text that is included in OLE objects by specifying point size. 

Drag Objects into a Drawing 

If you want to link data and drawings to ZWCAD+ drawings from other applications, besides 

inserting OLE objects, you can drag the selected data or drawings into ZWCAD+. Both applications 

must be running and visible on your screen. To drag information between applications, the other 

applications must support ActiveX. Objects dragged into a drawing are embedded, not linked. 

As manipulating for cutting and pasting, you do the dragging in the same way. The information is 

removed from one document and pasted into the other document when you do the dragging. 

Holding down CTRL while dragging creates a copy of the information without affecting the original 

document, as you do copying and pasting in the same way. 
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Control Objects' Quality 

Default quality level of the OLE objects is determined by system variable OLEQUALITY. To illustrate 

plotting effects, the quality here is divided into five grades: line quality, text quality, graphics quality, 

photo quality and high photo quality. 

In which line quality is the lowest grade, plots the drawing in the shortest way and occupies the 

least memory. While high photo quality plots the drawing in a longer way and occupies more 

memory. 

Limits for Inserting OLE Objects 

ZWCAD+ set some limits when linking or embedding the OLE objects. All these inherent limits are 

used for designing OLE objects. 

OLE objects are not displayed or plotted on xrefs or block references. 

Modifications made for plotting rotation are not reflected on OLE objects when using Microsoft 

Windows system plotter. Change plot orientation in Windows Plotting system configuration dialog 

box. 

ZWCAD+ limits the size of spreadsheet that is imported as OLE object. If import too large a 

spreadsheet, you can reduce the column width and row height, and reduce font size or partly paste 

the spreadsheet so as to divide the OLE objects into several objects in smaller size. 

Before importing OLE objects into other applications, use Windows copyclip viewer to preview OLE 

object. 

 

Commands Reference 

INSERTOBJ: Inserts a linked or embedded object 

OLELINKS: Updates, changes, and cancels existing OLE links 

OPTIONS: Customizes the ZWCAD+ settings 

PASTESPEC: Inserts data from the Clipboard and controls the format of the data  

PASTECLIP: Inserts data from the Clipboard 

System Variables Reference 

OLEQUALITY: Sets the default plot quality for OLE objects 

OLESTARTUP: Controls whether the source application of an embedded OLE object loads when 

plotting 
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 Export OLE Objects from Drawings 

Export ZWCAD+ drawings into other applications that are supportive to OLE objects, and then 

embed the objects of the drawing into other documents. 

Select objects in ZWCAD+ drawing, and hold CTRL+C or use other copy commands to copy selected 

objects, paste or selective paste the copies using copy commands of other applications to embed 

them from the ZWCAD+ into other documents. 

Embedding places a copy of the selected objects in the destination document. The object in the 

original drawing will not update when you edit the OLE object from within the destination 

document in a ZWCAD+ drawing. 

Dragging ZWCAD+ drawings into other programs 

If the other program in which you want to include ZWCAD+ drawings is compatible with ActiveX, an 

alternative to pasting drawings with menu commands is to drag drawing file icons from Windows 

Explorer into the other document. Dragging and dropping drawings does not use the Clipboard, so 

data on the Clipboard is not affected. 

When you drag a ZWCAD+ drawing file from Windows Explorer, you link or embed the entire 

drawing in the other document. When you drag the file, the cursor changes in response to the 

action you take. 

TIP Before you drag a drawing, position the Windows Explorer window and the other program's 

window so you can see the file icon and the document in which you want to drop it. 

To drag and embed drawings into another document 

Select the icon for the drawing file, and then drag the drawing into the document. 

 

Commands Reference 

COPYCLIP: Copies objects to the Clipboard without removing the source objects from the drawing 

CUTCLIP: Copies objects to the Clipboard and removes the objects from the drawing 

INSERTOBJ: Inserts a linked or embedded object 

OLELINKS: Updates, changes, and cancels existing OLE links 

System Variables Reference 

WMFBKGND: Controls the background display when objects are inserted in Windows metafile 

(WMF) format 

WMFFOREGND: Controls the foreground color when objects are inserted in Windows metafile 
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(WMF) format 

 Edit OLE Objects in Drawings 

You can modify an embedded or linked object in its original program from within ZWCAD+. When 

you modify an embedded object, you change the object only in ZWCAD+, not its original file (if you 

pasted the object from an existing file). When you modify a linked file, however, you open and 

change the original file. 

Double-click the OLE object to start server applications in which you can edit the OLE objects.  

ZWCAD+ provides two ways to edit OLE objects: one is to link or embed OLE objects which are 

supportive of other applications into ZWCAD+ drawings, or you can embed ZWCAD+ drawings into 

other applications. 

Embed ZWCAD+ drawings into Other Applications 

When you want to embed ZWCAD+ drawings into other applications, you use ZWCAD+ objects as 

the OLE objects while ZWCAD+ applications are taken as server applications. In the target 

application, which is so-called container applications, double clicking the inserted OLE objects to 

start ZWCAD+ application and modify OLE objects. Once you have changed OLE object, only the 

target application displays its change, the source OLE object is not changed. 

Link or Embed OLE Objects supportive of other Applications into 

ZWCAD+ 

When you link or embed OLE objects that are supportive of other applications into ZWCAD+, 

ZWCAD+ applications are used as container applications. 

If you select objects of ZWCAD+ using frame selection, the inserted OLE object overlapped with 

ZWCAD+ objects. But the objects to be selected are only provided in ZWCAD+, not OLE objects. 

Additionally, the edit and snap mode take no effect on OLE objects. To adjust and scale the size of 

the OLE objects, you should edit these objects using grips displayed on them. 

When you right click on the OLE object, a shortcut menu will be displayed with some editing 

properties such as: Cut, Copy, Delete object and On. 

 

Commands Reference 

COPYCLIP: Copies objects to the Clipboard without removing the source objects from the drawing 

CUTCLIP: Copies objects to the Clipboard and removes the objects from the drawing 

ERASE: Removes objects from a drawing  

PASTECLIP: Inserts data from the Clipboard 
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U: Reverses the most recent operation 

System Variables Reference 

OLEHIDE: Controls the display of OLE objects 

 Embed Drawings 

When you embed a ZWCAD+ drawing, it becomes part of the other program's document file. When 

you edit the drawing, you edit only the version that is embedded in the other document. 

Embedding is useful when you don't want to maintain a link to the ZWCAD+ drawing for the data 

you include in the other document. Edits made to the new drawing do not affect the original 

drawing. To transfer the file to other computers, you can transfer all the data in one file, but 

embedded objects increase the file size. 

From within a document in a program that supports ActiveX, such as Microsoft® Word, you can 

either create a new embedded ZWCAD+ drawing or embed an existing ZWCAD+ drawing. 

To create a ZWCAD+ drawing in another document 

In the document, choose Insert > OLE Object from the main menu. 

In the Insert Object dialog box, click Create New to create a new file. 

Under Object Type, choose ZWCAD+ Drawing, and then click OK. 

Create the ZWCAD+ drawing. 

Choose File > Exit from the main menu in ZWCAD+. 

To edit the ZWCAD+ drawing from within the document, double-click the drawing. 

TIP You can also embed an existing ZWCAD+ drawing from within another 

document. 

 

To embed selected ZWCAD+ entities 

In ZWCAD+, select the entities you want to embed. 

Choose Edit > Copy from the main menu (or press Ctrl+C). 

Open the document in which you want to embed the entities. 

Choose Edit > Paste from the main menu (or press Ctrl+V). 

 

To embed an entire ZWCAD+ drawing 

Open the document in which you want to embed the drawing. 

Choose Insert > OLE Object from the main menu. 

Click Create From File. 

Click Browse, and then choose the file you want to embed. 

Click Insert, and then click OK. 

 

Commands Reference 
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COPYCLIP: Copies objects to the Clipboard without removing the source objects from the drawing 

CUTCLIP: Copies objects to the Clipboard and removes the objects from the drawing 

ERASE: Removes objects from a drawing  

PASTECLIP: Inserts data from the Clipboard 

U: Reverses the most recent operation 

System Variables Reference 

OLEHIDE: Controls the display of OLE objects 

 Link Drawings 

When you link a ZWCAD+ drawing to another document, the other document contains only a 

reference to the ZWCAD+ drawing file, rather than the actual drawing. You link data in a saved 

ZWCAD+ file so that the other program can find the data and display it. 

Linking works well when you want to include the same ZWCAD+ data in more than one document. 

When you update the data, you need update it in only one location. The versions that are linked to 

other documents reflect the changes automatically. 

Linking a ZWCAD+ file to another document does not increase the file size the way embedding a 

ZWCAD+ object does. However, links require more maintenance. To transport the data, you must 

make sure to transfer all linked files to the other computer. 

To link a ZWCAD+ file to another document 

Open the drawing you want to link. 

NOTE Because a link is a reference to a file, you can link only files that are saved to a location on a 

disk. 

In the other program, open the document in which you want to include the ZWCAD+ drawing. 

Choose that program's command for inserting objects. 

In Microsoft® Office programs, choose Insert > Object. In the Object dialog box, click the Create 

From File tab. Specify the name of the drawing file you want to link. Select the Link To File check 

box, and then click OK. The drawing appears in the document, with a link to the original ZWCAD+ 

file. 

 

Commands Reference 

COPYCLIP: Copies objects to the Clipboard without removing the source objects from the drawing 

CUTCLIP: Copies objects to the Clipboard and removes the objects from the drawing 
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ERASE: Removes objects from a drawing  

PASTECLIP: Inserts data from the Clipboard 

U: Reverses the most recent operation 

System Variables Reference 

OLEHIDE: Controls the display of OLE objects 

14.3 Work with Data in Other Formats 

You can work with many different types of files, including files created with other applications. 

Topics in this section: 

 Import Files Created in Other Formats 

To open and use drawings or graphics generated with other applications in specified format. 

ZWCAD+ supports mutual conversion between DXF and WMF format. 

 Export Drawings to Other File Formats 

Export and convert ZWCAD+ drawings as other file formats. ZWCAD+ supports the output file 

format containing: WMF, DXF, BMP, DWG, DWT, PDF, EPS, DWF, SAT. 

 Work with Proxy Objects 

When the Runtime Extension application that created the custom object is not available to 

ZWCAD+ or other host applications, a proxy object is used as a substitute for a custom object. 

 Import Files Created in Other Formats 

To open and use drawings or graphics generated with other applications in specified format. 

ZWCAD+ supports mutual conversion between DXF and WMF format. Use the commands relative 

to each file types to convert formats among them. You can also convert formats by opening or 

importing files. 

ZWCAD+ supports the input file format containing: DXF, DWG, DWT, SAT, WMF. In which, DWG, DXF, 

DWT are imported using Open command. DXF refers to drawing exchange format, DWG refers to 

standard drawing file, and DWT refers to template drawing file. The additional SAT and WMF file 

should be imported by relevant commands. 

Import DXF Files 

As a drawing exchange file, DXF file contains text file of drawing information, which is also an 
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expression of ASCII or binary system of drawing file. Mainly used for sharing drawing data among 

applications. 

Select a DXF file from the Files of Type dropdown list to import this file into applications when 

performing Open function in ZWCAD+. You can import it into other drawing files and explode it. 

To import a DXF or DWT file 

Choose File > Open from the main menu. 

Choose the folder that contains the drawing. 

In Files of Type, choose the type of drawing you want to import. 

Choose the file you want to open. 

Click Open. 

Standard Toolbar:  

Command line OPEN 

 

Import ACIS SAT Files 

You can import geometry objects stored in SAT (ASCII) files using ACISIN or IMPORT commands. SAT 

(ASCII) files store entities as solids, regions or ACIS. ZWCAD+ converts the model to a body object 

or to solids and regions if the body is a true solid or a true region. After the conversion, ZWCAD+ 

creates new objects using its ShapeManager modeler and performs 3D operations and solids 

editing. 

To import an ACIS file 

Choose Insert > ACIS File from the main menu. 

Choose the directory containing the SAT file. 

Choose the SAT file you want to open. 

Click Open. 

Command line ACISIN 

 

Import WMF Files 

As a Windows metafile format, WMF files are frequently used to produce clip art and other 

non-technical images that you need for drawings. Use WMFIN or IMPORT command to insert a 

WMF file into a drawing file as a block. 

To be different from bitmaps, WMF files contain vector information that can be resized and printed 

without losing resolution. If 2D solids or wide lines are contained in the WMF file, turn off their 

display so as to increase drawing speed. 

Both vector and raster information can be contained in WMF files. However, ZWCAD+ uses only the 

vector information from a WMF file. ZWCAD+ ignores the raster information if using a WMF file 

containing raster information.  

 

Commands Reference 
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ACISIN: Imports an ACIS file 

BLOCK: Creates a block definition from objects you select 

EXPLODE: Breaks a compound object into its component objects 

IMPORT: Imports files in various formats 

OPEN: Opens an existing drawing file 

WMFIN: Imports a Windows metafile 

System Variables Reference 

None 

 Export Drawings to Other File Formats 

Export and convert ZWCAD+ drawings as other file formats. ZWCAD+ supports the output file 

format containing: WMF, DXF, BMP, DWG, DWT, PDF, EPS, DWF, SAT. 

WMF 

Exports drawing files as element files (.wmf) using WMFOUT or EXPORT command. As a Windows 

metafile format, WMF file includes lots of vector drawings or raster images. Generally, ZWCAD+ 

creates WMF files in vector drawings which are easy to pan or scale. 

DXF 

As a drawing exchange file, DXF file contains a text file of drawing information that is accessible for 

all the other CAD systems. If someone else is using CAD applications capable of identify DXF files, 

you can share the drawing by saving drawing as DXF file. 

User can export files as DXF format using Save or Save As command, select DXF file format from the 

Tools button of the Export dialog box, when saving the drawing as DXF format. DXF files are also 

saved as ASCII or binary format. 

Specify precise decimal digits as you saving drawing as DXF file, controls floating-precision up to 16 

digits for DXF files. You can also click Select Object option to save some objects as DXF file. 

BMP 

As bitmap file format, BMP is a kind of raster image format. The object displayed on screen 

together with colored viewport and objects in rendered viewport will be displayed in raster images 

as well. 

Export the entire drawing or partly export the drawing to device-independent raster images using 

EXPORT command. 
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DWG 

DWG is standard drawing file format generally supported by CAD software. 

DWT 

You can export drawings as DWT template file using Save or Save As command. 

To export a drawing to a BMP file 

Choose File > Export from the main menu. 

In the Export Data dialog box, under Files of Type, choose the Bitmap (*.bmp) file format. 

Specify the name of the file you want to create. 

Click Save. 

Select the objects you want to save, and then press Enter. 

Command line EXPORT 

 

PDF 

The PLOT command is available for exporting the drawing as a PDF file. 

PDF files allow you to distribute your drawing to others for viewing in Adobe® Acrobat ® Reader®, 

which is free software that users can download. PDF files can also be viewed, reviewed, and edited 

in Adobe® Acrobat. 

To export a drawing to a PDF file 

Choose File > Plot from the main menu. 

Choose DWG To PDF.pc5 for the Name option from the Printer/plotter area on the Plot dialog box. 

Click OK. 

Specify the location and the name for the PDF file in Browse for Plot File dialog box. 

Click Save. 

Command line PLOT  

 

EPS 

EPS format is housed PostScript file, a drawing file can be exported as EPS file using PLOT 

command. 

DWF 

Export ZWCAD+ drawings as Web DWF formats using DWFOUT or PLOT command. As a two 

dimension vector file, DWF publish ZWCAD+ drawings on Web or Intranet network. 

 

SAT 

Exports solids, regions, ACIS entities as SAT format using ACISOUT command. Additionally, trimmed 
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ShapeManager objects of the NURBS face, region and 3D solids are also exported as SAT file. 

To export an ACIS file 

Choose File > Export from the main menu. 

Select the ACIS entities you want to save. 

Specify the name of the file you want to create. 

Click Save. 

Command line EXPORT 

 

Commands Reference 

ACISOUT: Exports ZWCAD+ solid objects to an ACIS file 

BMPOUT: Saves selected objects to a file in device-independent bitmap format 

DWFOUT: Exports the current drawing into a DWF file 

EXPORT: Saves objects to other file formats 

PLOT: Plots a drawing to a plotter, printer, or file 

SAVEAS: Saves a copy of the current drawing under a new file name 

WBLOCK: Writes objects or a block to a new drawing file 

WMFOUT Saves objects to a Windows metafile  

System Variables Reference 

FACETRES: Adjusts the smoothness of shaded and rendered objects and objects with hidden lines 

removed 

WMFBKGND: Controls the background display when objects are inserted in Windows metafile 

(WMF) format 

 Work with Proxy Objects 

When the Runtime Extension application that created the custom object is not available to 

ZWCAD+ or other host applications, a proxy object is used as a substitute for a custom object. Later, 

the custom object replaces the proxy object if the application is available to ZWCAD+. 

As compared to corresponding custom objects, Proxy objects are endowed with significantly 

reduced capabilities. The extent to which proxy objects can be edited is determined by the parent 

Runtime Extension application. For example, to determine whether to erase and move an object, 

or change object properties, may or may not be possible on a proxy object, depending on the 
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application that created it. 

A Proxy Information dialog box will be displayed when you open a drawing. Which shows the total 

number of proxy objects in the drawing (both graphical and non-graphical) and the name of the 

missing application and provides additional information about the proxy object type and display 

state. You control the display of proxy objects with the dialog box. 

Edit Proxy Objects 

Proxy objects are enabled to be access, display, and also to perform the following manipulations: 

Erase proxy objects 

Quick select proxy objects 

Define block reference with proxy objects, insert drawings and block references with proxy objects, 

and explode. 

Export and plot preview proxy objects 

Edit operations such as MOVE, COPY, MIRROR, etc. 

 

Commands Reference 

None  

System Variables Reference 

PROXYGRAPHICS: Specifies whether images of proxy objects are saved in the drawing 

PROXYNOTICE: Displays a notice when a proxy is created 

PROXYSHOW: Controls the display of proxy objects in a drawing  

PROXYWEBSEARCH: Specifies how the program checks for object enablers 

14.4 Package a Set of Files for Internet Transmission 

With the application of etransmit, you can accomplish transmitting drawing files together with 

their associative files through Internet in forms of transmittal packages. The associative files 

included in the transmittal package are xrefs, fonts, raster images, etc. 

Generally, all of the included files such as xrefs, raster images and fonts will be ignored when you 

sending drawings to others. The receiver may not be able to display the transmitted drawing 

because of lacking these associative files. Using etransmit can help preventing such circumstances 

and decrease the error probability to a certain extent.  

Select files to pack 

Starts Create Transmittal dialog box, which provides two tabs for viewing and selecting files to be 

packed. 
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Files Tree: Displays drawing files in a tree structure together with their associative files (xrefs, 

fonts, raster images). You can expand or collapse this structure to display or hide the included 

dependent files. By default, drawing files and dependent files are included in the transmittal 

package automatically. Unless you deselect it by clicking at the check mark in front of each file.  

Files Table: Displays drawing files in forms of a list together with their associative files (xrefs, fonts, 

raster images). In which the detail information of each file such as file name, saving path, type, 

version size and date are listed. Transmittal package includes all these files automatically. You can 

deselect it by clicking at the check mark in front of each file in order to control the included 

contents of each transmittal package. 

Once you have performed eTransmit function for a drawing file, the common file types you can 

automatically add to the transmittal package are: 

*.dwg (root drawing file and all of its attached xrefs) 

Various image file types (raster image files that attach to root drawing or xref externally) 

*.fmp (font mapping files) 

User select or deselect files having been added into the transmittal package by clicking at the check 

box in front of the file or manually select files you want to include in the transmittal package by 

clicking at the Add File button on Files Tree or Files Table. 

The common file types that are not automatically added to a transmittal package are:  

*.shx (Compiled shape files used for text styles or complex linetypes) 

*.ttf (True Type font files used for text styles) 

All these files generally contain information about the object in initially formatted drawings or 

some specific information of applications run with the product, the receiver can still normally view 

the transmitted drawing in spite of lacking these files. 

Include notes in transmittal package 

Report file is automatically generated while generating transmittal package, and saved in the 

transmittal package together with the files list of the transmittal package as well. Meanwhile, this 

report includes dependent files associative to the drawing file (such as xrefs, fonts) as well as 

instructions about how to process these files so as to enable using for included drawing files. The 

information that user input in the Enter notes to include with this transmittal are also included in 

the report file.  

Select Transmittal Setups 

Once created a transmittal package, you can create new or modify existing transmittal setup and 

save it, so that you select it properly from the transmittal setup list on Create transmittal dialog box 

as you need when next time you create transmittal package. System default transmittal setup is 

named as STANDARD, for which you can change its default settings, but unable to perform rename 

or delete operation.  

Choose Transmittal Options 

You can specify the following transmittal setups when creating transmittal package, which greatly 
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facilitate using the etransmit function. 

Specify transmittal package type to be created as: ZIP file, self-extracting EXE file and folder (a 

specified folder position where the drawing will be packaged or copied) 

Choose options among Use organized folder structure, Place all files in one folder, Keep files and 

folders as is, to organize folder structure of transmitted files in logical structure. 

Add password protection for transmittal package of ZIP file and self-extracted EXE.  

Select Include fonts option to get all the font files associative to transmittal package (TTF and SHX), 

which facilitate receiver to view the drawing file.  

Send the transmittal package and transmittal report in form of e-mail attachment to relevant users.  

It should be noticed that, regardless of file structure included in the created transmittal package, 

absolute path of dependent files that are relative to the drawing file will be converted to relative 

path or not include path, so that you can easily find them while opening or editing drawing files.  

Create transmittal package in specified folder 

Select File > etransmit from the main menu.  

In the Create Transmittal dialog box, under Files Tree or Files Table area, click Add File button. 

In the Open folder, select the file to be added to the transmittal package, and then click Open. User 

can optionally repeat this procedure to add more files into transmittal package. 

To clear the selection for files being added into the transmittal package, click the check box marks 

beside any files on the Files Tree or Files Table.  

Click the Transmittal Setups button, select a transmittal setup from the Transmittal Setups dialog 

box, and then click Modify button. 

In the Modify Transmittal Setup dialog box, set the transmittal package type as Folder (set of files). 

Under Transmittal File Folder, click Browse to specify the folder where the transmittal package to 

be created. A standard file selection dialog box is displayed.  

Select the folder where the transmittal package will be created, and then click OK. 

In the Modify Transmittal Setup dialog box, click OK to close the dialog box. 

In the Transmittal Setups dialog box, click Close.  

(Optional) Specify any additional comments to include with the report file from the text box for 

Enter notes to include with this transmittal package in Create Transmittal dialog box. 

Click OK to create the transmittal package in the folder you specified. 

Command line ETRANSMIT 

 

Create transmittal package for self-extracting executable or ZIP file 

Select File > etransmit from the main menu 

In the Create Transmittal dialog box, under Files Tree or Files Table area, click Add File button. 

In the Open folder, select the file to be added to the transmittal package, and then click Open. User 

can optionally repeat this procedure to add more files into transmittal package. 

To clear the selection for files being added into the transmittal package, click the check box marks 

beside any files on the Files Tree or Files Table.  

Click the Transmittal Setups button, select a transmittal setup from the Transmittal Setups dialog 

box, and then click Modify button.  

In the Modify Transmittal Setup dialog box, set the transmittal package type as ZIP (*.zip) or 
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Self-extracting executable (*.exe).  

Under Transmittal File Folder, click Browse to specify the folder where the transmittal package to 

be created. A standard file selection dialog box is displayed.  

Select the folder where the transmittal package will be created, and then click OK. 

In the Modify Transmittal Setup dialog box, click OK to close the dialog box. 

In the Transmittal Setups dialog box, click Close. 

(Optional) Specify any additional comments to include with the report file from the text box for 

Enter notes to include with this transmittal package in Create Transmittal dialog box.  

Click OK to create the transmittal package in the folder you specified. 

Command line ETRANSMIT 

 

Unpack a self-extracting executable transmittal package 

Double-click the transmittal package file in Windows Explorer. 

In Extractor dialog box, select Browse to specify the folder where you want to unpack the 

transmittal files.  

Click OK.  

If the transmittal package is password protected, system prompt for entering the password. 

Click OK to close each dialog box.  

 

Commands Reference 

ETRANSMIT: Packages files associative to the drawing file for Internet transmission. 

System Variables Reference 

None 

14.5 ZWCAD+ Syble 

ZWCAD Syble is used to synchronize drawings between user's local directory and cloud storage. 

When a drawing in the cloud is modified, the local drawing will be updated automatically to ensure 

that the users can always browse the latest drawing data in various client products provided by 

ZWCAD. At the same time, ZWCAD Syble will also synchronize the user's custom profile and deploy 

the updated configuration to the local machine at an appropriate time. 

Users can configure the synchronization procedure in the Online tab of the Options dialog box in 

ZWCAD+, and they also can save the currently activated document directly to the cloud by clicking 

the command button in the Ribbon menu. 

When the Enable Cloud Storage in the Online tab is checked and the authorization of cloud storage 

provider has been successfully obtained, the icon of ZWCAD Syble will appear in the lower right 

corner of the local desktop. When the icon is selected, users can right-click to perform operations 

such as Start Sync, Stop Sync, check Sync Detail and ZWCAD Syble Folder, and Exit ZWCAD Syble. 
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Commands Reference 

OPTIONS: Customizes the ZWCAD+ settings 

SAVETOCLOUD: Opens the Save Drawing As dialog box, in which you can save the current 

drawing in its original format. Simultaneously, the drawing will also be automatically copied to the 

local sync path of current cloud storage device for ZWCAD+ Syble to upload synchronously 

UPLOADMULTIPLE: Launches the Open dialog box, from which you can select the files to be 

synchronized to the cloud 

ONLINESYNC: Opens or closes the custom configuration sync function 

SYNCSETTINGS: Opens the ZWCAD+ Custom Settings dialog box, from which you can select the 

profiles to be synchronized to the cloud 

System Variables Reference 

None 
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15 Compile and Work with Custom 

Applications 

 

 

 

LISP is an interpretive programming language, which provides simple mechanism for adding 

commands to ZWCAD+. Although LISP varies in different platform, generally it's connected to 

ZWCAD+ through IPC (interprocess communication), as the following figure shows. 

 

Similar to LISP application, a ZDS application accomplishes its function by means of uploading LISP 

and calling with series of external functions, and connects to LISP through IPC. 

 

This chapter contains the following contents: 

 LISP 

LISP is a full-featured, interpretive programming language (full name LISt Processor, which is list 

processing language). It is a sort of independent programming language embedded for ZWCAD+ 

customization.  

 VBA 

VBA is a kind of programming language including variety of Microsoft applications program 

environment (such as WORD, EXCEL, etc.). 

 ZDS 
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ZDS is an acronym for ZWCAD+ Development System, a C/C++ language interface compatible with 

the ADS® (AutoCAD® Development System) interface found in other CAD systems. ZDS provides 

hooks into ZWCAD+®, allowing you to create custom applications.  

 DCL 

DCL is an acronym for Dialog Control Language, a separate programming language that you can use 

with ZWCAD+® to create custom dialog boxes. In creating dialog boxes with DCL, you work with 

elements called tiles, cluster tiles (or clusters), and attributes. 

15.1 LISP 

LISP is a full-featured, interpretive programming language (full name List Processor, which is list 

processing language). It is a sort of independent programming language embedded for ZWCAD+ 

customization. LISP greatly extends most of the available commands and functions of ZWCAD+. 

LISP is similar to AutoLISP so that you can use the majority of applications written with AutoLISP in 

ZWCAD+. 

A LISP command stands for a function. Lisp function can perform the following actions:  

Load other LISP, DCL, ZDS application or ZWCAD+ files 

Prompt user to do relevant operations in the certain situation 

Execute standard command in ZWCAD+ 

Handle character string with arbitrary length  

Do mathematic calculation  

Store variable value used lately  

Read/write file  

Test and respond to the given condition.  

Select entity in drawing session.  

Modify the selected entity in drawing session.  

Export relevant information into screen or a file.  

You can produce customize resolution with application comprised of compound variant LISP 

functions. You can automate your job by extending CAD tools in ZWCAD+ or apply other 

applications into ZWCAD+. LISP can be used to produce any application you need in the special 

industries to intensify the CAD platform. 

Application of LISP expressions 

LISP has its particular functions and syntax. LISP codes are capable of tested directly without 

preparing extra procedure. Two syntaxes are provided in LISP. The first one puts the operator in 

front of the operating number, in which operators can be taken as functions with specific features, 

and the operating number is processed by functions. Each statement is separated by a blank. 

The second syntax divides the statement into two items within each bracket: function name as the 

first item and the parameters or variables of the function is second item. 

Create a LISP program 

Steps to write an application using LISP:  
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Open a text edited window such as NOTEBOOK.  

Write code in the text edited window.  

Save the new code file with the desired path and file name from File > Save As menu option. The 

extension name is lsp. 

Verify the code input.  

The following properties are contained in LISP functions: 

The codes are displayed in indent mode as other program languages do, but take no effects on 

performing programs.  

Newline is used to facilitate understanding and reading, and place multi-row codes in one line, 

which does not affect performing the program.  

All LISP statements are contained in the brackets which always appear in pairs.  

If multiple brackets pairs are contained in a statement, execute from the interior bracket.  

Text in codes appears behind the semicolon is a kind of annotation. Any text with semicolon in 

front will be ignored by programs.  

All LISP functions return value to the other functions that invoke them. By default, the value is 

calculated by the last expression. Generally the function princ without character string parameter 

follows the function that its name precedes with a prefix "c:". This function is aimed at exiting 

program without returning any value. 

Load and Run LISP Program 

LISP program is available only after loading, while how to apply a LISP program relies on the 

program itself. If functions are created in programs, it can be performed just like executing 

commands in ZWCAD+. Most of the LISP functions are provided with prompts instructing how to 

use them. You can load LISP program to ZWCAD+ before executing this program as performing 

APPLOAD command.  

Sample of LISP program 

The following LISP program explains how to create a green TEST layer, and draw a closed polyline 

on that layer. 

(defun C:testlisp (/) 

  (setvar "cmdecho" 0) 

  (command "-layer" "t" "test" "m" "test" "c" "green" "test" "l" 

"continuous"  

   "test" "lw" "0.5" "test" "") 

  (command "pline" "-2,-3,0" "6, 4, 0" "1, -10, 0" "-11, -9, 0" 

"-12, -1, 0" "-6, 2, 0" "-1, 7, 0" "c") 

  (command "regen") 

  (command "zoom" "e" "") 
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  (setvar "cmdecho" 1) 

  (princ) 

) 

Remarks 

User can reference LISP documents in "Developer's Help", to view LISP functions as well as relative 

tutorials that ZWCAD+ supports (it's recommended to reference specific instructions from 

"Help"-"Developer's Help"). 

15.2 VBA 

VBA is a kind of programming language including variety of Microsoft applications program 

environment (such as WORD, EXCEL, etc.) 

Microsoft VBA is a type of program environment for objects, capable of providing developing 

function as Visual Basic 6 (VB). The main difference between VBA and VB is that VBA runs together 

with ZWCAD+ in the same process space, and provides intellective and frequent program 

environment. 

VBA provides application integration for those application programs supportive of VBA. That is to 

say, ZWCAD+ (using other applications database) can be Automation controlling program such as 

Microsoft Word or Excel and other applications. 

You should purchase independent developed version of Visual Basic 6, providing ZWCAD+ VBA with 

extra components, such as external database engine and report forms compiling function. 

Four advantages of realizing VBA in ZWCAD+: 

VBA and its environment are prone to study and apply.  

VBA is capable of running together with ZWCAD+ in the same process space and facilitate the 

program operating. 

 Rapid and effective construction of dialog box, which enables developers construct prototype 

applications and receive design feedback quickly.  

The project is both independent and embedded supported. Which provides developers with 

flexible ways to release their applications.  

VBA applications are saved in Projects files. ZWCAD+® VBA project is a combination of code module, 

class module and window. All these modules and windows run together to execute specified 

function. The project can be stored in both ZWCAD+ drawings and also can be stored as 

independent file. 

You can open VBA manager through ZWCAD+ menu option "Tools-Macro-VBA Manager" to view 

VBA project in which you are allowed to create, load and close projects. 

Open VBA environment 

VBA has its own interface environment. You can execute from the menu "Tools-Macro-Visual Basic 

Editor" to open Visual Basic program and display VBA environment window which is short for IDE, 

i.e. Integrated Development Environment. 

ZWCAD+ VBA project is a collection of code modules, classes and forms, here module is self-include 

program code segment, and a project is capable of containing multiple modules. These modules 

and forms run together to perform given functions.  
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You can add new modules by selecting "Insert – Module" menu option from the Visual Basic 

project window. And next to open module file editor window, in which you can write codes. 

Meanwhile, a new module icon will be added in the module list in "Project" window with default 

name as Modual1.  

ZWCAD+ is running while opening VBA environment, you can toggle to ZWCAD+ platform from the 

last option on "View" menu in VBA IDE. 

VBA program samples 

The following VBA program draws a donut with inside diameter as 10, and outside diameter as 15:  

Sub DrawDonut() 

         

    Dim CenterPt(0 To 2) As Double 

    Dim OutRad As Double 

    Dim InRad As Double 

     

    CenterPt(0) = 10: CenterPt(1) = 10: CenterPt(2) = 0 

     

    OutRad = 15 

    InRad = 10 

     

    Dim pts(0 To 3) As Double 

     

    pts(0) = CenterPt(0) - InRad - Abs(OutRad - InRad) / 2 

    pts(1) = CenterPt(1) 

    pts(2) = CenterPt(0) + InRad + Abs(OutRad - InRad) / 2 

    pts(3) = CenterPt(1) 

 

    Dim ployObj As ZcadLWPolyline 

    Set PolyObj = 

ThisDrawing.ModelSpace.AddLightWeightPolyline(pts) 
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    PolyObj.Closed = True 

     

    For i = 0 To 1 

        PolyObj.SetBulge i, 1 

        PolyObj.SetWidth i, Abs(OutRad - InRad), Abs(OutRad - 

InRad) 

    Next i 

         

    PolyObj.Update 

     

'    ThisDrawing.Regen 

     

End Sub 

Remarks 

See "VBA Developer's Guide" and "VBA Reference" in "Developer's Help" to view the VBA 

functions as well as relevant tutorials provided in ZWCAD+ platform (it's recommended to 

reference specific instructions from "Help"-"Developer's Help"). 

15.3 ZDS 

ZDS is an acronym for ZWCAD+ Development System, a C/C++ language interface compatible with 

the ADS® (AutoCAD® Development System) interface found in other CAD systems. ZDS provides 

hooks into ZWCAD+®, allowing you to create custom applications.  

15.4 DCL 

DCL is an acronym for Dialog Control Language, a separate programming language that you can use 

with ZWCAD+® to create custom dialog boxes. In creating dialog boxes with DCL, you work with 

elements called tiles, cluster tiles (or clusters), and attributes. 

Remarks 

User can reference "DCL Programming Reference" in "Developer's Help" (it's recommended to 

reference specific instructions from "Help"-"Developer's Help"). 
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16 Glossary 

 

absolute coordinates 

Coordinate values measured from a coordinate system's origin point. 

acquired point 

In the tracking or object snap tracking method of locating a point, an intermediate location used as 

a reference. 

acquisition marker 

During tracking or object snap tracking, the temporary plus sign displayed at the location of an 

acquired point. 

aliasing 

The effect of discrete picture elements, or pixels, aligned as a straight or curved edge on a fixed grid 

appearing to be jagged or stepped. 

aligned dimension 

A dimension that measures the distance between two points at any angle. The dimension line is 

parallel to the line connecting the dimension's definition points. (DIMALIGNED) 

ambient color 

A color produced only by ambient light. 

ambient light 

Light that illuminates all surfaces of a model with equal intensity. Ambient light has no single 

source or direction and does not diminish in intensity over distance. 

angular dimension 

A dimension that measures angles or arc segments and consists of text, extension lines, and leaders. 

(DIMANGULAR) 
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angular unit 

The unit of measurement for an angle. Angular units can be measured in decimal degrees, 

degrees/minutes/seconds, grads, and radians. 

annotations 

Text, dimensions, tolerances, symbols, or notes. 

ANSI 

For American National Standards Institute. Coordinator of voluntary standards development for 

both private and public sectors in the United States. Standards pertain to programming languages, 

Electronic Data Interchange (EDI), telecommunications, and the physical properties of diskettes, 

cartridges, and magnetic tapes. 

anti-aliasing 

A method that reduces aliasing by shading the pixels adjacent to the main pixels that define a line 

or boundary. 

approximation points 

Point locations that a B-spline must pass near, within a fit tolerance. 

array 

Multiple copies of selected objects in a rectangular or polar (radial) pattern. (ARRAY). 

arrowhead 

A terminator, such as an arrowhead, slash, or dot, at the end of a dimension line showing where a 

dimension begins and ends. 

ASCII 

For American Standard Code for Information Interchange. A common numeric code used in 

computer data communications. The code assigns meaning to 128 numbers, using seven bits per 

character with the eighth bit used for parity checking. Nonstandard versions of ASCII assign 

meaning to 255 numbers. 

aspect ratio 

Ratio of display width to height. 
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associative hatch 

Hatching that conforms to its bounding objects such that modifying the bounding objects 

automatically adjusts the hatch. (BHATCH) 

attenuation 

The diminishing of light intensity over distance. 

attribute definition 

An object that is included in a block definition to store alphanumeric data. Attribute values can be 

predefined or specified when the block is inserted. Attribute data can be extracted from a drawing 

and inserted into external files. (ATTDEF) 

attribute extraction file 

An ASCII text file to which extracted attribute data is written. The contents and format are 

determined by the attribute extraction template file. 

attribute extraction template file 

An ASCII text file that determines which attributes are extracted and how they are formatted when 

written to an attribute extraction file. 

attribute prompt 

The text string displayed when you insert a block with an attribute whose value is undefined. 

attribute tag 

A text string associated with an attribute that identifies a particular attribute during extraction 

from the drawing database. 

attribute value 

The alphanumeric information associated with an attribute tag. 

ZWCAD+ window 

The drawing area, its surrounding menus, and the command line. 

axis tripod 

Icon with X, Y, and Z coordinates that is used to visualize the viewpoint (view direction) of a drawing 

without displaying the drawing. (VPOINT) 
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back face 

The opposite side of a front face. Back faces are not visible in a rendered image. 

baseline 

An imaginary line on which text characters appear to rest. Individual characters can have 

descenders that drop below the baseline. 

baseline dimension 

Multiple dimensions measured from the same baseline. Also called parallel dimensions. 

base point 

In the context of editing grips, the grip that changes to a solid color when selected to specify the 

focus of the subsequent editing operation. 

A point for relative distance and angle when copying, moving, and rotating objects.  

The insertion base point of the current drawing. (BASE) 

The insertion base point for a block definition. (BLOCK) 

Bezier curve 

A polynomial curve defined by a set of control points, representing an equation of an order one less 

than the number of points being considered. A Bezier curve is a special case of a B-spline curve. 

bitmap 

The digital representation of an image having bits referenced to pixels. In color graphics, a different 

value represents each red, green, and blue component of a pixel. 

blips 

Temporary screen markers displayed in the drawing area when you specify a point or select objects. 

(BLIPMODE) 

block 

A generic term for one or more objects that are combined to create a single object. Commonly 

used for either block definition or block reference.(BLOCK) 

block definition 

The name, base point, and set of objects that are combined and stored in the symbol table of a 

drawing. 
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block reference 

A compound object that is inserted in a drawing and displays the data stored in a block definition. 

Also called instance.(INSERT) 

B-spline curve 

A blended piecewise polynomial curve passing near a given set of control points.(SPLINE) 

BYBLOCK 

A special object property used to specify that the object inherits the color or linetype of any block 

containing it. 

BYLAYER 

A special object property used to specify that the object inherits the color or linetype associated 

with its layer. 

color map 

A table defining the intensity of red, green, and blue (RGB) for each displayed color. 

command line 

A text area reserved for keyboard input, prompts, and messages. 

construction plane 

A plane on which planar geometry is constructed. The XY plane of the current UCS represents the 

construction plane. 

continued dimension 

A type of linear dimension that uses the second extension line origin of a selected dimension as its 

first extension line origin, breaking one long dimension into shorter segments that add up to the 

total measurement. Also called chain dimension. (DIMCONTINUE) 

control frame 

A series of point locations used as a mechanism to control the shape of a B-spline. These points are 

connected by a series of line segments for visual clarity and to distinguish the control frame from fit 

points. The SPLFRAME system variable must be turned on to display control frames. 

coordinate filters 
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Functions that extract individual X, Y, and Z coordinate values from different points to create a new, 

composite point. Also called X,Y,Z point filters. 

Coons patch 

In 3D surface meshes, the bicubic surface (one curved in the M direction and another in the N 

direction) interpolated between four edges. 

crosshairs 

A type of cursor consisting of two lines that intersect. 

crossing selection 

A rectangular area drawn to select objects fully or partly within its borders. 

CTB file 

SA color-dependent plot style table. 

default 

A predefined value for a program input or parameter. Default values and options for ZWCAD+ 

commands are denoted by angle brackets (<>). 

definition points 

Points for creating a dimension. ZWCAD+ refers to the points to modify the appearance and value 

of a non-associative dimension when the dimensioned object is modified. Also called defpoints and 

stored on the special layer DEFPOINTS. 

dependent named objects (in xrefs) 

Named objects brought into a drawing by an external reference. 

DIESEL 

For Direct Interpretively Evaluated String Expression Language. A macro language for altering the 

status line with the MODEMACRO system variable and for customizing menu items. 

dimension line arc 

An arc (usually with arrows at each end) spanning the angle formed by the extension lines of an 

angle being measured. The dimension text near this arc sometimes divides it into two arcs. 
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dimension style 

A named group of dimension settings that determines the appearance of the dimension and 

simplifies the setting of dimension system variables. (DIMSTYLE) 

dimension text 

The measurement value of dimensioned objects. 

dimension variables 

A set of numeric values, text strings, and settings that control dimensioning features. (DIMSTYLE) 

direct distance entry 

A method to specify a second point by first moving the cursor to indicate direction and then 

entering a distance. 

drawing area 

The area in which your drawings are displayed and modified. The size of the drawing area varies, 

depending on the size of the window and on how many toolbars and other elements are displayed. 

drawing extents 

The smallest rectangle that contains all objects in a drawing, positioned on the screen to display 

the largest possible view of all objects. (ZOOM) 

drawing limits 

The user-defined rectangular boundary of the drawing area covered by dots when the grid is 

turned on. Also called drawing limits. (LIMITS) 

DWF 

For Design Web Format. A highly compressed file format that is created from a DWG file. DWF files 

are easy to publish and view on the Web.  

DWG 

Standard file format for saving vector graphics from within ZWCAD+. 

DXF 

For drawing interchange format. 
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edge 

The boundary of a face. 

elevation 

The default Z value above or below the XY plane of the current user coordinate system, which is 

used for entering coordinates and digitizing locations.  

embed 

To use object linking and embedding (OLE) information from a source document in a destination 

document. An embedded object is a copy of the information from a source document that is placed 

in the destination document and has no link to the source document. 

environment variable 

A setting stored in the operating system that controls the operation of a program. 

explode 

To disassemble a complex object, such as a block, dimension, solid, or polyline, into simpler objects. 

In the case of a block, the block definition is unchanged. The block reference is replaced by the 

components of the block. (EXPLODE) 

external reference (xref) 

A drawing file referenced by another drawing. (XREF) 

extrusion 

A 3D solid created by sweeping an object that encloses an area along a linear path. 

face 

A triangular or quadrilateral portion of a surface object. 

feature control frame 

The tolerance that applies to specific features or patterns of features. Feature control frames 

always contain at least a geometric characteristic symbol to indicate the type of control and a 

tolerance value to indicate the amount of acceptable variation. 

fence 

A multi-segmented line specified to select objects it passes through. 
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fill 

A solid color covering an area bounded by lines or curves. (FILL) 

fit points 

Locations that a B-spline must pass through exactly or within a fit tolerance. 

fit tolerance 

The setting for the maximum distance that a B-spline can pass for each of the fit points that define 

it. 

font 

A character set, comprising letters, numbers, punctuation marks, and symbols of a distinctive 

proportion and design. 

freeze 

A setting that suppresses the display of objects on selected layers. Objects on frozen layers are not 

displayed, regenerated, or plotted. Freezing layers shortens regenerating time. (LAYER) 

front faces 

Faces with their normals pointed outward. 

geometry 

All graphical objects such as lines, circles, arcs, polylines, and dimensions. Non-graphical objects, 

such as linetypes, lineweights, text styles, and layers are not considered geometry. 

grid 

An area covered with regularly spaced dots to aid drawing. The spacing between grid dots is 

adjustable. Grid dots are not plotted. (GRID) 

grid limits 

The user-defined rectangular boundary of the drawing area covered by dots when the grid is 

turned on. Also called drawing limits. (LIMITS) 

grip modes 

The editing capabilities activated when grips are displayed on an object: stretching, moving, 

rotating, scaling, and mirroring. 
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grips 

Small squares that appear on objects you select. After selecting the grip, you edit the object by 

dragging it with the pointing device instead of entering commands. 

HLS 

For hue, lightness, and saturation. A system of defining color by specifying the amount of hue, 

lightness, and saturation. 

initial environment 

The variables and settings for new drawings as defined by the default template drawing, such as 

zwcad.dwg or zwcadiso.dwg. 

interpolation points 

Defining points that a B-spline passes through. 

island 

An enclosed area within another enclosed area. Islands may be detected as part of the process of 

creating hatches, polylines, and regions. (BHATCH, BOUNDARY) 

ISO 

For International Standards Organization. The organization that sets international standards in all 

fields except electrical and electronics. Headquarters are in Geneva, Switzerland. 

isometric snap style 

A drafting option that aligns the cursor with two of three isometric axes and displays grid points, 

making isometric drawings easier to create. 

layer 

A logical grouping of data that are like transparent acetate overlays on a drawing. You can view 

layers individually or in combination. (LAYER) 

layer index 

A list showing the objects on each layer. Uses a layer index to locate what portion of the drawing is 

read when you partially open a drawing. Saving a layer index with a drawing also enhances 

performance when you work with external references. The INDEXCTL system variable controls 

whether layer and spatial indexes are saved with a drawing. 
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layer translation mappings 

Assignments of a set of layers to another set of layers that defines standards. These standards 

include layer names and layer properties. Also called layer mappings. 

layout 

The tabbed environment in which you create and design paper space layout viewports to be 

plotted. Multiple layouts can be created for each drawing. 

layout viewports 

Objects that are created in paper space that display views.(VPORTS) 

linetype 

How a line or type of curve is displayed. For example, a continuous line has a different linetype 

than a dashed line. Also called line font. (LINETYPE) 

lineweight 

A width value that can be assigned to all graphical objects except TrueType® fonts and raster 

images. 

link 

To use object linking and embedding (OLE) to reference data in another file. When data is linked, 

any changes to it in the source document are automatically updated in any destination document. 

mirror 

To create a new version of an existing object by reflecting it symmetrically with respect to a 

prescribed line or plane. (MIRROR) 

mode 

A software setting or operating state. 

model 

A two- or three-dimensional representation of an object. 

model viewports 

A type of display that splits the drawing area into one or more adjacent rectangular viewing areas. 

(VPORTS) 
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model space 

One of the two primary spaces in which CAD objects reside. Typically, a geometric model is placed 

in a three-dimensional coordinate space called model space. A final layout of specific views and 

annotations of this model is placed in paper space. (MSPACE) 

multi-sheet DWF 

A DWF file that contains multiple sheets. 

named object 

Describes the various types of non-graphical information, such as styles and definitions, stored with 

a ZWCAD+ drawing. Named objects include linetypes, layers, dimension styles, text styles, block 

definitions, layouts, views, and viewport configurations. Named objects are stored in definition 

(symbol) tables. 

named view 

A view saved for restoration later. (VIEW) 

node 

An object snap specification to locate points, dimension definition points, and dimension text 

origins. 

normal 

A vector that is perpendicular to a face. 

noun-verb selection 

Selecting an object first and then performing an operation on it rather than entering a command 

first and then selecting the object. 

NURBS 

For nonuniform rational B-spline curve. A B-spline curve or surface defined by a series of weighted 

control points and one or more knot vectors. 

object 

One or more graphical elements, such as text, dimensions, lines, circles, or polylines, treated as a 

single element for creation, manipulation, and modification. Formerly called entity. 
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Object Snap mode 

Methods for selecting commonly needed points on an object while you create or edit a drawing. 

object snap override 

Turning off or changing a running Object Snap mode for input of a single point. 

OLE 

For object linking and embedding. An information-sharing method in which data from a source 

document can be linked to or embedded in a destination document. Selecting the data in the 

destination document opens the source application so that the data can be edited. 

origin 

The point where coordinate axes intersect. For example, the origin of a Cartesian coordinate system 

is where the X, Y, and Z axes meet at 0,0,0. 

orthogonal 

Having perpendicular slopes or tangents at the point of intersection. 

Ortho mode 

A setting that limits pointing device input to horizontal or vertical (relative to the current snap 

angle and the user coordinate system). 

page setup 

A collection of plot device and other settings that affect the appearance and format of the final 

output. These settings can be modified and applied to other layouts. 

pan 

To shift the view of a drawing without changing magnification.(PAN) 

paper space 

One of two primary spaces in which ZWCAD+ objects reside. Paper space is used for creating a 

finished layout for printing or plotting, as opposed to doing drafting or design work. You design 

your paper space viewports using a layout tab. Model space is used for creating the drawing. You 

design your model using the Model tab.(PSPACE) 

PCP file 
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Partial plotter configuration file. Plot settings that are stored in a PCP file include pen assignments, 

plotting units, paper size, plot rotation, plot origin, scale factor, and pen optimization level. 

perspective view 

Objects in 3D seen by an observer positioned at the viewpoint looking at the view center. Objects 

appear smaller when the distance from the observer (at the view point) to the view center 

increases. Although a perspective view appears realistic, it does not preserve the shapes of objects. 

Parallel lines seemingly converge in the view, so measurements cannot be made to scale from 

perspective views. When you are looking at a viewport with a perspective view, the UCS icon has a 

different appearance. 

photorealistic rendering 

Rendering that resembles a photograph. 

pick button 

The button on a pointing device that is used to select objects or specify points on the screen. For 

example, on a two-button mouse, it is the left button. 

planar projection 

Mapping of objects or images onto a plane. 

plan view 

A view orientation from a point on the positive Z axis toward the origin (0,0,0). (PLAN) 

PMP file 

Plot Model Parameter. File containing custom plotter calibration and custom paper size information 

associated with plotter configuration file. 

point 

A location in three-dimensional space specified by X, Y, and Z coordinate values. 

A ZWCAD+ object consisting of a single coordinate location. (POINT) 

pointer 

A cursor on a video display screen that can be moved around to place textual or graphical 

information. 

polar array 



 

 537 

Objects copied around a specified center point a specified number of times. (ARRAY) 

Polar Snap 

A precision drawing tool used to snap to incremental distances along the polar tracking alignment 

path. 

polar tracking 

A precision drawing tool that displays temporary alignment paths defined by user-specified polar 

angles. 

polygon window selection 

A multisided area specified to select objects in groups. 

polyline 

An object composed of one or more connected line segments or circular arcs treated as a single 

object. Also called pline. (PLINE, PEDIT) 

plot style 

An object property that specifies a set of overrides for color, dithering, gray scale, pen assignments, 

screening, linetype, lineweight, endstyles, joinstyles, and fill styles. Plot styles are applied at plot 

time. 

plot style table 

A set of plot styles. Plot styles are defined in plot style tables and apply to objects only when the 

plot style table is attached to a layout or viewport. 

procedural materials 

Materials that generate a 3D pattern in two or more colors, and apply it to an object. These include 

marble, granite, and wood. Also called template materials. 

prompt 

A message on the command line that asks for information or requests action such as specifying a 

point. 

redraw 

To quickly refresh or clean up blip marks in the current viewport without updating the drawing's 

database.(REDRAW) 
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reference 

A definition, known as an external reference or block reference, that is used and stored in the 

drawing.(XREF) 

reflection color 

The color of a highlight on shiny material. Also called specular color. 

reflection mapping 

Creates the effect of a scene reflected on the surface of a shiny object. 

regenerate 

To update a drawing's screen display by recomputing the screen coordinates from the database. 

(REGEN) 

relative coordinates 

Coordinates specified in relation to previous coordinates. 

return button 

The button on a pointing device used to accept an entry. For example, on a two-button mouse, it is 

the right button. 

RGB 

For red, green, and blue. A system of defining colors by specifying percentages of red, green, and 

blue. 

rubber-band line 

A line that stretches dynamically on the screen with the movement of the cursor. One endpoint of 

the line is attached to a point in your drawing, and the other is attached to the moving cursor. 

running object snap 

Setting an Object Snap mode so it continues for subsequent selections.(OSNAP) 

save back 

To update the objects in the original reference (external or block reference) with changes made to 

objects in a working set during in-place reference editing. 
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script file 

A set of ZWCAD+ commands executed sequentially with a single SCRIPT command. Script files are 

created outside ZWCAD+ using a text editor, saved in text format, and stored in an external file with 

the file extension .scr. 

selection set 

One or more selected objects that a command can act upon at the same time. 

ShapeManager 

The technology used to produce 3D solids in ZWCAD+. 

shortcut keys 

Keys and key combinations that start commands; for example, CTRL+S saves a file. The function 

keys (F1, F2, and so on) are also shortcut keys. Also known as accelerator keys. 

shortcut menu 

The menu displayed at your cursor location when you right-click your pointing device. The shortcut 

menu and the options it provides depend on the pointer location and other conditions, such as 

whether an object is selected or a command is in progress. 

slide file 

A file that contains a raster image or slide of the objects displayed in the drawing area. Slide files 

have the file extension .sld. (MSLIDE, VSLIDE) 

smooth shading 

Smoothing of the edges between polygon faces. 

snap angle 

The angle that the snap grid is rotated. 

snap grid 

The invisible grid that locks the pointer into alignment with the grid points according to the spacing 

set by Snap. Snap grid does not necessarily correspond to the visible grid, which is controlled 

separately by GRID. (SNAP) 

Snap mode 
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A mode for locking a pointing device into alignment with an invisible rectangular grid. When Snap 

mode is on, the screen crosshairs and all input coordinates are snapped to the nearest point on the 

grid. The snap resolution defines the spacing of this grid.(SNAP) 

snap resolution 

The spacing between points of the snap grid. 

specular reflection 

The light in a narrow cone where the angle of the incoming beam equals the angle of the reflected 

beam. 

STB file 

For plot style table file. Contains plot styles and their characteristics. 

system variable 

A name that ZWCAD+ recognizes as a mode, size, or limit. Read-only system variables, such as 

DWGNAME, cannot be modified directly by the user. 

template drawing 

A drawing file with preestablished settings for new drawings such as zwcad.dwt and zwcadiso.dwt; 

however, any drawing can be used as a template. 

temporary files 

Data files created during a ZWCAD+ session. ZWCAD+ deletes the files by the time you end the 

session. If the session ends abnormally, such as during a power outage, temporary files might be 

left on the disk. 

text style 

A named, saved collection of settings that determines the appearance of text characters—for 

example, stretched, compressed, oblique, mirrored, or set in a vertical column. 

texture map 

The projection of an image (such as a tile pattern) onto an object (such as a chair). 

thaw 

A setting that displays previously frozen layers.(LAYER) 
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thickness 

The distance certain objects are extruded to give them a 3D appearance. (PROPERTIES, CHPROP, 

CHANGE, THICKNESS) 

TILEMODE 

A system variable that controls whether viewports can be created as movable, resizable objects 

(layout viewports), or as non-overlapping display elements that appear side-by-side (model 

viewports). 

toolbar 

Part of the ZWCAD+ interface containing icons that represent commands. 

tracking 

A way to locate a point relative to other points on the drawing. 

transparent command 

A command started while another is in progress. Precede transparent commands with an 

apostrophe. 

UCS icon 

An icon that indicates the orientation of the UCS axes. (UCSICON) 

user coordinate system (UCS) 

A user-defined coordinate system that defines the orientation of the X, Y, and Z axes in 3D space. 

The UCS determines the default placement of geometry in a drawing. 

vector 

A mathematical object with precise direction and length but without specific location. 

vertex 

A location where edges or polyline segments meet. 

view 

A graphical representation of a model from a specific location (viewpoint) in space. (VPOINT, VIEW) 
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viewpoint 

The location in 3D model space from which you are viewing a model. (VPOINT) 

viewport 

A bounded area that displays some portion of the model space of a drawing. The TILEMODE system 

variable determines the type of viewport created. 

When TILEMODE is off (0), viewports are objects that can be moved and resized on a layout. 

(MVIEW) 

When TILEMODE is on (1), the entire drawing area is divided into non-overlapping model 

viewports.(VPORTS) 

viewport configuration 

A named collection of model viewports that can be saved and restored. (VPORTS) 

window selection 

A rectangular area specified in the drawing area to select multiple objects at the same time. 

wipeout object 

A polygonal area that masks underlying objects with the current background color. This area is 

bounded by the wipeout frame, which you can turn on for editing and turn off for plotting. 

wireframe model 

The representation of an object using lines and curves to represent its boundaries. 

working drawing 

A drawing for manufacturing or building purposes. 

working set 

A group of objects selected for in-place reference editing. 

world coordinates 

Coordinates expressed in relation to the world coordinate system (WCS). 

world coordinate system (WCS) 

A coordinate system used as the basis for defining all objects and other coordinate systems. 
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zoom 

To reduce or increase the apparent magnification of the drawing area. (ZOOM)  


